Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 08/05/2012, à 18:28

Christophe C

my-weather-indicator dans Lubuntu - ça fonctionne !

Pour info, my-weather-indicator marche nickel dans Lubuntu (et d'autres LXDE, peut-être ?). Il n'est pas que pour Unity. Ca doit marcher aussi dans xubuntu, logiquement.

Je considère que c'est le meilleur indicateur météo du moment, avec ses 5 jours de prévision.

Pour installer le programme, il faut déclarer son PPA, puis installer le soft. Par le terminal :

sudo add-apt-repository ppa:atareao/atareao && sudo apt-get update && sudo apt-get install my-weather-indicator

Une fois le PPA paramétré, et le programme installé, il suffit de le lancer par alt+f2, de le paramétrer, et de cocher la case pour qu'il démarre automatiquement.

Sympa.

Dernière modification par Christophe C (Le 08/05/2012, à 18:29)


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.
Plank-config - Logiciel de configuration pour le dock Plank.

Hors ligne

#2 Le 18/05/2012, à 16:39

thib1984

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Bonjour Christophe, je serai intéressé par tester ton soft, mais voici le message d'erreur que je recois au lancement.

(16:10:25)thib1984@thib1984-1005PE:~$my-weather-indicator 
No LSB modules are available.
#####################################################
Distributor ID:    Ubuntu
Description:    Ubuntu 12.04 LTS
Release:    12.04
Codename:    precise
Version:    i686
#####################################################

My-Weather-Indicator version: 0.4.3.15
#####################################################
Url: http://www.google.com/ig/api?weather=Silla&hl=en
Traceback (most recent call last):
  File "/usr/share/my-weather-indicator/my-weather-indicator.py", line 487, in <module>
    mwi=MWI()
  File "/usr/share/my-weather-indicator/my-weather-indicator.py", line 159, in __init__
    self.work()
  File "/usr/share/my-weather-indicator/my-weather-indicator.py", line 167, in work
    self.set_menu()
  File "/usr/share/my-weather-indicator/my-weather-indicator.py", line 251, in set_menu
    self.notification.show()                    
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

Saurais-tu quelle manip je dois réaliser afin de surpasser cette difficulté?
Comme tu as l'air calé, connaitrais-tu un soft simple et afficace pour avoir des infos systèmes (cpu, etc) dans la barre des taches ou sur le bureau?

++

Hors ligne

#3 Le 18/05/2012, à 16:49

atichu

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

conky pour les info systéme tu cherche sur le forum il y en a plein a copier tongue


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#4 Le 19/05/2012, à 01:57

atichu

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

my indicator veux pas démarré dans un terminal mais si on l'allume du dock sa passe..


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#5 Le 19/05/2012, à 18:53

Christophe C

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Désolé, je ne comprend pas ces messages d'erreurs.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.
Plank-config - Logiciel de configuration pour le dock Plank.

Hors ligne

#6 Le 16/03/2014, à 09:57

groovyjona

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

bonjour à tous !

Petit Up pour moi. Installé mais impossible de le lancer en début de session. Je suis sous lubuntu 13.10. J'ai essayé de mettre "my-weather-indicator" ou "indicator-weather" dans les programmes au démarrage, ça ne fonctionne pas...
Une idée ?


Jonathan
Xubuntu 14.04 LTS - Et mon pc me remercie !

Hors ligne

#7 Le 16/03/2014, à 12:52

Christophe C

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

mais sinon, tu peut le lancer via un alt+f2 ?


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.
Plank-config - Logiciel de configuration pour le dock Plank.

Hors ligne

#8 Le 17/03/2014, à 08:36

groovyjona

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Christophe C a écrit :

mais sinon, tu peut le lancer via un alt+f2 ?

Non. Il faut le lancer depuis le menu.


Jonathan
Xubuntu 14.04 LTS - Et mon pc me remercie !

Hors ligne

#9 Le 17/03/2014, à 13:45

Christophe C

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

s'il se lance depuis les menus, il peut se lancer par l'ouverture de session.

Ce qui serait bien, c'est que tu tests via alt +F2, ou via le terminal, la commande qui lance le programme.

Si tu ne trouves pas, tu peux aller dans /user/share/applications pour ouvrir le .desktop correspondant, et voir la commande qu'il lance.

Et normalement, il suffit d'intégrer cela dans le lancement de session. je n'ai pas de lubuntu sous la main, mais je peux regarder ce soir.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.
Plank-config - Logiciel de configuration pour le dock Plank.

Hors ligne

#10 Le 17/03/2014, à 16:30

groovyjona

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Je vais essayer cela ce soir quand je rentre du boulot.
Merci du coup de main.


Jonathan
Xubuntu 14.04 LTS - Et mon pc me remercie !

Hors ligne

#11 Le 17/03/2014, à 22:50

Christophe C

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Bon, chez moi cela marche toujours :
1/ lancer le programme via Menu / accessoires / My-weather-indicator
2/ Dans l'onglet "emplacement", choisir sa ville. Perso j'ai décoché tous les items de cet onglet, cela marche mieux (avec son absence de transparence, openbox a du mal a afficher le widget)
3/ dans l'onglet "option générale", cocher "démarrage automatique".
Ensuite cela démarre tout seul à chaque démarrage. On clic sur l’icône dans la zone de notification, et on choisit ce qu'on veut, par exemple "prévisions".


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.
Plank-config - Logiciel de configuration pour le dock Plank.

Hors ligne

#12 Le 18/03/2014, à 08:37

groovyjona

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Ben moi toujours rien, même en allant pointer vers /user/share/applications/My-Weather-Indicator

Option démarrage avec la session cochée et toujours rien.
Ça ne se lance toujours pas en faisant alt+f2 et "My-Weather-Indicator", ça me met que ça ne reconnaît pas l'application gros.


Jonathan
Xubuntu 14.04 LTS - Et mon pc me remercie !

Hors ligne

#13 Le 18/03/2014, à 13:19

Christophe C

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Je l'ai réinstallé hier sur une dstro "fraiche", donc ce n'est pas un reste du passé. Je ne sais pas pourquoi cela ne marche pas chez toi. Désolé.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.
Plank-config - Logiciel de configuration pour le dock Plank.

Hors ligne

#14 Le 18/03/2014, à 15:17

lynn

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

groovyjona a écrit :

Ben moi toujours rien, même en allant pointer vers /user/share/applications/My-Weather-Indicator

Option démarrage avec la session cochée et toujours rien.
Ça ne se lance toujours pas en faisant alt+f2 et "My-Weather-Indicator", ça me met que ça ne reconnaît pas l'application gros.

Bonjour,

La commande pour lancer my-weather-indicator est située dans /opt.

Essaye avec cette commande dans un terminal :

/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

Linux est la solution ! Au fait, c'est quoi ton problème ?
Ubuntu 14.04 - 64 bits  -  Ubuntu 14.10 - 64 bits - Utopic Unicorn

Hors ligne

#15 Le 22/03/2014, à 12:11

groovyjona

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

lynn a écrit :
groovyjona a écrit :

Ben moi toujours rien, même en allant pointer vers /user/share/applications/My-Weather-Indicator

Option démarrage avec la session cochée et toujours rien.
Ça ne se lance toujours pas en faisant alt+f2 et "My-Weather-Indicator", ça me met que ça ne reconnaît pas l'application gros.

Bonjour,

La commande pour lancer my-weather-indicator est située dans /opt.

Essaye avec cette commande dans un terminal :

/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

Yes ! Ça fonctionne nickel. merci !


Jonathan
Xubuntu 14.04 LTS - Et mon pc me remercie !

Hors ligne

#16 Le 02/04/2014, à 16:07

thecham03

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

Merci pour l'info, j'avais cessé d'utiliser l'appli qui ne se mettait plus à jour.
Sympa de la retrouver, elle s'intègre bien dans Lubuntu.


Lubuntu 14.04 - 64 bits

Hors ligne

#17 Le 21/07/2014, à 10:41

artalis

Re : my-weather-indicator dans Lubuntu - ça fonctionne !

L'applet marche bien sous Lubuntu 12.04 et Lubuntu 14.04.
Par contre impossible de la lancer si les animations ont été cochées : préférences / emplacement principal / afficher l'animation. Cela crée pour moi un message d'erreur.
Le seul moyen de refaire fonctionner l'applet est de supprimer le fichier de configuration qui se situe dans /home/XXX/.config/my-weather-indicator

Hors ligne

  • Accueil
  • » Forum
  • » LXDE
  • » my-weather-indicator dans Lubuntu - ça fonctionne !

Haut de page ↑