Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 04/08/2014, à 11:59

smike2809

WOL + SSH avec commande halt reboot en continu

Bonjour,

J'ai un PC en dual boot (Windows 8.1 + Ubuntu 14.04 LTS) qui a comme gestionnaire de démarrage Grub2 avec une priorité de démarrage sur la partition Ubuntu. J'arrive sans problème à démarrer mon PC depuis l'extérieure mais lorsque je souhaite l’éteindre, soit via l'interface graphique d'ubuntu, soit via ssh avec la commande halt  ou shutdown -h now, le PC s’éteint mais redémarre quelques secondes après cela sans y toucher quoique se soit.

Pour l'arrêter je dois peser sur le bouton de démarrage pendant au moins 4 secondes. D'ou viens ce bug?

Hors ligne

#2 Le 04/08/2014, à 16:49

Kooothor

Re : WOL + SSH avec commande halt reboot en continu

Salut,

Ton phrasé est imprécis : est-ce qu'il se rallume seulement quand tu l'éteins de l'extérieur ou à chaque fois ? Quand tu dis via l'interface graphique, c'est avec VNC ?
Quand tu fais sudo shutdown -h now, aucune erreur n'est affichée ?
C'est intéressant comme comportement smile


@+
~ktr


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 04/08/2014, à 16:54

jplemoine

Re : WOL + SSH avec commande halt reboot en continu

smike2809 a écrit :

halt

c'est

sudo halt -p

Le -p éteint l'ordinateur...

Je pense que pour le shutdown, il faut faire -P pas -h.


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#4 Le 04/08/2014, à 17:12

smike2809

Re : WOL + SSH avec commande halt reboot en continu

Oui tu as raison cela manque de précision.
Alors quelque soit la méthode d'arrêt (à distance ou localement) le pc redémarre.
J'ai essayé les commandes shutdown, poweroff, halt avec tous les paramètre cités aucun changement, le pc redémarre.
Aussi en arrêtant normalement le pc (sous ubuntu: en haut à droite l'engrenage) le pc redémarre.

Je vais essayer de débrancher le câble réseau pour voir si cela change quelque chose.

Kooothor a écrit :

Salut,

Ton phrasé est imprécis : est-ce qu'il se rallume seulement quand tu l'éteins de l'extérieur ou à chaque fois ? Quand tu dis via l'interface graphique, c'est avec VNC ?
Quand tu fais sudo shutdown -h now, aucune erreur n'est affichée ?
C'est intéressant comme comportement smile


@+
~ktr

Hors ligne

#5 Le 04/08/2014, à 17:14

smike2809

Re : WOL + SSH avec commande halt reboot en continu

J'avoue avoir un peu de mal à comprendre la différence entre ses trois paramètres pour la commande shutdown:

-h
Arrêter la machine après l'arrêt du système.
-H
Après l'arrêt du système, la machine est arrêtée ou placée dans le gestionnaire de démarrage, pour les systèmes qui le permettent.
-P
Arrêter le système met la machine hors tension.

Quel est la différence entre le paramètre -h et -P

Hors ligne

#6 Le 05/08/2014, à 00:00

Kooothor

Re : WOL + SSH avec commande halt reboot en continu

Halte ça implique arrêter tous les CPU. Shutdown ça envoie une commande ACPI qui éteint vraiment l'ordi.

Donc la question c'est : as-tu essayé ceci :

sudo shutdown -P now

?
Mais bon normalement c'est -h qui fonctionne très bien. Mais peut-être que ton PC est particulier...   
Au fait tu n'as pas précisé : avec windows il s'éteint bien ?


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#7 Le 05/08/2014, à 22:49

smike2809

Re : WOL + SSH avec commande halt reboot en continu

Salut Kooothor,

Oui, sous windows il s’éteint bien. Rien ne change même si je débranche le câble réseau.
C'est vraiment bizarre. Y a t'il un moyen de centrer le problème?

Quelques précisions:
J'ai une carte mère avec un UEFI (Asus Z87-Pro).
Le démarrage est activé à la réception de paquet magiques sous windows.
Dans le UEFI la partition de démarrage est celle ou ubuntu est installé.

Hors ligne

#8 Le 05/08/2014, à 23:03

Kooothor

Re : WOL + SSH avec commande halt reboot en continu

Si tu disable le wol (man ethtool), est-ce qu'il se rallume toujours après shutdown -h ?


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#9 Le 06/08/2014, à 00:36

smike2809

Re : WOL + SSH avec commande halt reboot en continu

Avant le changement:

Supports Wake-on: pumbg
	Wake-on: g
 wol p|u|m|b|a|g|s|d...
              Sets Wake-on-LAN options.  Not all devices support this.  The argument to this option
              is a string of characters specifying which options to enable.

              p   Wake on PHY activity
              u   Wake on unicast messages
              m   Wake on multicast messages
              b   Wake on broadcast messages
              a   Wake on ARP
              g   Wake on MagicPacket™
              s   Enable SecureOn™ password for MagicPacket™
              d   Disable (wake on  nothing).   This  option
                  clears all previous options.
sudo ethtool -s eth0 wol d

Après le changement:

Supports Wake-on: pumbg
	Wake-on: d

cependant c'est pas le but de désactiver le wol car j'en ai besoin. Mais c'est bizarre ces redémarrages en boucle ça peut venir que de l'ordinateur car j'en n'ai plus de câble réseau connecté (mis à part pour écrire ce message). J'éteint le pc et vous dit si il redémarre encore en boucle avec les paramètres changés en début de message.

Hors ligne

#10 Le 06/08/2014, à 01:15

smike2809

Re : WOL + SSH avec commande halt reboot en continu

Aucun changement, démarrage en boucle. En désactivant le démarrage depuis le carte PCI-E plus de démarrage en boucle mais il faut que j'active ce paramètre sinon plus de WOL.
Toujours en attente d'une solution...
Il y a qqch dont j'aimerais être sûr. Est-ce que c'est logiciel ou matériel?

Hors ligne

#11 Le 06/08/2014, à 11:34

droopy191

Re : WOL + SSH avec commande halt reboot en continu

Salut,

Voyez aussi du coté des mises à jour du bios de la carte mère ( a faire avec les précautions d'usage).

Hors ligne

#12 Le 06/08/2014, à 19:19

smike2809

Re : WOL + SSH avec commande halt reboot en continu

J'ai fait la mise à jour du BIOS. Plus de problèmes de démarrage en boucle ça c'est déjà une bonne chose mais le wol ne fonctionne plus du tout.

Dernière modification par smike2809 (Le 06/08/2014, à 19:20)

Hors ligne

#13 Le 07/08/2014, à 07:43

droopy191

Re : WOL + SSH avec commande halt reboot en continu

smike2809 a écrit :

J'ai fait la mise à jour du BIOS. Plus de problèmes de démarrage en boucle ça c'est déjà une bonne chose mais le wol ne fonctionne plus du tout.

Retournez sous windows, et dans les propriétés de la carte, regarder si le WOL est activé:
- onglet gestion alimentation
- ou dans avancé,

Hors ligne

#14 Le 07/08/2014, à 11:13

smike2809

Re : WOL + SSH avec commande halt reboot en continu

wol
wol
wol

Ceci?

Hors ligne

#15 Le 07/08/2014, à 11:17

smike2809

Re : WOL + SSH avec commande halt reboot en continu

J'ai deux cartes réseau. Une intégré et une en PCI-E que j'ai ajouté car celle intégré n'est visiblement pas nativement supporté par ubuntu 14.04 bien que ce soit une intel. J'ai quand même modifié les deux cartes de manière semblables (voir images ci-dessus).
Mais est-ce que ces modifications ont réellement une influence lorsque le pc est éteint (Je veux bien croire lorsqu'il est en veille mais éteint j'ai de la peine à comprendre vu qu'il est totalement déconnecté de l'os)? Se pourrait-il qu'il y ait un conflit étant donné qu'il y a deux OS`?

Dernière modification par smike2809 (Le 07/08/2014, à 11:18)

Hors ligne

#16 Le 07/08/2014, à 15:58

droopy191

Re : WOL + SSH avec commande halt reboot en continu

smike2809 a écrit :

J'ai deux cartes réseau. Une intégré et une en PCI-E que j'ai ajouté car celle intégré n'est visiblement pas nativement supporté par ubuntu 14.04 bien que ce soit une intel. J'ai quand même modifié les deux cartes de manière semblables (voir images ci-dessus).
Mais est-ce que ces modifications ont réellement une influence lorsque le pc est éteint (Je veux bien croire lorsqu'il est en veille mais éteint j'ai de la peine à comprendre vu qu'il est totalement déconnecté de l'os)? Se pourrait-il qu'il y ait un conflit étant donné qu'il y a deux OS`?

J'ai souvent eu du mal avec le WOL en double démarrage, activer ce paramètre sous windows a réglé le pb sur plusieurs carte ASUS.
Si ce ce réglage ne règle pas le pb, je n'ai pas plus d'idée.

Hors ligne

Haut de page ↑