Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 03/08/2014, à 08:12

duocore

probleme pour faire fonctionner seafile en https[RESOLU]

Bonjour,

sur mon serveur Nginx reverse proxy, j'ai installé seafile. Je peux acceder à seafile par mon adresse interne: 192.168.1.4:8000 mais pas avec mon nom de domaine

je n'arrive pas à configurer seafile pour l'utiliser avec https.

je voudrais acceder à seafile soit par :  https://192.168.1.4/seafile  ou https://my_name_serveur/seafile


Merci de votre aide

Dernière modification par duocore (Le 06/08/2014, à 21:38)

Hors ligne

#2 Le 03/08/2014, à 09:33

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

je pense que mon probleme doit venir de la configuration de nginx:

access_log off;
add_header Cache-Control public;
server_tokens off;

# HTTP 80
server {
listen 80;
server_name servername;
root /var/www;
index index.php index.html index.htm;
client_max_body_size 1000M; #set max upload size
error_page  401 403 404 500 503 /error.html;
return 301 https://$server_name$request_uri;
 
location / {
proxy_pass http://192.168.1.4:80;
try_files $uri $uri/ /index.html;
}

location ~ ^/(admin|pydio|filez|seafile|shellinabox) {
rewrite ^ https://$server_name$request_uri? permanent;
}

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIP_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}
}

# https 443
server {
include /etc/nginx/proxy.conf;
listen 443 ssl;
keepalive_timeout 70;
server_name servername;
root /var/www;
index index.php index.html index.htm;


# ssl config
ssl on;
ssl_certificate /etc/ssl/localcerts/autosigned.crt;
ssl_certificate_key /etc/ssl/localcerts/autosigned.key;

ssl_session_timeout 5m;
ssl_protocols SSLv3 TLSv1.2;
ssl_ciphers RC4:HIGH:!aNULL:!MD5;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;

add_header X-Frame-Options DENY;

# DDOS protection - Tune Values or deactivate in case of issue
# limit_conn conn_limit_per_ip 20;
# limit_req zone=req_limit_per_ip burst=20 nodelay;

# statut for nginx auditing
location /nginx-statut {
stub_status on;
access_log off;
allow 127.0.0.1;
deny all;
}

location /shellinabox/ {
proxy_pass https://localhost:4200;
auth_basic "Access Administrateur";
auth_basic_user_file "/etc/nginx/.htpasswd";
access_log /var/log/nginx/shellinabox.access.log;
error_log /var/log/nginx/shellinabox.error.log;
}

location /filez{
		access_log      /var/log/nginx/filez.access.log;
		
		location ~ \.php$ {
                        include         fastcgi_params;
                        fastcgi_param   SCRIPT_FILENAME  $document_root$fastcgi_script_name;
                        fastcgi_pass unix:/var/run/php5-fpm.sock;

                }
                if (!-e $request_filename) {
                        rewrite ^/(.*)$ /filez/index.php last;
                }

}

location /pydio/ {
access_log /var/log/nginx/pydio.access.log;
error_log /var/log/nginx/pydio.error.log;
}

location ^~ /pydio/(conf|data) {
        deny all;
}
location /seafile {
access_log /var/log/nginx/seahub.access.log;
error_log /var/log/nginx/seahub.error.log;
        proxy_pass https://localhost:8000;  # je ne sais pas si il faut mettre a la place de localhost 192.168.1.4
        rewrite ^/seafile(.*)$ $1 break;
        client_max_body_size 0;    
 }

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIP_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}


}

Hors ligne

#3 Le 03/08/2014, à 14:09

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Salut,

Je n'ai pas le temps d'approfondir ta configuration (qui me semble peut-être trop complexe), je peux te montrer la mienne par contre.

J'accède à Seafile par l'URL « http://files.machin.truc », sans sous-répertoire, à toi d'adapter les "location" :

server {
        listen   [::]:443;
        server_name files.machin.truc;

        ssl on;
        ssl_certificate /etc/ssl/files.machin.truc.pem;
        ssl_certificate_key /etc/ssl/selfsigned.key;
        ssl_session_timeout 5m;
        ssl_protocols SSLv3 TLSv1;
        ssl_ciphers ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv3:+EXP;
        ssl_prefer_server_ciphers on;

        location / {
                fastcgi_pass    127.0.0.1:8000;
                fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;
                fastcgi_param   PATH_INFO           $fastcgi_script_name;

                fastcgi_param   SERVER_PROTOCOL     $server_protocol;
                fastcgi_param   QUERY_STRING        $query_string;
                fastcgi_param   REQUEST_METHOD      $request_method;
                fastcgi_param   CONTENT_TYPE        $content_type;
                fastcgi_param   CONTENT_LENGTH      $content_length;
                fastcgi_param   SERVER_ADDR         $server_addr;
                fastcgi_param   SERVER_PORT         $server_port;
                fastcgi_param   SERVER_NAME         $server_name;
        }
        location /media {
                root /bidule/seafile-server-latest/seahub;
        }

        access_log /var/log/nginx/machintruc/access.log;
        error_log /var/log/nginx/machintruc/error.log;
}

De ton côté tu utilises "proxy_pass" au lieu de "fastcgi_pass", en même temps tu n'as peut-être pas démarré Seafile en fastcgi...

Dernière modification par tiramiseb (Le 03/08/2014, à 14:13)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#4 Le 03/08/2014, à 16:03

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

comme j'ai plusieurs services : Pydio, shellinabox, googol, filez

j'ai reussi à configurer tous les services sauf seafile.

impossible de le configurer comme il faut: il fonctionne qu'en http et non pas en https.

merci de votre aide

Hors ligne

#5 Le 03/08/2014, à 19:43

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

j'ai trouvé ce tuto:http://draptik.github.io/blog/2014/04/21/installing-seafile-on-raspberry-pi/

et une fois que je fais https://192.168.1.4:8000 ou https://mon-serveur.org:8000

j'ai une erreur 502 Bad gateway

dans le fichier seahub.error.log

2014/08/03 20:52:34 [error] 3401#0: *25 upstream sent unsupported FastCGI protocol version: 60 while reading response header from upstream, client: 192.168.1.5, server: mon-serveur.org, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "192.168.1.4:8000"

pouvez vous m'aider?

par contre avec http://192.168.1.4:8000 impossible d'avoir access à seafile

Dernière modification par duocore (Le 03/08/2014, à 20:08)

Hors ligne

#6 Le 03/08/2014, à 21:30

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Je t'ai montré une configuration qui fonctionne. Tant que tu ne t'y penches pas, je ne peux pas t'aider plus que ça.

Maintenant, visiblement mes infos ne t'intéressent pas vu que tu préfères chercher des tutoriels plutôt que de travailler sur ce que je te donnes...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 03/08/2014, à 21:52

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

je ne comprend pas listen [::]:443

je me suis aider de tes infos pour faire mon fichier

Hors ligne

#8 Le 03/08/2014, à 21:54

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Explication de « [::]:443 » :
- les crochets pour dire que c'est de l'IPv6
- « :: » pour dire "n'importe quelle adresse"
- 443 pour le port

je me suis aider de tes infos pour faire mon fichier

Alors montre ta nouvelle configuration et les erreurs que tu as dans les logs avec cette configuration.

Dernière modification par tiramiseb (Le 03/08/2014, à 21:55)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#9 Le 03/08/2014, à 21:58

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

j'ai mis l'erreur dans mon post 5

Hors ligne

#10 Le 03/08/2014, à 22:00

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Et la configuration ? Et l'erreur de Nginx ? Et s'il-te-plaît utilise la balise "code" systématiquement...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#11 Le 03/08/2014, à 22:40

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

voici mon fichier de config nginx:

access_log off;
add_header Cache-Control public;
server_tokens off;

# HTTP 80
server {
listen 80;
server_name my.org;
root /var/www;
index index.php index.html index.htm;
client_max_body_size 1000M; #set max upload size
error_page  401 403 404 500 503 /error.html;
return 301 https://$server_name$request_uri;
 
location / {
proxy_pass http://192.168.1.4:80;
try_files $uri $uri/ /index.html;
}

location ~ ^/(pydio|filez|shellinabox) {
rewrite ^ https://$server_name$request_uri? permanent;
}

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIP_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}
}


server {    
 listen 8000; # <--------------------------------------- NGINX PORT jai utilisé listen 8000 car pour seafile il s'agit du port original   
 ssl on; # <-------------------------------------------- SSL    
ssl_certificate /etc/ssl/localcerts/autosigned.crt; # <--------- SSL    
ssl_certificate_key /etc/ssl/localcerts/autosigned.key; # <----- SSL    
root /var/www; 
server_name my.org; # <----------------- CHANGE THIS     
#error_page 497  https://$server_name:$server_port$request_uri;     
 location / {         
fastcgi_pass     127.0.0.1:8000;        
 fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;        
 fastcgi_param   PATH_INFO           $fastcgi_script_name;         
 fastcgi_param   SERVER_PROTOCOL $server_protocol;        
 fastcgi_param   QUERY_STRING        $query_string;        
 fastcgi_param   REQUEST_METHOD      $request_method;        
 fastcgi_param   CONTENT_TYPE        $content_type;        
 fastcgi_param   CONTENT_LENGTH      $content_length;        
 fastcgi_param   SERVER_ADDR         $server_addr;        
 fastcgi_param   SERVER_PORT         $server_port;        
 fastcgi_param   SERVER_NAME         $server_name;        
fastcgi_param   HTTPS   on;        
fastcgi_param HTTP_SCHEME https;         
 access_log      /var/log/nginx/seahub.access.log;        
 error_log       /var/log/nginx/seahub.error.log;    
 }     
#location /seafhttp {         
#rewrite ^/seafhttp(.*)$ $1 break;        
# proxy_pass http://127.0.0.1:8082;        
# client_max_body_size 0;    
# }     
 location /media {         
root /var/www/seafile/seafile-server-latest/seahub; # <-- change: 2014-07-11        
  include /etc/nginx/mime.types; # <--- UNCOMMENT THIS IF CSS FILES AREN'T LOADED    
 } 
}


# https 443
server {
include /etc/nginx/proxy.conf;
listen 443 ssl;
keepalive_timeout 70;
server_name my.org;
root /var/www;
index index.php index.html index.htm;


# ssl config
ssl on;
ssl_certificate /etc/ssl/localcerts/autosigned.crt;
ssl_certificate_key /etc/ssl/localcerts/autosigned.key;

ssl_session_timeout 5m;
ssl_protocols SSLv3 TLSv1.2;
ssl_ciphers RC4:HIGH:!aNULL:!MD5;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;

add_header X-Frame-Options DENY;

# DDOS protection - Tune Values or deactivate in case of issue
# limit_conn conn_limit_per_ip 20;
# limit_req zone=req_limit_per_ip burst=20 nodelay;

# statut for nginx auditing
location /nginx-statut {
stub_status on;
access_log off;
allow 127.0.0.1;
deny all;
}

location /shellinabox/ {
proxy_pass https://localhost:4200;
auth_basic "Access Administrateur";
auth_basic_user_file "/etc/nginx/.htpasswd";
access_log /var/log/nginx/shellinabox.access.log;
error_log /var/log/nginx/shellinabox.error.log;
}


# location /seafile {  
# proxy_pass http://192.168.1.4:8000;                                
# access_log /var/log/nginx/seahub.access.log;                
# error_log /var/log/nginx/seahub.error.log;  
# } 


location /filez{
		access_log      /var/log/nginx/filez.access.log;
		
		location ~ \.php$ {
                        include         fastcgi_params;
                        fastcgi_param   SCRIPT_FILENAME  $document_root$fastcgi_script_name;
                        fastcgi_pass unix:/var/run/php5-fpm.sock;

                }
                if (!-e $request_filename) {
                        rewrite ^/(.*)$ /filez/index.php last;
                }

}

location /pydio/ {
access_log /var/log/nginx/pydio.access.log;
error_log /var/log/nginx/pydio.error.log;
}

location ^~ /pydio/(conf|data) {
        deny all;
}

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIP_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}


}

voici mon fichier d'erreur:

2014/08/03 23:27:05 [error] 5416#0: *2 upstream sent unsupported FastCGI protocol version: 60 while reading response header from upstream, client: 192.168.1.5, server: my.org, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "192.168.1.4:8000"
2014/08/03 23:30:06 [error] 5416#0: *14 upstream sent unsupported FastCGI protocol version: 60 while reading response header from upstream, client: 5.104.224.15, server: my.org, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "my.org:8000"
2014/08/03 23:30:06 [error] 5416#0: *14 upstream sent unsupported FastCGI protocol version: 60 while reading response header from upstream, client: 5.104.224.15, server: my.org, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "my.org:8000"
2014/08/03 23:30:07 [error] 5416#0: *13 upstream sent unsupported FastCGI protocol version: 60 while reading response header from upstream, client: 5.104.224.15, server: my.org, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "my.org:8000"
2014/08/03 23:31:06 [error] 5416#0: *26 upstream sent unsupported FastCGI protocol version: 60 while reading response header from upstream, client: 192.168.1.5, server: my.org, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "192.168.1.4:8000"

et a chaque fois que je mets  https://my.org:8000 ou https://192.168.1.4:8000 j'ai une erreur 502 bad gateway

Dernière modification par duocore (Le 06/08/2014, à 17:19)

Hors ligne

#12 Le 04/08/2014, à 08:14

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

As-tu lancé Seafile en mode fastcgi ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#13 Le 04/08/2014, à 17:20

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

oui j'ai lancé seafile en mode fastcgi par cette commande:

./seahub.sh start-fastcgi

Hors ligne

#14 Le 04/08/2014, à 18:33

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Ok donc ça c'est correct. Par contre euh... NginX en écoute sur le port 8000, vraiment !?!?

server {    
 listen 8000;

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#15 Le 04/08/2014, à 21:04

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

j'ai changer le port en 8001 , cela fonctionne avec 192.168.1.4:8001 mais pour monserveur:8001

La connexion a été réinitialisée
      
      
      
      
      
        
        
          La connexion avec le serveur a été réinitialisée pendant le chargement de la page.
        

        
        

  Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus
    tard ;
  Si vous n'arrivez à naviguer sur aucun site, vérifiez la connexion
    au réseau de votre ordinateur ;
  Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy,
    assurez-vous que TorBrowser est autorisé à accéder au Web.

pouvez vous m'aider

Hors ligne

#16 Le 05/08/2014, à 06:54

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

cela fonctionne avec 192.168.1.4:8001 mais pour monserveur:8001 [...]

Le nom "monserveur" pointe-t-il vers l'adresse 192.168.1.4 ?

Pourquoi mets-tu en écoute sur un port différent alors qu'au début tu avais un "sous-répertoire" ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#17 Le 05/08/2014, à 19:19

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

monserveur est le raspberry sur lequel j'ai mis seafile.

monserveur est l'adresse que je tape quand je ne suis pas en local, alors que 192.168.1.4 est l'adresse locale

je pense que je vais refaire mon install de seafile.

Hors ligne

#18 Le 05/08/2014, à 19:25

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

monserveur est l'adresse que je tape quand je ne suis pas en local, alors que 192.168.1.4 est l'adresse locale

C'est-à-dire ? Ça pointe vers ton adresse publique ?
Si c'est ça, alors tu as probablement une redirection de ton routeur (box?) vers le port 80 de ton Raspberry : il faut alors faire une redirection su port 8001 aussi (ou alors configurer Seafile sur un "sous-répertoire" de ton site, comme tu l'envisageais dès le début : cette solution est mieux).

Autre possibilité, faire du virtual hosting (plusieurs noms qui pointent vers la même adresse IP, c'est alors NginX qui desservira tel ou tel site selon le nom qui est demandé).

je pense que je vais refaire mon install de seafile.

Aucun intérêt, ça semble marcher.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#19 Le 05/08/2014, à 21:06

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

j'ai refais mon fichier nginx:

access_log off;
add_header Cache-Control public;
server_tokens off;

# HTTP 80
server {
listen 80;
server_name monserveur.no-ip.org;
root /var/www;
index index.php index.html index.htm;
client_max_body_size 1000M; #set max upload size
error_page  401 403 404 500 503 /error.html;
return 301 https://$server_name$request_uri;
 
location / {
proxy_pass http://192.168.1.4:80;
try_files $uri $uri/ /index.html;
}

location ~ ^/(pydio|filez|shellinabox|seafile) {
rewrite ^ https://$server_name$request_uri? permanent;
}

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIP_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}
}


# https 443
server {
include /etc/nginx/proxy.conf;
listen 443 ssl;
keepalive_timeout 70;
server_name monserveur.no-ip.org;
root /var/www;
index index.php index.html index.htm;


# ssl config
ssl on;
ssl_certificate /etc/ssl/localcerts/autosigned.crt;
ssl_certificate_key /etc/ssl/localcerts/autosigned.key;

ssl_session_timeout 5m;
ssl_protocols SSLv3 TLSv1.2;
ssl_ciphers RC4:HIGH:!aNULL:!MD5;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;

add_header X-Frame-Options DENY;

# DDOS protection - Tune Values or deactivate in case of issue
# limit_conn conn_limit_per_ip 20;
# limit_req zone=req_limit_per_ip burst=20 nodelay;

# statut for nginx auditing
location /nginx-statut {
stub_status on;
access_log off;
allow 127.0.0.1;
deny all;
}

location /shellinabox/ {
proxy_pass https://localhost:4200;
auth_basic "Access Administrateur";
auth_basic_user_file "/etc/nginx/.htpasswd";
access_log /var/log/nginx/shellinabox.access.log;
error_log /var/log/nginx/shellinabox.error.log;
}

location /seafile {  
#proxy_pass https://localhost:8000;                                
access_log /var/log/nginx/seahub.access.log;                
error_log /var/log/nginx/seahub.error.log;  
fastcgi_pass    127.0.0.1:8000;        
 fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;        
 fastcgi_param   PATH_INFO           $fastcgi_script_name;         
 fastcgi_param   SERVER_PROTOCOL $server_protocol;        
 fastcgi_param   QUERY_STRING        $query_string;        
 fastcgi_param   REQUEST_METHOD      $request_method;        
 fastcgi_param   CONTENT_TYPE        $content_type;        
 fastcgi_param   CONTENT_LENGTH      $content_length;        
 fastcgi_param   SERVER_ADDR         $server_addr;        
 fastcgi_param   SERVER_PORT         $server_port;        
 fastcgi_param   SERVER_NAME         $server_name;        
 fastcgi_param   HTTPS   on;        
 fastcgi_param HTTP_SCHEME https;
} 

 location /seafhttp {
         rewrite ^/seafhttp(.*)$ $1 break;
         proxy_pass https://127.0.0.1:8082;
         client_max_body_size 0;
     }

location /media {
         root /home/seafile/seafile/seafile-server-latest/seahub; # <-- change: 2014-07-11        
 # include /etc/nginx/mime.types; # <--- UNCOMMENT THIS IF CSS FILES AREN'T LOADED    
 }

location /filez{
		access_log      /var/log/nginx/filez.access.log;
		
		location ~ \.php$ {
                        include         fastcgi_params;
                        fastcgi_param   SCRIPT_FILENAME  $document_root$fastcgi_script_name;
                        fastcgi_pass unix:/var/run/php5-fpm.sock;

                }
                if (!-e $request_filename) {
                        rewrite ^/(.*)$ /filez/index.php last;
                }

}

location /pydio/ {
access_log /var/log/nginx/pydio.access.log;
error_log /var/log/nginx/pydio.error.log;
}

location ^~ /pydio/(conf|data) {
        deny all;
}

location ~ \.php$ {
fastcgi_index index.php;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIP_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}


}

apres avoir relancer nginx, que ce sois avec https://monserveur.no-ip.org/seafile ou https://192.168.1.4/seafile
j'accede à seafile mais avec ce message: Sorry, but the requested page could not be found.

Hors ligne

#20 Le 05/08/2014, à 21:09

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Et dans les logs, ça donne quoi ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#21 Le 05/08/2014, à 21:58

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

je ne vois pas de fichier seahub.access.log , ni seahub.error.log

Hors ligne

#22 Le 05/08/2014, à 22:02

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

Pourtant tu les avais déjà avant... Tu les as supprimés entretemps ?
Ça doit bien être là...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#23 Le 05/08/2014, à 22:45

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

pour seahub.access.log:

192.168.1.6 - - [05/Aug/2014:23:34:47 +0200] "GET /seafile HTTP/1.1" 404 2372 "-" "Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0"
192.168.1.6 - - [05/Aug/2014:23:34:52 +0200] "GET /seafile?_=1407274487795 HTTP/1.1" 404 2372 "https://192.168.1.4/seafile" "Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0"

pour seahub.error.log

2014/08/05 23:21:11 [error] 2630#0: *62 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.1.6, server: monserveur.no-ip.org, request: "GET /seafile/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "192.168.1.4", referrer: "https://192.168.1.4/"
2014/08/05 23:23:29 [error] 2864#0: *5 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.1.6, server: monserveur.no-ip.org, request: "GET /seafile HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "192.168.1.4"
2014/08/05 23:28:47 [error] 2632#0: *9 connect() failed (111: Connection refused) while connecting to upstream, client: 5.104.224.246, server: mon serveur.no-ip.org, request: "GET /seafile/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8000", host: "monserveur.no-ip.org", referrer: "https://monserveur.no-ip.org/"

Dernière modification par duocore (Le 05/08/2014, à 23:15)

Hors ligne

#24 Le 06/08/2014, à 07:21

tiramiseb

Re : probleme pour faire fonctionner seafile en https[RESOLU]

(111: Connection refused)

Seafile est-il bien en fonctionnement ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#25 Le 06/08/2014, à 17:20

duocore

Re : probleme pour faire fonctionner seafile en https[RESOLU]

oui seafile est en fonctionnement:

seafile.sh start

seahub.sh start-fastcgi

Hors ligne

Haut de page ↑