Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 18/04/2014, à 16:44

paeschli

Changer disposition clavier Lubuntu 14.04

Bonjour,

Je n'arrive pas à changer la disposition clavier dans Lubuntu 14.04. L'ordinateur se lance avec le clavier US. N'ayant pas trouvé de solution dans le GUI, j'ai tapé

setxkbmap be

dans le terminal mais à chaque reboot je suis à nouveau dans le clavier US.

Quelqu'un a-t-il une solution définitive?

Merci d'avance smile


Intelligence is the ability to avoid doing work, yet getting the work done. - Linus Torvalds

Hors ligne

#2 Le 18/04/2014, à 21:14

Martial34

Re : Changer disposition clavier Lubuntu 14.04

Bonsoir.
Si tu veux sauvegarder la configuration de clavier que tu as choisie, tu dois la sélectionner dans ton terminal :

sudo dpkg-reconfigure keyboard-configuration

Hors ligne

#3 Le 19/04/2014, à 11:26

paeschli

Re : Changer disposition clavier Lubuntu 14.04

J'ai bien suivi les instructions et j'ai mis une configuration Belge, mais au reboot c'est de nouveau la disposition US qui se lance ...

Pourtant le terminal m'avais bien dit: Your console font configuration will be updated the next time your system
boots.

paeschli@paeschli-desktop:~$ setxkbmap be
paeschli@paeschli-desktop:~$ sudo dpkg-reconfigure keyboard-configuration
[sudo] password for paeschli: 
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
WARNING: Unknown X keysym "ISO_Level5_Shift"
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Traitement déclenché pour  initramfs-tools (0.103ubuntu4) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
paeschli@paeschli-desktop:~$ 

Intelligence is the ability to avoid doing work, yet getting the work done. - Linus Torvalds

Hors ligne

#4 Le 19/04/2014, à 15:16

Pierrot86

Re : Changer disposition clavier Lubuntu 14.04

Bonjour,

Pour changer de disposition de clavier graphiquement, tu peux utiliser le "Gestionnaire de disposition de clavier".

Il se trouve dans ton tableau de bord, et prend la forme d'un encadré noir affichant le nom de la disposition (dans ton cas, "US").

Clique droit dessus, puis choisis "Paramètres de Gestionnaire de disposition de clavier".

Dans la fenêtre qui s'affiche, décoche "Garder les dispositions du système". Dans la partie gauche, sous "Dispositions de clavier", clique sur "Ajouter" et choisis la disposition de ton choix. Tu peux ensuite supprimer la disposition US si tu ne l'utilises pas.

Normalement, la configuration sera sauvée au prochain démarrage.

Hors ligne

#5 Le 19/04/2014, à 17:04

paeschli

Re : Changer disposition clavier Lubuntu 14.04

Merci Pierrot86, ça a marché à la perfection. smile

Aurais-tu aussi une astuce pour mettre le num-lock ON par défaut?


Intelligence is the ability to avoid doing work, yet getting the work done. - Linus Torvalds

Hors ligne

#6 Le 19/04/2014, à 17:21

Pierrot86

Re : Changer disposition clavier Lubuntu 14.04

C'est bien détaillé dans la documentation : voir numlockx wink

Hors ligne

#7 Le 19/04/2014, à 18:16

paeschli

Re : Changer disposition clavier Lubuntu 14.04

sudo apt-get -y install numlockx
sudo sed -i 's|^exit 0.*$|# Numlock enable\n[ -x /usr/bin/numlockx ] \&\& numlockx on\n\nexit 0|' /etc/rc.local

a fait l'affaire.

Encore merci pour toute cette aide précieuse smile


Intelligence is the ability to avoid doing work, yet getting the work done. - Linus Torvalds

Hors ligne

#8 Le 12/06/2014, à 05:35

idioteidiote

Re : Changer disposition clavier Lubuntu 14.04

Bonjour
Pardon de me greffer sur votre sujet,
mais le problème que je rencontre sur mon lubuntu 14.04 est quasi similaire..

sauf que moi, ce qui me manque, c'est le choix pour avoir le clavier suisse-français,
le fameux:


qwertzuiopè
asdfghjkléà$
yxcvbnm,.-

voilà... j'ai tenté dans grub.cfg de modifier la ligne fr_FR en fr_CH
on va voir ce que ça donne.... une minute, j'essaie...

eh bien non, c'est râpé.... zut... rezut...

hmm


Fan des Acer Aspire One et de PC anciens pour leur donner une deuxième vie avec Ubuntu.

Hors ligne

#9 Le 13/07/2014, à 19:23

Becane

Re : Changer disposition clavier Lubuntu 14.04

Bonjour,
Pareil pour moi,
Quand je démarre une cession, souvent, le clavier redevient qwerty.
je dois cliquer sur l'icone "Fr" d'IBus pour remettre le clavier en mode azerty.
idem pour le clavier d'un autre portable que j'utilise...


Les gens heureux n'ont pas besoin de se presser.
                                                 
                                                                                     [Proverbe chinois]

Hors ligne

#10 Le 20/07/2014, à 10:37

Grompf

Re : Changer disposition clavier Lubuntu 14.04

idioteidiote a écrit :

Bonjour
Pardon de me greffer sur votre sujet,
mais le problème que je rencontre sur mon lubuntu 14.04 est quasi similaire..

sauf que moi, ce qui me manque, c'est le choix pour avoir le clavier suisse-français,
le fameux:


qwertzuiopè
asdfghjkléà$
yxcvbnm,.-

voilà... j'ai tenté dans grub.cfg de modifier la ligne fr_FR en fr_CH
on va voir ce que ça donne.... une minute, j'essaie...

eh bien non, c'est râpé.... zut... rezut...

hmm

Je me permets de relancer ce sujet : qqn a-t-il une solution pour utiliser le clavier suisse-français sous Lubuntu ?

Hors ligne

#11 Le 22/07/2014, à 21:33

Pierrot86

Re : Changer disposition clavier Lubuntu 14.04

Avez-vous essayé en passant par Menu > Préférences > Méthodes de saisie au clavier, dans l'onglet "Méthode de saisie", la liste déroulante offre le choix "français > French (Switzerland)" ?

Hors ligne

#12 Le 23/07/2014, à 16:57

Grompf

Re : Changer disposition clavier Lubuntu 14.04

J'avais pas vu ça ?
Bon, ben il faudra que je refasse des essais avec Lubuntu...

Hors ligne

#13 Le 10/08/2014, à 22:24

Grompf

Re : Changer disposition clavier Lubuntu 14.04

Pour le clavier suisser romand, j'ai trouvé la solution :
1. clic droit sur l'icône de la nationalité du clavier (En principe "US"); choisir "Paramètres"
2. décocher la case "garder la disposition du système"
3. cliquer sur "+ Ajouter"
4. Dans le menu déroulant, on ne voit pas l'option "French (Switzerland)", mais on voit l'option "German (Switzerland)", avec un drapeau suisse. Cliquer sur le petit triangle à gauche de "German (Switzerland)",
5. Toute une série de sous-options apparaît alors, parmis lesquelles "French (Switzerland)"
...

C'est fait !
Je n'avais pas vu ces petits triangles la première fois !!!!!

J'ai ensuite changé "la méthode de saisie active" (clic droit sur l'icône du clavier, en bas à droite de l'écran). Mais j'avoue ne pas avoir cherché ce qu'est cette méthode de saisie active...

Hors ligne

Haut de page ↑