Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 08/11/2013, à 19:47

Moem

Configuration eth0

Bonjour à tous,

J'ai installé Ubuntu, et un petit problème. Je suis connecté en filaire à Internet. Seulement, ça ne fonctionne pas. Ma carte est bien reconnue (lspci). J'ai bien activé mon interface (ip link set eth0 up). Et j'ai ajouté quelques lignes dans /etc/network/interfaces. Seulement, je pense que le problème vient de ce fichier. J'ai essayé avec :

auto eth0
iface eth0 inet dhcp

Mais ça ne fonctionnait pas. Il y avait une erreur DHCP. Je ne l'ai pas sous la main, mais en gros une erreur comme quoi il ne trouve rien en DHCP.

J'avoue que je ne sais plus trop quoi faire et mes connaissances en réseau ne vont pas plus loin.

Quelqu'un a une idée ?
Merci d'avance et bonne journée !

Hors ligne

#2 Le 08/11/2013, à 20:20

sinbad83

Re : Configuration eth0

Salut,
la meilleure configuration du fichier /etc/network/interfaces est toujours la plus simple:

auto lo
iface lo inet loopback

Donne les retours un par un de

sudo service network-manager restart
ifconfig
nm-tool
lspci | grep -i net
sudo lshw -C network
sudo mii-diag eth0

Dernière modification par sinbad83 (Le 08/11/2013, à 20:20)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#3 Le 08/11/2013, à 22:49

Moem

Re : Configuration eth0

Salut,

Finalement, je pense que ce que j'avais fait ne fonctionnait pas.
En fait, au début je n'avais pas de eth0 de reconnu. Par exemple quand je faisais un ip link set eth0 up, ça me ressortait "no such device". J'ai lu sur Internet qu'une solution était d'éditer le fichier /etc/udev/rules.d/70-persistent-net.rules et y ajouter une ligne pour son eth0. Avec ça mon eth0 apparaissant en faisant un ifconfig -a, mais à priori pas fonctionnel.
Du coup je préfère repartir du début, en effaçant la ligne que j'avais ajoutée dans le fichier de config unet, histoire que tout soit bien fait.

En faisant un ifconfig, j'ai donc :

# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:480 (480.0 B)  TX bytes:480 (480.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:08:ca:34:89:5c  
          inet6 addr: fe80::208:caff:fe34:895c/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:7379 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5561 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7969342 (7.9 MB)  TX bytes:885783 (885.7 KB)

Et

# ip link set eth0 up
Cannot find device "eth0"

Mon fichier /etc/network/interfaces:

# cat /etc/network/interfaces
auto lo
iface lo inet loopback

Et  le lspci :

# lspci | grep -i net
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
05:00.0 Ethernet controller: Atheros Communications Device 1083 (rev c0)

Et le lshw:

# lshw -C network
  *-network               
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 00:08:ca:34:89:5c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=2.6.35-22-generic firmware=N/A ip=192.168.*.* latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:ddc00000-ddc0ffff
  *-network UNCLAIMED
       description: Ethernet controller
       product: Atheros Communications
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:05:00.0
       version: c0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list
       configuration: latency=0
       resources: memory:dc800000-dc83ffff ioport:9000(size=128)

Le nm:

# nm-tool

NetworkManager Tool

State: connected

- Device: wlan0  [AndroidAP] ---------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             connected
  Default:           yes
  HW Address:        00:08:CA:34:x:x

  Capabilities:
    Speed:           65 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *AndroidAP:      Infra, 90:18:7C:B0:x:x, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA2
    ORANGE:          Infra, 0C:82:68:9E:x:x, Freq 2412 MHz, Rate 54 Mb/s, Strength 62 WPA WPA2

  IPv4 Settings:
    Address:         *********
    Prefix:          24 (255.255.255.0)
    Gateway:         ************

    DNS:             **********

Merci d'avance pour votre aide ! smile

Dernière modification par Moem (Le 08/11/2013, à 22:59)

Hors ligne

#4 Le 08/11/2013, à 22:53

toutafai

Re : Configuration eth0

Bonsoir,
donne tous les retours demandé par Simbad83


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#5 Le 08/11/2013, à 22:58

Moem

Re : Configuration eth0

J'ai édité mon message. wink

Hors ligne

#6 Le 09/11/2013, à 00:49

toutafai

Re : Configuration eth0

c'est bien ce que je pensais : que ta carte soit vu par lspci ne signifie pas qu'elle est reconnu, elle est simplement détectée par ubuntu, mais elle n'as pas de module (=pilote) pour être gérée par ubuntu.... donc toute les manipulations effectuées ont étés carrément inutiles !!!

quel version d'ubuntu tu as :

cat /etc/lsb-release
uname -r -m

Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#7 Le 09/11/2013, à 15:00

Moem

Re : Configuration eth0

Salut,

J'ai un Ubuntu 10.10 (j'avais ce CD qui trainait... et je voulais faire la MàJ vers 13.10 mais sans Ethernet...).
Donc forcément,

$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

Et

$ uname -r -m
2.6.35-22-generic i686

Merci ! smile

Hors ligne

#8 Le 09/11/2013, à 15:19

toutafai

Re : Configuration eth0

oups, la c'est un peu vieux effectivement, essaye cela : http://ubuntuforums.org/showthread.php?t=1677122


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#9 Le 09/11/2013, à 15:35

Zakhar

Re : Configuration eth0

Plein de problème avec les chips Ethernet Atheros. Pas la première fois que je vois ça aussi.

Le pauvre, si l'on en croit le thread que tu indiques, il va falloir qu'il en passe par un patch + recompile du driver hmm

A savoir au prochain achat de PC : vérifier qu'il n'y a pas de chip Ethernet Atheros... pas encore "out of the box" sur Linux visiblement ces messieurs d'Atheros.


"A computer is like air conditioning: it becomes useless when you open windows." (Linus Torvald)

Hors ligne

#10 Le 09/11/2013, à 16:27

toutafai

Re : Configuration eth0

heu oui et non, Atheros est (avec Intel), un de ceux qui marchent le plus "out of the box" (a part évidement pour les très récent chipset/matériel)....la c'est un peu de "sa faute" car il est avec une veille version (la 10.10) d'ubuntu, mais cela il ne pouvait pas le savoir, et je me doute bien qu'il ne l'as pas fait exprès...

Concernant la solution, il y a peut être d'autre solutions, je me suis contenté de copié collé la 1 er réponse google, il y en a certainement d'autres...au pire il a du wifi, libre a lui de télécharger une version plus recente qui n'aura pas ce probleme


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#11 Le 09/11/2013, à 17:05

Zakhar

Re : Configuration eth0

Tu as certainement raison pour les Wifi Atheros toutafai, ça a l'air d'être les plus "Linux Friendly" effectivement.

Je ne sais pas si les Ethernet Atheros sont "trop" récent ou pas, mais quoi qu'il en soit ce n'est pas la première fois que je vois des problèmes à leur sujet sur ce forum que je fréquente pas mal. wink


"A computer is like air conditioning: it becomes useless when you open windows." (Linus Torvald)

Hors ligne

#12 Le 14/08/2014, à 19:51

neutrehouse

Re : Configuration eth0

Bonjour

Est ce que le post est toujours actif?

Car j'ai un problème similaire sur un ordi que je viens d'installer sous linux mint qiana 17.

Merci

Hors ligne

Haut de page ↑