Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 15/08/2014, à 06:38

Romn

Plus d'affichage et ordinateur se fige

SalutSur ma nouvelle installation de Ubuntu 14.04, j'ai voulu installer les drivers Catalyst pour ma Radeon HD 7950 pour avoir des réglages plus pointu (par exemple le rafraichissement de l'écran à 120Hz comme j'ai un écran compatible), j'ai suivi la procédure ici : http://doc.ubuntu-fr.org/catalyst (en fait juste fait un apt install fglrx) et depuis je ne peux plus démarrer Ubuntu.
Quand je démarre j'ai une fenêtre "The system is running in low-graphics mode", quelque soit le choix que je fais après l'ordinateur reste figé et je ne peux plus rien faire.

En mode recovery je peux me connecter en ligne de commande.
J'ai voulu repasser au Xorg de base en suivant la section 3.1 de cette page : http://doc.ubuntu-fr.org/radeon
Malheureusement je ne peux pas générer de nouveau xorg.cong, j'ai une erreur :"Number of created screens does not match number of detected devices".

xrandr renvoie :"Can't open display".

Que puis-je faire pour réparer ça ?
Comment dois-t'on installer les drivers ATI normalement ? Qu'ai je fais de mal ?

Merci !

EDIT: J'ai oublié de détailler ma config :
- Core i5-3570K / 3.80 GHz
- MSI Z77A-G45
- Sapphire Radeon HD7950 FleX Version OC - 3 Go
- 2*4 Go Kingston DD3 1600 CL9

Dernière modification par Romn (Le 15/08/2014, à 06:39)

Hors ligne

#2 Le 15/08/2014, à 06:41

PPdM

Re : Plus d'affichage et ordinateur se fige

Le fichier  de conf n'est plus utilisé.
pour commencer

sudo remove flgrx --purge

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#3 Le 15/08/2014, à 06:45

Romn

Re : Plus d'affichage et ordinateur se fige

"Impossible de trouver le paquet flgrx"

J'ai déjà fait en essayant, de récupérer la configuration de base :

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon 
sudo apt-get install xserver-xorg-video-radeon
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core 
sudo dpkg-reconfigure xserver-xorg
sudo Xorg -configure

Dernière modification par Romn (Le 15/08/2014, à 06:46)

Hors ligne

#4 Le 15/08/2014, à 07:17

PPdM

Re : Plus d'affichage et ordinateur se fige

Ça dit quoi?

apt-cache show xserver-xorg-video-ati

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#5 Le 15/08/2014, à 11:32

Romn

Re : Plus d'affichage et ordinateur se fige

Ca donne les info sur le paquet :

Ce paquet fournit le pilote "ati" ...
...
Ce paquet a été compilé à partir du module pilote X.org xf86-video-ati
...

Je ne sais pas si tu as besoin d'info en particulier ou juste savoir s'il trouve le paquet.

Hors ligne

#6 Le 15/08/2014, à 11:40

PPdM

Re : Plus d'affichage et ordinateur se fige

OK, alors cela devrait fonctionner

sudo remove --purge ati*

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#7 Le 15/08/2014, à 22:04

Romn

Re : Plus d'affichage et ordinateur se fige

J'ai beaucoup d'erreurs en faisant cette commande et il ne supprime aucun packages :

Package 'cpp11-migrate-3.5' is not installed so not removed
Certains paquets ne peuvent être installés. Ceci peut signifier que vous avez demandé l'impossible... (:|)
...
E: Erreur, pkgProblem:: Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Toujours pas d'amélioration.

Hors ligne

#8 Le 16/08/2014, à 00:01

Romn

Re : Plus d'affichage et ordinateur se fige

Comme c'était une nouvelle installation, j'ai finalement formaté et réinstallé Ubuntu. C'est triste, j'avais vraiment envie de ne pas faire ça et de comprendre comment réparer (au cas où ça m'arrive plus tard sur une installation importante).

En tout cas merci pour ton aide. smile

Hors ligne

#9 Le 16/08/2014, à 02:51

Romn

Re : Plus d'affichage et ordinateur se fige

Ah bah ça y est tout est replanté comme la fois d'avant.

J'ai réinstallé Ubuntu, remis le drivers ATI uniquement avec le GUI, redémarré une ou deux fois et tout allait bien. J'ai commencé à installer les logiciels dont j'allais avoir besoin, j'ai ré-éteint mon ordi pour partir faire une course et maintenant il ne redémarre plus, j'ai le même problème qu'avant : "The system is running in low-graphics mode".cry.gif

Hors ligne

#10 Le 16/08/2014, à 06:00

PPdM

Re : Plus d'affichage et ordinateur se fige

ouvre une console :Ctrl+Alt+F1   Ctrl+Alt+F7 pour revenir en GUI

sudo apt-get install ubuntu-drivers-common
sudo  reboot

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#11 Le 16/08/2014, à 11:31

Romn

Re : Plus d'affichage et ordinateur se fige

Ctrl+Alt+F1/7 ne donne rien, la seule manière que j'ai pour avoir la main sur mon ordi c'est de démarrer en recovery et de choisir "Passer sur une console administrateur"' (et j'active la prise en charge du réseau avant).

sudo apt-get install ubuntu-drivers-common

Donne "ubuntu-drivers-common est déjà la plus récente version disponible" et il ne fait rien, après reboot c'est toujours coincé.

Hors ligne

#12 Le 16/08/2014, à 12:31

PPdM

Re : Plus d'affichage et ordinateur se fige

Oula !!  Je croyais que c'etait un simple plantage du serveurX en fait c'est beaucoup plus profond que ça.
En désespoir de cause tente ça, mais je ne garanti rien
Avant, n'oublie pas d'activer le réseau sion ça ne fonctionnera pas

sudo apt-get update && sudo apt-get install -f

Dernière modification par PPdM (Le 16/08/2014, à 12:31)


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#13 Le 16/08/2014, à 22:02

Romn

Re : Plus d'affichage et ordinateur se fige

Oui, un plantage de Xserver, je pense que j'aurais réussi à le rétablir, mais là je ne vois vraiment pas ce que je peux faire.

Hors ligne

#14 Le 16/08/2014, à 23:22

PPdM

Re : Plus d'affichage et ordinateur se fige

Tu as fais ma commande ?
Si oui, cela donne quoi ?

Dernière modification par PPdM (Le 16/08/2014, à 23:23)


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#15 Le 16/08/2014, à 23:30

Romn

Re : Plus d'affichage et ordinateur se fige

Ca dit que tout est à jour et ça ne change rien.

Je viens de réinstaller encore Ubuntu, et ce coup-ci j'ai tenté l'installation avec le driver téléchargé sur le site d'AMD, on va voir si ça tient encore après quelques reboot.

Hors ligne

#16 Le 17/08/2014, à 00:15

Romn

Re : Plus d'affichage et ordinateur se fige

Bon bilan, après avoir reboot plusieurs fois (> 4 avec un démarrage sur ma partition Windows (installée sur un disque indépendant)) ça replante, mais différemment avec ce nouveau driver : j'arrive à la fenêtre de connexion, je rentre mon mot de passe et je reste bloqué sur l'écran d'après (ça doit être la fin de lightdm mais pas encore Ubuntu).
Là par contre le Ctrl+Alt+F1 fonctionne et j'ai pu désinstaller le driver Ati et retourner à la configuration par défaut. smile

Mais c'est bizarre que ça plante à ce point quand même, bon et du coup j'ai pas moyen de passer mon écran en 120Hz. hmm

Dernière modification par Romn (Le 17/08/2014, à 00:17)

Hors ligne

Haut de page ↑