Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 16/05/2008, à 18:35

Bionet

[Résolu] configurer modem interne ISDN RNIS Numeris

Bonjour,

tout d'abord je voulais préciser que je suis à Mayotte (île aux moyens de communication préhistoriques où l'on se connectes en bas débit 56K ou en Numéris 64K).

Alors voilà, j'ai un modem interne ISDN (RNIS, NUMERIS) qui fonctionne très bien sous Windows. Mais comme cela fait 10 ans que j'utilise Linux (et 3 ans Ubuntu) je souhaite configurer cette carte également pour mon système préféré.

J'ai une carte AVM fritz card mais le tutoriel http://doc.ubuntu-fr.org/modem_isdn ne me donnes aucun résultat. Peut-être que la procédure de configuration a changé depuis la version "hoary" d'Ubuntu.

J'ai bien fais les choses suivantes :

Marche à suivre pour activer l'isdn sous hoary :

   1.      Installez les paquets linux-restricted-modules-generic (afin d'obtenir les pilotes avm binaires) et avm-fritz-firmware (pour récupérer le progiciel)
   2.      Éditez le fichier /etc/modules et ajoutez à la fin: capi

Mais le paquet linux-restricted-modules-generic était déjà installé (donc pas besoin de l'installer).

Ensuite, les fichiers cités dans le tutoriel n'existaient pas d'office après l'installation des pilotes avm-frit. Je ne pouvais donc pas les modifier.

Enfin, le modem (qui est reconnu d'office par le live-CD d'install d'Ubuntu) n'est pas reconnu par wvdial dont voici les réponses :

patrice@patrice-desktop:~$ wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
patrice@patrice-desktop:~$ wvdialconf 
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

WvModem<*1>: Cannot set information for serial port.
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.

Alors si quelqu'un a une piste pour que je puisse utiliser ce fichu modem interne je suis bien évidemment preneur big_smile

Dernière modification par Bionet (Le 18/05/2008, à 11:44)

Hors ligne

#2 Le 16/05/2008, à 20:20

snapshot

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Je pense que le modem est créé sous un nom différent de /dev/modem, reste à trouver lequel...

Il faudrait regarder dans /var/log/syslog pour savoir ce qui a été créé.

Connais-tu le nom du module correspondant à ce modem ?


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#3 Le 17/05/2008, à 09:51

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

J'ai repris toute l'installation depuis le début :

- Après avoir installé Ubuntu 8.04

- Aller dans Système/administration/Gestionnaire de paquets synaptic

- Dans le Gestionnaire de paquets aller dans Configuration/Dépôts

- Décocher toutes les cases déjà  cochées et cocher la case pour "CDRom contenant Ubuntu 8.04" puis fermer la fenètre

- Cliquer sur le bouton "Recharger" du gestionnare de paquets synpatic

- Cliquer sur "Rechercher" et saisir le mot-clé "ISDN"

- Clic droit sur l'icône à  gauche de "avm-fritz-firmware" et choisir "Sélectionner pour l'installation". Accepter tous les packages supplémentaire que le gestionnaire de paquets synpatic vous proposera.

- Cliquer sur "Appliquer" (sur le gestionnaire de paquets synaptic)
1211017196_install_avm_fritz_firmware.png

- La commande "ls /dev/.static/dev" donne le résultat suivant :

patrice@biotechno:/dev/.static/dev$ ls
agpgart    capi20.08  dsp1   loop1   midi3       ram11   raw1394    tty
audio      capi20.09  dsp2   loop2   mixer       ram12   rmidi0     tty0
audio1     capi20.10  dsp3   loop3   mixer1      ram13   rmidi1     tty1
audio2     capi20.11  fd     loop4   mixer2      ram14   rmidi2     tty2
audio3     capi20.12  full   loop5   mixer3      ram15   rmidi3     tty3
audioctl   capi20.13  i2c-0  loop6   mpu401data  ram16   sequencer  tty4
capi20     capi20.14  i2c-1  loop7   mpu401stat  ram2    shm        tty5
capi20.00  capi20.15  i2c-2  mem     null        ram3    smpte0     tty6
capi20.01  capi20.16  i2c-3  midi0   port        ram4    smpte1     tty7
capi20.02  capi20.17  i2c-4  midi00  ptmx        ram5    smpte2     tty8
capi20.03  capi20.18  i2c-5  midi01  pts         ram6    smpte3     tty9
capi20.04  capi20.19  i2c-6  midi02  ram         ram7    sndstat    urandom
capi20.05  console    i2c-7  midi03  ram0        ram8    stderr     xconsole
capi20.06  core       kmem   midi1   ram1        ram9    stdin      zero
capi20.07  dsp        loop0  midi2   ram10       random  stdout

- La commande "sudo wvdialconf" donne le résultat suivant :

patrice@biotechno:/dev/.static/dev$ sudo wvdialconf
[sudo] password for patrice: 
Editing `/etc/wvdial.conf'.
Scanning your serial ports for a modem.
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   
Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?
Please read the FAQ at http://open.nit.ca/wiki/?WvDial
If you still have problems, send mail to <wvdial-list@lists.nit.ca>.

A ce moment là , le fichier /var/log/syslog contient :

May 17 15:02:07 biotechno syslogd 1.5.0#1ubuntu1: restart.
May 17 15:02:07 biotechno anacron[5517]: Job `cron.daily' terminated (exit status: 1) (mailing output)
May 17 15:02:07 biotechno anacron[5517]: Can't find sendmail at /usr/sbin/sendmail, not mailing output
May 17 15:03:35 biotechno kernel: [  527.711839] UDF-fs: No VRS found
May 17 15:03:36 biotechno kernel: [  527.744517] ISO 9660 Extensions: Microsoft Joliet Level 3
May 17 15:03:36 biotechno kernel: [  527.781484] ISO 9660 Extensions: RRIP_1991A
May 17 15:03:47 biotechno kernel: [  539.237172] capifs: Rev 1.1.2.3
May 17 15:05:30 biotechno anacron[5517]: Job `cron.weekly' started
May 17 15:05:30 biotechno anacron[7472]: Updated timestamp for job `cron.weekly' to 2008-05-17
May 17 15:05:31 biotechno syslogd 1.5.0#1ubuntu1: restart.
May 17 15:05:31 biotechno anacron[5517]: Job `cron.weekly' terminated
May 17 15:10:30 biotechno anacron[5517]: Job `cron.monthly' started
May 17 15:10:30 biotechno anacron[7971]: Updated timestamp for job `cron.monthly' to 2008-05-17
May 17 15:15:25 biotechno anacron[5517]: Job `cron.monthly' terminated (mailing output)
May 17 15:15:25 biotechno anacron[5517]: Can't find sendmail at /usr/sbin/sendmail, not mailing output
May 17 15:15:25 biotechno anacron[5517]: Normal exit (3 jobs run)

[...] suite au prochain post

Dernière modification par Bionet (Le 17/05/2008, à 11:57)

Hors ligne

#4 Le 17/05/2008, à 11:49

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Suite du message précédent [...]

- Redémarrage de la machine

- Au redémarrage, un icône "nouveaux pilotes propriétaires en cours d'utilisation" apparaît en haut à  droite de Gnome

- Lorsqu'on clique sur cet icône on peut constater que le pilote "CAPI4Linux: Driver for AVM Fritz!card PCI" est bien déclaré comme "Activé" et "en cours d'utilisation".

- Après le redémarrage, dans le fichier /var/log/syslog, il y a :

May 17 15:19:16 biotechno kernel: [   26.651637] Linux agpgart interface v0.102
May 17 15:19:16 biotechno kernel: [   26.710923] agpgart: Detected VIA KT400/KT400A/KT600 chipset
May 17 15:19:16 biotechno kernel: [   26.715791] agpgart: AGP aperture is 64M @ 0xf8000000
May 17 15:19:16 biotechno kernel: [   26.758052] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
May 17 15:19:16 biotechno kernel: [   26.811098] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
May 17 15:19:16 biotechno kernel: [   26.918019] CAPI Subsystem Rev 1.1.2.8
May 17 15:19:16 biotechno kernel: [   26.923391] fcpci: module license 'Proprietary' taints kernel.
May 17 15:19:16 biotechno kernel: [   27.024485] fcpci: AVM FRITZ!Card PCI driver, revision 0.7.2
May 17 15:19:16 biotechno kernel: [   27.024491] fcpci: (fcpci built on Apr 10 2008 at 23:06:14)
May 17 15:19:16 biotechno kernel: [   27.024493] fcpci: -- 32 bit CAPI driver --
May 17 15:19:16 biotechno kernel: [   27.024602] ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 19
May 17 15:19:16 biotechno kernel: [   27.024608] fcpci: AVM FRITZ!Card PCI found: port 0xb800, irq 19
May 17 15:19:16 biotechno kernel: [   27.024611] fcpci: Loading...
May 17 15:19:16 biotechno kernel: [   27.024614] fcpci: Driver 'fcpci' attached to fcpci-stack. (152)
May 17 15:19:16 biotechno kernel: [   27.252991] fcpci: Stack version 3.11-07
May 17 15:19:16 biotechno kernel: [   27.427949] input: Power Button (FF) as /devices/virtual/input/input2
May 17 15:19:16 biotechno kernel: [   27.437059] ACPI: Power Button (FF) [PWRF]
May 17 15:19:16 biotechno kernel: [   27.437202] input: Power Button (CM) as /devices/virtual/input/input3
May 17 15:19:16 biotechno kernel: [   27.452662] ACPI: Power Button (CM) [PWRB]
May 17 15:19:16 biotechno kernel: [   29.193612] kcapi: Controller [001]: fcpci-b800-19 attached
May 17 15:19:16 biotechno kernel: [   29.193617] kcapi: card [001] "fcpci-b800-19" ready.
May 17 15:19:16 biotechno kernel: [   29.193681] fcpci: Loaded.

Je n'arrive toujours pas à comprendre comment faire pour que wvdial utilises ce modem.

à bientôt,

PS : promis, dès que ça marche je mets à jour la doc à ce sujet sur le wiki. cool

Dernière modification par Bionet (Le 17/05/2008, à 13:35)

Hors ligne

#5 Le 17/05/2008, à 14:00

snapshot

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

humm... intéressant !

CAPI est l'interface ISDN de linux semble-t-il. Il faut paramétrer wvdial spécialement pour que ça puisse marcher. Ce n'est plus une question de brancher wvdial sur /dev/modem ou /dev/.static/dev/capi20 (as-tu essayé ?) car à mon avis, il ne sert à rien d'attendre une porteuse sur due l'ISDN... j'ai entendu parler d'un plugin CAPI pour wvdial, je continue les recherches


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#6 Le 17/05/2008, à 14:12

snapshot

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Je me demande si tu as bien besoin de wvdial justement... Il est destiné à coller ensemble un modem et PPP. Mais une carte ISDN n'est psa un modem !

Je viens de trouver qu'il y a un package pppdcapiplugin...


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#7 Le 17/05/2008, à 14:29

snapshot

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

je crois bien avoir trouvé ici ! http://occidopagus.nl/linux/capi.html#id835911
Pas besoin de wvdial

Tu installe le package pppdcapiplugin

Tu crées ce fichier dans /etc/ppp/peers/<ton FAI>

Tu mets ceci :

sync
noauth
user <ton login>
plugin userpass.so
password <ton mot de passe>
defaultroute
plugin capiplugin.so
number <le N° de téléphone>
protocol hdlc
ipcp-accept-local
ipcp-accept-remote
/dev/null

Et pour te connecter : pppd call <ton FAI>

Dernière modification par snapshot (Le 17/05/2008, à 14:30)


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#8 Le 17/05/2008, à 15:26

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Bonjour,

- le package en question se trouve ici https://launchpad.net/ubuntu/hoary/i386 … 3-4ubuntu1 (mais il est également sur le CD d'Ubuntu).

- installation du plugin pppdcapiplugin (voir image)
1211039486_pppdcapiplugin.png

- copie du texte suivant dans /etc/ppp/peers/orange (fichier créé pour l'occasion où l'on remplace les login, mdp et téléphone par les coordonnées du FAI) :

sync
noauth
user <ton login>
plugin userpass.so
password <ton mot de passe>
defaultroute
plugin capiplugin.so
number <le N° de téléphone>
protocol hdlc
ipcp-accept-local
ipcp-accept-remote
/dev/null

Ajout du module capi au démarrage (on édite le fichier /etc/modules et on ajoute "capi" à la fin) :

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
capi

- Créer la connexion à l'aide de l'outil situé dans le menu Système ⇒ Administration ⇒ Réseau

1211039384_config_utilitaire_reseau.png

On a bien un "modem RNIS" qui est apparu, mais la case à cocher en face de la connection avec modem ISDN refuse de rester cochée.


- Redémarrage de l'ordinateur

- Essai de la commande "pppd call orange" et "pon ppp0". Pas de message d'erreur mais l'ordinateur n'est pas connecté.

patrice@biotechno:~$ pon ppp0
Plugin capiplugin.so loaded.
capiplugin: $Revision: 1.36 $
capiconn:  1.13 
patrice@biotechno:~$ pppd call orange
Plugin userpass.so loaded.
userpass: $Revision: 1.5 $
Plugin capiplugin.so loaded.
capiplugin: $Revision: 1.36 $
capiconn:  1.13

- Voici la réponse à  la commande "capiinfo" :

patrice@biotechno:~$ sudo capiinfo
Number of Controllers : 1
Controller 1:
Manufacturer: 
CAPI Version: 2.0
Manufacturer Version: 49.23
Serial Number: 1000001
BChannels: 0
Global Options: 0x00000000
B1 protocols support: 0x00000000
B2 protocols support: 0x00000000
B3 protocols support: 0x00000000

  0100
  0000
  00000000
  00000000
  00000000
  00000000
  00000000 00000000 00000000 00000000 00000000 00000000
  00000000 00000000 00000000 00000000 00000000

Supplementary services support: 0x000003ff
   Hold / Retrieve
   Terminal Portability
   ECT
   3PTY
   Call Forwarding
   Call Deflection
   MCID
   CCBS

-Il y a un répertoire "isdn" qui s'est créé tout seul dans /etc/ppp/peers/. Il contient plusieurs fichiers ressemblants au fichier "orange" précédemment créé. Mais aucun fichier d'aide ou de config.

En bref, ça ne fonctionne toujours pas mais c'est peut-être également du au fonctionnement d'Orange et France-Télécom sur Mayotte. En effet, sous Windows il faut se reconnecter de nombreuses fois avant d'avoir une connection stable. C'est possible que les utilitaires Linux ne soient pas prévus pour des connections ISDN merdiques à ce point. Je vais réessayer la commande "pppd call orange" vers 3h00 du matin car le réseau est relativement plus tranquille à ces heures nocturnes.

Dernière modification par Bionet (Le 17/05/2008, à 17:57)

Hors ligne

#9 Le 18/05/2008, à 11:40

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Super,

je me connectes depuis Linux avec mon modem interne ISDN. Mais ce n'est pas vraiment aussi simple qu'il n'y paraît. La faute incombe essentiellement à France-Telecom et Orange sur Mayotte qui fournissent un service vraiment exécrable.

Je m'explique :

pour se connecter avec son modem ISDN interne, tous les packages sont sur le CD de Hardy. Il faut installer les paquets "avm-fritz-firmware" et très certainement "pppdcapiplugin" (bien que je n'en suis pas certain pour ce dernier)

Ensuite il faut configurer le lancement automatique du module CAPI (voir quel fichier modifié ci-avant).

Ensuite il faut configurer sa connection avec l'outil Système => Administration => Réseau en choisissant modem ISDN comme modem.

Redémarrer Ubuntu pour lancer le modul CAPI ou saisir "sudo capiinit" dans une console.

Dans  l'outil Système => Administration => Réseau cocher la case correspondant à la connection et normalement ça se connectes.

Si la case se décoche automatiquement c'est que la connection se fait mal (c'est le cas à Mayotte). La nouvelle tentative de connection ne se fera pas toute seule à priori (et c'est bien le principal point d'achopement par rapport à l'outil sous MS Windows sui recompose tout seul jusqu'à reconnection). Il faudra recocher la case pour tenter une nouvelle connection (et c'est long : environ 25 sec à chaque fois, alors quand il faut le faire 48 fois comme ce que je viens de faire cela devient pénible).

Mais ça marche big_smile

Ci-joint les captures d'écran en attendant que je trouve une procédure plus claire pour modifier la doc du Wiki à ce niveau :

Tentative de connection (en cours après avoir cocher la case) :
1211103238_tentative_connexion.png

Connection ratée (la case s'est décochée au bout de 3 secondes) :
1211103334_tentative_connexion_ratee.png

Connection réussie (la case reste cochée tant que la connection n'est pas coupée arbitrairement par France-Telecom !) :
1211103557_tentative_reussie.png


Il ne reste plus qu'à peaufiner la chose que que la méthode soit reproductible et surtout à 100% fonctionnelle à Mayotte, certainement la dernière zone au monde à utiliser l'ISDN !!!

Hors ligne

#10 Le 18/05/2008, à 11:43

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

J'oubliais que, pour ne pas avoir de faux-négatifs dans les connections ISDN, il faut corriger le paramétrage par défaut de Firefox :

Dans Edition => Préférences => Avancé => Réseau  => Paramètres, cocher "Pas de Proxy" et redémarrer Firefox.

Hors ligne

#11 Le 19/05/2008, à 10:34

mavosaure

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Hello!

Je suis venu voir si tu t'en sortais...

Une petite suggestion, par rapport à mon expérience pour paramétrer mon softmodem 56k. En passant par
Système => Administration => Réseau
on n'a quasi aucune option pour configurer wvdial (mais est ce que tu passes encore par wvdial avec ta dernière méthode?).
Par contre en passant Gnome-PPP (qui interface wvdial, tout comme l'applet "Réseau" de Gnome)doit gérer les modem ISDN. Il est un peu rustique mais permet de tester la reconnaissance du modem et de bien paramétrer les options de (re)numérotation et la conduite à tenir en cas d'échec...

Dis moi ce que ça donne si tu as l'occasion d'essayer...


Xub'

Hors ligne

#12 Le 19/05/2008, à 12:36

snapshot

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Justement, la difficulté ici est que l'on n'a pas affaire à un modem : pas de séquence AT à envoyer, donc pas de wvdial.  En fait pppd communique directement avec la carte ISDN en passant pas une API spéciale appelée CAPI.

Paradoxalement, c'est certainement plus facile à configurer puisqu'on est en numérique de bout en bout, sauf qu'on n'a généralement plus l'habitude de le faire puisque que (quasiment) tout le monde est en ADSL et qu'il manque clairement de la doc sur ce sujet


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#13 Le 19/05/2008, à 16:26

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Bonjour,

merci pour ces pistes supplémentaires. Je pense que la solution trouvée précédemment permet - dans l'absolu - de se connecter en ISDN. Le seul problème que je rencontre c'est que j'ai réussi à me connecter qu'une seule fois, le temps de faire les mises à jour de sécurité et la francisation du système.

Il n'aurait pas fallu que je redémarre l'ordinateur car je n'ai plus jamais réussi (plus de 25 tentatives) à me reconnecter.

Je réessaierai une fois tard dans la nuit mais je vais attendre le prochain WE pour le faire histoire de ne pas m'achever ma semaine de boulot neutral

Vraiment, il faudrait qu'une association de consommateurs fasse mordre la poussière à France-Telecom + Orange qui se foutent vraiment de la gueule du monde sur Mayotte. Ils se permettent de continuer à vendre des forfaits internet (et de l'ISDN) alors que, visiblement, leur infrastructure ne tient pas la charge. Il y a bien un petit opérateur (STOI) qui propose un faux haut-débit en WiFi mais il ne couvre qu'une toute petite partie de l'île et évidemment pas là où j'habite !

C'est vraiment la dèche au niveau communication ces départements ou collectivités d'outre-mer. Je vous laisse imaginer à quel point c'est galère pour les procédures officielles dans les établissements scolaires (ASSR, mutations des enseignants, inscription des élèves, poursuites d'étude en métropole...) car tout passe par internet dorénavant et nous on est encore à l'internet "signaux de fumée par temps de brouillard".

à bientôt

Hors ligne

#14 Le 19/05/2008, à 18:20

Bionet

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Ouaiiiiiii !

Il y a eu la coupure d'électricité fatale. Comme ça arrive assez souvent, la dernière coupure d'électricité de ce soir (qui a tout de même duré plus d'1h) a remis à zéro toutes les connections internet de Mayotte.

Alors dès que le courant est revenu j'ai pu me connecter directement.

Voici la manip : il suffit (à partir du moment où la case est bien cochée dans l'outil réseau, comme énnoncé ci-avant) de cliquer gauche sur le nm-applet (icone de connection réseau en haut à droite de gnome) et choisir "Connexion à distance => se connecter à ppp0 via modem..." et là ça se connectes directement.

1211214373_connection_isdn.png

Voilà,

et dommage pour ceux qui n'avaient pas de prise anti sur-tension à Mayotte ce soir car je pense que le pic de tension avant la coupure a du faire pas mal de dégâts informatique mad

Dernière modification par Bionet (Le 19/05/2008, à 18:26)

Hors ligne

#15 Le 19/05/2008, à 19:38

frasq

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Pire que Mayotte ? Les Vosges ! Toujours pas d'ADSL dans mon village et environ 100 coupures de courant par an, à chaque orage ou sans raison.

A propos de Numéris/ISDN, j'ai passé des dizaines d'heures sur le sujet, sans succès jusqu'à la version 8.04 d'Ubuntu, mais pas sans mal. En fait, comme souvent, une fois qu'on a compris comment configurer isdnutils et le pilote du modem, c'est assez simple. Sauf que la version du pilote ISDN de la version 2.6.24-16 du kernel que j'ai installé a un bug énorme :

http://bugzilla.kernel.org/show_bug.cgi?id=9923

Notez bien le numéro du rapport de bug : 9923.

J'ai appliqué le patch, compilé et installé le module i4l corrigé, et tout marche parfaitement. La révision suivante du kernel devrait normalement inclure la correction.

J'ai un modem France Telecom :

Network controller: Cologne Chip Designs GmbH ISDN network controller [HFC-PCI] (rev 02)

Jusqu'à présent, je n'arrivais pas à faire fonctionner le pilote. Depuis Ubuntu 8.04, il suffit de le lancer à la main :

modprobe type=35 protocol=2

ou dans /etc/modules :

isdn
hisax

avec la ligne suivante dans /etc/modprobe.d/hisax :

options hisax type=35 protocol=2

Vérifiez dans /var/log/syslog que HiSax est bien démarré :

May 19 13:08:13 gway kernel: [  178.582302] HiSax: Version 3.5 (module)
May 19 13:08:13 gway kernel: [  178.582306] HiSax: Layer1 Revision 2.46.2.5
May 19 13:08:13 gway kernel: [  178.582309] HiSax: Layer2 Revision 2.30.2.4
May 19 13:08:13 gway kernel: [  178.582311] HiSax: TeiMgr Revision 2.20.2.3
May 19 13:08:13 gway kernel: [  178.582314] HiSax: Layer3 Revision 2.22.2.3
May 19 13:08:13 gway kernel: [  178.582317] HiSax: LinkLayer Revision 2.59.2.4
May 19 13:08:13 gway kernel: [  178.582335] HiSax: Total 1 card defined
May 19 13:08:13 gway kernel: [  178.582349] HiSax: Card 1 Protocol EDSS1 Id=HiSax (0)
May 19 13:08:13 gway kernel: [  178.582353] HiSax: HFC-PCI driver Rev. 1.48.2.4
May 19 13:08:13 gway kernel: [  178.583541] ACPI: PCI Interrupt 0000:02:0b.0[A] -> GSI 23 (level, low) -> IRQ 19
May 19 13:08:13 gway kernel: [  178.583557] HiSax: HFC-PCI card manufacturer: CCD/Billion/Asuscom card name: 2BD0
May 19 13:08:13 gway kernel: [  178.583580] HFC-PCI: defined at mem f8e12c00 fifo eda08000(0x2da08000) IRQ 19 HZ 250
May 19 13:08:13 gway kernel: [  178.583589] HFC 2BDS0 PCI: IRQ 19 count 1185
May 19 13:08:13 gway kernel: [  178.583601] HFC_PCI: resetting card
May 19 13:08:13 gway kernel: [  178.701651] HFC 2BDS0 PCI: IRQ 19 count 1220
May 19 13:08:13 gway kernel: [  178.701667] HiSax: DSS1 Rev. 2.32.2.3
May 19 13:08:13 gway kernel: [  178.701672] HiSax: 2 channels added

Notez que le pilote a bien détecté les 2 canaux du modem.

Une fois le modem correctement interfacé, il suffit de lancer PPP avec isdnutils :

/etc/init.d/isdnutils start

Les fichiers de configuration sont dans /etc/isdn.

Essayez la commande isdnconf pour générer une première version.

Editez les fichiers si nécessaire, en particulier isdn.conf :

[GLOBAL]
COUNTRYPREFIX = +
COUNTRYCODE = 33
AREAPREFIX = 0
AREACODE = 8
...

[ISDNCTRL]
INTERFACES = {

  [INTERFACE]
  NAME = ippp0
  PHONE_OUT = 0860888080
  SECURE = on
  DIALMODE = auto
  DIALMAX = 2
  HUPTIMEOUT = 10
  IHUP = on
  CHARGEHUP = off
  L2_PROT = hdlc
  L3_PROT = trans
  ENCAP = syncppp
  PPPBIND = 0
}

Le numéro d'appel 0860888080 est spécifique aux Vosges. Remplacez-le par celui mentionné dans votre contrat Numéris.

Vérifiez la configuration avec isdnctrl :

isdnctrl readconf
isdnctrl list ippp0

Essayez la commande suivante pour appeler le FAI :

isdnctrl dial ippp0

J'ai eu un peu de mal à régler le numéro d'appel. J'ai mis AREACODE à 8 sans trop de conviction. En tout cas, si la connexion échoue, vérifiez le numéro appelé dans /var/log/syslog :

May 19 13:25:38 gway kernel: [  397.104571] ippp0: dialing 1 0860888080...
May 19 13:25:38 gway isdnlog: (HiSax driver detected)
May 19 13:25:38 gway isdnlog: May 19 13:25:38 * tei 91 calling ? with ''  BEARER: Unrestricted digital information, CCITT standardized coding
May 19 13:25:38 gway isdnlog: May 19 13:25:38 * tei 91 callin

#16 Le 10/11/2008, à 21:34

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Frasq,

Tu m'interesse bigrement, j'ai une carte itoo du même type que toi, et je galère depuis la version 7.04, 7.10, 8.04 et maintenant 8.10 d'Ubuntu, j'avais même essayé avec des Mandriva, mais tout ça sans succes.

Pourrais-tu donner une liste complete des paquets à installer, et de la procédure complête pour faire fonctionner tout çà?

Cà fait des années que je me traine XP à cause du RNIS, et XP commence sérieusement à me gonfler (et je ne parle même pas de Vista...) ...

Merci

A+

Hors ligne

#17 Le 11/11/2008, à 08:21

Bionet11

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Bonjour,

pour faire reconnaître automatiquement le modem ISDN en question

paquets à installer (il faut les choisir sur le CD d'install uniquement sinon ça cherche à récupérer directement des versions plus récentes sur internet et ça fait planter l'install... tu pourra toujours mettre à jour après mais il faudra d'abord avoir un modem fonctionnel ! pour cela : Système->administration->sources de logiciels et tu décoches tout  sauf le CD dans tous les onglets et tu lances le Système->Gestionnaire de paquets synaptic et tu fais un "Recharger" pour remettre la liste des paquets à jour du CDRom... il faut que le CD soit dans le lecteur) :

- linux-restricted-modules-generic (en fait ce paquet était déjà installé pour ma part) ;
- avm-fritz-firmware (présent sur le CD d'installation)
- pppdcapiplugin (présent sur le CD d'installation)

ensuite, je ne sais plus si c'est vraiment nécessaire de faire ce qui est indiqué dans la partie "PCI" de l'article suivant : http://doc.ubuntu-fr.org/modem_isdn . Tu peux éventuellement passer directement à l'étape suivante et voir si ça marche direct (et compléter ce forum au cas où par ta version simplifiée).

enfin, dans le Network-Manager applet (nm-applet : 2 petits écrans noirs en haut de l'écran à droite) il faut configurer la connexion (clic gauche -> configuration manuelle -> Déverrouiller -> Connexion point à point -> propriétés) et tu configures ta connexion ISDN qui devrait alors être un choix possible de modem.

Normalement, ça se connecte directement à internet sans manipulation quelle qu'elle soit. Il faudra veiller à ce que le firewall se lance bien automatiquement (ça je ne sais pas encore comment faire : "sudo ufw enable" pour le lancer à chaque fois !).

Pour ma part, j'ai installé Ubuntu 8.04.1 car je souhaite profiter du support à long terme de cette distribution. Je n'installerai pas la distri 8.10 car je ne veux pas risquer d'avoir des soucis avec mon modem ISDN sachant qu'il fonctionne dans les conditions actuelles et que rien n'est garanti dans la version 8.10 (ce type de matériel étant de moins en moins supporté et il va disparaître de lui même car il n'en est plus fabriqué).

bien cordialement,

Patrice

#18 Le 11/11/2008, à 10:37

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Merci pour ta réponse, mais j'ai déjà fait la mise à jour 8.10.

Dois-je, à ton avis, essayer de faire la manip avec le cd 8.10 alternate ou le cd alternate 8.04 ?

Merci

A+

Hors ligne

#19 Le 11/11/2008, à 13:43

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Je viens d'essayer, et ce n'est pas brillant. Je rappelle que j'avais déjà effectué la maj 8.10 depuis le cd alternate.

J'ai lancé le gestionnaire de paquets Synaptic et regardé, dans un premier temps ce qui avait été installé:

il semblerait que j'ai tous les paquets installés sauf avm-fritz-firmware

Le cd 8.10 était bien activé dans synaptic, mais pas de paquet.

J'ai donc décoché le CD 8.10, et coché le cd 8.04, mais j'ai alors un message m'indiquant que les index n'ont pas pu être remplacés ou que les anciens (donc ceux de la 8.10) ont été conservés.

Bref, ce ne semble pas très bien parti ...

Je suppose qu'il n'y a pas moyen de défaire la mise à jour, d'autant que cette mise à jour à supprimé des paquets.

Je viens de récupérer le paquet avm-fritz-firmware-2.6.15-29_3.11+2.6.15.12-29.1_i386.deb sur le site ubuntu

Il me donne une dépendance que j'ai aussi téléchargé: drdsl_1.2.0-0ubuntu1_i386.deb

Je ne suis pas bien sur que ce soit nécessaire.

Comment les installer depuis un répertoire local ?

Comme tu peux le voir, je suis un débutant en linux

Merci

A+

Dernière modification par JujuLand (Le 11/11/2008, à 13:50)

Hors ligne

#20 Le 11/11/2008, à 22:05

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Ca avance doucement, mais ce n'est pas encore çà ...

J'ai installé avm-fritz... en double-cliquant dans le gestionnaire de fichier (appt-get ne fonctionnait pas, message d'erreur)

Pas d'erreur lors de cette install. Je n'ai pas installé drdsl

J'ai fait un lsmod

# lsmod

hisax                 519044  0 
crc_ccitt              10112  1 hisax
isdn                  138720  1 hisax
slhc                   14208  2 ppp_generic,isdn

J'ai essayé le modprobe sans succes

# modprobe type=35 protocol=2
FATAL: Module type=35 not found.

Le syslog me donne çà:

Nov 11 18:46:54 alain-ubuntu kernel: [   44.875150] ISDN subsystem Rev: 1.1.2.3/1.1.2.3/1.1.2.2/1.1.2.3/1.1.2.2/1.1.2.2 loaded
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973611] HiSax: Linux Driver for passive ISDN cards
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973617] HiSax: Version 3.5 (module)
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973622] HiSax: Layer1 Revision 2.46.2.5
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973626] HiSax: Layer2 Revision 2.30.2.4
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973629] HiSax: TeiMgr Revision 2.20.2.3
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973633] HiSax: Layer3 Revision 2.22.2.3
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973636] HiSax: LinkLayer Revision 2.59.2.4
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973654] HiSax: Total 1 card defined
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973670] HiSax: Card 1 Protocol EDSS1 Id=HiSax (0)
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973677] HiSax: HFC-PCI driver Rev. 1.48.2.4
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973710] pci 0000:02:05.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973719] HiSax: HFC-PCI card manufacturer: CCD/Billion/Asuscom card name: 2BD0
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973737] HFC-PCI: defined at mem e0056000 fifo dd928000(0x1d928000) IRQ 17 HZ 250
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973747] HFC 2BDS0 PCI: IRQ 17 count 0
Nov 11 18:46:54 alain-ubuntu kernel: [   44.973764] HFC_PCI: resetting card
Nov 11 18:46:54 alain-ubuntu kernel: [   45.092023] HFC 2BDS0 PCI: IRQ 17 count 35
Nov 11 18:46:54 alain-ubuntu kernel: [   45.092044] HiSax: DSS1 Rev. 2.32.2.3
Nov 11 18:46:54 alain-ubuntu kernel: [   45.092049] HiSax: 2 channels added
Nov 11 18:46:54 alain-ubuntu kernel: [   45.092061] HiSax: MAX_WAITING_CALLS added

Et là, çà se gatte

# /etc/init.d/isdnutils start
 * Starting ISDN services...                                                     *   There is apparently no configuration created yet.
 *   You can create configuration files with the 'isdnconfig' tool.
 *  
 *   If you don't want this warning in future, please create the file
 *      /etc/isdn/noconfig
 *   For more information, see /usr/share/doc/isdnutils-base/HOWTO.isdnutils.gz
 ipppd                                                                   [ OK ]

# Sorry - this system lacks PPP kernel support.
Check whether you configured at least the ippp0 device!
# isdnconf
Le programme 'isdnconf' n'est pas installé actuellement.  Vous pouvez l'installer en tapant :
apt-get install isdnlog
bash: isdnconf : commande introuvable
# apt-get install isdnlog
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet isdnlog n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Aucun paquet ne correspond au paquet isdnlog

Quand je regarde la liste des paquets dans synaptics, j'ai ça:

X  ipppd            for networking over ISDN with syncPPP
-  isdnlog          for logging ISDN calls (and much more)
X  isdnutils-xtools for X ISDN apps (currently only xisdnload and xmonisdn)
X  isdnutils-doc    for extensive documentation (basic docs are of course
                   included with each package)
-  isdnvboxserver   ISDN answering machine, things needed on a server system
X  isdnvboxclient   ISDN answering machine, client side (vbox)

impossible d'activer isdnlog.

Là, je cale ...

Je vais essayer de réinstaller isdnutils, mais je doute ...

A+

Hors ligne

#21 Le 11/11/2008, à 23:03

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Pas moyen d'installer isdnlog, en fait, en regardant de plus prêt, je m'apercois que la mise à jour à remplacé certains paquets et pas d'autre.

Je vais essayer d'installer tous les paquets correspondant à la dernière version. sinon, je recommencerai avec la version correspondant à Hardy.

Si ça fonctionne, çà devrait vouloir dire que c'est ok avec la 8.10, sinon qu'il faudrait désinstaller la dernière version , et sinon, que 8.10 n'aime pas l'ISDN.

A suivre ...

Hors ligne

#22 Le 23/11/2008, à 21:38

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

J'ai pas mal galéré, et ai décidé de repartir à zéro:

- Suppression de l'install (7.10 > 8.04 > 8.10)
- Installation de 7.10
- Installation de paquets manquants (soit depuis le CD, soit depuis des fichiers deb chargés sur le dépot restricted depuis connexion XP)
- capiutils_3.12.20071127-0ubuntu2_i386.deb (pas sur de son utilité)
- isdnlog-data_3.12.20071127-0ubuntu2_all.deb
- isdnlog_3.12.20071127-0ubuntu2_i386.deb
- avm-fritz-firmware-2.6.24-21_3.11+2.6.24.14-21.51_i386.deb
- avm-fritz-firmware_2.6.24.21.23_i386.deb

Après tout ça

********
Logs
********

Nov 23 19:56:20 ubuntu-alain kernel: [   42.779792] CAPI Subsystem Rev 1.1.2.8
Nov 23 19:56:20 ubuntu-alain kernel: [   42.786111] capifs: Rev 1.1.2.3
Nov 23 19:56:20 ubuntu-alain kernel: [   42.813651] capi20: Rev 1.1.2.7: started up with major 68 (middleware+capifs)
Nov 23 19:56:20 ubuntu-alain kernel: [   42.886860] ISDN subsystem Rev: 1.1.2.3/1.1.2.3/1.1.2.2/1.1.2.3/1.1.2.2/1.1.2.2 loaded
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970789] HiSax: Linux Driver for passive ISDN cards
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970795] HiSax: Version 3.5 (module)
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970800] HiSax: Layer1 Revision 2.46.2.5
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970804] HiSax: Layer2 Revision 2.30.2.4
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970807] HiSax: TeiMgr Revision 2.20.2.3
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970813] HiSax: Layer3 Revision 2.22.2.3
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970817] HiSax: LinkLayer Revision 2.59.2.4
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970851] HiSax: Card 1 Protocol EDSS1 Id=HiSax (0)
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970857] HiSax: HFC-PCI driver Rev. 1.48.2.4
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970889] pci 0000:02:05.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970898] HiSax: HFC-PCI card manufacturer: CCD/Billion/Asuscom card name: 2BD0
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970919] HFC-PCI: defined at mem e002c000 fifo ddb18000(0x1db18000) IRQ 17 HZ 250
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970929] HFC 2BDS0 PCI: IRQ 17 count 0
Nov 23 19:56:20 ubuntu-alain kernel: [   42.970947] HFC_PCI: resetting card
Nov 23 19:56:20 ubuntu-alain kernel: [   43.088021] HFC 2BDS0 PCI: IRQ 17 count 35
Nov 23 19:56:20 ubuntu-alain kernel: [   43.088039] HiSax: DSS1 Rev. 2.32.2.3
Nov 23 19:56:20 ubuntu-alain kernel: [   43.088042] HiSax: 2 channels added
Nov 23 19:56:20 ubuntu-alain kernel: [   43.088054] HiSax: MAX_WAITING_CALLS added
.....
Nov 23 19:56:26 ubuntu-alain kernel: [   54.722194] isdn: Verbose-Level is 2
Nov 23 19:56:26 ubuntu-alain ipppd[6965]: Found 1 device: 
Nov 23 19:56:26 ubuntu-alain ipppd[6970]: ipppd i2.2.12 (isdn4linux version of pppd by MH) started
Nov 23 19:56:26 ubuntu-alain ipppd[6970]: init_unit: 0 
Nov 23 19:56:26 ubuntu-alain ipppd[6970]: Connect[0]: /dev/ippp0, fd: 8

********************************
Après modif du fichier isdn.conf
********************************

root@ubuntu-alain:/etc/isdn# isdnctrl readconf

Security for ippp0 is on
Dialmax for ippp0 is 2 times.
Hangup-Timeout for ippp0 is 10 sec.
Incoming-Hangup for ippp0 is on
Charge-Hangup for ippp0 is off
Layer-2-Protocol for ippp0 is hdlc
Layer-3-Protocol for ippp0 is trans
Encapsulation for ippp0 is syncppp
ippp0 bound to 0
ISDN Configuration read from /etc/isdn/isdn.conf.

root@ubuntu-alain:/etc/isdn# isdnctrl list ippp0

Current setup of interface 'ippp0':

EAZ/MSN:                0
Phone number(s):
  Outgoing:             0860888080
  Incoming:             
Dial mode:              auto
Secure:                 on
Callback:               off
Reject before Callback: on
Callback-delay:         5
Dialmax:                2
Hangup-Timeout:         10
Incoming-Hangup:        on
ChargeHangup:           off
Charge-Units:           0
Charge-Interval:        0
Layer-2-Protocol:       hdlc
Layer-3-Protocol:       trans
Encapsulation:          syncppp
Slave Interface:        None
Slave delay:            10
Master Interface:       None
Pre-Bound to:           Nothing
PPP-Bound to:           0

root@ubuntu-alain:/etc/isdn# isdnctrl dial ippp0
Dialing of ippp0 triggered

*******************************
Dans les logs, suite à l'appel:
*******************************

Nov 23 20:04:32 ubuntu-alain kernel: [  540.754350] ippp0: dialing 1 0860888080... 
Nov 23 20:04:32 ubuntu-alain isdnlog: Nov 23 20:04:32 * tei 72 calling ? with ''  BEARER: Unrestricted digital information, CCITT standardized coding 
Nov 23 20:04:32 ubuntu-alain isdnlog: Nov 23 20:04:32 * tei 72 calling ? with ''  64 kbit/s, Circuit mode 
Nov 23 20:04:32 ubuntu-alain isdnlog: Nov 23 20:04:32 * tei 72 calling +33 860888080,  with ''  RING (Data) 
Nov 23 20:04:33 ubuntu-alain isdnlog: Nov 23 20:04:33 * tei 72 calling +33 860888080,  with ''  CHANNEL: BRI, B1 needed 
Nov 23 20:04:33 ubuntu-alain isdnlog: Nov 23 20:04:33 tei 72 calling +33 860888080,  with ''  CONNECT (Data) 
Nov 23 20:04:33 ubuntu-alain isdnlog: Nov 23 20:04:33 tei 72 calling +33 860888080,  with ''  INTERFACE ippp0 calling 0860888080 
Nov 23 20:04:33 ubuntu-alain ipppd[6970]: Local number: 0, Remote number: 0860888080, Type: outgoing
Nov 23 20:04:33 ubuntu-alain ipppd[6970]: PHASE_WAIT -> PHASE_ESTABLISHED, ifunit: 0, linkunit: 0, fd: 8
Nov 23 20:04:33 ubuntu-alain kernel: [  542.036041] isdn_net: ippp0 connected
Nov 23 20:04:33 ubuntu-alain ipppd[6970]: Remote message: 
Nov 23 20:04:33 ubuntu-alain ipppd[6970]: MPPP negotiation, He: No We: No
Nov 23 20:04:33 ubuntu-alain kernel: [  542.205482] Received CCP frame from peer slot(0)
Nov 23 20:04:33 ubuntu-alain kernel: [  542.205498] [0/0].ccp-rcv[0]: 01 01 00 0a 11 06 00 01 01 03 
Nov 23 20:04:33 ubuntu-alain ipppd[6970]: local  IP address 193.250.186.27
Nov 23 20:04:33 ubuntu-alain ipppd[6970]: remote IP address 193.251.96.145
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: Modem hangup
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: Connection terminated.
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: taking down PHASE_DEAD link 0, linkunit: 0
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: closing fd 8 from unit 0
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: link 0 closed , linkunit: 0
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: reinit_unit: 0 
Nov 23 20:04:44 ubuntu-alain ipppd[6970]: Connect[0]: /dev/ippp0, fd: 8
Nov 23 20:04:44 ubuntu-alain kernel: [  552.656022] isdn_net: local hangup ippp0
Nov 23 20:04:44 ubuntu-alain kernel: [  552.656066] ippp0: Chargesum is 0
Nov 23 20:04:44 ubuntu-alain isdnlog: Nov 23 20:04:44 tei 72 calling +33 860888080,  with ''  Normal call clearing (User) 
Nov 23 20:04:44 ubuntu-alain kernel: [  552.660501] ippp_ccp: freeing reset data structure dcc57000
Nov 23 20:04:44 ubuntu-alain kernel: [  552.660952] ippp, open, slot: 0, minor: 0, state: 0000
Nov 23 20:04:44 ubuntu-alain kernel: [  552.660964] ippp_ccp: allocated reset data structure de245000
Nov 23 20:04:45 ubuntu-alain isdnlog: Nov 23 20:04:45 tei 72 calling +33 860888080,  with ''  HANGUP ( 0:00:12 I=169.0 b O=175.0 b)

*****************************************
Dans les logs, suite à un nouvel l'appel:
*****************************************

Nov 23 20:13:08 ubuntu-alain kernel: [ 1056.840721] ippp0: dialing 1 0860888080... 
Nov 23 20:13:08 ubuntu-alain isdnlog: Nov 23 20:13:08 * tei 72 calling ? with ''  BEARER: Unrestricted digital information, CCITT standardized coding 
Nov 23 20:13:08 ubuntu-alain isdnlog: Nov 23 20:13:08 * tei 72 calling ? with ''  64 kbit/s, Circuit mode 
Nov 23 20:13:08 ubuntu-alain isdnlog: Nov 23 20:13:08 * tei 72 calling +33 860888080,  with ''  RING (Data) 
Nov 23 20:13:09 ubuntu-alain isdnlog: Nov 23 20:13:09 * tei 72 calling +33 860888080,  with ''  CHANNEL: BRI, B1 needed 
Nov 23 20:13:09 ubuntu-alain isdnlog: Nov 23 20:13:09 tei 72 calling +33 860888080,  with ''  CONNECT (Data) 
Nov 23 20:13:09 ubuntu-alain isdnlog: Nov 23 20:13:09 tei 72 calling +33 860888080,  with ''  INTERFACE ippp0 calling 0860888080 
Nov 23 20:13:09 ubuntu-alain ipppd[6970]: Local number: 0, Remote number: 0860888080, Type: outgoing
Nov 23 20:13:09 ubuntu-alain ipppd[6970]: PHASE_WAIT -> PHASE_ESTABLISHED, ifunit: 0, linkunit: 0, fd: 8
Nov 23 20:13:09 ubuntu-alain kernel: [ 1058.164038] isdn_net: ippp0 connected
Nov 23 20:13:09 ubuntu-alain ipppd[6970]: Remote message: 
Nov 23 20:13:09 ubuntu-alain ipppd[6970]: MPPP negotiation, He: No We: No
Nov 23 20:13:10 ubuntu-alain kernel: [ 1058.336457] Received CCP frame from peer slot(0)
Nov 23 20:13:10 ubuntu-alain kernel: [ 1058.336473] [0/0].ccp-rcv[0]: 01 01 00 0a 11 06 00 01 01 03 
Nov 23 20:13:10 ubuntu-alain ipppd[6970]: local  IP address 193.250.186.90
Nov 23 20:13:10 ubuntu-alain ipppd[6970]: remote IP address 193.251.96.145
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: Modem hangup
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: Connection terminated.
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: taking down PHASE_DEAD link 0, linkunit: 0
Nov 23 20:13:20 ubuntu-alain kernel: [ 1068.744022] isdn_net: local hangup ippp0
Nov 23 20:13:20 ubuntu-alain kernel: [ 1068.744073] ippp0: Chargesum is 0
Nov 23 20:13:20 ubuntu-alain isdnlog: Nov 23 20:13:20 tei 72 calling +33 860888080,  with ''  Normal call clearing (User) 
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: closing fd 8 from unit 0
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: link 0 closed , linkunit: 0
Nov 23 20:13:20 ubuntu-alain kernel: [ 1068.758895] ippp_ccp: freeing reset data structure de245000
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: reinit_unit: 0 
Nov 23 20:13:20 ubuntu-alain ipppd[6970]: Connect[0]: /dev/ippp0, fd: 8
Nov 23 20:13:20 ubuntu-alain kernel: [ 1068.760932] ippp, open, slot: 0, minor: 0, state: 0000
Nov 23 20:13:20 ubuntu-alain kernel: [ 1068.760954] ippp_ccp: allocated reset data structure de245000
Nov 23 20:13:20 ubuntu-alain isdnlog: Nov 23 20:13:20 tei 72 calling +33 860888080,  with ''  HANGUP ( 0:00:11 I=169.0 b O=175.0 b)

Y'a donc du mieux, puisque la connexion aboutie, et on a même attribution d'une adresse IP.
Par contre, je ne comprends pas pourquoi j'ai une déconnexion (11 ou 12 secondes semble-t-il).

Celà pourrait-il être dû à un paramètre, ou à l'authentification ?

Merci

A+

Hors ligne

#23 Le 24/11/2008, à 17:55

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Bon, après un redémarrage de Ubuntu, la connexion tient.

Je ne sais pas si c'est de cause à effet, ou si le Wanadoo/Orange merdait, mais maintenant la connexion tient.

J'ai encore un problème, car avec la 8.10, il semblerait que les connexions distantes ne soient plus accessibles depuis les divers utilitaires réseaux présents.

Je suis sûr que la connexion est bien établie, car j'ai pu faire la mise à jour système et recevoir mes mails, mais absolument impossible de naviguer avec Firefox ou Epiphany.

Seul l'outil réseau (administrateur) voit le périphérique "Inconnu (ippp0)", et je vois les compteurs de paquets évoluer.

Je me suis fait deux shells pour me connecter ou me déconnecter, mais ils sont rudimentaires, et de plus je ne vois pas l'état de la connexion sous X. Existe-t-il un utilitaire qui gère ce typoe de connexion et puisse l'afficher ?

Je progresse, mais ce n'est pas encore tout à fait le moment de lacher XP...:/

Vivement la ligne d'arrivée.

Si quelqu'un a quelques idées sur mes problèmes résiduels ... qu'il n'hésite pas.

PS: il semble que le forum soit légèrement buggé: sur le post précédent que j'ai voulu modifier (en effet, j'ai installé 8.10 et non 7.10), après modif et envoi, j'ai eu un message d'erreur sur un balise code non fermée. C'était vrai, mais juste du au fait que le message avait, lors du passage en mode édition coupé en longueur.

En reprenant le message initial et en essayant de le renvoyer complet et modifié, plantage (semble-t-il) du forum et impossible de se reconnecter au serveur.

Bref, ça fait deux fois que ça se produit (pour moi) sur une modif de post en général assez long.

A+

Hors ligne

#24 Le 25/11/2008, à 09:36

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

Bon, enfin, ça fonctionne ...

Comme je n'arrivais pas à naviguer, j'ai installé Epiphany, et en regardant dans les menus, j'ai trouvé que j'étais en mode hors-connexion. J'ai décoché, et hop ... çà roule.

Je n'ai toujours pas compris pourquoi et comment c'était passé hors-connexion, d'autant que j'ai essayé de suite avec Firefox, et çà a fonctionné de suite.

Y aurait-il un lien étroit entre Firefox et Epiphany? Comme ils sont en Gecko 1.9 tous les deux, utiliseraient-ils Xulplayer ?

Bref c'est résolu, et c'est le principal.

Seul problème résiduel, le manque de visibilité de la connexion. Je me suis fait deux lanceurs de shell qui connecte et déconnecte, mais on ne voit pas l'état de la connexion, et c'est parfois barbant, d'autant qu'hier soir, j'ai eu quelques déconnexions, peut-être dues à Orange, invisibles, mais bien visibles lorsque je voukais naviguer ou faire autre chose ...

Existe-t-il un utilitaire qui puisse gérer et visualiser la connexion ?

Merci

A+

Hors ligne

#25 Le 25/11/2008, à 19:38

JujuLand

Re : [Résolu] configurer modem interne ISDN RNIS Numeris

J'ai un autre problème. Je ne sais pas si c'est lié au provider, mais j'ai de nombreux hangups, ce qui est relativement casse-c...

A+

Hors ligne

Haut de page ↑