Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 13/12/2005, à 08:30

kinji

[Driver NVIDIA]Panique à bord !!

Bonjour à tous,

Fraîchement convertis à Linux depuis une semaine, je tente d'installer l'accélération graphique via les pilotes nvidia (ma carte est une Geforce 5700 Ultra).
J'ai donc galeré durant toute une semaine avant hier soir de réussir à installer les derniers drivers en suivant ce http://forum.ubuntu-fr.org/viewtopic.php?id=20499.

Je me dis chouette, rebootons un petit peu pour voir si ça tiens le choc. Et là plus rien, un message d'erreur de X me disant que NVIDIA Kernel Source est en version 1.7174 alors que lui est en 1.8167.

Si je remets nv dans mon fichier xorg.conf, ça marche tout de suite mais.. sans accélération graphique !

Je n'y comprends plus rien, j'ai vraiment besoin d'aide là smile


J'ai un noyau 2.6.12-k7 et plus aucun paquet d'installer en rapport avec nvidia.

Ah de plus, si je tente une réinstall des drivers (en suivant la méthode du post), il me dit ceci : (extrait du log d'install)

-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This is most likely
       because the kernel module was built using the wrong kernel source files.
       Please make sure you have installed the kernel source files for your
       kernel and that they are properly configured; on Red Hat Linux systems,
       for example, be sure you have the 'kernel-source' RPM installed.  If you
       know the correct kernel source files are installed, you may specify the
       kernel source path with the '--kernel-source-path' command line option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
   -1 File exists
-> Kernel messages:
   [4294708.550000] Bluetooth: RFCOMM socket layer initialized
   [4294708.550000] Bluetooth: RFCOMM TTY layer initialized
   [4294711.815000] NVRM: RM/client version mismatch!!
   [4294711.815000] NVRM:    aborting to avoid catastrophe!
   [4294712.696000] eth1: no IPv6 routers present
   [4294715.992000] NVRM: RM/client version mismatch!!
   [4294715.992000] NVRM:    aborting to avoid catastrophe!
   [4294728.877000] NVRM: RM/client version mismatch!!
   [4294728.877000] NVRM:    aborting to avoid catastrophe!
   [4294840.882000] NVRM: RM/client version mismatch!!
   [4294840.882000] NVRM:    aborting to avoid catastrophe!
   [4294848.347000] NVRM: RM/client version mismatch!!
   [4294848.347000] NVRM:    aborting to avoid catastrophe!
   [4294852.545000] NVRM: RM/client version mismatch!!
   [4294852.545000] NVRM:    aborting to avoid catastrophe!
   [4294856.738000] NVRM: RM/client version mismatch!!
   [4294856.739000] NVRM:    aborting to avoid catastrophe!
   [4294860.826000] NVRM: RM/client version mismatch!!
   [4294860.826000] NVRM:    aborting to avoid catastrophe!
   [4295240.206000] NVRM: RM/client version mismatch!!
   [4295240.206000] NVRM:    aborting to avoid catastrophe!
   [4295264.470000] NVRM: RM/client version mismatch!!
   [4295264.470000] NVRM:    aborting to avoid catastrophe!
   [4295460.129000] NVRM: RM/client version mismatch!!
   [4295460.129000] NVRM:    aborting to avoid catastrophe!

Voilà, si vous pouviez m'aider avant que je ne m'arrache tout mes cheveux ça serait cool smile

#2 Le 13/12/2005, à 08:39

Anbreizh

Re : [Driver NVIDIA]Panique à bord !!

Tu as tester les paquets dispo dans Synaptic ? Je pense que tu devrai tester avec de te lance dans l'installation a la main wink


"C'est le devoir de chaque homme de rendre au monde au moins autant qu'il en a reçu"     Albert Einstein
Pour votre webcam : http://projet.jbtheou.fr
Mon site web (Mathématique, physique, science et service de publication ) http://jbtheou.fr

Hors ligne

#3 Le 13/12/2005, à 08:47

kinji

Re : [Driver NVIDIA]Panique à bord !!

oui oui oui.
durant toute la semaine, j'ai essayé avec nvidia-glx et nvidia-settings en suivant les consignes du Wiki.

Mais je ne pouvais même pas relancer X, j'avais tout de suite l'erreur.

Au moins là j'ai reussi à l'avoir une dizaine de minutes avant de rebooter !

#4 Le 13/12/2005, à 10:56

max63

Re : [Driver NVIDIA]Panique à bord !!

Moi j'ai une Geforce4 et je dois utiliser les paquet nvidia-glx-lagacy pour que la 3D marche sinon j'avais également ce meme genre de message d'erreur... je ne sais vraiment pas pourquoi .. a quoi cela correspond... par contre tu pourrais également essayé


Tout sur l'actualité frakassante du libre : http://www.frakass.org

Hors ligne

#5 Le 13/12/2005, à 10:57

kinji

Re : [Driver NVIDIA]Panique à bord !!

Ouais je vais tenter ce midi de réinstaller les paquets avec Synaptic. J'espere que ça va pas foutre le binz avec l'install que j'ai faîtes des drivers.

#6 Le 13/12/2005, à 12:49

Golgoth

Re : [Driver NVIDIA]Panique à bord !!

max63 a écrit :

Moi j'ai une Geforce4 et je dois utiliser les paquet nvidia-glx-lagacy pour que la 3D marche sinon j'avais également ce meme genre de message d'erreur... je ne sais vraiment pas pourquoi .. a quoi cela correspond... par contre tu pourrais également essayé

dans son cas il ne doit pas installer les nvidia-glx-legacy puisqu'il a une geforce 5700!


Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#7 Le 13/12/2005, à 13:15

max63

Re : [Driver NVIDIA]Panique à bord !!

Mais en fait c'est quoi la diff entre ces 2 types de drivers ??? Avant j'avais une geforce 3 sur ma breezy avec le nvidia-glx classic, et avec la geforce 4 je suis obligé de mettre les legacy ???

Dernière modification par max63 (Le 13/12/2005, à 13:16)


Tout sur l'actualité frakassante du libre : http://www.frakass.org

Hors ligne

#8 Le 13/12/2005, à 13:25

Golgoth

Re : [Driver NVIDIA]Panique à bord !!

Dans le readme du driver version 1.0-8174 (le dernier)

Below are the legacy GPUs that are no longer supported in the unified driver. These GPUs will continue to be maintained through the special legacy NVIDIA GPU driver releases.

NVIDIA chip name                                 Device PCI ID
RIVA TNT                                            0x0020
RIVA TNT2/TNT2 Pro                             0x0028
RIVA TNT2 Ultra                                0x0029
Vanta/Vanta LT                                        0x002C
RIVA TNT2 Model 64/Model 64 Pro        0x002D
Aladdin TNT2                                         0x00A0
GeForce 256                                        0x0100
GeForce DDR                                       0x0101
Quadro                                                   0x0103
GeForce2 GTS/GeForce2 Pro              0x0150
GeForce2 Ti                                         0x0151
GeForce2 Ultra                                       0x0152
Quadro2 Pro                                        0x0153


Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#9 Le 13/12/2005, à 13:27

Golgoth

Re : [Driver NVIDIA]Panique à bord !!

@kinji

est-tu sûr d'avoir viré ces paquets:

nvidia-glx
nvidia-glx-dev
nvidia-glx-legacy
nvidia-glx-legacy-dev
nvidia-kernel-common
nvidia-kernel-source
nvidia-legacy-kernel-source
nvidia-settings

???

J'ai suivi ce même tuto sans aucun pb...

Dernière modification par Golgoth (Le 13/12/2005, à 13:30)


Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#10 Le 13/12/2005, à 13:54

kinji

Re : [Driver NVIDIA]Panique à bord !!

Bon alors en fait par je ne sais quel petit miracle, en virant tout bien réinstallant les paquets via synaptic, j'ai reussi à avoir l'accélération graphique : houra !

Maintenant, est ce que je desinstall pour installer les nouveaux drivers ou pas ? Est ce que ça change beaucoup en perf ?

#11 Le 13/12/2005, à 17:16

max63

Re : [Driver NVIDIA]Panique à bord !!

Ben voila pourquoi je suis étonné vu que ma geforce 4 ne fait pas partie de la liste....

Golgoth a écrit :

Dans le readme du driver version 1.0-8174 (le dernier)

Below are the legacy GPUs that are no longer supported in the unified driver. These GPUs will continue to be maintained through the special legacy NVIDIA GPU driver releases.

NVIDIA chip name                                 Device PCI ID
RIVA TNT                                            0x0020
RIVA TNT2/TNT2 Pro                             0x0028
RIVA TNT2 Ultra                                0x0029
Vanta/Vanta LT                                        0x002C
RIVA TNT2 Model 64/Model 64 Pro        0x002D
Aladdin TNT2                                         0x00A0
GeForce 256                                        0x0100
GeForce DDR                                       0x0101
Quadro                                                   0x0103
GeForce2 GTS/GeForce2 Pro              0x0150
GeForce2 Ti                                         0x0151
GeForce2 Ultra                                       0x0152
Quadro2 Pro                                        0x0153


Tout sur l'actualité frakassante du libre : http://www.frakass.org

Hors ligne

#12 Le 23/01/2006, à 23:59

sksbir

Re : [Driver NVIDIA]Panique à bord !!

max63 a écrit :

Ben voila pourquoi je suis étonné vu que ma geforce 4 ne fait pas partie de la liste....

Golgoth a écrit :

Dans le readme du driver version 1.0-8174 (le dernier)

Below are the legacy GPUs that are no longer supported in the unified driver. These GPUs will continue to be maintained through the special legacy NVIDIA GPU driver releases.

NVIDIA chip name                                 Device PCI ID
RIVA TNT                                            0x0020
RIVA TNT2/TNT2 Pro                             0x0028
RIVA TNT2 Ultra                                0x0029
Vanta/Vanta LT                                        0x002C
RIVA TNT2 Model 64/Model 64 Pro        0x002D
Aladdin TNT2                                         0x00A0
GeForce 256                                        0x0100
GeForce DDR                                       0x0101
Quadro                                                   0x0103
GeForce2 GTS/GeForce2 Pro              0x0150
GeForce2 Ti                                         0x0151
GeForce2 Ultra                                       0x0152
Quadro2 Pro                                        0x0153

Bonjour, je suis en train de fouiller le forum pour mes propres problemes de carte nvidia, mais j'ai l'impression que tu as mal lu : ta carte ne fait effectivement pas partie de la liste, mais il s'agit de la liste des cartes qui ne sont plus supportées.
Ta carte devrait donc etre supportée par ce driver

Hors ligne

Haut de page ↑