Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 28/08/2014, à 16:01

Niavlys

[Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Bonjour,

Je n'arrive pas à lancer le gestionnaire d'alimentation sur XFCE (Ubuntu 14.04). La commande xfce4-power-manager --debug renvoie :

Gestionnaire d'alimentation: Un autre gestionnaire d'alimentation est déjà lancé

Comment identifier et arrêter cet autre gestionnaire d'alimentation ?

Merci beaucoup pour votre aide.

Dernière modification par Niavlys (Le 28/08/2014, à 23:12)

Hors ligne

#2 Le 28/08/2014, à 16:23

Blabladodo

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Salut,


Tu as installé ton bureau XFCE depuis une installation de Ubuntu ?

Auquel cas tu dois avoir encore gnome-power-manager, essayes de le désinstaller voir si tu peux lancer xfce4-power-manager après ça.


MSI GE60 2PL-75XFR : Dual boot Windows 7 x64 / Voyager 14.04 HD x64 : pc portable
HP Pavilion g6 1354ef : Voyager 14.04 HD x32 (merci à Rodofr et à son équipe) : pc portable
PIV 2,8 GHz, 1,5 Go RAM, Nvidia FX 5200, DDEs 60, 80, 120 Go avec Debian Wheezy+XFCE pour le moment : pc fixe (quand ça marche encore, ben ça marche encore !)

Hors ligne

#3 Le 28/08/2014, à 16:37

Niavlys

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Salut,

Merci pour la suggestion. Je viens d'essayer mais ça affiche :

gnome-power-manager : commande introuvable

D'ailleurs c'est un peu bizarre car Gnome est installé sur ma machine.

D'autres idées ?

Merci en tous cas.

Hors ligne

#4 Le 28/08/2014, à 18:15

Blabladodo

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Essayes directement :

sudo apt-get remove gnome-power-manager

(je n'ai pas trouvé de commande faisant répondre gnome-power-manager sur mon système même après installation, et pourtant il était quand même là big_smile )

S'il le trouve et te proposer de le désinstaller, fais le. Ensuite essayes de relancer xfce4-power-manager pour voir ce que ça donne.

Dernière modification par Blabladodo (Le 28/08/2014, à 18:17)


MSI GE60 2PL-75XFR : Dual boot Windows 7 x64 / Voyager 14.04 HD x64 : pc portable
HP Pavilion g6 1354ef : Voyager 14.04 HD x32 (merci à Rodofr et à son équipe) : pc portable
PIV 2,8 GHz, 1,5 Go RAM, Nvidia FX 5200, DDEs 60, 80, 120 Go avec Debian Wheezy+XFCE pour le moment : pc fixe (quand ça marche encore, ben ça marche encore !)

Hors ligne

#5 Le 28/08/2014, à 23:11

Niavlys

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Merci pour l'idée, la suppression du paquet est risquée car il y a des utilisateurs de Gnome sur la même machine.

Par contre, ça m'a donné l'idée de lancer htop pour supprimer manuellement les processus gnome-power-manager actifs. Surprise, il n'y en avait pas.
En revanche, il y avait plusieurs processus xfce4-power-manager actifs : l' "autre gestionnaire d'alimentation" de mon premier message, c'était xfce4-power-manager lui-même.

Donc le problème que je rencontrais (impossible d'accéder au gestionnaire d'alimentation depuis le menu) ne venait pas du gestionnaire d'alimentation, mais du logiciel de configuration du gestionnaire : xfce4-power-manager-settings. Depuis le début je me posais une question qui n'était pas la bonne.

En parcourant les forums, j'ai trouvé ceci pour débloquer le logiciel de configuration : se déconnecter, lancer une console avec Ctrl+Alt+F1, supprimer les informations de session contenues du cache :

rm -rf  ~/.cache/sessions/

puis revenir à l'écran graphique avec Alt+F7 et se reconnecter.

Et ça marche !! Je sais pas pourquoi, mais ça marche.

Un grand merci à toi, Blabladodo dont le pseudo me fait sourire à chaque lecture, pour tes bonnes idées qui m'ont orienté vers cette solution cool


Edit : suppression du sudo inutile dans la ligne de commande précédente et d'un CTRL superflu.

Dernière modification par Niavlys (Le 29/08/2014, à 11:24)

Hors ligne

#6 Le 29/08/2014, à 01:46

Elzen

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Hum, une petite remarque en passant : les fichiers que tu supprimes ici sont dans ton répertoire personnel, donc sont censés être liés à ton compte. Tu n'as donc, en théorie, pas besoin du sudo pour les supprimer. Si jamais tu en as effectivement eu besoin, c'est sans doute qu'il y a quelque chose qui ne va pas quelque part, donc ça pourrait valoir le coup de vérifier, au cas où.


Elzen : polisson, polémiste, polymathe ! (ex-ArkSeth)
Un script pour améliorer quelques trucs du forum.
La joie de t'avoir connu surpasse la peine de t'avoir perdu…
J'ai pour qualité de ne jamais attaquer les gens. J'ai pour défaut de souvent avoir l'air de le faire.

Hors ligne

#7 Le 29/08/2014, à 02:52

Niavlys

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Très juste, le sudo est une erreur de recopie. Merci, je corrige le post précédent.

Hors ligne

#8 Le 29/08/2014, à 05:31

MicP

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

  Niavlys a écrit :

... puis revenir à l'écran graphique avec Ctrl+Alt+F7 ...

Hors ligne

#9 Le 29/08/2014, à 11:27

Niavlys

Re : [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Impressionnant, vous voyez vraiment tout !!
C'est plus simple sans CTRL, je corrige, merci.

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [Résolu] Le gestionnaire d'alimentation ne se lance pas (XFCE)

Haut de page ↑