Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 27/03/2007, à 16:39

Tzorg

[TUTO] Clavier qwerty au lieu d'azerty

Voici la procedure à suivre si vous vous retrouvez avec un clavier Qwerty suite à une install en français: sad
il suffit d'éditer votre fichier xorg.conf

gksudo gedit /etc/X11/xorg.conf

Remplacez "us" par "fr" comme ci-dessous

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"

Attention !
Si vous devez activer un restricted module pour votre carte video, faites le avant (pas toujours pratique pour les mdp admin...) car le manager réclame un xorg.conf non modifié.

Vous voilà donc avec un clavier français.

tongue

Dernière modification par Tzorg (Le 27/03/2007, à 19:05)

Hors ligne

#2 Le 28/03/2007, à 20:52

biblibart

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bravo et merci, je ne suis pas informaticienne mais bénévole en charge d' un bibli à gérer sous ubuntu....je me suis retrouvée avec un clavier qwerty suite à quelques manips...et votre solution marche !!!!!!!

#3 Le 19/05/2008, à 16:30

loudness14

Re : [TUTO] Clavier qwerty au lieu d'azerty

big_smile Merci ça fonctionne d'enfer

Hors ligne

#4 Le 23/05/2008, à 23:09

On / Off

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bein pour moi ça n'a pas marché... :-(

Mais comme la vidéo est encore mal configurée (portable Dell...) je me suis douté d'une embrouille entre les fichiers de config.

Au moment de la fenêtre de connexion (clavier us), j'ai fait Ctrl+Alt+F1 afin d'arriver sur un  terminal en mode texte. Après avoir renseigné les login et password (tjs en clavier us) j'ai été éditer le fichier avec la commande sudo vim /etc/X11/xorg.conf

Ce fichier n'est pas le même car ma première modification n'est pas présente. Je l'ai refaite.

Depuis, ça fonctionne de partout en clavier azerty :-)

#5 Le 06/08/2008, à 10:27

plac

Re : [TUTO] Clavier qwerty au lieu d'azerty

Merci, ca marche.
Vaut mieux pas utiliser vi pour faire la manip, parce-que les code pour sortir et enregistrer en qwerty, bonjour.
merci encore

#6 Le 19/09/2008, à 14:23

micnad

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bonjour
Apres l installation des drivers nvidia 173.14.12 ,chez moi ca ne fonctionne pas cette manipulation. Des que je touche au fichier xorg.conf, c est la panique au reboot.
Je reviens en 800/600
J ai aussi modifie le clavier dans les preferences mais toujours du qwerty. Pourtant il n y a plus de clavier USA dans l'agencement.
Quand je fais la modification dans préférences, clavier, Je suis en azerty pendant la session, mais au reboot, retour au qwerty.
Je suis à votre écoute
merci
micnad

Hors ligne

#7 Le 03/02/2010, à 17:04

malbo

Re : [TUTO] Clavier qwerty au lieu d'azerty

Ce tuto est obsolète pour Ubuntu 9.10 : ça ne sert à rien de tenter de créer un fichier xorg.conf et de coller dedans ce que propose le tuto (j'ai testé pour vous, c'est nase). Il faut utiliser la "Méthode 1 : Utiliser 2 configurations sur 1 même clavier" du lien suivant :
http://doc.ubuntu-fr.org/clavier#methode_1_utiliser_2_configurations_sur_1_meme_clavier
C'est à dire passer par :

Commençons par ajouter un nouveau clavier. Menu Système > Préférences > Clavier ….
Choisissons l'onglet Agencement, puis le bouton Ajouter….

Puis ajouter un agencement "France" et le définir par défaut.
Au redémarrage du PC, ce sera bon.

Dernière modification par malbo (Le 03/02/2010, à 17:08)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#8 Le 06/05/2011, à 19:33

tuxonroller

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bonjour

Je reprend ce fil car j'ai installé ubuntu 11.04 depuis l'alternate CD.
A l'installation, comme d'habitude, j'ai fait la détection du clavier auto, il m'a bien trouvé que j'étais en français mais toute la fin de l'installation s'est déroulée en Qwerty et au redémarrage j'étais en Qwerty.
J'ai pu régler le pb assez simplement sur gdm/gnome (via le choix dans du clavier dans la liste déroulante prévue à cet effet).
Par contre, les terminaux (Ctrl + Alt F1 à F6) sont tous en Qwerty. J'ai édité le /etc/default/keyboard qui était en us à fr, mais rien n'a changé.
Pour l'instant je suis oblligé de faire un loadkeys fr en root à chaque fois. Quelqu'un aurait-il une solution pour corriger le problème?

Je pense qu'il doit y avoir un petit bug sur l'alternate car j'ai fait 2 installations et j'ai eu le même problème.

Gaylord

Hors ligne

#9 Le 06/05/2011, à 19:50

meremichel

Re : [TUTO] Clavier qwerty au lieu d'azerty

salut
nano /etc/X11/xorg.conf.d/10-evdev.conf

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "xkb_layout" "fr"

En ligne

#10 Le 15/09/2011, à 22:18

schmilblick

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bonjour,

Toujours le problème à la reconnexion. J'ai modifié l'agencement dans les préférences du clavier qui rajoute USA à chaque connexion ou redémarrage, je n'ai pas de fichier xorg.conf, j'ai modifié le fichier etc/default/keyboard, redémarré, rien n'y fait.
C'est rare que je ne trouve pas une solution sur le net, mais là... je sèche.

D'avance merci,
M

Hors ligne

#11 Le 15/09/2011, à 22:48

schmilblick

Re : [TUTO] Clavier qwerty au lieu d'azerty

sudo dpkg-reconfigure keyboard-configuration et redémarrage ne règlent pas non plus le problème.
Le français est bien la première langue dans l'agencement. L’icône de notification indique USA, avec le français sélectionné quand on clique pour avoir le menu contextuel. Si je ne re-sélectionne pas le français, le clavier lui est en qwerty.
Je suis sur la dernière version 11.04 d'ubuntu.

Hors ligne

#12 Le 17/10/2011, à 12:02

Phil95610

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bonjour,
Même problème sous Ubuntu 11.10. L'écran d'accueil ne permet que les entrées en clavier QWERTY.
Une solution est d'aller éditer en ROOT le fichier /etc/default/keyboard.
Dans un terminal :
sudo nautilus
ouvrir le fichier où on a

XKBMODEL="a4techKB21"
XKBLAYOUT="us,af"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

le modifier
XKBMODEL="a4techKB21"
XKBLAYOUT="fr,us"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

enregistrer

rebooter
(Eh bé j'ai eu un de ces mal.....)

Dernière modification par Phil95610 (Le 17/10/2011, à 12:02)

Hors ligne

#13 Le 31/10/2011, à 23:03

jibel

Re : [TUTO] Clavier qwerty au lieu d'azerty

malbo a écrit :

Ce tuto est obsolète pour Ubuntu 9.10 : ça ne sert à rien de tenter de créer un fichier xorg.conf et de coller dedans ce que propose le tuto (j'ai testé pour vous, c'est nase). Il faut utiliser la "Méthode 1 : Utiliser 2 configurations sur 1 même clavier" du lien suivant :
http://doc.ubuntu-fr.org/clavier#method … me_clavier
C'est à dire passer par :

Commençons par ajouter un nouveau clavier. Menu Système > Préférences > Clavier ….
Choisissons l'onglet Agencement, puis le bouton Ajouter….

Puis ajouter un agencement "France" et le définir par défaut.
Au redémarrage du PC, ce sera bon.

salut Malbo ,
je reviens sur ton post (même si j'ai ouvert une discussion pour clavier qwerty) dans truc & astuces .
lors de l'install d'hybryde il était dit de configurer le clavier et langues, ce que bien entendu j'ai zappé
ce qui fait que je me retrouve avec un MdeP en qwerty pour toutes les taches administratives .
J'ai donc essayé de demarrer en recovery mode------->root------->passwd login pour changer le MdeP
ça ne marche pas , because le typing en qwerty ou il y a quelques "sigles" genre ($) et (~) que je n'arrive pas a
reproduire parce que le clavier est en azerty ,que j'avais reconfiguré apres l'install, d'ou l'erreur de maintenant .
C'est ces sigles que je cherche a trouver, s'il existe un raccourci , merci de me dire comment ,
cordialement,


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Ub.12.04, 14.04, Kub. 13.10, 14.04,Voy 14.04,13.10,13.04,12.04 LTS , Mint 17, hybryde fus13.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#14 Le 01/11/2011, à 07:02

malbo

Re : [TUTO] Clavier qwerty au lieu d'azerty

jibel,
Je n'y connais rien dans ces problèmes de clavier. J'ai simplement écrit que le tuto du post #1 est obsolète. Ce qui ne fait pas de moi un expert du domaine loin de là.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#15 Le 01/11/2011, à 10:10

jibel

Re : [TUTO] Clavier qwerty au lieu d'azerty

Pas de probleme , @+


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Ub.12.04, 14.04, Kub. 13.10, 14.04,Voy 14.04,13.10,13.04,12.04 LTS , Mint 17, hybryde fus13.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#16 Le 14/04/2013, à 15:17

USB29

Re : [TUTO] Clavier qwerty au lieu d'azerty

Bonjour,

J'ai aussi un probleme avec la langue de mon clavier qui se met en qwerty à chaque redémarrage.
Voici ce que m'indique mon fichier xorg.conf :

Section "Screen"
	Identifier	"Default Screen"
	DefaultDepth	24
EndSection

Section "Module"
	Load	"glx"
EndSection

Dois-je remplacer mon contenu par celui ci :

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"

Hors ligne

Haut de page ↑