Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#751 Le 12/09/2014, à 20:18

apos22

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

Babdu89 a écrit :

Bonjour.
J'ai déjà préparé mes clé avec Gparted (partition FAT32 avec le label ; multisystem  ou MULTISYSTEM ) .
Au lancement du MultiSystem , il trouve la clé avec le label qui lui convient.
Une clé sans label, ou avec un autre label, systématiquement, j'aurais le message qui demande l'autorisation de mettre le label  multisystem sur la partition FAT32 .
Débrancher, rebrancher, et monter la clé, pour que MultiSystem puisse l'utiliser .

@+.   Babdu89  .

Thanks, i alredy tried this and reformatted a new stick. There are also multiple sticks and drives with partitions named MULTISYSTEM. None works. On an old Ubuntu 12.04 LTS everything works fine. On all actual 14.04 LTS systems, it does not work.

I asume a really big bug in the program or the uninstatallation (--purge) routine. Installing on another Ubuntu 14.04 LTS, where multisystem was not installed before, everything works fine. So it must be a problem with the configuration or installation / reinstallation of mulitsystem on this three pcs. The picture is, when using my mulitsytem sticks:

1.  12.04 LTS (oder installaion): working
2.  14.04 LTS (plain new multisystem installation): working
3.  14.04 LTS (older  an updated installation of multisystem): error
4.  14.04 LTS (older  an updated installation of multisystem): error
5.  14.04 LTS (older  an updated installationof multisystem): error

For sake, I created a new testuser on one of the systems with the errror (new home directory). The error remains.

Due to the fact, that this is a france speaking forum (but the link on the homepage of multisytem links here and the developper does not anwer on mails with the contact page), I am going to post in an more international envoironment.

Thanks for your advices so far.
Axel

P.s: Renaming .bashrc does not work, neither is a serious solution I think.

Dernière modification par apos22 (Le 12/09/2014, à 21:04)

Hors ligne

#752 Le 12/09/2014, à 22:36

apos22

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

frafa a écrit :

@apos22
Hi
temporarily rename your file
$HOME/.bashrc in $HOME/save.bashrc
and retest ...

Does not work and also needs a logout /  login. And the .bashrc is the same on all 5 machines I tested!

The problem is, that multisytem does not start at all. A file /tmp/multisystem-detection-usb ist created and contains a correct line:

/dev/sdb1|SanDisk|SanDisk_Ultra|14770 Mio|12138 Mio|2632 Mio|disk|usb|/media/apos/MULTISYSTEM|A225-F222

but the gui never starts.

A file  /tmp/multisystem-seleciton-usb is never created!. So the system never finds the stick.

PATH: /home/USERNAME/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games


After inspection the code of multisystem I really cannot see, where the problem is. One of the main problems for me as a programmer is, that there is not a clear and structured code base, a clear separation of gui code and fuctional code, a lot of duplicate code and not much comments. So far my respect for this work, and that this is working - but I think one should refactor the whole thing  - if not write at least the gui part completely new with a higher programming language. Nevertheless thanks for the programm.

If I find a solution, I will post it here. As far as I can say now , it is a problem with the gui code and / or the detection of the stick.
The simplest solution would be, if the was a failover code, that simply starts the first detetcted multisytem partition out of the list of avaiable devices.

A bug tracker would be a good thing. Is https://bugs.launchpad.net/multisystem used at all, or exists another bug tracker?

Greets
Axel

Dernière modification par apos22 (Le 12/09/2014, à 22:37)

Hors ligne

#753 Le 13/09/2014, à 02:02

frafa

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

@Mahad-S
Bonjour,
Tu voit ta clé usb dans le fenêtre de sélection ou pas ?
Tu la sélectionne avant de cliquer sur valider ou pas ?

Branche ta clé usb, démarre multisystem,
et fait passer le contenu de ce fichier: /tmp/multisystem/multisystem-debog-detect-list

Vous pouvez mettre ce que vous voulez en label, a condition de ne pas mettre de caractères accentuée, et surtout de ne pas mettre d'espace.

Hors ligne

#754 Le 14/09/2014, à 09:45

ljere

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

Bonjour,
un petit rappel des règles:
La langue du forum est le français


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#755 Le 14/09/2014, à 13:02

PPdM

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

ljere a écrit :

Bonjour,
un petit rappel des règles:
La langue du forum est le français

Je crois que c'est un correspondant anglophone.


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#756 Le 14/09/2014, à 16:14

Mahad-S

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

@frafra,

Mais justement! Le problème est là: je n'ai pas de fenêtre de sélection. Multisystem charge, puis une fenêtre grise apparait puis disparait en une demi seconde et après, j'ai direct mon msg d'erreur. J'ai essayé en mettant la clé, sans mettre la clé, avec label, sans label, en ajoutant moi meme le depot multisystem ou en passant par le .sh.

Pour le fichier que tu m'as demandé, il est vide et bien vide, et il fait 0 o, tout comme le fichier multisystem-detection-usb.
Dans le même dossier, le fichier multisystem-statusbar rend:

Is your USB key connected?

Please connect a FAT32 formatted
USB volume
and mount it in /media

Then, relaunch MultiSystem.

Si je trouve quelque chose d'intéressant, je le poste. Mais c'est quand même curieux parce qu'avant, j'avais quand même le menu de sélection même sans avoir de clé qui était branchée...

Merci pour vous interesser a mon probleme!

Dernière modification par Mahad-S (Le 14/09/2014, à 16:22)

Hors ligne

#757 Le 14/09/2014, à 17:25

Babdu89

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

Bonjour.
Tu n'as pas ceci qui s'affiche longtemps?

1410708202.png

Mais ce messages?

1410708226.png

@+.   Badu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#758 Le 14/09/2014, à 23:12

Mahad-S

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

Exactement, la première image est ce que j'ai toujours eu depuis que j'utilise multisystem, la seconde ce que j'ai depuis quelque semaine immadiatement après que je clique sur le prog pour le lancer.

Hors ligne

#759 Le 16/09/2014, à 16:42

frafa

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

Bonjour,
Sous Ubuntu 14.10 c'est gtkdialog qui ne fonctionne plus,
le bug est référencé, il ne reste plus a espérer que Thunor nous trouve la solution rapidement,
c'est là: https://code.google.com/p/gtkdialog/issues/detail?id=77

Attempt to unlock mutex that was not locked

je regarde de mon coté dans la semaine ...

Dernière modification par frafa (Le 16/09/2014, à 16:43)

Hors ligne

#760 Le 16/09/2014, à 17:12

Mahad-S

Re : MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2]

Super! Même si ça ne fonctionne pas encore, je suis content de voir que tout ça est bien dialogué et que je ne suis pas le seul être au monde à avoir déjà eu ce problème wink

Merci!

Hors ligne

Haut de page ↑