Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 30/01/2006, à 13:13

micfrip

PHP4+PHP5 en même temp

Bonjour à tous,

Je cherche un bon tuto pour installer les deux versions de php en parallèle.

J'ai pu dégotter de l'info "générale" sur ce sujet mais rarement des directives claires.

Apparement, la meilleure solution (préconisée par Mr Daspet lui-même) serait d'installer php4 et php5 en fastcgi et de faire la distinction selon le virtual host.

Si quelqu'un a déjà réalisé cette prouesse, je lui serai vraiment reconnaissant de me l'expliquer car là, je rame un peu.

Merci d'avance.


-mic-

#2 Le 30/01/2006, à 13:49

soupaloignon

Re : PHP4+PHP5 en même temp

Un réponse en demi teinte...
En installant Xampp tu peux choisir de demarrer en php4 ou 5 selon tes besoins

Because such very new versions like PHP 5 always should be handled with care we decided to include both current versions of PHP into XAMPP since version 1.4.7: PHP 5.x and PHP 4.x. If you find out your PHP application doesn't work with PHP 5 you will be able to switch back easily to PHP 4.

By the following command you can switch "back" to PHP 4.x:

/opt/lampp/lampp php4

And with the following command you can switch back to PHP 5.x:

/opt/lampp/lampp php5

Je parlais de réponse en demi teinte car Xampp est plus dédié aux tests qu'à de la production (d'après les dires des auteurs). Ceci dit il semblerait qu'il y ai du retour d'experience en production plutot positif (mais je ne retrouve plus les pages qui parlaient de ça)

Le site de Xampp http://www.apachefriends.org/en/index.html

Cordialement


==> Libérez les huitres du bassin d'Arcachon <==

Hors ligne

#3 Le 30/01/2006, à 18:26

micfrip

Re : PHP4+PHP5 en même temp

Merci pour ta réponse.

Ce système ne m'arrange pas vraiment car, effectivement, c'est impossible à utiliser en production.

Je reste persuadé que la meilleure manière est celle du fastcgi mais la doc n'est pas évidente à trouver.

( ou alors, il faut instancier deux versions d'Apache ou utiliser des extensions différentes et ça, c'est loin d'être l'idéal )

Haut de page ↑