Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 01/02/2006, à 13:00

Maitrepylos

GTK+ 2.6

Bonjour,
je dois installer gtk+ 2.6 sur ma Brezzy, or je ne sais quel fichier téléchargé.

apparament je possède la 2.4, et je voudrais utilser php-gtk avec ma version 5.1 de php.

pouvez m'aider à installer GTK 2.6.

merci


L'experience est la somme de toutes nos erreurs

Hors ligne

#2 Le 01/02/2006, à 16:46

thx1138

Re : GTK+ 2.6

Maitrepylos a écrit :

apparament je possède la 2.4, et je voudrais utilser php-gtk avec ma version 5.1 de php.

Euh, si tu as une Breezy, y'a un petit problème avec ton install.

En effet, si on regarde sur http://packages.ubuntu.com, on s'aperçoit que Gtk+ est en version 2.8.x  et non 2.4.x !

Pour savoir ce que tu as chez toi :

dpkg -l |grep libgtk2.0-0

They did not know it was impossible, so they did it - Mark Twain

Hors ligne

#3 Le 02/02/2006, à 10:31

Maitrepylos

Re : GTK+ 2.6

Bonjour,

effectivement j'ai bien la version 2.8, mais quand je veux compiler php-gtk pour php5.1

il me met ceci comme erreur

checking for GTK+ - version >= 2.6.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: PHP-GTK 2.x requires GTK+ 2.6.0 or higher

L'experience est la somme de toutes nos erreurs

Hors ligne

#4 Le 03/02/2006, à 09:23

thx1138

Re : GTK+ 2.6

Deux solutions :

- soit tu n'as pas installé le package libgtk2.0-dev;
- soit il y a une erreur dans les scripts autotools de PHP-Gtk.


They did not know it was impossible, so they did it - Mark Twain

Hors ligne

#5 Le 03/02/2006, à 15:08

Maitrepylos

Re : GTK+ 2.6

J'ai déja eu un problème similaire avec pgadmin 1.4, je devais installer une librairie que j'avais supèrieur sur la machine.

Je vais installer leur librairie et je verrais!.

Merci de ton aide


L'experience est la somme de toutes nos erreurs

Hors ligne