Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 04/04/2005, à 10:08

JL

Problème avec le driver ADSL eagle-usb

Bonjour,

Après avoir fait ./configure (et après avoir installé les linux-header de mon noyau), j'ai ce message d'erreur lors du make :

root@cube:/usr/local/src/eagle-usb-2.1.0 # make
make -C driver
make[1]: entrant dans le répertoire /usr/local/src/eagle-usb-2.1.0/driver
USE_CMVS=0 make  -C /lib/modules/2.6.8.1-3-powerpc/build SUBDIRS=/usr/local/src/eagle-usb-2.1.0/driver modules
make[2]: entrant dans le répertoire /usr/src/linux-headers-2.6.8.1-3-powerpc
  CC [M]  /usr/local/src/eagle-usb-2.1.0/driver/eu_main.o
Dans le fichier inclus à partir de include/asm/machdep.h:8,
          à  partir de include/asm/irq.h:6,
          à  partir de include/asm/hardirq.h:8,
          à  partir de include/linux/interrupt.h:12,
          à  partir de include/linux/usb.h:15,
          à  partir de /usr/local/src/eagle-usb-2.1.0/driver/Adiutil.h:53,
          à  partir de /usr/local/src/eagle-usb-2.1.0/driver/eu_main.c:34:
include/asm/setup.h:8:28: asm-m68k/setup.h : Aucun fichier ou répertoire de ce type
make[3]: *** [/usr/local/src/eagle-usb-2.1.0/driver/eu_main.o] Erreur 1
make[2]: *** [_module_/usr/local/src/eagle-usb-2.1.0/driver] Erreur 2
make[2]: quittant le répertoire /usr/src/linux-headers-2.6.8.1-3-powerpc
make[1]: *** [eagle-usb.ko] Erreur 2
make[1]: quittant le répertoire /usr/local/src/eagle-usb-2.1.0/driver
make: *** [build] Erreur 2

Au passage, je suis sous UBUNTU HOARY (Power-PC).
Merci.

Jérôme.

#2 Le 04/04/2005, à 10:46

Gillaume

Re : Problème avec le driver ADSL eagle-usb

je dis peut etre une évidence :
mets "sudo" devant make....
essaie au moins . hmm


Guili Guili

Hors ligne

#3 Le 04/04/2005, à 11:12

nikola

Re : Problème avec le driver ADSL eagle-usb

Il est déjà en root (#) wink


Venez prendre un café :)

Hors ligne

#4 Le 04/04/2005, à 11:14

raph

Re : Problème avec le driver ADSL eagle-usb

Pas besoin des droits administrateur pour compiler! Seulement pour installer wink

Par contre le pilote eagle est disponible en paquets dans l'archive principale.
Ils s'appellent eagle-usb-utils et eagle-usb-data.

On peut les trouver ici : http://higgs.djpig.de/ubuntu/www/hoary/net/
si jamais tu dois les télécharger depuis un autre poste ou un Windows.

Ils s'installent classiquement via

dpkg -i eable-usb*.deb

Par contre leur script de démarrage n'a pas bien fonctionné la dernière fois que j'en ai installé mais une recherche sur le forum te donnera une astuce (à base de /etc/init.d/bootmisc.sh) qui a marché pour moi big_smile

Edit:

Il est déjà en root (#)

Oeil de lynx tongue

Dernière modification par raph (Le 04/04/2005, à 17:55)


... enfin peut-être.

Hors ligne

#5 Le 04/04/2005, à 17:13

JL

Re : Problème avec le driver ADSL eagle-usb

Merci pour vos réponses rapides...

raph a écrit :

Par contre le pilote eagle est disponible en paquets dans multiverse.
Ils s'appellent eagle-usb-utils et eagle-usb-data.

On peut les trouver ici : http://higgs.djpig.de/ubuntu/www/hoary/net/

Ces paquets sont compilés pour Power-PC ???

Jérôme.

#6 Le 04/04/2005, à 17:53

raph

Re : Problème avec le driver ADSL eagle-usb

OUI! big_smile
Le paquet eagle-usb-data est multiplateformes et le paquet eagle-usb-utils est disponible pour i386, amd64, ia64 et ppc.

Ils sont même sur le CD (en tout cas de la hoary preview i386)

Dernière modification par raph (Le 04/04/2005, à 17:55)


... enfin peut-être.

Hors ligne

#7 Le 05/04/2005, à 15:42

JL

Re : Problème avec le driver ADSL eagle-usb

Ca progresse, mais c'est pas encore ça...

Voilà ou j'en suis : après installation des paquets et configuration du modem F@st800, tout a l'air d'être OK sauf que je n'ai pas de connection Internet (pas de ping non plus).
Voilà ci-dessous les résultats de eagleconfig, eaglestat, startadsl, eaglediag :

root@cube:/home/jerome/Installations # eagleconfig
.......
Chargement du module...        [ OK ]
Chargement du DSP & options... [ OK ]
Attente modem opérationnel...  [ OK ]

Configuration réussie.

root@cube:/home/jerome/Installations # eaglestat
eagle-usb status display
-------------------------------------------------------------
Driver version 1.9.9
USB Bus : 001    USB Device : 006        Dbg mask: 0x0
Ethernet Interface : eth1
MAC: 00:60:4c:33:0c:23
Tx Rate  0000000000  Rx Rate  0000000000  Crc      0000000000
FEC      0000000000  Margin   0000000040  Atten    0000000006 dB
VID-CPE  0000000000  VID-CO   0000000000  HEC      0000000000
VPI      0000000008  VCI      0000000035  Delin          GOOD
Cells Rx 0000000000  Cells Tx 0000000000
Pkts Rx  0000000000  Pkts Tx  0000000000
OAM      0000000000  Bad VPI  0000000000  Bad CRC  0000000000
Oversiz. 0000000000

Modem is operational

root@cube:/home/jerome/Installations # startadsl

root@cube:/home/jerome/Installations # eaglediag
Diagnostic (1.13 2004/08/29) driver eagle-usb 20050405150833
# System Information
Linux cube 2.6.8.1-3-powerpc #1 Tue Oct 12 13:15:29 BST 2004 ppc GNU/Linux
testing/unstable
Linux version 2.6.8.1-3-powerpc (buildd@royal) (gcc version 3.3.4 (Debian 1:3.3.4-9ubuntu5)) #1 Tue Oct 12 13:15:29 BST 2004
version gcc 3.3.4 (Debian 1:3.3.4-9ubuntu5) used : 3.3.4 (Debian 1:3.3.4-9ubuntu5)
# module loaded ?        [ OK ]
# modem operational ?    [ OK ]
# Config vpi/vci/encapsulation/isp : 8 23 6 (pppoa) FR07
# pppd launched ?        [ OK ]
# Service for connection [ OK ]
[b]# ping IP ?              [ KO ]
# test DNS resolution ?  [ KO ][/b]

Que faire ???

Jérôme.

(qui désespère d'avoir l'Internet du monde sur son Cube)

#8 Le 05/04/2005, à 17:43

raph

Re : Problème avec le driver ADSL eagle-usb

As tu fait :

sudo startadsl

???

Le script qui est censé le faire automatiquement ne marche pas (en tout cas chez mes parents)

J'ai donc ajouté dans /etc/init.d/bootmisc.sh les lignes suivantes:
eaglectrl -w
startadsl -s
comme suggéré dans un des posts du forum, ça marche au redémarage, c'est pas trés propre mais ça a le mérire de fonctionner.

Sinon rien ne t'empêche de le faire manuellement losque tu veux te connecter:

sudo eaglectrl -w
sudo startadsl -s

Tu es proche de profiter de ta connection, ne laches pas l'affaire si vite wink

Edit : oups j'avais pas fait dérouler la fenêtre au dessus, désolé roll
Je laisse ce qui est ci-dessus car ça peut servir à d'autres wink

Je reprends, donc,
Déja es-tu bien chez Tiscali en 512?
Peux tu nous dire ce que donne un ifconfig?

Dernière modification par raph (Le 05/04/2005, à 17:49)


... enfin peut-être.

Hors ligne

#9 Le 07/04/2005, à 20:31

JL

Re : Problème avec le driver ADSL eagle-usb

C'est encore moi, toujours avec mon pb de connection...

raph a écrit :

Déja es-tu bien chez Tiscali en 512?

Oui, c'est bien ça.

raph a écrit :

Peux tu nous dire ce que donne un ifconfig?

root@cube:/home/jerome # ifconfig
lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hà´te
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:17787 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17787 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:1283615 (1.2 MiB)  TX bytes:1283615 (1.2 MiB)

Sinon, voilà ce que donne un tail -f /var/log/messages :

Apr  7 11:37:51 localhost pppd[4851]: pppd 2.4.2 started by root, uid 0
Apr  7 11:37:51 localhost pppd[4851]: Using interface ppp0
Apr  7 11:37:51 localhost pppd[4851]: Connect: ppp0 <--> /dev/pts/2
Apr  7 11:37:52 localhost kernel: NET: Registered protocol family 17
Apr  7 11:38:22 localhost pppd[4851]: LCP: timeout sending Config-Requests
Apr  7 11:38:22 localhost pppd[4851]: Connection terminated.
Apr  7 11:38:22 localhost pppd[4851]: Using interface ppp0
Apr  7 11:38:22 localhost pppd[4851]: Connect: ppp0 <--> /dev/pts/2
Apr  7 11:38:53 localhost pppd[4851]: LCP: timeout sending Config-Requests
Apr  7 11:38:53 localhost pppd[4851]: Connection terminated.
Apr  7 11:38:54 localhost pppd[4851]: Using interface ppp0
Apr  7 11:38:54 localhost pppd[4851]: Connect: ppp0 <--> /dev/pts/2
Apr  7 11:39:25 localhost pppd[4851]: LCP: timeout sending Config-Requests
Apr  7 11:39:25 localhost pppd[4851]: Connection terminated.

On dirait qu'il y a un pb avec ppp...
Mais je n'en sait pas davantage.

Dois-je garder un espoir d'aller plus loin ? sad

Jérôme.

#10 Le 10/04/2005, à 10:32

JL

Re : Problème avec le driver ADSL eagle-usb

Bon, j'ai résolu mon pb : en désespoire de cause, j'ai cassé tout mon système et j'ai réinstallé une Hoary à la place de ma Warty. Le driver eagle-usb (version 2.1.0) s'est parfaitement bien compilé, mon modem F@st800 s'est parfaitement bien synchronisé, et ma connexion est opérationnelle. merci Hoary !

Voilà, mon pb devait venir d'un bug ou d'une incompatibilité au niveau de mon précédent noyau... Merci quand-même pour m'avoir aidé.

Vous pouvez mettre [résolu] dans le titre du fil.

Jérôme.

Haut de page ↑