Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 14/04/2005, à 21:35

slapps

Probleme avec checkinstall et dpkg-deb

Bonjour

J'ai un problème lors de l'utilisation de checkinstall, étant nouveau sous une distrib avec apt, j'ai un peu de mal d'où vient l'erreur.

Le message d'erreur que me sort checkinstall :

dpkg-deb - erreur : (upstream) version (« mtaskbar ») ne contient pas de chiffres
dpkg-deb: 1 erreurs dans le fichier de contrôle

Merci d'avance pour les réponses, slapps

#2 Le 15/04/2005, à 19:35

lamiricore

Re : Probleme avec checkinstall et dpkg-deb

Pourrais-tu expliciter un peu: que voulais tu faire?

#3 Le 15/04/2005, à 21:15

slapps

Re : Probleme avec checkinstall et dpkg-deb

Pardon .... pour les explications insufisantes :

Alors je veux juste créer un paquet .deb à partir d'une source je fais :

./configure
make
su
checkinstall
puis je choisis le type de paquets débian

Et c'est là que ça bloque, et il me demande si je veux voir les logs .... et il me donne ces deux lignes hmm

Merci slapps

#4 Le 16/04/2005, à 11:00

siko

Re : Probleme avec checkinstall et dpkg-deb

Il faut juste modifier la version qui contient mtaskbar et mettre des chiffre à la place.

#5 Le 16/04/2005, à 17:57

slapps

Re : Probleme avec checkinstall et dpkg-deb

siko a écrit :

Il faut juste modifier la version qui contient mtaskbar et mettre des chiffre à la place.

C'està dire je change ça ou ?? dsl j'suis un peu perdu avec les paquets debian roll

Hors ligne

#6 Le 09/02/2006, à 14:45

hasek

Re : Probleme avec checkinstall et dpkg-deb

slapps a écrit :
siko a écrit :

Il faut juste modifier la version qui contient mtaskbar et mettre des chiffre à la place.

C'està dire je change ça ou ?? dsl j'suis un peu perdu avec les paquets debian roll

c'est simple

quand check install te dit ça

1 -  Summary: [ Firefox 1.5.0.1 amd64 ubuntu 5.10 package ]
2 -  Name:    [ mozilla ]
3 -  Version: [ 1.5.0.1 ]  <---------------il doit y avoir de chiffres ici
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ checkinstall ]
7 -  Architecture: [ x86_64 ] ---> changer en amd64
8 -  Source location: [ http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5.0.1/source/firefox-1.5.0.1-source.tar.bz2 ]
9 -  Alternate source location: [  ]

tu choisis l'option 3 et tu modifie le champ version et tu y met le numéro de version au lieu