Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 12/02/2006, à 12:29

GB

failed to load the NVIDIA kernel désolé :-(((

Pb comment mettre en oeuvre l'accélération graphique sur une GEForce2 MX64 32Mo ???

voici mon kernel
  uname -r
  2.6.12-10-k7

J'ai l'impression de ne pas être le premier mais je n'ai pas trouvé de solution en lisant les post. J'ai bien essayé de suivre certaines recettes mais sans succès aussi je post sad

Des infos sur ma config
Amd 1,2GHz 384 Mo, carte graphique Winfast GeForce2 MX64 32 Mo

Voici tous les paquets nvidia installés :

  nvidia-kernel-common
  nvidia-glx-dev
  nvidia-glx
  linux-restricted-modules-2.6.12-10-k7-nvidia-legacy
  linux-restricted-modules-2.6.12-10-k7
  xserver-xorg-driver-nv

Cela a l'air cohérent

J'ai bien activé
  sudo nvidia-glx config enable


J'ai remplacé nv par nvidia dans xorg.conf


MAIS j'ai toujours "Failed to load the NVIDIA kernel module"

SVP je ne peux pas jouer à Tuxracer (PPracer excusez moi) tongue

Hors ligne

#2 Le 16/02/2006, à 21:48

mr_pouit

Re : failed to load the NVIDIA kernel désolé :-(((

t'as essayé en supprimant linux-restricted-modules-2.6.12-10-k7 ? Il me semble que les modules dont tu as besoin sont dans linux-restricted-modules-2.6.12-10-k7-nvidia-legacy ; et là ça fait doublon je pense big_smile.

PS : Et plutôt que de remplacer nv par nvidia directement dans xorg.conf, tu peux utiliser "sudo dpkg-reconfigure xserver-xorg" wink


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#3 Le 16/02/2006, à 22:19

neu9

Re : failed to load the NVIDIA kernel désolé :-(((

oups, j'ai posté un peu la meme chose mais dans "Graphisme" (PATAPAI)

si tu résous le pb signale le, j'ai aussi une nvidia (GeForce 5200) et un AMD Athlon1800+

Hors ligne

#4 Le 18/02/2006, à 11:24

neu9

Re : failed to load the NVIDIA kernel désolé :-(((

en fait, non seulement j'arrive pas à activer l'accélération graphique, mais en plus maintenant sur plusieurs progs j'ai "Erreur de segmentation" au démarrage (Slune, xmms)

ma config :

uname -a
Linux aldorande 2.6.12-10-386 #1 Mon Feb 13 12:13:15 UTC 2006 i686 GNU/Linux

mes paquets installés contenant "nvidia" :
linux-restricted-modules-2.6.12-10-386
nvidia-glx  1.0.7667-0ubuntu
nvidia-kernel-common  1.0.7667+1
nvidia-settings  1.0.3ubuntu6
xserver-xorg-driver-nv  6.8.2-77

AMD 1800+, GeForce5200, MB ASUS A7S333

avant slune fonctionnait mais ramait à mort

est-ce que par harsard j'ai une incompatibilité entre i686 GNU/Linux et les paquets 386 ?

Hors ligne

#5 Le 18/02/2006, à 11:56

neu9

Re : failed to load the NVIDIA kernel désolé :-(((

en désinstallant
  linux-restricted-modules-2.6.12-10-386
synaptic m'a imposé d'enlever
  linux-386
  nvidia-glx

=> plus de "Erreur de segmentation" sur xmms et Slune,

mais évidemment, Slune rame toujours

pensez vous que je devrais essayer plutot
nvida-glx tout seul ?
linux-restricted-modules-2.6.12-10-686 tout seul ?
les deux ?

Hors ligne

#6 Le 18/02/2006, à 12:47

mr_pouit

Re : failed to load the NVIDIA kernel désolé :-(((

GB > il te faut seulement les paquets -legacy . Les paquets nvidia-glx tout court ne supportent que les cartes récentes, alors que les paquets -legacy supportent tnt, tnt2, geforce 2 et compagnie.

neu9 > essaie d'installer :
linux-image-k7 (vu que tu as un amd)
linux-restricted-modules-2.6.12-10-k7
nvidia-glx 
nvidia-kernel-common 
nvidia-settings 

Puis tu fais "sudo dpkg-reconfigure xserver-xorg", tu sélectionnes le pilote nvidia, tu redémarres, et là slune ne devrait plus ramer wink

Dernière modification par mr_pouit (Le 18/02/2006, à 12:47)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#7 Le 18/02/2006, à 13:41

neu9

Re : failed to load the NVIDIA kernel désolé :-(((

merci du conseil Mr Pouit,

j'essaie
synaptic ready, see you after restart..... :crossingfingers:
linux-image-2.6.12-10-k7 (version 2.6.12-10.28) sera installé
linux-restricted-modules-2.6.12-10-k7 (version 2.6.12.4-11.1) sera installé
nvidia-glx (version 1.0.7667-0ubuntu25.1) sera installé

Hors ligne

#8 Le 18/02/2006, à 15:06

neu9

Re : failed to load the NVIDIA kernel désolé :-(((

perdu sad

j'ai bien reconfiguré le serverX avec debconf ( "sudo dpkg-reconfigure xserver-xorg" ), j'ai redémarré, et pouf.

le server x ne peut pas démarrer
extrait du /var/log/Xorg.0.log

(II) NVIDIA X Driver  1.0-7667  Fri Jun 17 07:03:12 PDT 2005
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found
....
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found

voici le xorg.conf généré :

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "\uffffcran g\uffffn\uffffrique"
        Option          "DPMS"
        HorizSync       30-70
        VertRefresh     50-160
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Monitor         "\uffffcran g\uffffn\uffffrique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

en remettant l'ancien xorg ca redémarre
mais j'ai de nouveau les erreurs de segmentation

l'ancien (enfin l'actuel maintenant yikes ) xorg pour info

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Driver          "nv"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "\uffffcran g\uffffn\uffffrique"
        Option          "DPMS"
        HorizSync       28-64
        VertRefresh     43-60
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Monitor         "\uffffcran g\uffffn\uffffrique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

Hors ligne

#9 Le 18/02/2006, à 15:23

neu9

Re : failed to load the NVIDIA kernel désolé :-(((

la:
http://howto.stephane-huc.net/nVidia/Faq/Problem/Server_X/fail_load/
j'ai trouvé :

Le module nVidia n'arrive pas à se charger...
Examinez donc la sortie dmesg, puis essayez de charger le module : modprobe nvidia.
Si lsmod rapporte qu'un module noyau " nvidia " est chargé, il est possible que des fichiers de périphériques (/dev/nvidiactl, /dev/nvidia0..7) soient manquants.

en effet :

>lsmod|grep nvidia
nvidia               3711172  0
agpgart                34888  2 sis_agp,nvidia
>ls /dev/nv*
ls: /dev/nv*: Aucun fichier ou répertoire de ce type

quand donc connaitrais-je les joies du pingouin qui fuse ?

Hors ligne

Haut de page ↑