Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 18/02/2006, à 09:27

jmb

impossible de faire fonctionner la 3d

cela fait une semaine j'ai installer ubuntu tout va bien sauf les jeux en trois d. je possede un duron 900 avec une geforce2 ti. j.ai essayer  plusieurs methode pour installer les driver nvidia mais ca ne marche pas .quand je redemarre .il y a toujour un message qui me dit que mon serveur x est mal configurer. je ne sait plus quoi verifier.

Hors ligne

#2 Le 18/02/2006, à 11:41

papadon

Re : impossible de faire fonctionner la 3d

Télécharge EasyUbuntu, décompresse-le et à l'exécution coche uniquement la
catégorie 3D (Pilote supportant la 3D pour les cartes graphiques Nvidia et ATI).
Suit la procédure comme indiqué, puis fait un Ctrl+Alt+BckSpc pour relancer le serveur X.:)
Sélectionne ensuite un écran de veille dont le nom commence par GL ... et teste-le.
Si c'est fluide, l'accélération est active et ok pour les jeux.;)

Dernière modification par papadon (Le 18/02/2006, à 11:43)

Hors ligne

#3 Le 18/02/2006, à 17:45

jmb

Re : impossible de faire fonctionner la 3d

bonjour, j'ai installer easyubuntu .tout semble bien aller.j'appuie sur ctrl+alt+backspc,la session ce ferme,j'ouvre a nouveau ma session,essaie des ecran de veille certaine fonction mais d'autre n'affiche rien comme (bubble 3d) l'ecran reste noir.j'essayer tuxracer et cube mais il ne veule pas demarrer . merci

Hors ligne

#4 Le 18/02/2006, à 22:17

neu9

Re : impossible de faire fonctionner la 3d

comme j'ai le meme souci (voir le post "kernel machin désolé :-(((" ), j'ai essayé easyubuntu (ca a l'air tres tres pratique).

je me suis remis dans une config correcte (tous les paquets "suspects" en mois) avec Slune qui se lance, mais qui rame.
j'ai suivi les conseils ci-dessous de papadon

la log easyubuntu donne quelques erreurs (vue en live, mais perdues apres le restart du server X)
ca se terminait par qqch du genre "nivida-glx exited with status 1"

et slune ne se lance plus du tout (donc la 3D ne marche pas)

 slune
* Slune * Slune lives in /usr/share/games
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Video mode set failed : Couldn't find matching GLX visual
Exception exceptions.RuntimeError: <exceptions.RuntimeError instance at 0xb7d22a8c> in '_soya.init_video' ignored
* Soya 3D * Warning : glGetString returns NULL!
Erreur de segmentation

sad sad sad sad sad

Hors ligne

#5 Le 19/02/2006, à 00:39

patlas

Re : impossible de faire fonctionner la 3d

salut,

+1

avant, s'était saccadé et maintenant même pas de lancement.


pc 3800 amd 64 1go ram : bubuntu
pc Dell précision 2600 512 mb  : Bubuntu
portable MSI VR600 64 : bubuntu et IBM T23 PIII : opengeu (e17)
tout en un BROTHER DCP-560-CN

Hors ligne

#6 Le 19/02/2006, à 06:29

jmb

Re : impossible de faire fonctionner la 3d

enfin,enfi,enfin,apres plusieur heures de manipulation de toute sorte j'ai enfin reussie a faire fonctionner la TROIS D .j'ai utiliser la methode (installation en mode graphique) du  pilot nvidia.citer dans la documation de ce site.je l'avait deja essayer quelque fois , mais j'avais toujours des erreurs dans la demarche.le probleme etait au niveau des choix des paquets installer sur l'ordi, en fonction de son materiel.ce qui n'est pas  tres bien expliquer soit dit en passant pour un novice comme moi.

voici ma configuration
duron 900
carte nvidia geforce2 ti
kernel 2.6.12-10-k7

paquets installer:
linux-restricted-modules-2.6.1:2.6.12.4-11.1
nvidia-glx-legacy
nvidia-kernel-commun
nvidia-legacy-kernel-source
nvidia-settings

plus on a de la difficulter a resoudre un probleme
plus grande est la joie quand on a resolue le probleme

Hors ligne

#7 Le 19/02/2006, à 11:05

neu9

Re : impossible de faire fonctionner la 3d

allez je tente le coup

nvidia-glx sera désinstallé
linux-restricted-modules-2.6.12-10-386-nvidia-legacy (version 2.6.12.4-11.1) sera installé
nvidia-glx-legacy (version 1.0.7174-0ubuntu25.1) sera installé

normalement, la GeForce FX5200 n'utilise pas les legacy mais les "normaux", mais bon, chuis bon à rien et prêt à tout... tongue

Hors ligne

#8 Le 19/02/2006, à 11:15

papadon

Re : impossible de faire fonctionner la 3d

Bonjour,
voyez-vous le logo Nvidia apparaitre avant l'ouverture du bureau ?
Avez-vous bien la valeur 'nvidia' comme paramètre de l'option 'Driver' de la section
'Device' du fichier xorg.conf ? hmm

Hors ligne

#9 Le 19/02/2006, à 11:26

neu9

Re : impossible de faire fonctionner la 3d

hello,
non, pas de logo;
et oui, pour tester l'install des packages cités à 10H05, j'ai mis "nvidia" a la place de "nv"

=> le serveur X n'a plus voulu démarrer.

/var/log$ grep -i nvidia Xorg.0.log
(**) |   |-->Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
(--) PCI:*(1:0:0) nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @ 0xe7000000/24, 0xf0000000/27, BIOS @ 0xeffe0000/17
(II) Module glx: vendor="NVIDIA Corporation"
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
(EE) Failed to initialize GLX extension (NVIDIA X driver not foun

du coup j'ai remis "nv" dans device pour revenir au bureau
(j'ai pas lynx en console lol )

PS : sympa ton bureau !

Dernière modification par neu9 (Le 19/02/2006, à 11:29)

Hors ligne

#10 Le 19/02/2006, à 12:20

neu9

Re : impossible de faire fonctionner la 3d

bon j'ai re-désinstallé des paquets et réinstallé uniqument nvidia-glx
j'ai donc :

dpkg -l | grep -i nvidia
ii  nvidia-glx                                1.0.7667-0ubuntu25.1                 NVIDIA binary XFree86 4.x/X.Org driver
rc  nvidia-glx-legacy                         1.0.7174-0ubuntu25.1                 NVIDIA binary XFree86 4.x/X.Org 'legacy' dri
ii  nvidia-kernel-common                      1.0.7667+1                           NVIDIA binary kernel module common files
ii  nvidia-settings                           1.0-3ubuntu6                         Tool of configuring the NVIDIA graphics driv

mais quand je tente de lancer la commande indiquée dans le tuto
sudo nvidia-glx-config enable
j'obtiens

Error: your X configuration has been altered.
This script cannot proceed automatically. If you believe that this
not correct, you can update the md5sum entry executing the following
command:
md5sum /etc/X11/xorg.conf | sudo tee /var/lib/xfree86/xorg.conf.md5sum
otherwise edit manually /etc/X11/xorg.conf to change the Driver section
from nv to nvidia.

la, je vois pas quoi faire hmm

Hors ligne

#11 Le 19/02/2006, à 13:01

neu9

Re : impossible de faire fonctionner la 3d

bon, j'ai fait ca
md5sum /etc/X11/xorg.conf | sudo tee /var/lib/xfree86/xorg.conf.md5sum

puis
sudo nvidia-glx-config enable
=> ca a marché (pas de message d'erreur)

restart serveur X => freeze
reboot => OK mais à nouveau "erreur de segmentation" sur xmms, slune...
méééééééheuuuuuu !

je fais un sudo nvidia-glx-config disable pour voir si je reviens à l'état précédent.

Hors ligne

#12 Le 24/02/2006, à 21:32

Lestat the vampire

Re : impossible de faire fonctionner la 3d

Essaie mon tuto sur l'install des drivers nvidia à la main. Mais desinstalle bien tous les paquets nvidia de ton système avant de l'essayer.
A+

Hors ligne

Haut de page ↑