Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 19/02/2006, à 22:25

gontofe

erreur v4l

Salut à tous,

J'ai un problème avec Ubuntu depuis la mise à jour du kernel linux il y a quelques jours:

J'ai une webcam creative webcam nx, et depuis la mise à jour du kernel (je suis passé du 2.6.12-9-386 au 2.6.12-10-386), dès que je démarre un logiciel comme camorama ou gnomemeeting, j'ai tout qui plante (même la souris ne bouge plus), et je suis obligé à éteindre l'ordi manuellement.

Comment faire pour regler ce problème?

Mike

p.s. J'utilise actuellement GAIM, mais il me faudrait quoi comme logiciel pour me servir de la webcam (quand elle marchera) sur msn?

Hors ligne

#2 Le 19/02/2006, à 22:28

Stemp

Re : erreur v4l

Salut,

Il faut réinstaller le driver spca5xx, fait une petite recherche sur le forum et tu trouveras ton bonheur


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#3 Le 19/02/2006, à 23:32

gontofe

Re : erreur v4l

J'ai essayé d'installer le pilote spca5xx, mais en tapant 'make' je reçois l'erreur:

   Building SPCA5XX driver for 2.5/2.6 kernel.
   Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/mike/Desktop/spca5xx-20060202 CC=/usr/bin/gcc-3.4 modules
make: *** /lib/modules/2.6.12-10-386/build: No such file or directory.  Stop.
make: *** [default] Error 2

j'ai également essayé avec compileur 3.4, ça marche tjrs pas.

Mike

Hors ligne

#4 Le 20/02/2006, à 03:34

Stemp

Re : erreur v4l

Voila pourquoi je disais de faire une petite recherche.
Tu aurais vu qu'il fallait utiliser la version 3 de Gcc et récupèrer quelques paquets.
Je n'ai pas le fil entête, donc à toi de trouver wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#5 Le 20/02/2006, à 11:46

gontofe

Re : erreur v4l

et voilà pourquoi j'avais déjà fait une recherche!

J'ai vu sur http://forum.ubuntu-fr.org/viewtopic.php?id=14920 que tu a répondu à qqun en lui disant qu'il fallait compiler avec gcc-3.4 donc c'est ce que j'ai fait, et j'ai obtenu l'erreur suivant:

Building SPCA5XX driver for 2.5/2.6 kernel.
   Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/mike/Desktop/spca5xx-20060202 CC=gcc-3.4 modules
make: *** /lib/modules/2.6.12-10-386/build: No such file or directory.  Stop.
make: *** [default] Error 2

J'ai aussi vérifié que build-essential, linux-image, linux-headers était les versions les plus récentes, et j'ai executé make avec sudo.

Alors je fais comment? Ca fait pas très longtemps que je suis sous Linux, il faut m'excuser si je te semble un peu crétin!

Modif' du 21/02

J'ai reussi à trouver une solution, après avoir désinstallé easycam 1 et 2, et après avoir supprimé le dossier SPCA5XX j'ai tout refait depuis le début et ça marche.

J'ai trouvé de l'info sur le forum anglophone (http://www.ubuntuforums.org/showthread.php?t=75284), je crois que la seule différence c'est linux-restricted-modules - bizarre!

sudo apt-get install linux-headers-`uname -r` linux-restricted-modules-`uname -r` build-essential gcc-3.4
wget http://mxhaard.free.fr/spca50x/Download/spca5xx-20060202.tar.gz
tar xvfz spca5xx-20060202.tar.gz
cd spca5xx-20060202
sudo make CC=gcc-3.4
sudo modprobe -r spca5xx
sudo rm -rf /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx*
sudo make install
sudo modprobe spca5xx

Mais enfin l'important c'est que ça marche.

Dernière modification par gontofe (Le 21/02/2006, à 10:26)

Hors ligne

#6 Le 21/02/2006, à 23:46

Galyatord

Re : erreur v4l

Dans une bataille feroce pour installer la web cam PHILIPS SPC 200 NC, j'ai essayé le code proposé par Gontofe.
J'ai lancé camorama par le menu et j'ai vu ma tronche...mais l'image est à 90° et surtout une seconde relance dans la même session provoque un freeze et oblige un reboot PC. J'ai un fonctionnement très aléatoire!

J'ai trouve unse solution sous (http://doc.ubuntu-fr.org/materiel/webcam_scpa50x) sans succès.

Puis j'ai trouvé:
"
Avec certaines version du chipset de la Quickcam Messenger, le driver fonctionne bien lors de la compilation et le test avec xawtv est concluant, mais après un reboot, cela ne fonctionne plus. Ceci est du à un mauvais chargement du driver. La solution la plus commune est de le recharger de la manière suivante:
"
Je pense que j'ai le même soucis avec les drivers SPCA5XX.
Avez-vous un piste?