Contenu | Rechercher | Menus

#226 Le 16/12/2015, à 21:58

manon123
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

L'ajout a été automatique avec le script.

Pour le bouton, c'était un bouton à configurer en choisissant une palette de couleurs etc. juste après l'installation du programme.

C'était avec le script complémentaire au tien :

Image.


Asus, carte-mère Z97-E, 16 Go RAM, Xubuntu 16.04 et LinuxMint 17 Rosa. Ubuntu 16.04 sur portable.

Hors ligne

#227 Le 16/12/2015, à 22:16

metalux
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Je ne trouve pas le dépôt MEGA, j'ai seulement trouvé un .deb, tu peux m'indiquer un lien que je teste?

Pour le bouton, en fait c'est une notification. Et tu la règles avec l'application maj-auto-notify. L'as-tu installée? Si tu n'en n'es pas sûr, lance en terminal:

maj-auto-notify

comme ça tu sauras si elle est installée. Pour quitter, passe par le bouton Quitter et non par la croix des décorations de fenêtre, sinon ça ne quitte pas correctement.

Hors ligne

#228 Le 16/12/2015, à 22:35

manon123
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Voici l'adresse de l'installation où je l'avais trouvé :

Sa description (en anglais) : megasync

Installation
Download the Mega Sync Client for Linux. Open the terminal in the directory you downloaded the deb file, then Copy/Paste the following code: sudo dpkg -i megasync-xUbuntu_14.04_amd64.deb. After that start mega from the Dash, from there one it will start up at login.

Note:

The deb file also adds a ppa in your sources list. Meaning future updates, you will get via your Software Updater.

For the people that don't trust any type of PPA, but still want mega, I uploaded the binary: megasync-gui to virustotal.

Mega sync will start automatically: In the unity panel you will see a MEGA icon which gives you multiple options to choose from.


Asus, carte-mère Z97-E, 16 Go RAM, Xubuntu 16.04 et LinuxMint 17 Rosa. Ubuntu 16.04 sur portable.

Hors ligne

#229 Le 16/12/2015, à 23:48

metalux
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

J'ai regardé un peu et c'est plus compliqué que je le pensais. Les dépôts owncloud et MEGA sont des cas un peu particulier, je ne sais pas si il y en a d'autres comme ceux-ci (pas sûr qu'il y en ait d'autres), mais pour l'instant il ne faut pas les sélectionner avec le script et ajouter dans unnatended-upgrades (le fichier est éditable directement à partir du script) juste avant la ligne: // List of packages to not update

Unattended-Upgrade::Origins-Pattern {
        "o=obs://Mega/MEGAsync/xUbuntu_14.04,a=xUbuntu_14.04";
};

Il faudra adapter la ligne en fonction de sa version d'Ubuntu. Le plus simple est de vérifier avec cette commande:

grep Origin /var/lib/apt/lists/mega.*Release

Hors ligne

#230 Le 01/04/2016, à 18:09

El Catala
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Bonsoir,

J' ai tenté d' utiliser ce script sans succès. De plus, depuis, plus de mise à jour et impossible de passer par "Paramètres systèmes" puisque la fonction "Recherche de mise à jour" est désactivée.
Comment puis-je supprimer ce script et réactiver la recherche par " Paramètre système"?

Bonne soirée


PC portable EasyNote TE69KB
Ubuntu 15.04
LibreCad 2.2 : LibreOffice 5.0.3

Hors ligne

#231 Le 01/04/2016, à 18:53

metalux
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Bonjour El Catala,
Je doute du rapport de cause à effet, ce script n'intervient que sur le fichier unattended-upgrades pour automatiser les mises à jour. Dommage que tu n'as pas réussi à l'utiliser mais je suis prêt à t'aider si tu es toujours intéressé par ce script. En attendant, tu as une option dans le script pour tout annuler et remettre comme avant l'utilisation de celui-ci, il s'agit de l'option "Restaurer la configuration initiale". Si ça ne résous pas tes problèmes, donne moi le retour de:

cat /etc/apt/apt.conf.d/50unattended-upgrades

ainsi que de:

sudo apt-get update
sudo apt-get upgrade

Avais-tu installé les dépendances avant d'utiliser le script? En particulier gksu?

Hors ligne

#232 Le 03/04/2016, à 19:53

El Catala
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Bonsoir metalux,

Suite à votre intervention, voici les réponses demandées:
Première commande:
cat /etc/apt/apt.conf.d/50unattended-upgrades

// Automatically upgrade packages from these (origin:archive) pairs
Unattended-Upgrade::Allowed-Origins {
"Canonical:vivid";
"Ubuntu:vivid-backports";
"Ubuntu:vivid";
"Ubuntu:vivid-security";
"Ubuntu:vivid-updates";
"LP-PPA-cinelerra-ppa:vivid";
"LP-PPA-yoggic-dpluzz:vivid";
};
// List of packages to not update (regexp are supported)
Unattended-Upgrade::Package-Blacklist {
//	"vim";
//	"libc6";
//	"libc6-dev";
//	"libc6-i686";
};

// This option allows you to control if on a unclean dpkg exit
// unattended-upgrades will automatically run 
//   dpkg --force-confold --configure -a
// The default is true, to ensure updates keep getting installed
//Unattended-Upgrade::AutoFixInterruptedDpkg "false";

// Split the upgrade into the smallest possible chunks so that
// they can be interrupted with SIGUSR1. This makes the upgrade
// a bit slower but it has the benefit that shutdown while a upgrade
// is running is possible (with a small delay)
//Unattended-Upgrade::MinimalSteps "true";

// Install all unattended-upgrades when the machine is shuting down
// instead of doing it in the background while the machine is running
// This will (obviously) make shutdown slower
//Unattended-Upgrade::InstallOnShutdown "true";

// Send email to this address for problems or packages upgrades
// If empty or unset then no email is sent, make sure that you
// have a working mail setup on your system. A package that provides
// 'mailx' must be installed. E.g. "user@example.com"
//Unattended-Upgrade::Mail "root";

// Set this value to "true" to get emails only on errors. Default
// is to always send a mail if Unattended-Upgrade::Mail is set
//Unattended-Upgrade::MailOnlyOnError "true";

// Do automatic removal of new unused dependencies after the upgrade
// (equivalent to apt-get autoremove)
//Unattended-Upgrade::Remove-Unused-Dependencies "false";

// Automatically reboot *WITHOUT CONFIRMATION*
//  if the file /var/run/reboot-required is found after the upgrade 
//Unattended-Upgrade::Automatic-Reboot "false";

// If automatic reboot is enabled and needed, reboot at the specific
// time instead of immediately
//  Default: "now"
//Unattended-Upgrade::Automatic-Reboot-Time "02:00";

// Use apt bandwidth limit feature, this example limits the download
// speed to 70kb/sec
//Acquire::http::Dl-Limit "70";

Pour la deuxième commande,le résultat est:

Atteint http://fr.archive.ubuntu.com vivid InRelease
Ign http://dl.google.com stable InRelease                                      
Atteint http://fr.archive.ubuntu.com vivid-updates InRelease                   
Atteint http://fr.archive.ubuntu.com vivid-backports InRelease                 
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://fr.archive.ubuntu.com vivid-security InRelease                  
Réception de : 1 http://ppa.launchpad.net vivid InRelease [15,4 kB]            
Atteint http://archive.canonical.com vivid InRelease                           
Atteint http://dl.google.com stable Release                                    
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://dl.google.com stable/main amd64 Packages                        
Réception de : 2 http://ppa.launchpad.net vivid/main amd64 Packages [6 091 B]  
Réception de : 3 http://ppa.launchpad.net vivid/main i386 Packages [6 088 B]   
Réception de : 4 http://ppa.launchpad.net vivid/main Translation-en [2 406 B]  
Atteint http://archive.canonical.com vivid/partner amd64 Packages              
Atteint http://archive.canonical.com vivid/partner i386 Packages               
Atteint http://archive.canonical.com vivid/partner Translation-en              
Atteint http://fr.archive.ubuntu.com vivid/main Sources                 
Atteint http://fr.archive.ubuntu.com vivid/restricted Sources                  
Atteint http://fr.archive.ubuntu.com vivid-backports/restricted Sources        
Atteint http://fr.archive.ubuntu.com vivid-backports/multiverse Sources        
Atteint http://fr.archive.ubuntu.com vivid-backports/restricted amd64 Packages 
Atteint http://ppa.launchpad.net vivid/main Sources                            
Atteint http://fr.archive.ubuntu.com vivid-backports/multiverse amd64 Packages 
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://fr.archive.ubuntu.com vivid-backports/restricted i386 Packages  
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://fr.archive.ubuntu.com vivid-backports/multiverse i386 Packages  
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://fr.archive.ubuntu.com vivid-backports/multiverse Translation-en 
Atteint http://fr.archive.ubuntu.com vivid-backports/restricted Translation-en 
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://ppa.launchpad.net vivid/main i386 Packages               
Atteint http://ppa.launchpad.net vivid/main Translation-en              
Atteint http://ppa.launchpad.net vivid/main amd64 Packages              
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://ppa.launchpad.net vivid/main Translation-en              
Atteint http://fr.archive.ubuntu.com vivid/universe Sources
Atteint http://fr.archive.ubuntu.com vivid/multiverse Sources
Atteint http://fr.archive.ubuntu.com vivid/main amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid/restricted amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid/universe amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid/multiverse amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid/main i386 Packages
Atteint http://fr.archive.ubuntu.com vivid/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com vivid/universe i386 Packages
Atteint http://fr.archive.ubuntu.com vivid/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com vivid/main Translation-fr
Atteint http://fr.archive.ubuntu.com vivid/main Translation-en
Atteint http://fr.archive.ubuntu.com vivid/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com vivid/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com vivid/restricted Translation-fr
Atteint http://fr.archive.ubuntu.com vivid/restricted Translation-en
Atteint http://fr.archive.ubuntu.com vivid/universe Translation-fr
Atteint http://fr.archive.ubuntu.com vivid/universe Translation-en
Atteint http://fr.archive.ubuntu.com vivid-updates/main Sources
Atteint http://fr.archive.ubuntu.com vivid-updates/restricted Sources
Atteint http://fr.archive.ubuntu.com vivid-updates/universe Sources
Atteint http://fr.archive.ubuntu.com vivid-updates/multiverse Sources
Atteint http://fr.archive.ubuntu.com vivid-updates/main amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-updates/restricted amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-updates/universe amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-updates/multiverse amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-updates/main i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-updates/restricted i386 Packages  
Atteint http://fr.archive.ubuntu.com vivid-updates/universe i386 Packages    
Atteint http://fr.archive.ubuntu.com vivid-updates/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-updates/main Translation-en
Atteint http://fr.archive.ubuntu.com vivid-updates/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com vivid-updates/restricted Translation-en
Atteint http://fr.archive.ubuntu.com vivid-updates/universe Translation-en
Atteint http://fr.archive.ubuntu.com vivid-backports/main Sources
Atteint http://fr.archive.ubuntu.com vivid-backports/universe Sources
Atteint http://fr.archive.ubuntu.com vivid-backports/main amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-backports/universe amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-backports/main i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-backports/universe i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-backports/main Translation-en
Atteint http://fr.archive.ubuntu.com vivid-backports/universe Translation-en
Atteint http://fr.archive.ubuntu.com vivid-security/main Sources
Atteint http://fr.archive.ubuntu.com vivid-security/restricted Sources
Atteint http://fr.archive.ubuntu.com vivid-security/universe Sources
Atteint http://fr.archive.ubuntu.com vivid-security/multiverse Sources
Atteint http://fr.archive.ubuntu.com vivid-security/main amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/restricted amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/universe amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/multiverse amd64 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/main i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/universe i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com vivid-security/main Translation-en
Atteint http://fr.archive.ubuntu.com vivid-security/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com vivid-security/restricted Translation-en
Atteint http://fr.archive.ubuntu.com vivid-security/universe Translation-en
30,0 ko réceptionnés en 17s (1 709 o/s)                                        
W: Impossible de récupérer http://dl.google.com/linux/chrome/deb/dists/stable/Release  Impossible de trouver l'entrée « main/binary-i386/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

et enfin pour la troisième commande:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.19.0-49 linux-headers-3.19.0-49-generic
  linux-image-3.19.0-49-generic linux-image-extra-3.19.0-49-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Fait
Les paquets suivants seront mis à jour :
  google-chrome-stable my-weather-indicator
2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 52,8 Mo dans les archives.
Après cette opération, 2 338 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://dl.google.com/linux/chrome/deb/ stable/main google-chrome-stable amd64 49.0.2623.110-1 [48,7 MB]
Réception de : 2 http://ppa.launchpad.net/atareao/atareao/ubuntu/ vivid/main my-weather-indicator all 0.7.5-0extras15.10.0 [4 153 kB]
52,8 Mo réceptionnés en 30s (1 726 ko/s)                                       
(Lecture de la base de données... 351744 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../google-chrome-stable_49.0.2623.110-1_amd64.deb ...
Dépaquetage de google-chrome-stable (49.0.2623.110-1) sur (48.0.2564.109-1) ...
Préparation du dépaquetage de .../my-weather-indicator_0.7.5-0extras15.10.0_all.deb ...
Dépaquetage de my-weather-indicator (0.7.5-0extras15.10.0) sur (0.7.0-0extras15.10.0) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+15.04.20150202-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.58ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour fontconfig (2.11.1-0ubuntu6) ...
Paramétrage de google-chrome-stable (49.0.2623.110-1) ...
Paramétrage de my-weather-indicator (0.7.5-0extras15.10.0) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47ubuntu1) ...

Par contre, pourriez-vous m' expliquer le tenant de ces trois commandes et surtout la première.

Merci de votre intervention et bonne soirée.

Cordialement


PC portable EasyNote TE69KB
Ubuntu 15.04
LibreCad 2.2 : LibreOffice 5.0.3

Hors ligne

#233 Le 03/04/2016, à 20:56

metalux
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Bonsoir,
Finalement tout est normal, tu utilises bien le script et avec succès contrairement à ce que tu crois (je me permets de te tutoyer, le tutoiement étant habituellement utilisé sur le forum, fais en de même wink )
Voici un extrait de la documentation:

Ubuntu 15.04 (nom de code : The Vivid Vervet) est la vingt-deuxième version d'Ubuntu. Son cycle de développement a débuté en octobre 2014, suivant la sortie de la précédente mouture. La version stable, finale d'Ubuntu 15.04 a été publiée le 23 avril 2015 ; son cycle de maintenance s'échelonnera sur neuf mois, soit jusqu'au 4 février 2016

Donc depuis le 04 février, les dépôts de Vivid ont été désactivés ce qui explique que la fonction "Recherche de mise à jour" est désactivée. Cette version n'est plus maintenue, je te conseille de passer soit à trusty (Ubuntu 14.04) soit de patienter un tout petit peu et passer à Xenial (Ubuntu 16.04) qui va sortir ce mois-ci. Ce sont des LTS maintenues 5 ans contrairement à Vivid qui était maintenu simplement 9 mois.
Pour les 3 commandes que je t'ai demandé, voici à quoi elles servent:
1-sudo apt-get update met à jour la liste des paquets disponibles. Cette étape est indispensable avant de mettre à jour pour comparer la liste la plus récente avec les paquet installés et voir ceux qui ont une version plus récente.
2-sudo apt-get upgrade va mettre à jour les paquets qui ont une version plus récente. Ta distribution n'étant plus maintenue, rien ne t'es proposé hormis les paquets en provenance de dépôts extérieurs. C'est le cas ici pour les 2 dépôts suivants qui proposent une mise à jour:

http://dl.google.com/linux/chrome/deb/ pour Google-chrome
http://ppa.launchpad.net/atareao/atareao/ubuntu/ pour my-weather-indicator

L'autre commande sert à vérifier le contenu du fichier /etc/apt/apt.conf.d/50unattended-upgrades, c'est ce fichier qui est modifié par le script maj_auto.
On y voit que tu as demandé la mise à jour automatique pour l'ensemble des mises à jour des dépôts Ubuntu (hormis proposed mais c'est ce qu'il faut faire, c'est le paramétrage de base d'Ubuntu) ainsi que pour les P.P.A. de Cinerella et Dpluzz. Il n'y a eu aucune mise à jour de faîte avec la commande sudo apt-get upgrade pour Cinerella ou Dpluzz, ce qui est normal car le script met à jour ces paquets depuis que tu l'as installé. Tu ne t'es même pas rendu compte comme c'était automatique mais tu as bien les dernières versions de ces logiciels grâce au script.

J'en profite pour te faire une remarque concernant cette erreur:
W: Impossible de récupérer http://dl.google.com/linux/chrome/deb/d … le/Release  Impossible de trouver l'entrée « main/binary-i386/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu
La solution est dans la documentation de Google-chrome, sinon utilise Chromium à la place.

Hors ligne

#234 Le 04/04/2016, à 18:58

El Catala
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Bonsoir metalux,
En fait, n' ayant pas demandé d' être prévenu par courriel, je ne me suis pas rendu compte des mises à jour. Pour le tutoiement, pas de soucis, mais à 67 ans, on ne se refait pas.
Pour vivid, je vais patienter jusqu' au 21 avril pour pour passer en version 16.04 LTS.
Encore merci de vos réponses et bonne continuation


PC portable EasyNote TE69KB
Ubuntu 15.04
LibreCad 2.2 : LibreOffice 5.0.3

Hors ligne

#235 Le 27/04/2016, à 21:56

ewfzapp
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

merci c'est top


www.indigenecreations.fr

Hors ligne

#236 Le 27/04/2016, à 22:20

metalux
Membre

Re : [Script] Mise à jour automatique pour tous les paquets (y compris PPA)

Ça fait plaisir smile

Hors ligne