Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 15/04/2005, à 22:25

ludal

[RESOLU][twinview - nvidia - hoary] N'arrive pas à configurer 2 écrans

Bonjour à tous.

Oui, je sais, la question a été posée 100 000 fois, mais je bute. Voici mon problème.

J'avais fait une première install de la Warty, j'avais réussi à configurer le twinview en suivant les conseils de ce monsieur. Lors de mon upgrade vers Hoary ça a tout planté... impossible de refaire marcher le bouzin.

J'ai réinstallé ma Warty en faisant immédiatement l'update vers Hoary. Pour l'instant tout se passe bien, mais je n'arrive plus en suivant les conseils de ce même site à mettre en oeuvre le twinview.

J'ai branché un echan LCD à la sortie principale et un CRT à la sortie DVI avec un connecteur DVI=>VGA

Voici mon XF86Config-4

# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"v4l"
	Load	"vbe"
	Load	"xtt"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV36 [GeForce FX 5700 LE]"
	Driver		"nv"
	BusID		"PCI:2:0:0"
	Option "TwinView" "true"
	Option "SecondMonitorHorizSync" "30.0-65.0"
	Option "SecondMonitorVertRefresh" "50.0-90.0"
	Option "MetaModes" "1280x1024, 1280x1024; 1024x768, 1024x768; 640x480, NULL"
	Option "TwinViewOrientation" "RightOf"
	Option "ConnectedMonitor" "dfp,dfp"
EndSection

Section "Monitor"
	Identifier	"B17AAH/S"
	HorizSync	31-81
	VertRefresh	56-75
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV36 [GeForce FX 5700 LE]"
	Monitor		"B17AAH/S"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

Merci de me dire si vous voyez une coquille ou si vous connaissez un bug qui pourrait m'exploquer pourquoi je n'y arrive plus...

Dernière modification par ludal (Le 17/04/2005, à 18:04)

Hors ligne

#2 Le 16/04/2005, à 01:04

lamiricore

Re : [RESOLU][twinview - nvidia - hoary] N'arrive pas à configurer 2 écrans

Il me semble que pour Hoary (en fait je suis sûr mais bon je n'ai jamais fait la mise à jour de warty à hoary) ce n'est Xfree mais X.org le serveur graphique (suite à des problèmes de licences) :il faut donc modifier xorg.conf ; la syntaxe est la même mais fais une sauvegarde au préalable de ce fichier

#3 Le 16/04/2005, à 11:09

PengouinPdt

Re : [RESOLU][twinview - nvidia - hoary] N'arrive pas à configurer 2 écrans

lamiricore a raison !

sur ubuntu, c'est bien le fichier /etc/X11/xorg.conf, et non /etc/X11/XFree86.conf-4 !

après si tu utilises le driver générique 'nv', tu ne pourras pas avoir accès à la fonctionnalité TwinView.
Il te faut installer le pilote propriétaire nVidia, voir la section documentation du site ubuntu, c'est trois commandes à taper, le reste se fait solo.

Sur ce, il te faudra veiller à modifier dans ta section "Device",
* en changeant :
- Option "nv" par Option "nvidia"
- Option "TwinView" "CRT-0 RightOf CRT-1"
(et, oui, en étant sur sortie VGA, tes écrans sont reconnus commes des CRT et non DFP !)
- enleve les '.0' des valeurs sur les Options "SecondMonitor...", pas besoin de les préciser autant, puisque "30.0-65.0" est égal à "30-65" !!!

* en supprimant :
- Option "ConnectedMonitor"
(n'est nécessaire que si vraiment tes écrans ne sont pas gérés, ce qui serait fortement étonnant vu leur jeunesse !)

* en ajoutant :
- Option "NvAgp" "3"
- Option "RenderAccel" "on"

Enfin, je cultive un HowTo qui devrait t'être utile !

Dernière modification par ste (Le 16/04/2005, à 11:10)

Hors ligne

#4 Le 16/04/2005, à 20:05

ludal

Re : [RESOLU][twinview - nvidia - hoary] N'arrive pas à configurer 2 écrans

Merci à vous pour vos réponses, effectivement, c'était bien cela. Il ne me reste plus qu'à peaufiner ma configuration, mais l'essentiel est là : Mes 2 écrans.

Hors ligne

#5 Le 17/04/2005, à 12:14

lamiricore

Re : [RESOLU][twinview - nvidia - hoary] N'arrive pas à configurer 2 écrans

Non il te reste aussi à éditer ton premier post et rajouter [résolu] wink

#6 Le 18/04/2005, à 18:26

lemanu

Re : [RESOLU][twinview - nvidia - hoary] N'arrive pas à configurer 2 écrans

Est ce que quelqu'un peut poster sa config Xorg pour le twinview (avec sortie TV pas de second ecran):D

Je suis surtout interressé par la section device:)

Merci d'avance:cool:

Haut de page ↑