Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#126 Le 01/08/2016, à 22:33

Tuxmouraille

Re : Synthèse vocale SVOX Pico

Bonjour à tous,
Sympa qu'il est encore des gens qui s'intéresse à gSpeech. Je l'avais laissé tombé.
Ubuntu 16.04 est passé à gstreamer 1.0  donc il manque des paquets gstreamer 0.10 qui avant étaient installés par défaut.
Ceux ci suffisent chez moi: gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-pulseaudio

Dernière modification par Tuxmouraille (Le 01/08/2016, à 22:39)


Le support d'Optimus pour Linux.
Ubuntu 12.10 64 bits, portable ASUS N53SN-SZ161V, Intel® Core™ i5-2410M @ 2.30GHz, 8080MB SODIM Ram, NVIDIA® GeForce™ GT 550M

Hors ligne

#127 Le 01/08/2016, à 22:52

alansan2011

Re : Synthèse vocale SVOX Pico

Mais bien sur qu'il y a encore des gens qui s'intéressent à gSpeech !!!
Pour ma part, c'est la meilleur qualité vocale en tts sous linux !!!!
;-)


Ubuntu 12.04.5 LTS * UbuntuStudio 14.04.4 LTS * Ubuntu 16.04 LTS en test régulier.....

Hors ligne

#128 Le 01/10/2016, à 17:43

Laurdbayrone

Re : Synthèse vocale SVOX Pico

Tuxmouraille a écrit :

Bonjour à tous,
Sympa qu'il est encore des gens qui s'intéresse à gSpeech. Je l'avais laissé tombé.

Bien sur, c'est une belle application très utile pour les "flémmards" de la lecture comme moi.
Merci pour ton travail.


Ubuntu: Humanité envers les autres...
Mon modeste blog: http://laurdbayrone.wordpress.com/

Hors ligne

#129 Le 27/01/2017, à 11:30

Isaric

Re : Synthèse vocale SVOX Pico

J'ai bien d'installé (de base ???) gstreamer1.0-plugins-base...

Tuxmouraille a écrit :

... qui s'intéresse à gSpeech. Je l'avais laissé tombé....

La documentation svoxpico qui parle de gSpeech est peut-être obsolète ?
Il ne s'installe pas chez moi ! sad
Quand je vois les prouesses des smartphones, je voulais reproduire la même chose sur l'ordinateur, mais je n'ai pas trouvé de solution.


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#130 Le 27/01/2017, à 12:15

gl38

Re : Synthèse vocale SVOX Pico

Qu'entends-tu par "Il ne s'installe pas" ?
As-tu téléchargé le deb ? Avec gdebi ça devrait l'installer.
La solution avec git m'a l'air de fonctionner aussi.
Quelle est ta version d'ubuntu et ton environnement ?
Cordialement,
Guy

Hors ligne

#131 Le 27/01/2017, à 13:49

Isaric

Re : Synthèse vocale SVOX Pico

Merci pour ta réponse gl38

Je suis en 16-10 64 bits

J'ai beau demander de l'installer, il ne s'installe pas (ou ?) :
capture gspeech.deb
Aussi je ne vois rien dans synaptic.


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#132 Le 27/01/2017, à 14:15

gl38

Re : Synthèse vocale SVOX Pico

Synaptic ne le trouve pas car le paquet deb vient d'une tierce partie.
As-tu essayer de bêtement télécharger le deb ? firefox doit proposer de l'installer avec gdebi, c'est le bon choix.
Cordialement,
Guy

Hors ligne

#133 Le 27/01/2017, à 14:31

Isaric

Re : Synthèse vocale SVOX Pico

gl38 a écrit :

As-tu essayer de bêtement télécharger le deb ?

Oui, je fais ensuite un clic droit "ouvrir avec Installation de l'application" ( ou ctrl+o )

La capture du post 131 : capture gspeech.deb, n'est pas synaptic (que j'utilise habituellement et qui est installé).
C'est "Logiciels ubuntu" installé par ubuntu (et je ne sais pas si c'est "gdebi" puisque j'ai seulement gdebi-core d'installé).


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#134 Le 27/01/2017, à 14:40

gl38

Re : Synthèse vocale SVOX Pico

Chez moi le paquet gdebi-core contient la commande gdebi.
Tu pourrais essayer de télécharger le fichier deb.
Tu devrais obtenir un fichier gSpeech.deb dans ton dossier Téléchargements
Tu tapes alors dans un terminal

cd ~/Téléchargements
sudo gdebi gSpeech.deb

Est-ce que ça marche ?
Cordialement,
Guy

Hors ligne

#135 Le 27/01/2017, à 15:10

Isaric

Re : Synthèse vocale SVOX Pico

$ sudo gdebi gSpeech.deb
[sudo] Mot de passe de isaric : 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
Ce paquet ne peut pas être installé
Dependency is not satisfiable: python-gst0.10 (>= 0.10)
$ 

"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#136 Le 27/01/2017, à 15:22

gl38

Re : Synthèse vocale SVOX Pico

Bon. Il va y avoir des difficultés. le paquet python-gst0.10 est dans Ubuntu 16.04, pas dans la 16.10 visiblement.
Comme je me sers pas de versions qui ne sont pas LTS, je ne peux rien faire d'autre.
Cordialement,
Guy

Hors ligne

#137 Le 27/01/2017, à 16:54

L'Africain

Re : Synthèse vocale SVOX Pico

Salut c'est le deb que j'ai packagé et que j'ai mis sur mon drive? Je n'ai pas non plus de 16.10, mais tu peux peut-être modifier le fichier control en modifiant le nom de la dépendance, puis recréer le paquet avec

dpkg-deb -b mon_paquet

Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#138 Le 27/01/2017, à 18:07

Isaric

Re : Synthèse vocale SVOX Pico

Merci L'Africain, mais je ne souhaite pas me lancer dans la fabrication de paquets, cela me dépasse... roll


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#139 Le 27/01/2017, à 18:30

gl38

Re : Synthèse vocale SVOX Pico

Tu peux essayer avec git comme indiqué dans la doc, ti installes git et tu tapes

git clone https://github.com/tuxmouraille/gSpeech.git

tu vas obtenir un dossier gSpeech qui contient plusieurs exécutables dont un gSpeech.sh
en allant dans le dossier gSpeech avec cd, tu peux voir ce que donne

./gSpeech.sh

Ça a évidemment plus de chance de marcher si tu installes le paquet qui manque python-gst0.10 en essayant de voir ce que synaptic propose de ressemblant si on lui demande de chercher python-gst
Cordialement,
Guy

Hors ligne

#140 Le 27/01/2017, à 18:45

Isaric

Re : Synthèse vocale SVOX Pico

J'ai un paquet

python-gst-1.0

dans synaptic, je l'ai installé mais cela ne résoud pas mon problème de dépendance.


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#141 Le 27/01/2017, à 19:30

L'Africain

Re : Synthèse vocale SVOX Pico

Le paquet manquant est ici essaye de l'installer pour voir.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#142 Le 27/01/2017, à 19:51

Isaric

Re : Synthèse vocale SVOX Pico

$ $ sudo gdebi python-gst0.10_0.10.22-3ubuntu3_amd64.deb
...
Ce paquet ne peut pas être installé
Dependency is not satisfiable: libgstreamer-plugins-base0.10-0 (>= 0.10.32)
$ sudo gdebi libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb
...
Dependency is not satisfiable: libgstreamer0.10-0 (>= 0.10.36)
$

Je fais l'opération d'installation de ces 5 paquets.deb

libgstreamer0.10-0 (>= 0.10.36)
libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb
libgstreamer-plugins-base0.10-0 (>= 0.10.32)
python-gst0.10_0.10.22-3ubuntu3_amd64.deb
gSpeech.deb

Et je reviens...

Dernière modification par Isaric (Le 27/01/2017, à 20:09)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#143 Le 27/01/2017, à 20:12

L'Africain

Re : Synthèse vocale SVOX Pico

Là je comprends pas ce que tu fais, il suffit que tu doubles clic sur le paquet téléchargé et l'installer avec gdebi, si c'est Logiciels-Ubuntu qui s'ouvre clic droit sur le paquet, ouvrir avec gdebi (mets-le par défaut tant que tu y es).


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#144 Le 28/01/2017, à 08:06

Isaric

Re : Synthèse vocale SVOX Pico

L'Africain a écrit :

Là je comprends pas ce que tu fais, il suffit que tu doubles clic sur le paquet téléchargé et l'installer avec gdebi, si c'est Logiciels-Ubuntu qui s'ouvre clic droit sur le paquet, ouvrir avec gdebi (mets-le par défaut tant que tu y es).

J'ai peut-être des méthodes peu conventionnelle, des habitudes... roll
Changer, je suis retissant. smile

J'ai bien les paquets dans synaptic et lancé gspeech, mais rien ne se passe ?
mini_362611gspeech.png

[édit] :
le deb libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb n'y est pas ?
Je le réinstalle

$ sudo gdebi libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb[sudo] Mot de passe de isaric : 
...
...
 This package contains the core library and elements.
Voulez-vous installer le paquet logiciel ? [o/N] :o
(Lecture de la base de données... 220186 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb ...
Dépaquetage de libgstreamer0.10-0:amd64 (0.10.36-1.5ubuntu1) sur (0.10.36-1.5ubuntu1) ...
Paramétrage de libgstreamer0.10-0:amd64 (0.10.36-1.5ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...
$

Il n’apparaît toujours pas !

Dernière modification par Isaric (Le 28/01/2017, à 08:15)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#145 Le 28/01/2017, à 11:21

L'Africain

Re : Synthèse vocale SVOX Pico

Désolé, je veux bien t'aider, mais il faudrait que tu commences par faire ce qu'on te propose. Parce que sinon on parlera pas le même langage. Là tu nous parles de  libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb je vois pas ce que ça vient maintenant faire là dedans, alors qu'avant tu parlais de python-gst0.10 que je t'ai proposé d'installer.
À toi de voir.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#146 Le 29/01/2017, à 08:08

Isaric

Re : Synthèse vocale SVOX Pico

Merci L'Africain pour tes remarques, je suis pas très clair et m'embrouille un peu. roll

Sur la photo du post #144 on voit bien python-gst0.10 (python-gst0.10_0.10.22-3ubuntu3_amd64.deb) qui est installé.
Pour l'installer il m'a fallu résoudre d'autres dépendances, que j'ai donc installé avant, d'où la liste des paquets mentionnées:

J'ai ces 4 (et non 5)  paquets.deb :

libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb
libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb
python-gst0.10_0.10.22-3ubuntu3_amd64.deb
gSpeech.deb

Et lorsque je lance gspeech rien ne se passe neutral

$ gspeech

"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#147 Le 29/01/2017, à 08:25

L'Africain

Re : Synthèse vocale SVOX Pico

Ok maintenant c'est clair. Si j'ai bien compris toutes les dépendances sont satisfaites puisque tu as installé gspeech.
Quand tu lances gspeech il devrait s'afficher dans le tableau de bord supérieur, rien chez toi?

Question bête, as-tu installé libttspico-utils?

Dernière modification par L'Africain (Le 29/01/2017, à 08:29)


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#148 Le 29/01/2017, à 09:23

Isaric

Re : Synthèse vocale SVOX Pico

L'Africain a écrit :

Ok maintenant c'est clair. Si j'ai bien compris toutes les dépendances sont satisfaites puisque tu as installé gspeech.
Quand tu lances gspeech il devrait s'afficher dans le tableau de bord supérieur, rien chez toi?

Je vois rien nul part.

L'Africain a écrit :

...as-tu installé libttspico-utils?

oui version :
1.0+git20130326-4


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#149 Le 29/01/2017, à 16:44

L'Africain

Re : Synthèse vocale SVOX Pico

Là je sèche! python est installé ? Je suppose que oui? Sinon à part réinstaller une 16.04...


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#150 Le 29/01/2017, à 21:29

gl38

Re : Synthèse vocale SVOX Pico

Est-ce que tu as essayé le test de la doc :

pico2wave -l fr-FR -w test.wav "Faites demi-tour dès que possible !"
play test.wav

Cordialement,
Guy

Hors ligne