Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 30/12/2016, à 12:10

sylvone

Virtualbox / Périphériques USB non détectés

Bonjour à tous,

j'ai Linux Mint 18.1 Mate, avec Virtualbox 5.1.12 et le pack d'extension correspondant installé.

J'ai créé une machine virtuelle sous Windows 10 afin d'utiliser une machine USB dont les pilotes n'existent que pour Windows (Silhouette Portrait pour les connaisseurs). Merci de ne pas m'aiguiller sur des solutions utilisables sous Linux, mon épouse veut le logiciel fourni avec, et les "bidouillages" existants sous Linux sont il est vrai assez compliqués, et surtout ne lui permettent pas d'échanger avec d'autres utilisateurs les fichiers vectoriels...

J'ai donc installé Virtualbox, en utilisant le package deb 5.1.12 AMD64, et installé le pack d'extensions correspondant..

Après avoir lu quelques discussions sur la problématique USB (celui-ci et celui-là notamment), je n'ai toujours pas de périphériques USB visibles et connectables.
Mes clefs USB sont bien montés dans Mint lorsque je les branche, mais elles ne sont pas vues sous virtualbox.

Après avoir créé le groupe vboxusers et ajouté mon login au groupe, la commande id me retourne bien :

uid=1000(sylvain) gid=1000(sylvain) groupes=1000(sylvain),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),113(lpadmin),130(sambashare),1001(vboxusers)

Donc a priori, je suis  bien dans le groupe idoine.

Mais je n'arrive toujours pas à connecter quelque périphérique que ce soit en USB, sauf, fait étrange ,la Webcam, qui est accessible sur la machine invité  non pas via Périphériques-->USB, mais via Périphériques-->Webcams.

Pour le reste, lorsque j'insère une clé USB, un HDD USB ou mon lecteur DVD USB, rien n'est vu sous ma machine invité, tandis que sous Mint, RAS, c'est monté tout seul.

Quelqu'un pourrait-il m'aiguiller ?

Dernière modification par sylvone (Le 30/12/2016, à 12:14)


PC1 : MSI Z97 / i7 4790K / 16Go / 250Go SSD / 1To HDD / GTX 970
PC2 : Gigabyte Z77MX / Core i7 3770k / GTX 970/ 16Go / SSD 120Go / HDD 2To
Port 1 : Lenovo Yoga 710 / i7 6500U / 8Go / 256Go SSD / 940MX

Hors ligne

#2 Le 30/12/2016, à 12:22

sylvone

Re : Virtualbox / Périphériques USB non détectés

Une petite copie d'écran de ce que cela donne lorsque je veux afficher les périphériques USB :
http://cuchteam.fr/web_images/vbox_usb_1_tn.png


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par cqfd93 (Le 31/12/2016, à 17:58)


PC1 : MSI Z97 / i7 4790K / 16Go / 250Go SSD / 1To HDD / GTX 970
PC2 : Gigabyte Z77MX / Core i7 3770k / GTX 970/ 16Go / SSD 120Go / HDD 2To
Port 1 : Lenovo Yoga 710 / i7 6500U / 8Go / 256Go SSD / 940MX

Hors ligne

#3 Le 31/12/2016, à 12:40

sylvone

Re : Virtualbox / Périphériques USB non détectés

Bonjour,

Un petit "up" pour ce souci que je ne parviens pas à régler.
Personne n'y aurait été confronté ?


PC1 : MSI Z97 / i7 4790K / 16Go / 250Go SSD / 1To HDD / GTX 970
PC2 : Gigabyte Z77MX / Core i7 3770k / GTX 970/ 16Go / SSD 120Go / HDD 2To
Port 1 : Lenovo Yoga 710 / i7 6500U / 8Go / 256Go SSD / 940MX

Hors ligne

#4 Le 31/12/2016, à 15:47

erresse

Re : Virtualbox / Périphériques USB non détectés

Bonjour,

Juste une remarque qui n'a peut-être aucun rapport avec le problème, mais sur ta copie d'écran, je vois :
- "Activer le contrôleur USB" --> OK
- "Contrôleur 3.0 (xHCI) --> OK
Est-ce que les périphériques USB que tu veux utiliser sont des USB3 ?
Parce-que dans le cas contraire, il faudrait peut-être que tu actives "Contrôleur USB 2.0 (EHCI)" à la place dans ta machine virtuelle.
Ça ne coûte rien d'essayer...
Bonne nouvelle année !
big_smile


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#5 Le 31/12/2016, à 17:51

sylvone

Re : Virtualbox / Périphériques USB non détectés

erresse a écrit :

Bonjour,

Juste une remarque qui n'a peut-être aucun rapport avec le problème, mais sur ta copie d'écran, je vois :
- "Activer le contrôleur USB" --> OK
- "Contrôleur 3.0 (xHCI) --> OK
Est-ce que les périphériques USB que tu veux utiliser sont des USB3 ?
Parce-que dans le cas contraire, il faudrait peut-être que tu actives "Contrôleur USB 2.0 (EHCI)" à la place dans ta machine virtuelle.
Ça ne coûte rien d'essayer...
Bonne nouvelle année !
big_smile

Bonjour,

merci de ton aide.
Oui, j'utilise un Hub USB3, branché sur un port USB3 sur mon ordi.
J'ai essayé les deux autres (1.1 et 2.0) et ça ne change hélas rien.

Bonne année à toi aussi !


PC1 : MSI Z97 / i7 4790K / 16Go / 250Go SSD / 1To HDD / GTX 970
PC2 : Gigabyte Z77MX / Core i7 3770k / GTX 970/ 16Go / SSD 120Go / HDD 2To
Port 1 : Lenovo Yoga 710 / i7 6500U / 8Go / 256Go SSD / 940MX

Hors ligne

#6 Le 04/01/2017, à 23:19

Compyl

Re : Virtualbox / Périphériques USB non détectés

Bonjour,
Je rencontre le même problème que Sylvone et je bloque exactement au même endroit.
Je me suis ajouté au group "vboxusers".
Quand je branche mon périphérique USB (un oscilloscope DDS140 dont les drivers ne sont disponibles que sur windows), je peux voir que Linux en utilisant "lsusb" mais pourtant dans la fenêtre de réglage des paramètres USB de ma machine virtuelle (Windows 7) mon périphérique n'est pas proposé hmm

Rq: C'est difficile de trouver des infos sur ce sujet car on a tendance à toujours retomber sur des topics pour des clés USB...

Je suis preneur de toute aide sur le sujet smile

Hors ligne