Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/12/2016, à 16:22

wallace27

lenteur de chromium-browser à l'ouverture

Bonjour,

Pourquoi chromium-browser est-il plus lent à ouvrir que google-chome sur Lubuntu ?

Est-il possible d'éliminer cette lenteur ?

Merci pour votre aide.

Hors ligne

#2 Le 24/12/2016, à 16:59

xubu1957

Re : lenteur de chromium-browser à l'ouverture

Bonjour,

Une hypothèse :

Le15/11/2015, inbox a écrit :

Salut,

C'est probablement l'accélération graphique, utilisée par Chromium, qui pose problème.

Essaye de le lancer avec :

chromium-browser --disable-gpu

A+

[EDIT] Les paramètres possibles de Chromium en mode commande

On peut aussi désactiver l'accélération graphique en modifiant les paramètres du navigateur :

> Menu  >Choisir Paramètres >Afficher les paramètres avancés ...

> Système (vers le bas de la page)

et décocher : Utiliser l'accélération matérielle


Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Modifier sous son premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000
Adhérent de : Linux-Azur

En ligne

#3 Le 24/12/2016, à 20:42

wallace27

Re : lenteur de chromium-browser à l'ouverture

Merci beaucoup, ça va déjà plus vite. Par contre google-chrome reste plus rapide au démarrage, je ne me l'explique pas...

Hors ligne

#4 Le 24/12/2016, à 21:04

xubu1957

Re : lenteur de chromium-browser à l'ouverture

Avec des extensions identiques ?


Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Modifier sous son premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000
Adhérent de : Linux-Azur

En ligne

#5 Le 24/12/2016, à 21:08

wallace27

Re : lenteur de chromium-browser à l'ouverture

Oui avec les mêmes extensions.

Mais c'est incroyable, depuis que j'ai désactivé l'accélération matérielle j'ai également l'impression que tout le reste est plus rapide également, même le chargement des sites.

Hors ligne

#6 Le 24/12/2016, à 21:10

xubu1957

Re : lenteur de chromium-browser à l'ouverture

Un historique plus chargé, en mémoire ?


Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Modifier sous son premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000
Adhérent de : Linux-Azur

En ligne

#7 Le 24/12/2016, à 21:20

wallace27

Re : lenteur de chromium-browser à l'ouverture

non plus, c'est la même chose, il y a eu cette différence dès la première installation de ces deux browsers. Et la différence réapparaît sur chaque machine sur laquelle je les installe.

Hors ligne

#8 Le 25/12/2016, à 06:06

moko138

Re : lenteur de chromium-browser à l'ouverture

Je ne serais pas étonné que chrome fasse comme beaucoup de gros machins sous windows :
passer devant tout le monde au lieu de faire la queue, et forcer son chargement anticipé dès le démarrage.

Pour le savoir
À la fin du démarrage du système, avant de lancer aucun navigateur, fais

top -d 30 | grep chrom >> 2chrom.txt

sans oublier Ctrl c  au bout de 20 secondes pour stopper la commande.

Ensuite seulement, tu lances un navigateur et tu colles ici le contenu de

cat 2chrom.txt

Donne aussi :

ls -la /etc/xdg/autostart
ls -la ~/.config/autostart

Dernière modification par moko138 (Le 25/12/2016, à 06:09)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#9 Le 25/12/2016, à 22:16

wallace27

Re : lenteur de chromium-browser à l'ouverture

x@x:~$ top -d 30 | grep chrom >> 2chrom.txt

x@x:~$ cat 2chrom.txt
x@x:~$ ls -la /etc/xdg/autostart
total 156
drwxr-xr-x  2 root root 4096 déc 20 23:48 .
drwxr-xr-x 21 root root 4096 jui 30 01:25 ..
-rw-r--r--  1 root root  202 fév 25  2016 at-spi-dbus-bus.desktop
-rw-r--r--  1 root root  194 mar 31  2016 blueman.desktop
-rw-r--r--  1 root root  462 mai 25  2016 evolution-alarm-notify.desktop
-rw-r--r--  1 root root  485 nov  1  2015 gnome-keyring-pkcs11.desktop
-rw-r--r--  1 root root  478 nov  1  2015 gnome-keyring-secrets.desktop
-rw-r--r--  1 root root  445 nov  1  2015 gnome-keyring-ssh.desktop
-rw-r--r--  1 root root  448 jan  4  2016 gnome-screensaver.desktop
-rw-r--r--  1 root root  464 avr 20  2016 gnome-user-share-obexpush.desktop
-rw-r--r--  1 root root  444 avr 20  2016 gnome-user-share-webdav.desktop
-rw-r--r--  1 root root  279 mar 27  2014 gsettings-data-convert.desktop
-rw-r--r--  1 root root  249 jan 28  2015 indicator-application.desktop
-rw-r--r--  1 root root  302 mai 27  2016 indicator-bluetooth.desktop
-rw-r--r--  1 root root  310 avr  7  2016 indicator-datetime.desktop
-rw-r--r--  1 root root  298 nov 25  2015 indicator-keyboard.desktop
-rw-r--r--  1 root root  237 avr  9  2014 indicator-network.desktop
-rw-r--r--  1 root root  286 jan  5  2016 indicator-power.desktop
-rw-r--r--  1 root root  252 avr 12  2016 indicator-session.desktop
-rw-r--r--  1 root root  295 avr  7  2016 indicator-sound.desktop
-rw-r--r--  1 root root 2445 déc 21  2015 light-locker.desktop
-rw-r--r--  1 root root  210 aoû  4 20:00 nautilus-autostart.desktop
-rw-r--r--  1 root root  350 jun 13  2016 nm-applet.desktop
-rw-r--r--  1 root root  242 fév  3  2014 nvidia-settings-autostart.desktop
-rwxr-xr-x  1 root root 7119 mar  7  2016 org.kde.korgac.desktop
-rw-r--r--  1 root root  358 aoû  8  2012 polkit-gnome-authentication-agent-1.desktop
-rw-r--r--  1 root root  375 mar 14  2014 print-applet.desktop
-rw-r--r--  1 root root 4474 mar 21  2016 pulseaudio.desktop

Hors ligne

#10 Le 26/12/2016, à 03:46

moko138

Re : lenteur de chromium-browser à l'ouverture

J'ai médit : pas trace de chrome ni de chromium !


Par ailleurs, tu parles en #1 de Lubuntu, distribution légère, qu'on préconise
- sur les machines pauvres en ram ;
- ou quand on vise la vélocité.
Or
1) chrome et chromium sont de redoutables ramivores.
2) Tu lances au démarrage nautilus d'Ubuntu et korgac de Kubuntu.Ce mélange de paquets provenant de 3 environnements différents est parfait pour ralentir un système.

Dernière modification par moko138 (Le 26/12/2016, à 06:24)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#11 Le 05/01/2017, à 21:19

wallace27

Re : lenteur de chromium-browser à l'ouverture

Korgac je ne sais même pas ce que c'est. Est-ce que je peux le désinstaller sans soucis ? Si oui, comment ?

Hors ligne

#12 Le 05/01/2017, à 21:56

wallace27

Re : lenteur de chromium-browser à l'ouverture

en fait une fois que chromium est démarrer et ouvert c'est en ordre il n'y a pas de soucis tout est fluide et rapide et pas d'attente lors de l'ouverture d'un nouvel onglet. Dès lors, est-il possible de pré-démarrer chromium dès le démarrage de session et/ou faire en sorte qu'il soit impossible de le fermer une fois qu'il a été ouvert au moins une fois ?

Merci pour votre aide.

Hors ligne