Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/08/2016, à 13:34

raymond973

[Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour,

Actuellement utilisateur de Ubuntu 14.04 LTS, je voudrais passer à la 16.04.

Après avoir fureté sur le net je me rend compte qu le logiciel ffdiaporama, que j'utilise pas mal, n'existe pas dans les dépôts de la 16.04 dans sa dernière version. Hors j'ai pas mal de réalisations effectuées avec la dernière version, je ne suis pas sur de pouvoir les ouvrir/modifier avec une version antérieure.
J'ai vu aussi que certains avaient procédé à une compilation après application d'un patch : https://github.com/JonasCz/ffdiaporama-1604-builds. Il y a également 2 .DEB à disposition mais en 32 bits alors que je suis en 64.

Le problème c'est que je ne maîtrise pratiquement pas l'anglais et je ne comprends pas trop comment patcher et quoi patcher avant de faire la compilation.

Quelqu'un a-t-il effectuer cette opération ? Si oui comment ?

Merci de vos lumières.

Raymond

Dernière modification par raymond973 (Le 26/08/2016, à 15:55)

Hors ligne

#2 Le 17/08/2016, à 13:41

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour,

Sous Xubuntu 16.04 64bits, j'utilise ffDiaporama 2.1.

## Ffdiaporama
# sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 77296259 
deb http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty main
deb-src http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty main

---> 1471437543.png

A+

Hors ligne

#3 Le 17/08/2016, à 15:25

SESTAY

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonsoir,
si tu est encore sur la version 14.04, normalement si tu fais une migration vers 16.04, ffDiaporama devrait toujours fonctionner sans problème.


une modeste participation à ffDiaporama Changement d'adresse du site http://tvb2016.pagesperso-orange.fr/ff/co/siteWeb.html.
Actuellement le projet ffDiaporama est en stand by, si des amateurs veulent s'y coller, ils seront les bienvenues.

Hors ligne

#4 Le 17/08/2016, à 15:53

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Ok merci pour vos réponses.

Je vais donc tenter la migration.

Hors ligne

#5 Le 25/08/2016, à 17:57

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour,

Après installation de la 16.04.1, réinstallation avec sauvegarde du home, j'ai eu un message m'indiquant que certain logiciel devaient être réinstallés manuellement. Le cas de ffdiaporama entre autre.

J'ai donc appliqué les commandes du post #2 pour installer la version 2.1.

J'ai ce message :

Les paquets suivants contiennent des dépendances non satisfaites :
ffdiaporama : Dépend: libqt5help5 (>= 5.0.2) mais il n'est pas installable
               Dépend: qt5-image-formats-plugins mais il n'est pas installable
               Dépend: libav-tools mais il n'est pas installable
               Dépend: libavcodec-extra mais il n'est pas installable
               Dépend: libavresample1 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libavcodec54 (>= 6:9.1-1) mais il n'est pas installable ou
                        libavcodec-extra-54 (>= 6:9.11) mais il n'est pas installable
               Dépend: libavfilter3 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libavformat54 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libavutil52 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libexiv2-12 mais il n'est pas installable
               Dépend: libswscale2 (>= 6:9.1-1) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Il semble que des versions de paquets ne correspondent pas.
Si quelqu'un a une idée.....

Merci de votre aide.

Hors ligne

#6 Le 25/08/2016, à 18:04

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour,

raymond973 a écrit :

J'ai donc appliqué les commandes du post #2 pour installer la version 2.1.

Et ensuite, tu as bien fait un :

sudo apt-get update

A+

Hors ligne

#7 Le 25/08/2016, à 18:15

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Et ensuite, tu as bien fait un :

sudo apt-get update

A+

Oui fait.

Hors ligne

#8 Le 25/08/2016, à 18:22

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Re,

Tu peux donner les retours complets de :

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall ffdiaporama
sudo apt-get install -f

A+

Dernière modification par michel_04 (Le 25/08/2016, à 18:23)

Hors ligne

#9 Le 25/08/2016, à 18:47

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Merci de te préoccuper de mon problème.

Le problème reste le même.

Voila le résultat des différentes commandes :

    raymond@raymond-Inspiron-3442:~$ sudo apt-get update
    [sudo] Mot de passe de raymond :
    Atteint:1 http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu xenial InRelease
    Atteint:2 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                                                                 
    Atteint:3 http://archive.canonical.com xenial InRelease                                                                         
    Réception de:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [94,5 kB]                                           
    Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                         
    Ign:6 http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty InRelease                                                   
    Atteint:7 http://fr.archive.ubuntu.com/ubuntu xenial-security InRelease                                                         
    Atteint:8 http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty Release                                                 
    Atteint:9 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                       
    Atteint:10 http://josm.openstreetmap.de/apt xenial InRelease                                                                   
    Atteint:12 http://download.virtualbox.org/virtualbox/debian xenial InRelease                           
    94,5 ko réceptionnés en 0s (110 ko/s)
    Lecture des listes de paquets... Fait
    W: http://ppa.launchpad.net/ffdiaporamatea … elease.gpg: Signature by key B68EE2B202D8BEDB4986D5188FC2C0DC77296259 uses weak digest algorithm (SHA1)
    raymond@raymond-Inspiron-3442:~$ sudo apt-get dist-upgrade
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Calcul de la mise à jour... Fait
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    raymond@raymond-Inspiron-3442:~$ sudo apt-get install --reinstall ffdiaporama
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation :

    Les paquets suivants contiennent des dépendances non satisfaites :
    ffdiaporama : Dépend: libavcodec-extra
                   Dépend: libavresample1 (>= 6:9.1-1) mais il n'est pas installable
                   Dépend: libavcodec54 (>= 6:9.1-1) mais il n'est pas installable ou
                            libavcodec-extra-54 (>= 6:9.11) mais il n'est pas installable
                   Dépend: libavfilter3 (>= 6:9.1-1) mais il n'est pas installable
                   Dépend: libavformat54 (>= 6:9.1-1) mais il n'est pas installable
                   Dépend: libavutil52 (>= 6:9.1-1) mais il n'est pas installable
                   Dépend: libexiv2-12 mais il n'est pas installable
                   Dépend: libswscale2 (>= 6:9.1-1) mais il n'est pas installable
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
    raymond@raymond-Inspiron-3442:~$ sudo apt-get install -f
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    raymond@raymond-Inspiron-3442:~$

Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 25/08/2016, à 18:55)

Hors ligne

#10 Le 25/08/2016, à 19:09

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Re,

Active les dépôts universe et multiverse, puis donne les retours (entre balises Code, pas Quote) de :

cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall ffdiaporama
sudo apt-get install -f

A+

Hors ligne

#11 Le 25/08/2016, à 20:14

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Désolé pour la balise code, je ne poste que très rarement et pas au top.

Résultat de la commande cat /etc/apt/sources.list

raymond@raymond-Inspiron-3442:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted universe

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse universe

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security main restricted universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-security main restricted universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu xenial main
# deb-src http://extras.ubuntu.com/ubuntu xenial main
deb http://archive.canonical.com/ xenial partner
deb http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu xenial main
deb http://josm.openstreetmap.de/apt xenial universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security multiverse

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.


# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

## This software is not part of Ubuntu, but is offered by third-party
deb http://download.virtualbox.org/virtualbox/debian xenial contrib
## developers who want to ship their latest software.

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports multiverse restricted main universe
deb http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty main
deb-src http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty main
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
raymond@raymond-Inspiron-3442:~$ 

Résultat de la commande cat /etc/apt/sources.list.d/*

raymond@raymond-Inspiron-3442:~$ cat /etc/apt/sources.list.d/*
raymond@raymond-Inspiron-3442:~$ 

Résultat de la commande sudo apt-get update

raymond@raymond-Inspiron-3442:~$ sudo apt-get update
[sudo] Mot de passe de raymond : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu xenial InRelease                                               
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                          
Atteint:4 http://archive.canonical.com xenial InRelease                                                                         
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-security InRelease                                                         
Ign:6 http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty InRelease                                                   
Atteint:7 http://josm.openstreetmap.de/apt xenial InRelease                                                                     
Atteint:8 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                        
Atteint:9 http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu trusty Release                                                 
Atteint:10 http://download.virtualbox.org/virtualbox/debian xenial InRelease                                                    
Réception de:11 http://security.ubuntu.com/ubuntu xenial-security InRelease [94,5 kB]            
Réception de:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [66,8 kB]
Réception de:14 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [58,1 kB]
219 ko réceptionnés en 1s (174 ko/s)   
Lecture des listes de paquets... Fait
W: http://ppa.launchpad.net/ffdiaporamateam/stable/ubuntu/dists/trusty/Release.gpg: Signature by key B68EE2B202D8BEDB4986D5188FC2C0DC77296259 uses weak digest algorithm (SHA1)
raymond@raymond-Inspiron-3442:~$ 

Résultat de la commande sudo apt-get dist-upgrade

raymond@raymond-Inspiron-3442:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
raymond@raymond-Inspiron-3442:~$ 

Résultat de la commande sudo apt-get dist-upgrade

raymond@raymond-Inspiron-3442:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
raymond@raymond-Inspiron-3442:~$ 

Résultat de la commande sudo apt-get install --reinstall ffdiaporama

raymond@raymond-Inspiron-3442:~$ sudo apt-get install --reinstall ffdiaporama
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 ffdiaporama : Dépend: libavcodec-extra
               Dépend: libavresample1 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libavcodec54 (>= 6:9.1-1) mais il n'est pas installable ou
                        libavcodec-extra-54 (>= 6:9.11) mais il n'est pas installable
               Dépend: libavfilter3 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libavformat54 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libavutil52 (>= 6:9.1-1) mais il n'est pas installable
               Dépend: libexiv2-12 mais il n'est pas installable
               Dépend: libswscale2 (>= 6:9.1-1) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
raymond@raymond-Inspiron-3442:~$ 

Résultat de la commande sudo apt-get install -f

raymond@raymond-Inspiron-3442:~$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
raymond@raymond-Inspiron-3442:~$ 

A+

encore merci

Hors ligne

#12 Le 26/08/2016, à 10:07

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour,

Hum, là je ne vois pas.

Essaie de purger tout ce qui concerne ffdiaporama, puis de le réinstaller :

sudo apt-get purge ffdiaporama*
sudo apt-get install ffdiaporama

A+

Dernière modification par michel_04 (Le 26/08/2016, à 11:02)

Hors ligne

#13 Le 26/08/2016, à 11:11

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour,

Toujours le même problème et les mêmes messages.

C'est pour cela que j'aurais voulu tenté une compilation mais là je suis nul.

Hors ligne

#14 Le 26/08/2016, à 11:18

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Re,

raymond973 a écrit :

Toujours le même problème et les mêmes messages.
C'est pour cela que j'aurais voulu tenté une compilation mais là je suis nul.

Ce qui m'ennuie c'est ça :

E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Lorsque tu as fait :

sudo apt-get purge ffdiaporama*

Est-ce qu'en retour tu as eu une erreur ?

Lorsque tu installes un autre paquet, as-tu la même erreur ?
Essaie :

sudo apt-get update
sudo apt-get install soundconverter

A+

Hors ligne

#15 Le 26/08/2016, à 11:49

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Merci de ton aide.

Non aucune erreur lors de la purge de ffdiaporama.

L'installation d'autre paquet ne pose aucun problème.

Hors ligne

#16 Le 26/08/2016, à 13:12

SESTAY

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour.
j'ai laissé un message sur le site ffDiaporama pour avoir une version 64 bit

Essai ceci mais je ne suis pas sûr que cela fonctionne https://drive.google.com/file/d/0B8q2e2 … BIS3M/view
Peut-être faudra t-il rendre ce fichier exécutable.

pour la compilation étapes à suivre (traduction du site)
    1 > Aller ici https://github.com/JonasCz/ffdiaporama-1604-builds cliquer sur Clone or download
    (les fichier sont patchés)
    2 > décompresser l'archive dans ce dossier seul le dossier ffDiaporama-source nous concerne.
    3 > Installer le dépendances nécéssaires à la compilation.

sudo apt-get install libqt5multimedia5-plugins libtag1-dev libssh-dev libssl-dev libcurl4-openssl-dev libcurlpp-dev libcurlpp0 libqgsttools-p1 libqt5multimediaquick-p5 qtmultimedia5-dev build-essential libavcodec-dev libavdevice-dev libavfilter-dev libavformat-dev libavresample-dev libexiv2-dev libflac-dev libswscale-dev qt5-image-formats-plugins qt5-qmake libqt5quickwidgets5 libsdl-image1.2-dev libsdl-mixer1.2-dev qt5-default qttools5-dev-tools qttools5-dev libqt5svg5-dev libqt5help5 libqt5sql5-sqlite

    4 > compilation aller dans le dossier [.../ffdiaporama-1604-builds-master/ffDiaporama-source/ffDiaporama/src/ffDiaporama]
   

qmake ffDiaporama.pro /PREFIX=/usr
make

    5 > Installation:
   

sudo make install

     6 > les ressources [/ffDiaporama-source/ffDiaporama_rsc]
   

qmake ffDiaporama_rsc.pro /PREFIX=/usr
make install

Bon courage!

Dernière modification par SESTAY (Le 25/01/2017, à 10:43)


une modeste participation à ffDiaporama Changement d'adresse du site http://tvb2016.pagesperso-orange.fr/ff/co/siteWeb.html.
Actuellement le projet ffDiaporama est en stand by, si des amateurs veulent s'y coller, ils seront les bienvenues.

Hors ligne

#17 Le 26/08/2016, à 14:05

raymond973

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

J'ai tenté la compilation, ça fonctionne.
Par contre pour installer les ressources j'ai dû faire un

sudo make install

pour que le programme puisse créer le répertoire dans /usr/share.

Un grand merci à vous.

Hors ligne

#18 Le 26/08/2016, à 14:48

michel_04

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Re,

raymond973 a écrit :

J'ai tenté la compilation, ça fonctionne.

Je reviens et je vois que c'est OK, cool
Merci @ SESTAY d'avoir pris le relais. wink
Avant de partir j'avais jeté (vite fait) un oeil au Readme pour la compilation.
Rien de sorcier.
Sauf peut-être le fait que les explications sont en anglais ?
Content pour toi.

Tu peux ajouter [Résolu] au titre de ton post en cliquant sur "Modifier" au bas de ton premier message, merci.

A+

Dernière modification par michel_04 (Le 26/08/2016, à 14:49)

Hors ligne

#19 Le 10/01/2017, à 00:15

Toobuntu

Re : [Résolu]FFdiaporama 2.1 sous ubuntu 16.04

Bonjour

J'ai compilé ffDiaporama dans une machine virtuelle Virtualbox , mais il y a un problème lors de la compilation. sad

Sur une installation réelle , la compilation passe sans problème. smile

Quelqu'un sait quels sont les paquets à installer en plus dans une machine virtualisée pour faire la compilation ? roll


Ubuntu 16.04 , 14.04 , 12.04 sur une machine avec une carte beats audio jack ne fonctionne pas avec :/ et du bluetooth sans driver :/ et un EFI qui est une calamité.

Hors ligne