Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/02/2017, à 16:37

L'Africain

Installation efi impossible avec WIndows 10

Bonjour,
On vient de me demander une installation sur un mediacom smartbook s140 32G avec Windows 10 préinstallé. Grâce à ce post j'ai enfin réussi à démarrer sur la clé usb!! J'ai créé la clé avec unetbootin, et copier le fichier bootia32.efi au bon endroit (même avec multisystem ça marche), maintenant le portable démarre sur la clé. Hélas Une fois le logo ubuntu affiché, l'écran devient désespéramment noir.
Mon autre crainte c'est qu'une fois Ubuntu installé (si on y arrive) il ne démarre plus correctement et que je n'ai aucun moyen d'y remettre Windows10! Parce que  à vrai dire je n'ai aucune idée de comment ou pourrait réinstaller Windows.
Dans le bios il y a moyen de désactiver l'efi, pour le legacy mais ça ne change rien.

J'ai testé avec ubuntu en 32 et en 64 bits.
Merci d'avance
PS: Dans le bios il y a une multitude d'options, ça sera compliqué de toutes les décrire mais j'ai bien désactivé le secure boot et le fast boot.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#2 Le 24/02/2017, à 18:55

Bougron

Re : Installation efi impossible avec WIndows 10

Bonjour
Je ne sais pas si je vais pouvoir t'aider.         J'ai vu la description de ce produit ici http://icecat.com.ua/fr_be/p/mediacom/m … 43136.html et ici http://www.mediacomeurope.it/notebook/s … spx?XRI=25
C'est assez succinct.   J'ai vaguement compris par une autre discussion, qu'il faut s'attendre à des problèmes
Je ne sais pas trop si tu bootes avec unetbootin ou multisystem
Pour tout problème d'écran noir, je propose d'installer l'option nomodeset qui fonctionne dans 80% des cas.
Il y a une façon simple de faire décrite au paragraphe 6.1 de cette doc pour des installations classiques https://doc.ubuntu-fr.org/kernel
J'espère pour toi que  la mise de l'option va marcher.      Si la mise de l'option nomodeset ne marche pas, on l'installera à la manière de l'option "persistent" en modifiant les commandes de lancement    qui doivent certainement $etre restées très proche de celles indiquées

Va-t-elle résoudre  ce premier obstacle? Je ne sais pas

Je pense que tu peux éliminer le ubuntu 64 bits.      pour aller sur la version 32 bits car la mémoire ne fait que 2 Go et une version plus légère du style Xubuntu ou même Lubuntu
Ayant compris que tu disposes seulement de 32 Go de place disque,  je ne vois pas trop si tu pourras faire cohabiter windows 10 et .buntu dans ce faible espace aussitôt que tu voudras y mettre quelques logiciels.

De plus "Dans le bios il y a moyen de désactiver l'efi, pour le legacy"    La logique veut qu'on installe  sur le SSD avec un bios positionné comme l'est windows. http://lemeilleurantivirus.fr/comment-s … gacy-bios/

Dernière modification par Bougron (Le 24/02/2017, à 19:17)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#3 Le 24/02/2017, à 20:45

L'Africain

Re : Installation efi impossible avec WIndows 10

Bonjour Bougron,
Déjà merci pour ta réponse. J'ai aussi eu du mal à trouver des infos sur ce matériel.
Donc pour ma part, j'avais déjà utiliser l'option nomodeset avec multisystem, je vais encore tenter avec unetbootin. En effet j'ai essayé de booter avec les deux. Et les deux avec une 64 ou 32 fonctionne bien jusqu'au logo .buntu. Pour ma part j'avais démarrer avec une Ubuntu Mate et une xubuntu.
j'ai essayé le mode legacy et uefi.
Je reteste tout ça et te tiens au courant.
Cordialement,

Edit : eh ben!! J'ai mis en legacy dans le bios ça démarre quand même en uefi (grub affichage) comme ne efi mais ça démarre...) j'ai la possililité d'installer... Sauf que j'hésite il faudrait au moins avant que je sache comment réinstaller windows... En gros il faudrait que je trouve le moyen de pouvoir réinstaller windows en cas de pepins, or windows ne démarre pas sur l'usb et il n'y a pas de lecteur cd.

Dernière modification par L'Africain (Le 24/02/2017, à 21:01)


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#4 Le 24/02/2017, à 20:56

Bougron

Re : Installation efi impossible avec WIndows 10

Si cela marche à peu prés bien, J'en déduis que tu aurais une grille d'accueil te proposant d'essayer avant d'installer
Si oui, prends ce choix et donnes le retour de la commande

sudo blkid

l'idée est de savoir si le ssd est détecté

Dernière modification par Bougron (Le 24/02/2017, à 20:57)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#5 Le 24/02/2017, à 21:02

L'Africain

Re : Installation efi impossible avec WIndows 10

Excuse je vais faire ça mais entre temps pour ne pas poster deux fois j'ai éditer le post du haut...


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#6 Le 24/02/2017, à 21:12

L'Africain

Re : Installation efi impossible avec WIndows 10

Il semble que ça ne soit pas l'option nomodeset qui fonctionne, mais installer directement?? Ce que j'avais fait tout à l'heure, puis j'avais quitté pour me retrouver sur le live-bureau. En fait je n'en sais rien maintenant ça ne marche plus!
Par contre pour réinstaller Windows j'ai peut-être une solution ici
Demain je vais refaire ça calmement...


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#7 Le 24/02/2017, à 21:25

Bougron

Re : Installation efi impossible avec WIndows 10

Dans un premier temps, lances windows, dis lui de ne pas hiberner. puis regardes si tu ne peux pas diminuer la taille du C: de 5 go
Cela devrait te permettre d'installer  buntu ´a coté de windows'.

Pour faire une clé usb de windows10 bootable, il y a plein de solutions si tu ne possedes pas la clé usb d'installation.
L'idée est de la faire, de booter et de commencer l'installation et aller jusq'au moment il propose la liste des partitions pour le choix de celle à utiliser.

Dernière modification par Bougron (Le 24/02/2017, à 21:33)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#8 Le 25/02/2017, à 09:40

L'Africain

Re : Installation efi impossible avec WIndows 10

Pour l'hibernation, j'ai déjà fait ça. Je connais ce problème. Je vais créer la clé pour windows.
Pour ce qui est de la détection des partitions j'avais eu le temps d'aller sur gparted la seule fois ou ça avait booté, et le disque était détecté comme truc mmc pas comme sda.
Et même durant la procédure d'installation il voyait très bien windows 10 et me proposait d'installer à côté. Pour l'instant le vrai problème c'est qu'il ne va pas au delà du splash screen... Sauf une seule fois mais je suis incapable de dire pourquoi!!
En tout cas merci déjà pour ton aide!


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#9 Le 25/02/2017, à 12:24

L'Africain

Re : Installation efi impossible avec WIndows 10

Ok j'ai réussi à réinstaller windows donc on peut tenter ubuntu. J'ai donc une clé qui démarre mais qui reste bloquée sur le slash screen, ou plutôt qui passe le splash pour aboutir sur un écran noir. J'ai testé avec nomodeset, une seule fois ça a booté plus loin que le slash et m'aurait alors permis d'installer.
Donc on a un démarrage jusqu'au live aléatoire une réussite pour une vingtaine d'échecs.
Une proposition?


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#10 Le 25/02/2017, à 12:46

L'Africain

Re : Installation efi impossible avec WIndows 10

Ok je viens de terter avec l'option quiet slash=off nomodeset et acpi=off et j'arrive sur le live usb. Mais alors il ne voit pas le disque mmc comme la fois précédente, donc je n'ai pas installé (évidemment)...
Peut-être une autre option? Peut-être aussi quelque chose dans le bios lié à l'acpi?


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#11 Le 25/02/2017, à 13:08

Bougron

Re : Installation efi impossible avec WIndows 10

L'Africain a écrit :

.... Peut-être aussi quelque chose dans le bios lié à l'acpi?

L'ACPI (Advanced Configuration and Power Interface) sert à contrôler et à alimenter en électricité les composants qui en ont besoin (lecteur CD, HD, etc... si toutefois ces derniers le supportent).
En gros ça sert à contrôler l'énergie et principalement pour les ordinateurs portables.
De là, a penser que cela coupe le courant du eMMC   ce qui le rend invisible
enlèves donc cette option.

Dernière modification par Bougron (Le 25/02/2017, à 13:14)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#12 Le 25/02/2017, à 14:13

L'Africain

Re : Installation efi impossible avec WIndows 10

Oui mais sans cette option pas moyen d'arriver au live-usb. Ça marche pas. Donc si tu as une autre idée?
Maintenant dans le bios onglet advanced il y plein de truc... Notament un "emmc secure erase", qui semble dire qu'activer cela supprimerait tout le contenu du emmc...


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#13 Le 25/02/2017, à 14:28

L'Africain

Re : Installation efi impossible avec WIndows 10

Question j'ai lu sur d'autres post qu'il fallait à certains moment définir un mot de passe bios, dans mon cas ce n'est pas nécessaire comme il réussi à démarrer sur la clé c'est ça?


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#14 Le 25/02/2017, à 14:50

Bougron

Re : Installation efi impossible avec WIndows 10

Pour le "emmc secure erase" Cela sera une écriture d'une collection de zéros dans toute la totalité du eMMC.
Si tu fais cette action, aucun outil ne pourra récupérer les données.

Ce que tu peux faire, c'est définir un mot de passe dans le bios, Si un seul caractère suffit, ne t'en prives pas car si tu l'oublies c'est terminé....
Pour beaucoup de bios, mettre ce mot de passe ouvre la porte à la présentations d'autres onglets ou d'autres lignes dans les onglets
Si le bios est bien fait, il devra alors proposer, une ligne permettant sa suppression.

Peux-tu confirmer windows10 fonctionne?
J'aimerais savoir si tu l'as installé en EFI https://www.google.fr/url?sa=t&rct=j&q= … 3327,d.ZGg
Si oui, on va demander à windows de lancer le boot de la clé USB. https://libreaquimperle.blogspot.fr/p/r … ndows.html
En espérant que cela va marcher
J'ai bien noter le dilemme On peut booter avec acpi=off pas pas de support
Mais du coup , je me demande comment tu as fait lorsque tu dis
" j'avais eu le temps d'aller sur gparted la seule fois ou ça avait booté, et le disque était détecté comme truc mmc pas comme sda"
Il faudrait que tu te retrouves dans cette situation.  pour lancer l'installation de ubuntu!
Il devrait proposer le choix  "a coté de windows"

Dernière modification par Bougron (Le 25/02/2017, à 15:02)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#15 Le 25/02/2017, à 15:33

Bougron

Re : Installation efi impossible avec WIndows 10

Sinon vas dans le bios et regardes comme la connexion au eMMC est faite
C'est dans le paramétrage   AHCI   Il faudrait qu'il  soit sur ON et non sur RAID


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#16 Le 25/02/2017, à 17:05

L'Africain

Re : Installation efi impossible avec WIndows 10

Ok d'abord la fois où j'ai démarré sans le acpi=off et ben je ne sais pas comment, j'ai réessayé juste après et ça n'a plus fonctionné!!!
Pour Windows il est installé en efi j'ai vérifié alors qu'il était sur l'option legacy. D'ailleurs dans le bios quand je mets legacy ça boot quand même en efi car j'ai l'écran de boot de grub en mode efi pas celui en legacy.
Mon problème n'est donc pas de démarrer sur la clé ça ça marche depuis que j'ai mis le fichier bootia32. Le problème c'est d'aller plus loin que le splash screen.
Voici  quelques trucs dans le bios:
Advanced → Security configuration : txe avec plein de lignes avec txe enabled pui ptt puis measured boot.
Dans boot configuration OS/Bom selection → grisé il y a windows 8.x/bom3.1


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#17 Le 25/02/2017, à 17:10

L'Africain

Re : Installation efi impossible avec WIndows 10

Tiens je viens de voir une erreur avec le splash screen off : failed to mount /dev/mmc.. Avec une erreur qui semble dire qu'il y a une partition inconsistante. IL est vrai qu'en réinstallant windows il y avait 4 partitions, je n'ai pas osé les supprimer. J'ai juste supprimer la principale pour y remettre windows dessus. Crois-tu que je peux supprimer toutes les partitions windows?


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#18 Le 25/02/2017, à 18:43

Bougron

Re : Installation efi impossible avec WIndows 10

Cela n'apporte rien de supprimer les partitions windows.
J'ai du mal à suivre tout ce que tu décris.
Il me semble que tu as eu un début de possibilité d'installer.
J'en déduis que tu as eu une grille d'accueil te proposant quelques choix dont "essayer avant d'installer"
Peux-donc faire un boot-info, Je sais qu'il sera de mauvaise qualité à cause du eMMC, mais on y verra peut-être un truc. https://doc.ubuntu-fr.org/tutoriel/boot-info


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#19 Le 25/02/2017, à 20:50

L'Africain

Re : Installation efi impossible avec WIndows 10

Je récapitules.
D'abord ça bootait pas du tout. Puis j'ai réussi à booter grâce au info de l'autre post avec le fichier bootia32.exe. Puis maintenant ça boot mais ça reste bloqué sur un écran noir après le slash screen. Sur une trentaine de tentative j'ai réussi une fois à accéder au processus d'installation et j'ai pu voir le disque emmc dans gparted. Le processus d'installation lui même reconnaissait windows car il me proposait l'installation à côté.
Mais j'ai stoppé le procéssus car je ne savais pas encore avec certitude si je pourrais réinstaller windows en cas de problème.
Après j'ai rééssayer mainte fois d'arriver au bureau du live usb plus moyen, je ne sais évidemment pas pourquoi! je ne peux donc pas faire de boot-info.
Ensuite j'ai désactiver le splash screen pour voir le erreur au démarrage c'est là que j'ai constaté l'erreur sur /dev/emmc...
Maintenant lorsque j'ai réinstallé Windows (pour un problème de langue et surtout pour être sûr que ça marche jusqu'au bout) J'ai constaté qu'il y a une partition qu'on ne voit pas quand on est déjà sur Windows (je l'ai vu qu'au moment de la réinstallation). Donc sur le emmc il y 3 partitions visible en clic droit sur ordinateur > Gérer... La partition efi, la partition windows, et une partition recovery de 800M. Alors qu'au moment de la réinstallation de Windows il y en avait 4.
Voilà pour les diverses procédures.
Je suis à peu près certains que le problème se situe au niveau du disque emmc, puisque qu'avec l'option acpi=off j'arrive à accéder au bureau du live-cd.
Autre bizarrerie, quoi que je choisisse dans le bios (legacy ou pas, sécure boot ou pas) ça démarre toujours en efi. C'est pas difficile à savoir puisque en efi on a le menu grub qui s'affiche.
Alors pour finir, je me suis dit que la faute pourrait être lié à cette partition invisible. Peut-être est-ce elle qu'Ubuntu a du mal à lire et donc à booter correctement. Il me semble avoir vu, mais ça allait très vite, une ligne qui parlait de secteur incorrect sur le disque. Voilà pourquoi j'ai émit l'hypothèse qu'une suppression de toutes le partition pourrait peut être résoudre le problème.
Le problème je ne sais pas à quoi sert cette fameuse partition cachée.

Bonne soirée et merci pour ton aide.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#20 Le 25/02/2017, à 21:58

Bougron

Re : Installation efi impossible avec WIndows 10

Bonsoir
Réponse très rapide faite à partir d'un ipad.
Cette partition ´invisible ´ est une petite partition que windows utilise pendant son installation. Il la masque à l'utilisateur windows. Ubuntu ne sait pas encore la lire. souvent elle est nommée MSR.
Elle n'est pas la cause du problème.

AJOUT.  Elle est supprimable. Mais si on a besoin de réinstaller Windows, il la refabriquera pour pouvoir se réinstaller; Donc vu sa taille, il semble inutile de la supprimer

Dernière modification par Bougron (Le 26/02/2017, à 12:23)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#21 Le 26/02/2017, à 09:18

L'Africain

Re : Installation efi impossible avec WIndows 10

...elle n'est pas la cause du problème.

Ok merci au moins c'est clair de ce côté là, je pourrais donc la supprimer lors d'une éventuelle réinstallation de Windows (32 gigas c'est petit alors je me dis que si je peux grappiller quelques megas...)
Pour ce qui est du problème de boot as-tu une (autre) idée?
Dans le bios j'ai aussi remarqué qu'il n'y a pas vraiment de mode legacy, en réalité c'est un efi ou legacy, c'est à dire que s'il ne voit pas d'efi il boote en legacy.
Franchement je ne comprend pas comment c'est possible d'avoir réussi une fois et plus les fois d'après.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne