Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 06/02/2017, à 21:02

Séros

Battle.net ne se lance pas (Ubuntu 16.04)

Bonjour,

J'ai installé Battle.net (pour installer Heartstone) comme indiqué dans le tuto dédié (https://doc.ubuntu-fr.org/hearthstone_avec_wine).
Tout a l'air de bien fonctionné, mais lorsque je lance Battle.net, y'a une barre de chargement qui s'affiche, puis plus rien (pas de message d'erreur, rien).

J'ai cru comprendre que je n'étais pas la seule à rencontrer des problèmes récemment avec Battle.net, mais je me suis un peu perdue dans les messages du forum et j'ai peur de faire des bêtises.
Que faire?

Merci d'avance,

Seros (et tarba et manouche, les joueurs!)

Dernière modification par Séros (Le 28/02/2017, à 19:49)

Hors ligne

#2 Le 07/02/2017, à 00:05

J5012

Re : Battle.net ne se lance pas (Ubuntu 16.04)

https://doc.ubuntu-fr.org/hearthstone_avec_wine

En octobre 2016, ce tutoriel est obsolète suite aux mises à jour d'hearthstone. Il vaut mieux suivre la procédure décrite ici ....

https://forum.ubuntu-fr.org/viewtopic.p … #p21570703 (va direct au #44)

Hors ligne

#3 Le 15/02/2017, à 19:57

Séros

Re : Battle.net ne se lance pas (Ubuntu 16.04)

Bonjour,
Merci, j'ai suivi la procédure, tout va bien jusqu'à l'install de Battle.net
Tout a l'air de fonctionner, mais une fois que je veux lancer Battle.net, y'a un message d'erreur qui s'affiche (le classique "Battle.net a rencontré une erreur et doit se fermer"
Merci

Hors ligne

#4 Le 15/02/2017, à 20:43

J5012

Re : Battle.net ne se lance pas (Ubuntu 16.04)

tu as suivi les instructions de abelthorne pas-a-pas ?
ou est-ce que tu en as changé quelques lignes ? (par ex ne pas avoir telechargé battle dot net, ou l'avoir telechargé ailleurs ...)

Hors ligne

#5 Le 17/02/2017, à 14:04

abelthorne

Re : Battle.net ne se lance pas (Ubuntu 16.04)

Quelle version de Wine utilises-tu (wine --version dans un terminal) ? Est-ce que tu as ajouté un dépôt tiers pour Wine (si oui, lequel) ?

Hors ligne

#6 Le 23/02/2017, à 13:25

Séros

Re : Battle.net ne se lance pas (Ubuntu 16.04)

Bonjour à tous!

Du coup, oui j'ai bien suvi pas à pas la procédure, sans rien changer, et je ne peux pas me connecter à Battle.net (je me suis donc arrêtée là sur la procédure, à la fin du message 44).
Sinon, j'ai la version 1.8 de Wine.

Merci !

Hors ligne

#7 Le 23/02/2017, à 14:29

abelthorne

Re : Battle.net ne se lance pas (Ubuntu 16.04)

Il faudrait essayer avec une version plus récente, avec le PPA de WineHQ (attention : désinstalle d'abord ta version de Wine, toutes les dépendances et désactive un éventuel PPA déjà utilisé avant d'ajouter celui-là).

Hors ligne

#8 Le 24/02/2017, à 13:59

J5012

Re : Battle.net ne se lance pas (Ubuntu 16.04)

un test winehq de hearthstone : https://appdb.winehq.org/objectManager. … &iId=30038
utilise wine 1.9.19 ...

le script pol : https://www.playonlinux.com/fr/app-1950 … stone.html
utilise wine 1.9.18 ...

Hors ligne

#9 Le 26/02/2017, à 01:41

dexter74

Re : Battle.net ne se lance pas (Ubuntu 16.04)

Bonjour,

je te propose de suivre mon guide:

#Installation de winehq de la branche staging (la meilleur selon moi)
sudo add-apt-repository ppa:wine/wine-builds --yes ; sudo apt-get update ; sudo apt-get install --install-recommends winehq-staging --yes ; 

#Installation de winetricks (Important car il permet d'installer les librairy requise pour bien faire tourrner les exe
cd /usr/bin ; sudo wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks ; sudo chmod +x winetricks ;

Pour permettre à battle de pas buggé:

terminale => winecfg
ajouter une application =>   nom du fichier: "Battle.net.exe" (sans guillemet) , ouvrir (t'en fou si tu es pas dans le dossier de l'exe)

Cliquer "Battle.net.exe" => Version de windows => Windows XP
Pour le premier lancement utiliser Battle.net Launcher.exe puis Battle.net.exe
D'après de nombreux retour, il es suggérer de désactiver les notifications pour éviter le plantage dans battle.

Fix 1:

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
sudo apt-get install p11-kit winbind

Fix 2:

@ fixme:msvcp:_Mtx_init_in_situ unknown flags ignored: 2 
Cliquer "Battle.net.exe" => onglet bibliothèque
Ajouter le dll "MSVCP140.dll" , clique dessus et mettre sur intégré





Pour t'aiguiller si besoin:
- [Wine] Battle.net https://appdb.winehq.org/objectManager. … &iId=28855
- [Wine] Hearstone: https://appdb.winehq.org/objectManager. … ngId=93226


PS: TESTE et approuvé
je désactiver tous les dll msvcp puis lance le jeux
err:module:import_dll Library MSVCP140.dll (which is needed by L"F:\\Jeux\\Battle.net\\Battle.net.8423\\Qt5Quick.dll") not found
Le msvcp140 est celui de l'application

ta aussi version si tu veux connaitre

Dernière modification par dexter74 (Le 26/02/2017, à 01:54)

Hors ligne

#10 Le 28/02/2017, à 10:51

Séros

Re : Battle.net ne se lance pas (Ubuntu 16.04)

bonjour à tous.

Après avoir suive les instructions pas à pas de dexter74, battle.net s'intalle sans probleme et sans erreur.

Heathstone s'installe aussi très bien.

Merci a tous et bon match

Dernière modification par Séros (Le 28/02/2017, à 10:51)

Hors ligne