Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/03/2017, à 21:57

bencat

L'hibernation crash le système - Hard reboot obligatoire...

Bonjour à tous,

Après avoir recherché un peu partout depuis plus d'une semaine, je m'en remet à vous.

J'ai un problème avec la mise en hibernation de mon système Ubuntu 16.04.

J'ai voulu suivre les instructions de la doc Ubuntu, j'ai donc tapé "pm-hibernate" dans mon Terminal, le système réagit, un écran noir apparaît, puis mon desktop revient, pour finir par freezer, le curseur ne bouge plus, et je dois faire un hard reboot en pressant longuement mon bouton power.
Après plusieurs recherches, j'ai pu lire que la partition swap devait être au moins égal à ma RAM, j'ai donc pu me rendre compte que ma partition était "plus petite" que ma RAM : 5.91Go pour le swap suivant GParted - 6Go de RAM sur la machine.
J'ai donc booté via le LiveUSB, désactivé ma partition swap, redimensionné ext4 pour gratter de l'espace, puis j'ai gonflé d'1Go mon swap.

Mais cela ne règle pas le problème...

Je précise qu'avant Ubuntu ( installé suite à la demande du boss de ma nouvelle entreprise ) j'avais une distrib Mint, avec laquelle je n'avais aucun problème de mise en hibernation du système.

Avez-vous une solution ? Cette fonction m'est indispensable pour travailler correctement, ce serait une énorme perte pour moi de ne pas pouvoir l'utiliser...


Je vous en remercie par avance !

Benoît.


Modération
Bonjour,
Un membre ne peut pas supprimer une discussion mais il suffit de le demander en utilisant le lien « Signaler aux modérateurs ».

Réponse à la Modération
Bonjour,
Merci beaucoup pour ce retour, je débarque sur ce forum, et je n'étais pas sur que cette fonction soit faite pour ça smile
Je le saurais si il y a une prochaine fois ! Merci encore.

Dernière modification par bencat (Le 12/03/2017, à 22:18)

Hors ligne

#2 Le 13/03/2017, à 14:03

Bougron

Re : L'hibernation crash le système - Hard reboot obligatoire...

bencat a écrit :

Bonjour à tous,

J'ai voulu suivre les instructions de la doc Ubuntu, j'ai donc tapé "pm-hibernate" dans mon Terminal, le système réagit, un écran noir apparaît, puis mon desktop revient, pour finir par freezer, le curseur ne bouge plus, et je dois faire un hard reboot en pressant longuement mon bouton power.
Après plusieurs recherches, j'ai pu lire que la partition swap devait être au moins égal à ma RAM, j'ai donc pu me rendre compte que ma partition était "plus petite" que ma RAM : 5.91Go pour le swap suivant GParted - 6Go de RAM sur la machine.
J'ai donc booté via le LiveUSB, désactivé ma partition swap, redimensionné ext4 pour gratter de l'espace, puis j'ai gonflé d'1Go mon swap.

Bonjour
D'abord, si ta partition de swap fait 5,91 go alors qu'elle devrait faire 6 Go, le manque d'espace n'est pas très significatif car il est très rare qu'une RAM soit utilisée à 100%
Maintenant que ton swap est plus grand, Il faudrait que tu informes l'hiberneur que la partition à utiliser a changé de référence.
Lis bien le paragraphe 3.6 de la doc https://doc.ubuntu-fr.org/swap

Et afin que vos mises en veille et hibernations se produisent correctement, vous devrez de même modifier le fichier /etc/initramfs-tools/conf.d/resume pour y renseigner le bon UUID :
RESUME=UUID=db245df9-851d-695b-a3f7-d40f039a6cc6
et ensuite, le faire prendre en compte par le système :
sudo update-initramfs -u -k $(uname -r)

Dernière modification par Bougron (Le 13/03/2017, à 14:05)


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne

#3 Le 21/05/2017, à 18:48

bencat

Re : L'hibernation crash le système - Hard reboot obligatoire...

Bonjour,

Je suis désolé de donner des nouvelles si tardivement.

Je confirme que je n'ai pas réussi à le mettre en place, l'écran se fige quoi que je fasse.
J'ai abandonné l'idée de le mettre en place sur cette machine mais j'ai pu le faire sur une machine plus récente.

Merci encore pour ton aide Bougron !

Hors ligne