Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/10/2014, à 20:13

ar barzh paour

[Enfin Résolu] configuration MIDI

voir la solution #16 !!!!!!

bonsoir à tous

le clavier électronique que j'utilise beaucoup en liaison avec mon PC est tombé en panne
j'ai donc voulu jouer directement mes fichiers midi sur mon PC mais là , impossible :

en 14.04 (32 bits) (je précise 32 bits car le résultat n'est pas le même en 64 bits voir plus bas)a12 pour moi)
quand je clique sur un fichier midi "x.mid" j'obtiens le message suivant :

Impossible de trouver le greffon requis
Vidéos nécessite d'installer un greffon pour lire les fichiers multimédias du type suivant : audio/x-midi-event decoder

mais rien n'est proposé
même chose quand je tape en ligne de commande

totem <nom du fichier> 

dans synaptic j'ai effectué une recherche avec le terme midi : résultat :
libwildmidi1
libwildmidi-config
libportsmf0
freepats

et pourtant ça marchait bien avant quand j'étais en 12.04 !!!!!!
donc sur ma version 12.04
quand je clique sur ce même fichier "x.mid" , totem se lance et lit bien le fichier
dans la fenêtre "Processus" du moniteur système je vois  : totem <nom du fichier>

en 12.04 dans synaptic j'ai effectué une recherche avec le terme midi : résultat :
timidity
timidity-daemon
alsa-utils
gimp

et les mêmes que dans 14.04
libwildmidi1
libwildmidi-config
libportsmf0
freepats


je suis allé sur ma version 14.04 64 bits (a11 pour moi) j'obtiens aussi:

Vidéos nécessite d'installer un greffon pour lire les fichiers multimédias du type suivant : audio/x-midi-event decoder

mais par contre il me propose l'installation de
gstreamer1.0-plugins-bad (i386)
greffons GStreamer de l'ensemble "bad"

malheureusement en acceptant cette installation j'ai le message d'erreur

impossible de résoudre les dépendances du paquet
 Les paquets suivants ont des dépendances non satisfaites :

gstreamer1.0-plugins-bad:i386: Depends: libc6 (>= 2.15) mais la version 2.19-0ubuntu6.3 va être installée
                               Depends: libcurl3-gnutls (>= 7.16.2) mais la version 7.35.0-1ubuntu2.1 va être installée
                               Depends: libdvdnav4 (>= 4.1.3) mais la version 4.2.1-3 va être installée
                               Depends: libdvdread4 (>= 4.1.3) mais la version 4.2.1-2ubuntu1 va être installée
                               Depends: libegl1-x11 mais c'est un paquet virtuel
                               Depends: libgcc1 (>= 1:4.1.1) mais la version 1:4.9.1-0ubuntu1 va être installée
                               Depends: libgles2 mais c'est un paquet virtuel
                               Depends: libglib2.0-0 (>= 2.37.3) mais la version 2.40.0-2 va être installée
                               Depends: libgnutls26 (>= 2.12.17-0) mais la version 2.12.23-12ubuntu2.1 va être installée
                               Depends: libgstreamer-plugins-bad1.0-0 (= 1.2.4-1~ubuntu1) mais la version 1.2.4-1~ubuntu1 va être installée
                               Depends: libgudev-1.0-0 (>= 146) mais la version 1:204-5ubuntu20.6 va être installée
                               Depends: libmpg123-0 (>= 1.6.2) mais la version 1.16.0-1ubuntu1 va être installée
                               Depends: libopenal1 (>= 1:1.13) mais la version 1:1.14-4ubuntu1 va être installée
                               Depends: liborc-0.4-0 (>= 1:0.4.18) mais la version 1:0.4.18-1ubuntu1 va être installée
                               Depends: librsvg2-2 (>= 2.36) mais la version 2.40.2-1 va être installée
                               Depends: librtmp0 (>= 2.3) mais la version 2.4+20121230.gitdf6c518-1 va être installée
                               Depends: libsoundtouch0 (>= 1.7.1-3~) mais la version 1.7.1-5 va être installée
                               Depends: libstdc++6 (>= 4.1.1) mais la version 4.8.2-19ubuntu1 va être installée
                               Depends: libusb-1.0-0 (>= 2:1.0.8) mais la version 2:1.0.17-1ubuntu2 va être installée
                               Depends: libxml2 (>= 2.7.4) mais la version 2.9.1+dfsg1-3ubuntu4.3 va être installée
                               Depends: gstreamer1.0-plugins-bad-videoparsers (= 1.2.4-1~ubuntu1) mais la version 1.2.4-1~ubuntu1 va être installée
                               Depends: gstreamer1.0-plugins-bad-faad (= 1.2.4-1~ubuntu1) mais la version 1.2.4-1~ubuntu1 va être installée

dans synaptic j'ai effectué une recherche avec le terme midi : résultat :
libfluidsynth1
a2jmidid
libwildmidi1
libwildmidi-config
libportsmf0
freepats
alsa-utils
gimp
libpcsclite1
xserver-xorg-input-synaptics

et comme sur cette version j'ai installé en plus
ardour3, scolily, JACKKeyboard, qtractor , lilypond
je trouve aussi

ardour3
lilypond
scoly
jack-keyboard
qtractor

en m'inspirant de la documentation  :
installation de timidity
timidity <nom.mid> fonctionne mais comment associer timidity au fichier .mid ? timidity ne fait pas parti des applications proposées pour "Ouvrir avec"
ajout de timidity-interfaces-extra
un clic droit sur le fichier affiche le choix "Ouvir avec TiMidity++ MIDI Sequencer

ce que je voudrais obtenir :
un clic sur le fichier x.mid ouvre une application (totem ou autre) ET joue le son du fichier  en question

Dernière modification par ar barzh paour (Le 26/11/2015, à 19:33)


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#2 Le 10/10/2014, à 10:21

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

je viens d'essayer avec Ubuntu-Studio :
Totem "joue" bien mes fichiers midi
il manque donc quelquechose à Ubuntu 14.04 !!!!!!!!!!!!!!!!
mais quoi ?


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#3 Le 14/10/2014, à 08:09

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

sans réponse ?

j'ai créé un bug dans launchpad #1380902

bug 1380902


mon bug a été annulé , on m'a demandé des infos que je n'ai pas comprises pour pouvoir les donner

Dernière modification par ar barzh paour (Le 31/12/2014, à 10:05)


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#4 Le 14/10/2014, à 08:42

Korak

Re : [Enfin Résolu] configuration MIDI

Bonjour,

Sais-tu mettre ton (ou tes) fichiers MIDI à disposition pour que je puisse tester sur mon PC?


OS: Ubuntu 14.04 64 bits + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#5 Le 14/10/2014, à 17:40

bluedid29

Re : [Enfin Résolu] configuration MIDI

Bonjour ar barzh paour, cool

J'ai installé la version 14.04-1 version 64bits et les fichiers Midifile sont lus par Totem directement, peut être effectivement un bogue avec la première version d'Ubuntu 14.04.

Lecture directe aussi avec le lecteur Média Parole (installé de base).

En installant ensuite timidity et timidity-interfaces-extra pas de soucis non plus pour la lecture en cliquant dessus et en choisissant... ...Timidity wink

Il y a donc plusieurs solutions ! smile

Essaye d'installer tout ce qui concerne ubuntu studio via le gestionnaire de paquet Synaptic...

BlueDid cool

Dernière modification par bluedid29 (Le 14/10/2014, à 17:52)


Linux en Audio et Midi, c'est magique ;-) http://linuxmao.org Debian Wheezy, testing, Sid, Ubuntu Tango 10.04, Kx 12.04, Studio 13.04, 14.04, Mint17 et blog MAO sur Linux http://bluedid29.mdl29.net/

Hors ligne

#6 Le 15/10/2014, à 16:43

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

@korak
non je ne sais pas faire mais en cherchant au hasard de le recherche sur le web tu peux télécharger un fichier de ce type lien ci- dessous

fichier midi


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#7 Le 15/10/2014, à 17:12

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

@ bluedid29
il faut que je vois ça de plus près
par contre
"installer tout ce qui concerne ubuntu studio" sur ma version 32 bits , ça je ne sais pas faire ,intaller ubuntu studio sur une partition à part , oui j'ai déja


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#8 Le 18/10/2014, à 02:21

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

il y a vraiment un problème avec ces fichiers :
le 17-10-2014
je télécharge la version Ubuntu 12.04 sur le site
ubuntu-12.04.5-desktop-i386.iso
j'installe cette version sur une partition d'essai
clic sur un fichier midi : OK totem s'ouvre et joue le fichier
je fais un mise à jour de 12.04 vers 14.04
la mise à jour se passe bien (mise à part qu'il faut répondre à des questions de temps en temps et que si on ne reste pas devant l'écran , la mise à jour attend ..)
j'arrive donc sur une version 14.04 , clic sur le fichier midi : et là même message :
Video necessite d'installer un greffon pour lire les fichiers audio/x-midi-event decoder
greffon qu'il ne trouve pas


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#9 Le 18/10/2014, à 05:46

Korak

Re : [Enfin Résolu] configuration MIDI

J'ai oublié de te répondre, désolé.

J'ai essayé de lire des fichiers MIDI et même problème que toi.

Ce qui m'étonne c'est que les fichiers MIDI téléchargé sur le site dont tu as donné le lien ne font que quelques Ko (environ 25 Ko). Est-ce bien normal???


OS: Ubuntu 14.04 64 bits + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#10 Le 18/10/2014, à 18:19

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

@korak
oui c'est normal , ce type de fichier ne contient pas de "son" mais des instructions qui seront décodées par le logiciel receveur


plus de détail sur MIDI


si tu installes timidity ( présent dans la logithèque )
il suffit de taper dans un terminal

 timidity <nom du fichier midi> 

pour pouvoir normalement "écouter" le morceau de musique

Dernière modification par ar barzh paour (Le 18/10/2014, à 18:28)


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#11 Le 24/02/2015, à 14:48

Etranger

Re : [Enfin Résolu] configuration MIDI

Bonjour,
Depuis peu sous 14.04 64 bits, j'ai été confronté au même problème (demande de plugin introuvable) en voulant écouter une radio en direct. Le problème venait de ce que seul rhythmbox est proposé, alors que totem est aussi installé. En faisant "ouvrir avec" et en sélectionnant /usr/bin/totem, plus de problème, ça marche tout seul !

Michel

Hors ligne

#12 Le 25/02/2015, à 16:38

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

merci Etranger pour cette réponse , mais ça ne marche pas ...
1-j'ouvre totem , je choisis le ficchier .mid : le résultat :
Impossible de trouver le greffon requis
Videos nécessite d'installer un greffon pour lire les fichiers multimédia du type suivant : audio/x-midi-event decoder
j'ai essayé en 32 bits et en 34 bits pour le même résultat
2- via nemo ou nautilus : ouvrir avec : le hic c'est que là il me propose des applications : audacity , ... Rythmbox ,Videos (c'est totem) ) autre application , et dans les autres applications je ne peux pas (ne sais pas) choisir /usr/bin/totem
heureusement mon piano numérique refonctionne ...... mais ça m'oblige à le mettre en route à chaque fois....


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#13 Le 26/02/2015, à 15:04

Etranger

Re : [Enfin Résolu] configuration MIDI

Bonjour ar barzh paour,
Effectivement, ce sont deux problèmes distincts. Je n'arrive pas non plus à lire les fichiers midi avec Vidéos alias totem. Mais là, l'erreur est intéressante, j'obtiens une fenêtre d'alerte disant :

Ligne de commandes invalide
Le format des paramètres passés à l’application est invalide. Merci de signaler ce bogue !
Les paramètres étaient :
--transient-for=58720271
gstreamer|1.0|totem|audio/x-midi-event decoder|decoder-audio/x-midi-event

Par contre avec timidity (déjà cité plus haut) ça marche.

Hors ligne

#14 Le 26/02/2015, à 15:58

erresse

Re : [Enfin Résolu] configuration MIDI

Bonjour à tous,
Effectivement, Timidity joue sans problème les fichiers .mid (vu qu'il est fait pour cela) mais il faut lui ajouter "freepats" pour un meilleur rendu...
Et VLC joue directement les fichiers .mid sans rien ajouter.
cool
En revanche, si on veut pouvoir jouer des .mid sous wine, il faut passer par le démon timidity-daemon (je n'ai trouvé que ça qui fonctionne dans ce cas).
tongue


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#15 Le 25/04/2015, à 17:46

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

je refais le tour de mes posts et je tombe sur celui-là ( lecture fichier .mid)

avec vlc j'obtiens ce message:
"Pas de module de décodage approprié pour le format
Vlc ne supporte probablement pas le format audio ou vidéo "MIDI". Malheureusement il n'y a rien à faire
"

Dernière modification par ar barzh paour (Le 25/04/2015, à 17:50)


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#16 Le 26/11/2015, à 19:30

ar barzh paour

Re : [Enfin Résolu] configuration MIDI

la lecture ce ce post
https://forum.ubuntu-fr.org/viewtopic.php?id=1854581
m'a permis de régler mon problème
merci à olnd
par curiosité je suis allé sur le lien AskUbuntu, bien m'en a pris , cela m'a permis de régler ce problème qui durait depuis le passage de 12.04 à 14.04
j'ai fait une recherche avec le mot midi et j'ai trouvé
http://askubuntu.com/questions/403307/p … m-on-13-10
que j'ai appliqué

j'ai chargé fluid soundfont-gm et tout roule ..... totem me lit maintenant mes fichiers midi par double clic

Dernière modification par ar barzh paour (Le 26/11/2015, à 19:37)


Ubuntu 16.04 64 bits (depuis juillet 2016) , gnome3 en essai (juin 2017)
divers versions Ubuntu et Studio 14.04 LTS 64 bits
(01/2017 ) :PC          : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz 2Go de RAM 800 MHz
(06/2017) : Portable : Intel(R) Core(TM)2  Duo CPU     T5750  @ 2.00GHz 3Go de RAM DDR2 667 Mhz

Hors ligne

#17 Le 14/03/2017, à 11:06

liviusbarbatus

Re : [Enfin Résolu] configuration MIDI

Merci pour le message de ar barzh paour qui m'a permis d'installer le greffon pour vlc et totem par

sudo apt-get install vlc-plugin-fluidsynth

Le paquet additionnel fluid-soundfont-gm a été ajouté.


Dell XPS M1330 Ubuntu 16.04.01 LTS
Asus PC1025CE Lubuntu 16.04.01 LTS

Hors ligne