Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 18/03/2017, à 09:33

vercoucas

Perte connexion DNS après mise en veille

Bonjour à tous,

J'ai installé xubuntu 16.04 sur un PC ACER ASPIRE M1100 il y a quelques mois et après la période de mise au point l'ensemble donne entière satisfaction.
Mais depuis quelques jours le PC perd le connxion DNS après une mise en veille.
Après un arrêt complet tout se passe bien, j'ai la liaison internet sur chromium et firefox, la connexion est stable.
Mais après une mise en veille les 2 navigateurs me donnent un message d'erreur concernant le serveur DNS.

ping 8.8.8.8 passe sans problème, donc la wifi , la box et internet fonctionnent mais
ping www.google.fr me renvoie le message d'erreur :unknown host www.google.fr
J'ai pensé qu'une récente mise à jour pouvait être la source du problème.
J'ai fait l'essai avec les noyaux 4.4.0.62 et 4.4.0.64 et j'ai le même défaut.

Je récupère ma connexion en réactivant network-manager.
sudo service network-manager restart

et après tout fonctionne ... mais bon ce n'est pas satisfaisant

Voilà quelques retours qui détaillent cela.


Chromium

Ce site est inaccessible

Impossible de trouver l'adresse DNS du serveur gw.geneanet.org.
Essayez les suggestions ci-dessous :
Vérifier les configurations du proxy, du pare-feu et du DNS
DNS_PROBE_FINISHED_BAD_CONFIG

Firefox

Firefox ne peut trouver le serveur à l’adresse forum.ubuntu-fr.org.

    Veuillez vérifier la syntaxe de l’adresse (saisie de ww.example.com au lieu de www.example.com par exemple) ;
    Si vous n’arrivez à naviguer sur aucun site, vérifiez la connexion au réseau de votre ordinateur ;
    Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy, assurez-vous que Firefox a l’autorisation d’accéder au Web.
sylvieb@ACER:~$ inxi -Fxz -c 10
System:    Host: ACER Kernel: 4.4.0-67-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Ubuntu 16.04 xenial
Machine:   System: Acer product: Aspire M1100 v: R01-A0
           Mobo: Acer model: F690GVM Bios: Phoenix v: 6.00 PG date: 05/04/2007
CPU:       Single core AMD Sempron 3600+ (-UP-) cache: 256 KB
           flags: (lm nx sse sse2 sse3) bmips: 1995 speed/max: 1000/2000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690 [Radeon X1200] bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1440x900@74.98hz
           GLX Renderer: Gallium 0.4 on ATI RS690
           GLX Version: 2.1 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.4.0-67-generic
Network:   Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: ee00 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Netgear WPN111 RangeMax Wireless USB 2.0 Adapter
           driver: ar5523 usb-ID: 001-005
           IF: wlx00184dd30da0 state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (43.7% used)
           ID-1: /dev/sda model: ST3250820AS size: 250.1GB
Partition: ID-1: / size: 32G used: 6.1G (20%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 1.88GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 171 Uptime: 22 min Memory: 394.0/1748.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.461) inxi: 2.2.35 
sylvieb@ACER:~$

sylvieb@ACER:~$ uname -a
Linux ACER 4.4.0-67-generic #88-Ubuntu SMP Wed Mar 8 16:34:45 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
sylvieb@ACER:~$ 


sylvieb@ACER:~$ iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlx00184dd30da0  IEEE 802.11bg  ESSID:"regis"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 02:FD:D7:DD:DE:38   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=30/70  Signal level=-80 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:241  Invalid misc:47   Missed beacon:0

sylvieb@ACER:~$ 

sylvieb@ACER:~$ ifconfig
enp2s0    Link encap:Ethernet  HWaddr 00:01:6c:0e:0d:0d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:19 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:2920 erreurs:0 :0 overruns:0 frame:0
          TX packets:2920 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1 
          Octets reçus:208067 (208.0 KB) Octets transmis:208067 (208.0 KB)

wlx00184dd30da0 Link encap:Ethernet  HWaddr 00:18:4d:d3:0d:a0  
          inet adr:192.168.0.11  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::d211:174e:5704:6681/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:23 erreurs:0 :0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:2173 (2.1 KB) Octets transmis:10552 (10.5 KB)

sylvieb@ACER:~$


sylvieb@ACER:~$ ping -c10 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=58 time=37.9 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=58 time=33.6 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=58 time=33.4 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=58 time=33.0 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=58 time=33.1 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=58 time=33.5 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=58 time=33.4 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=58 time=33.1 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=58 time=35.0 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=58 time=32.7 ms

--- 8.8.8.8 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9012ms
rtt min/avg/max/mdev = 32.787/33.910/37.992/1.491 ms
sylvieb@ACER:~$ ping -c10 www.google.fr
ping: unknown host www.google.fr
sylvieb@ACER:~$ 

Ayant vu le fil de moko138 sur à propos du noyau 4.4.0-67, je l'ai désinstallé et je suis maintenant en 4.4.0-66

Merci de votre aide

Hors ligne

#2 Hier à 09:18

vercoucas

Re : Perte connexion DNS après mise en veille

Bonjour à tous,

En fin de compte j'ai tout réinstallé xubuntu 16.04.
Et là j'ai eu la mauvaise surprise de voir que mon problème est encore présent.
Il ne reste comme noyau que 4.4.0.66 et 4.4.031.
Si je relance network-manager en retour de veille, la connexion s'établit et est parfaitement stable.

Autre élément que je n'avais pas signalé car je ne suis pas sûr qu'il y ait un lien : le voyant de la clé wifi reste allumée quand le PC est mis à l'arrêt.

Pour voir j'ai mis la clé usb de mon autre PC, (TL-WN725N chip 8188eu) en remplacement de la "wpn111 chip ar5523" qui l'équipe normalement ...la liaison wifi fonctionne et je ne perds plus la liaison en retour de veille.

Le problème semble donc lié à ma clé wifi : Card-2: Netgear WPN111 RangeMax Wireless USB 2.0 Adapter
           driver: ar5523 usb-ID: 001-005


Merci de votre aide

Hors ligne

#3 Hier à 17:06

f.x0

Re : Perte connexion DNS après mise en veille

Bonjour vercoucas,

tu peux faire cette manip pour automatiser le restart de network-manager :
1) - Créer un script dans le répertoire /etc/pm/sleep.d :

echo -e '#!/bin/sh\n/etc/init.d/network-manager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh

2) - Rendre le script exécutable:

sudo chmod +x /etc/pm/sleep.d/NWM.sh

Dernière modification par f.x0 (Hier à 17:07)


SOPI

Hors ligne