Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 01/04/2017, à 18:43

CyrilB39

Erreur montage NAS bloque le démarrage

Bonjour,
j'ai une configuration en dual-boot ubuntu / Windows 10, et un NAS sur mon réseau local.
J'accède au NAS en montant automatiquement quelques répertoires partagés via /etc/fstab (ci dessous les lignes correspondantes) :

//192.168.1.27/Mp3    /media/raid/NAS_Mp3    cifs    x-systemd.automount,sec=ntlmv2,credentials=/home/cyril/.smbcredentials,uid=1000,gid=1001,_netdev,setuids    0    0
//192.168.1.27/Photos    /media/raid/NAS_Photos    cifs    x-systemd.automount,sec=ntlmv2,credentials=/home/cyril/.smbcredentials,uid=1000,gid=1001,_netdev,setuids    0    0
//192.168.1.27/Videos    /media/raid/NAS_Videos    cifs    x-systemd.automount,sec=ntlmv2,credentials=/home/cyril/.smbcredentials,uid=1000,gid=1001,_netdev,setuids    0    0
//192.168.1.27/docbackups    /media/raid/NAS_Backupdocuments    cifs    x-systemd.automount,sec=ntlmv2,credentials=/home/cyril/.smbcredentials,gid=1001,uid=1000,_netdev    0    0

Et tout cela fonctionne bien.

Un problème survient quand je boote sous  windows, et que j'arrête l'ordinateur en faisant "Arrêter" . Si je redémarrage ensuite sous linux (peu importe le temps après l'arrêt de l'ordi), le démarrage d'ubuntu s'arrête au milieu sur une erreur de montage des dossiers NAS... En gros les messages cifs indiquent un pb de socket qui rend impossible la connexion aux répertoires distants, donc pas de montage, et impossible de poursuivre le démarrage sous linux.
Le plus troublant est que si je redémarre Windows, et que je fais ensuite "redémarrer" et non pas "arrêter" dans windows, alors aucun pb de montage des répertoires NAS au boot de Linux (c'est d'ailleurs la seule solution que j'ai pour redémarrer mon système)

Donc j'ai deux problèmes en fait :
1- il semble que Windows ferme de manière différente les connexions réseaux sur mon NAS selon que je fais "arrêter" ou "redémarrer"
2- les erreurs de montage cifs via le fstab quand la connexion avec le NAS est bloquée empêchent le démarrage de linux (ce qui n'est pas logique car un point de montage défectueux ne devrait pas empêcher le système de démarrer).

Aujourd'hui donc je prends l'habitude de ne plus utiliser "Arreter" sous windows, mais "redemarrer" et dans ce cas tout fonctionne très bien, mais ce n'est quand même ni pratique ni très normal.

Merci de votre aide...

Hors ligne

#2 Le 01/04/2017, à 19:01

michel_04

Re : Erreur montage NAS bloque le démarrage

Bonjour,

CyrilB39 a écrit :

Aujourd'hui donc je prends l'habitude de ne plus utiliser "Arreter" sous windows, mais "redemarrer" et dans ce cas tout fonctionne très bien, mais ce n'est quand même ni pratique ni très normal.

Tu as enlevé l'hibernation sur ton Windows 10 ?

A+

Hors ligne

#3 Le 02/04/2017, à 11:35

CyrilB39

Re : Erreur montage NAS bloque le démarrage

Alors j'ai pas bien compris si l'hibernation était activée ou pas, c'est pas hyper clair dans windows. Toujours est il que je n'avais pas de fichier C:\hiberfil.sys sur mon disque.
J'ai coché la case "afficher l'hibernation" dans le menu, et surtout j'ai désactivé le redémarrage rapide, et ca marche !!!!

Bon je cherche pas plus loin, tout fonctionne, merci beaucoup.

Pour ma culture, le fait qu'ubuntu de finisse pas de démarrer si un point de montage bloque, c'est normal ?

Hors ligne

#4 Le 02/04/2017, à 12:06

michel_04

Re : Erreur montage NAS bloque le démarrage

Re,

CyrilB39 a écrit :

Pour ma culture, le fait qu'ubuntu de finisse pas de démarrer si un point de montage bloque, c'est normal ?

Voir mount et fstab : Le montage des systèmes de fichiers.
Utiliser les options auto et noauto (montage auto ou pas).

Exemple :

pas de montage auto a écrit :

## HDD Freebox
//mafreebox.freebox.fr/Disque\040dur /media/freebox cifs _netdev,noauto,username=freebox,password=xxxxxxxxxx,cache=none,uid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

montage auto a écrit :

## HDD Freebox
//mafreebox.freebox.fr/Disque\040dur /media/freebox cifs _netdev,username=freebox,password=xxxxxxxxxx=none,uid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

A+

Dernière modification par michel_04 (Le 02/04/2017, à 12:07)

Hors ligne

#5 Le 02/04/2017, à 14:18

CyrilB39

Re : Erreur montage NAS bloque le démarrage

Super, je vais tester ça à l'occasion.

Encore merci

Hors ligne