Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 16/04/2017, à 11:10

ysuire

Problème JAVA

Bonjour,

J'utilise un logiciel d'indexation pour la généalogie qui fonctionne en .sh, mais depuis quelques mois, je n'arrive plus à accéder à ce logiciel.

Le message d'erreur que le terminal me donne est :

~/Documents$ sudo sh Indexing_unix.sh
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.6 and at most 1.6.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

Apparemment, un patch a été fait par quelqu'un pour outrepasser ce message d'erreur, mais il semblerait que celui ci ne soit plus à jour non plus ... le lien ici :

No suitable JAVA VM found

Quelqu'un pourrait-il m'aider à le modifier afin que je puisse à nouveau l'utiliser ?

Merci !


PC Dell Optiplex GX520, Ubuntu 16.10 32 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 2 Go RAM PC4200

Hors ligne

#2 Le 17/04/2017, à 16:56

gl38

Re : Problème JAVA

C'est curieux que les Mormons se moquent de la sécurité informatique : java 1.6 est obsolète depuis un bon moment.
Cordialement,
Guy

Hors ligne

#3 Le 17/04/2017, à 17:37

ysuire

Re : Problème JAVA

Merci pour ce commentaire constructif qui va très certainement m'aider dans ma problématique ... Et sinon d'autres solutions ?


PC Dell Optiplex GX520, Ubuntu 16.10 32 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 2 Go RAM PC4200

Hors ligne

#4 Le 17/04/2017, à 17:41

ublender

Re : Problème JAVA

Bonjour,

Où peut on trouver ce logiciel? J'aimerais voir si on peut le bidouiller afin de ne pas avoir à installer une aussi vieille version de java.
Et il y a vraiment besoin de sudo?

Dernière modification par ublender (Le 17/04/2017, à 17:47)

Hors ligne

#5 Le 17/04/2017, à 18:51

soshy

Re : Problème JAVA

ublender a écrit :

J'aimerais voir si on peut le bidouiller afin de ne pas avoir à installer une aussi vieille version de java.

Je pense que java 8 devrait fonctionner. La compatibilité ascendante de Java est normalement très bonne.

ublender a écrit :

Et il y a vraiment besoin de sudo?

Mon avis gratuit sur un logiciel dont on ne connait même pas le nom est : non.

@ysuire
Tu peux essayer avec un truc du style

INSTALL4J_JAVA_HOME=/usr/lib/jvm/default-java/jre/bin/ sh Indexing_unix.sh

Comme je sais pas trop à quelle étape faut s'arreter tu peux aussi essayer:

INSTALL4J_JAVA_HOME=/usr/lib/jvm/default-java/jre/ sh Indexing_unix.sh

Je doute que remonter plus haut soit utile.

Dernière modification par soshy (Le 17/04/2017, à 18:54)

Hors ligne

#6 Le 17/04/2017, à 21:14

ublender

Re : Problème JAVA

On est bien d'accord pour sudo.

Ce logiciel veut java 6, le but c'est justement de lui faire croire qu'il utilise la version 6 alors qu'il en utilise une plus récente.
must be at least 1.6 and at most 1.6

Hors ligne

#7 Le 17/04/2017, à 21:41

soshy

Re : Problème JAVA

C'est pas comme ça que ça fonctionne. Quand tu lances un programme java, ça lance la JVM, puis la JVM exécute le bytecode qu'on lui donne. Le bytecode à été généré à partir du code source avec une version cible. Le bytecode généré peut ensuite être lancé par n'importe quelle JVM correspondant à cette version cible, ou avec une version supérieur. Ensuite ton code peut vérifier une version spécifique, mais ça parait assez stupide.

Le message d'erreur ici, il est renvoyé par le script sh à coup sûr, qui est pas foutu de trouver une JVM pour lancer le programme Java. De là à ce que le script ait genre 5 ou 10 ans et qu'il ait été fait comme un pied en vérifiant une version minimum requise, et la version maximum existant à l'époque il y a pas loin...

A la limite, faudrait le contenu du script histoire de virer ce controle foireux.

Dernière modification par soshy (Le 17/04/2017, à 21:49)

Hors ligne

#8 Le 17/04/2017, à 22:19

ysuire

Re : Problème JAVA

Le logiciel se trouve ici : https://familysearch.org/indexing/get-s … r#/desktop

Merci pour votre aide. Je fais ça pour aider des personnes à trouver leurs ancêtres, mormons ou non.

Ce qui m'étonne c'est que ce problème est très récent car il y a quelques mois ça marchait impeccablement bien. Ils ont fait une mise à jour et ils ont dû faire une erreur.

Je vous dirai les résultats des solutions données dès que possible

Dernière modification par ysuire (Le 17/04/2017, à 22:23)


PC Dell Optiplex GX520, Ubuntu 16.10 32 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 2 Go RAM PC4200

Hors ligne

#9 Le 18/04/2017, à 10:05

ublender

Re : Problème JAVA

J'ai même pas réussi à le lire avec mousepad (équivalent de gedit), par contre avec

strings Indexing_unix.sh | less

On voit le script puis un truc après. J'ai du mal à comprendre le script. J'imagine que c'est cette ligne

 if [ "$ver_minor" -gt "6" ]; then

qu'il faut modifier en

 if [ "$ver_minor" -gt "8" ]; then

Il y a une deuxième ligne du même type deux lignes en dessous.
Donc je propose de modifier ce fichier à l'aide d'un éditeur hexadécimal (j'utilise bless qui se trouve dans les dépôts) et tu recherches le texte à modifier, et tu remplaces le 36 par 38

Dernière modification par ublender (Le 18/04/2017, à 10:21)

Hors ligne

#10 Le 18/04/2017, à 13:02

soshy

Re : Problème JAVA

Il s'ouvre bien dans vi, et gedit aussi il me semble, cependant supprimer les lignes et sauver a pas l'air de le rendre heureux.
En revanche, ceci a l'air de fonctionner:

tail -c 1399964 Indexing_unix.sh > binary.bin
head -n 599 Indexing_unix.sh > tmpscript.sh
sed -i '116,136d' tmpscript.sh
cat tmpscript.sh binary.bin > fixed.sh
rm binary.bin tmpscript.sh
chmod +x fixed.sh
./fixed.sh

Et vu que c'est un script d'installation, il faut peut-etre bien le lancer en sudo en fin de compte...

Edit:
En fait, ceci doit suffire:

sed -i '116,136d' Indexing_unix.sh
./Indexing_unix.sh

Dernière modification par soshy (Le 18/04/2017, à 15:45)

Hors ligne

#11 Le 18/04/2017, à 13:57

ysuire

Re : Problème JAVA

Je l'ai toujours lancé en sudo car en effet c'est bien un script d'installation.
Je ne suis pas chez moi donc pour l'instant je ne peux pas tester, mais je vous en dirai plus. Merci en tout cas.


PC Dell Optiplex GX520, Ubuntu 16.10 32 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 2 Go RAM PC4200

Hors ligne

#12 Le 21/04/2017, à 00:03

ysuire

Re : Problème JAVA

soshy a écrit :

Il s'ouvre bien dans vi, et gedit aussi il me semble, cependant supprimer les lignes et sauver a pas l'air de le rendre heureux.
En revanche, ceci a l'air de fonctionner:

tail -c 1399964 Indexing_unix.sh > binary.bin
head -n 599 Indexing_unix.sh > tmpscript.sh
sed -i '116,136d' tmpscript.sh
cat tmpscript.sh binary.bin > fixed.sh
rm binary.bin tmpscript.sh
chmod +x fixed.sh
./fixed.sh

Et vu que c'est un script d'installation, il faut peut-etre bien le lancer en sudo en fin de compte...

Edit:
En fait, ceci doit suffire:

sed -i '116,136d' Indexing_unix.sh
./Indexing_unix.sh

Le premier code fonctionne bien pour démarrer l'installeur. Seulement, voici la seconde étape :

mini_711228Capturedu20170420235651.png


PC Dell Optiplex GX520, Ubuntu 16.10 32 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 2 Go RAM PC4200

Hors ligne