Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 22/04/2017, à 22:53

pasApas

apt bloque par cause de paquet cassé

bonjour

comme en témoigne mes relativement nombreux msg dans ce sous-répertoire, je suis sous ubuntu 16.04 depuis très longtemps, et n'ai pas rencontré de difficulté majeure coriace.

ça marche, et même plutôt très bien...

toutefois, j'ai un paquet installé par une tentative d'installation (sans doute anodine) en tant que dépendance, et je ne me rappelle plus quoi, car ça remonte à plusieurs semaines, qui bloque maintenant apt totalement.

j'espérais, c'est souvent comme cela en instable, qu'une actualisation ultérieure allait de me permettre de retomber automatiquement sur mes pieds... mais il n'en est rien car cela n'installe plus du tout!

la cause résulte dans la version du paquet libssl1 64 bit et 32 bit. j'ai le bon niveau, donc tout marche, mais une version caduque.

apt et synaptic s'avèrent impuissants.

quelles autres possibilités existent-elles?

crdlmt


Kubuntu 64 bit 17.04 sur Laptop DELL XPS 15 à puces intel
clavier us intl + ibus-hangul, ainsi que jwm et ratpoison en plus
et divers Linux live ou Linux constructibles soi-même (SliTaz / NuTyx / Puppy)

Hors ligne

#2 Le 22/04/2017, à 22:55

foustala

Re : apt bloque par cause de paquet cassé

donne des logs de ce qui bloque

sudo apt-get update
sudo apt-get upgrade

Hors ligne

#3 Le 22/04/2017, à 23:38

pasApas

Re : apt bloque par cause de paquet cassé

rebonjour

voila (avec le log de apt --fix-broken install

...
Réception de:9 [url]http://security.ubuntu.com/ubuntu[/url] zesty-security InRelease [89.2 kB]
Atteint:10 [url]http://lu.archive.ubuntu.com/ubuntu[/url] zesty-backports InRelease       
Err:11 [url]http://ppa.launchpad.net/nowrep/qupzilla/ubuntu[/url] zesty Release           
  404  Not Found
Lecture des listes de paquets... Fait                                          
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'file:/var/cache/apt-build/repository apt-build InRelease' doesn't support architecture 'i386'
E: The repository 'http://ppa.launchpad.net/nowrep/qupzilla/ubuntu zesty Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libssl1.0.0 : Casse: libssl1.0.0:i386 (!= 1.0.2g-1ubuntu4.6) mais 1.0.2g-1ubuntu11 est installé
 libssl1.0.0:i386 : Casse: libssl1.0.0 (!= 1.0.2g-1ubuntu11) mais 1.0.2g-1ubuntu4.6 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
sudo apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.10.0-11 linux-headers-4.10.0-11-generic
  linux-image-4.10.0-11-generic linux-image-extra-4.10.0-11-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Die folgenden zusätzlichen Pakete werden Installiert
  libssl1.0.0
Les paquets suivants seront mis à jour :
  libssl1.0.0
1 mis à jour, 0 nouvellement installés, 0 à enlever et 228 non mis à jour.
6 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1,080 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [Y/n]

et, en continuant comme propose:

Préconfiguration des paquets...
(Lecture de la base de données... 402603 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libssl1.0.0_1.0.2g-1ubuntu11_amd64.deb ...
Dépaquetage de libssl1.0.0:amd64 (1.0.2g-1ubuntu11) sur (1.0.2g-1ubuntu4.6) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libssl1.0.0_1.0.2g-1ubuntu11_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/doc/libssl1.0.0/changelog.Debian.gz », qui est différent d'autres instances du paquet libssl1.0.0:amd64
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libssl1.0.0_1.0.2g-1ubuntu11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 23/04/2017, à 01:43)


Kubuntu 64 bit 17.04 sur Laptop DELL XPS 15 à puces intel
clavier us intl + ibus-hangul, ainsi que jwm et ratpoison en plus
et divers Linux live ou Linux constructibles soi-même (SliTaz / NuTyx / Puppy)

Hors ligne

#4 Le 22/04/2017, à 23:47

foustala

Re : apt bloque par cause de paquet cassé

désactive ton dépôt qupzilla qui n'est pas porté sur zesty, ça ne fera pas de mal.

puis tente


sudo apt-get update
sudo apt-get purge libssl1.0.0:i386
sudo apt-get autoremove

et ne valide pas s'il t'envoie vers la désinstallation de plus de 10 paquets

Dernière modification par foustala (Le 22/04/2017, à 23:48)

Hors ligne

#5 Le 23/04/2017, à 09:35

pasApas

Re : apt bloque par cause de paquet cassé

bonjour
Merci!
Comment desactive-t-on (la voie ¨academique¨!) un tel depot? (que j´avais installe aussi en suivant la voie ¨academique¨ specifiee sur la page de Qupzilla! Je crois d´ailleurs que mes ennuis proviennent de l´absence d´un bon navigateur web dans Kubuntu et d´un probl`eme d´accents. J´ai du tester des tas de choses pour arriver `a travailler avec tous mes moyens normaux ou presque! D´ailleurs, dans Debian9 RC que j´ai aussi installe, je n´ ai plus installe KDE du tout, mais tout de suite LXQT...).
Crdlmt


Kubuntu 64 bit 17.04 sur Laptop DELL XPS 15 à puces intel
clavier us intl + ibus-hangul, ainsi que jwm et ratpoison en plus
et divers Linux live ou Linux constructibles soi-même (SliTaz / NuTyx / Puppy)

Hors ligne

#6 Le 23/04/2017, à 22:12

pasApas

Re : apt bloque par cause de paquet cassé

est-ce que le probl`eme pourrait ^etre lie `a skype qui depend de libssl1.0.0:i386?


Kubuntu 64 bit 17.04 sur Laptop DELL XPS 15 à puces intel
clavier us intl + ibus-hangul, ainsi que jwm et ratpoison en plus
et divers Linux live ou Linux constructibles soi-même (SliTaz / NuTyx / Puppy)

Hors ligne

#7 Le 24/04/2017, à 00:34

foustala

Re : apt bloque par cause de paquet cassé

On verra pour skype après. on pourra toujours le reinstaller une fois que le conflit entre les deux version de libssl sera résolu.

pour le ppa, il y a pleins de façon dont

sudo add-apt-repository --remove ppa:nowrep/qupzilla

et lance les commandes demandées

sudo apt-get update
sudo apt-get purge libssl1.0.0:i386
sudo apt-get autoremove
sudo apt-get upgrade

Hors ligne