Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 25/04/2017, à 16:33

Mirala

Problème accès Internet par câble

J’ai un mini PC GigaByte sous Ubuntu 16.04. Depuis l’installation, j’utilise la connexion filaire sans problème. Maintenant je ne peux utiliser que la connexion WIFI pour aller sur Internet. Sur mon réseau local, je peux pinguer mon NAS ASUSTOR et accèder à son interface graphique pour gérer mes sauvegardes. Je peux également pinguer un autre PC sous Seven. J’ai une Livebox Play.

J’ai lancé les quelques commandes que je connais et qui donnent les résultats suivants :

alain@ALAIN-PC:/etc/network$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 40:8d:5c:33:be:b8  
          inet adr:192.168.1.16  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: 2a01:cb00:4b8:be00:428d:5cff:fe33:beb8/64 Scope:Global
          adr inet6: fe80::428d:5cff:fe33:beb8/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:8116 erreurs:0 :483 overruns:0 frame:0
          TX packets:5845 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:5553288 (5.5 MB) Octets transmis:861312 (861.3 KB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:5644 erreurs:0 :0 overruns:0 frame:0
          TX packets:5644 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1 
          Octets reçus:406848 (406.8 KB) Octets transmis:406848 (406.8 KB)

wlan0     Link encap:Ethernet  HWaddr b4:6d:83:ca:69:df  
          inet adr:192.168.1.11  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: 2a01:cb00:4b8:be00:939:5f5b:e0a3:fc4e/64 Scope:Global
          adr inet6: 2a01:cb00:4b8:be00:b66d:83ff:feca:69df/64 Scope:Global
          adr inet6: fe80::b66d:83ff:feca:69df/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:3552 erreurs:0 :0 overruns:0 frame:0
          TX packets:2704 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:1035291 (1.0 MB) Octets transmis:575922 (575.9 KB)

alain@ALAIN-PC:/etc/network$ cat interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
	address 192.168.1.16
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
	gateway 192.168.1.1

Mes machines ont des adresses statiques.

Si l'un d'entre a une idée, j'en serai très heureux. Par avance, merci.


Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 25/04/2017, à 16:40)

Hors ligne

#2 Le 25/04/2017, à 21:04

J5012

Re : Problème accès Internet par câble

la connexion eth0 est une connexion filaire ! et d'apres ifconfig, elle fonctionne correctement ...

la wifi transmet egalement correctement ...

selon ifconfig, les deux interfaces transmettent simultanement ...

Hors ligne

#3 Le 25/04/2017, à 21:41

Mirala

Re : Problème accès Internet par câble

Bonsoir, merci pour votre réponse. Le fait que je puisse gérer mon NAS sans problème confirme que ce n'est pas un problème de carte. Je pense que c'est plutôt un problème logiciel mais en consultant le forum je n'ai pas vu de piste qui me permette de lancer d'autres tests...

Hors ligne

#4 Le 26/04/2017, à 07:14

Mirala

Re : Problème accès Internet par câble

Une précision supplémentaire, en déconnectant le WIFI si je pingue 8.8.8.8 ça marche !

alain@ALAIN-PC:~$ sudo ifconfig
[sudo] Mot de passe de alain : 
eth0      Link encap:Ethernet  HWaddr 40:8d:5c:33:be:b8  
          inet adr:192.168.1.16  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: 2a01:cb00:4b8:be00:428d:5cff:fe33:beb8/64 Scope:Global
          adr inet6: fe80::428d:5cff:fe33:beb8/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:1902 erreurs:0 :350 overruns:0 frame:0
          TX packets:1348 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:525011 (525.0 KB) Octets transmis:275172 (275.1 KB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:1686 erreurs:0 :0 overruns:0 frame:0
          TX packets:1686 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1 
          Octets reçus:141220 (141.2 KB) Octets transmis:141220 (141.2 KB)

wlan0     Link encap:Ethernet  HWaddr b4:6d:83:ca:69:df  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:5704 erreurs:0 :2 overruns:0 frame:0
          TX packets:2172 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:5591233 (5.5 MB) Octets transmis:377167 (377.1 KB)
alain@ALAIN-PC:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=57 time=2.55 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=57 time=2.01 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=57 time=2.99 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=57 time=2.67 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=57 time=2.05 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=57 time=2.91 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=57 time=2.67 ms
^C
--- 8.8.8.8 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6008ms
rtt min/avg/max/mdev = 2.014/2.556/2.998/0.358 ms

SI l'un d'entre vous a une piste, je suis toujours preneur ! par avance, merci.

Hors ligne

#5 Le 26/04/2017, à 07:17

xubu1957

Re : Problème accès Internet par câble

Bonjour,

C'est pas en lien avec ce bug : launchpad.net/ubuntu/+source/thermald/+bug/1682637 ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

Hors ligne

#6 Le 26/04/2017, à 08:15

Mirala

Re : Problème accès Internet par câble

Bonjour xubu1957,

Je viens de passer de mon adresse statique à une configuration en dhcp et ça marche mais ça n'est sur le fond pas très satisfaisant. Je vais examiner le lien que vous m'avez indiqué.

Merci beaucoup.

Hors ligne

#7 Le 26/04/2017, à 08:48

Mirala

Re : Problème accès Internet par câble

Étant toujours en recherche d'une connexion filaire mais avec adresse statique, j'ai lancé la commande suivante :

alain@ALAIN-PC:~$ sudo ethtool -i eth0

Elle donne :

driver: r8169
version: 2.3LK-NAPI
firmware-version: rtl8168g-2_0.0.1 02/06/13
expansion-rom-version: 
bus-info: 0000:03:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

Sur le forum j'ai vu que le driver r8168 semblait marcher, je vais essayer cette modif.
Bonne journée.

Hors ligne

#8 Le 28/04/2017, à 23:27

J5012

Re : Problème accès Internet par câble

@mirala : l'adresse statique ne conditionne pas le fonctionnement de l'interface eth0 ...

pourquoi parles-tu toujours de filaire ? eth0 est filaire ...

si tu veux une ip statique, c'est à toi de la definir manuellement , soit avec l'application network manager, soit dans un fichier de configuration ... voir la doc ...
https://doc.ubuntu-fr.org/network-manager

Hors ligne

#9 Le 03/05/2017, à 08:25

Mirala

Re : Problème accès Internet par câble

Après installation du driver r8168, je n'accède plus à Internet avec le câble (que je définisse une IP statique ou en dhcp). J'y accède seulement avec le WIFI. Je pense que ce driver est peut-être adapté pour les distributions SUSE mais pas sur Debian ou Ubuntu. Avez-vous des infos sur ce driver ? Par avance, merci.

Hors ligne

#10 Le 03/05/2017, à 23:04

J5012

Re : Problème accès Internet par câble

ton precedent retour de ifconfig montrait que l'interface eth0 fonctionnait bien ...
certains ordi ne sont pas capables d'utiliser simultanement 2 interfaces reseaux dues aux choix commerciaux de certains oem ...

si tu coupes le wifi, eth0 ne prend pas la releve automatiquement ? → si network manager gere les interfaces reseaux et qu'il ne reconnait pas eth0 (ce qui serait bizarre puisque ifconfig le voit), il le montrerait ...

si network manager ne gere pas les interfaces reseaux alors c'est normal ... et c'est toi qui doit activer l'interface eth0 et demander l'allocation dhcp ...

Hors ligne

#11 Le 04/05/2017, à 07:16

Mirala

Re : Problème accès Internet par câble

@ J5012
Merci pour ton aide. Les deux interfaces réseaux fonctionnaient depuis l'achat de ce mini PC et l'installation d'Ubuntu en janvier 2016. Pour répondre à ta question, si je coupe le WIFI, eth0 ne prend pas la relève et ne peut pas la prendre puisque il n'apparait plus en lançant ifconfig. D'autres post sur le forum évoquent le driver de la carte réseau qui pose problème lors d'un changement de kernel.
Je continue à chercher sur les forum en anglais !

Hors ligne

#12 Le 04/05/2017, à 12:53

J5012

Re : Problème accès Internet par câble

comment coupes-tu le wifi ?

si le wifi et eth0 sont sur la meme puce, il est techniquement acceptable et logique que la coupure de l'un coupe l'autre ...

Hors ligne

#13 Le 06/05/2017, à 19:51

Mirala

Re : Problème accès Internet par câble

Je pense avoir deux puces. J'avais les deux accès et pouvait passer de l'un à l'autre depuis un an. D'autre part, j'ai pu lancer un liveCD d'UBUNTU et me connecter sur Internet sur eth0. Je pense comme le notent beaucoup de posts qu'il s'agit du driver (module) du circuit RealTek. Merci ++.

Hors ligne

#14 Le 07/05/2017, à 17:06

zilglo

Re : Problème accès Internet par câble

Bonsoir,
J'ai eu le même soucis régler par l'une ou l'autre des deux soluces ci-dessous (trouvé sur le net ... )
J'ai ajouté dans le fichier /etc/network/interfaces
auto eth0
iface eth0 inet dhcp
et c'est bon !
Ou bien avec la commande :
sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

Hors ligne

#15 Le 12/05/2017, à 12:34

Mirala

Re : Problème accès Internet par câble

@ zilglo,
Je n'étais pas disponible pour répondre à ta proposition rapidement. Cette solution je l'ai effectuée (cf. mon post du 26 avril). Après c'est la config en dhcp qui ne marchait plus. J'ai tout réinstallé (la 16.04) et tout remarche. Comprends qui peut ! Merci encore.

Hors ligne