Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 07/05/2017, à 17:01

nco7

[Résolu]Session xfce et session xubuntu

Bonjour à tous !

J'ai un petit soucis, le bouton "paramètres sonores" de l'indicateur ne fonctionne plus. Avant, il ouvrait la fenêtre pulseaudio mais maintenant il ne fait rien. Par contre, quand je lance directement pulseaudio par la méthode graphique ("Contrôle de volume PulseAudio") ça marche !
En mode console, quand je tape pulseaudio dans la console j'ai ceci:

pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Échec de pa_pid_file_create().

en root j'ai ceci :

sudo pulseaudio
W: [pulseaudio] main.c: Le programme n'est pas conçu pour être lancé en tant que root (sauf si --system est renseigné).
E: [pulseaudio] core-util.c: Home directory not accessible: Permission non accordée

Après investigations, j'ai compris que cela venait du fait que j'étais en session xfce et non xubuntu, grâce à ce post :
https://askubuntu.com/questions/712201/ … s-not-open
Il y aurait un soucis dans le code de l'indicateur.
Je n'ai aucune idée de ce qui m'a fait changer de session. Le problème maintenant c'est que je ne peux pas changer de session, quand je me log avec lightdm, en haut je peux cliquer sur le bouton session mais j'ai qu'un seul choix : xfce session.

Help big_smile

edit: le son marche très bien, seulement le bouton qui ne marche pas

Dernière modification par nco7 (Le 22/05/2017, à 01:08)

Hors ligne

#2 Le 12/05/2017, à 18:46

Bruno Letat

Re : [Résolu]Session xfce et session xubuntu

Bonjour,

c'est un bug dans pulseaudio qui ne prend pas correctement en compte xfce mais ça se contourne. Il faut lui faire croire qu'on est en xubuntu.
La technique, c'est de faire un

export DESKTOP_SESSION="xubuntu"

Ensuite tu te déconnectes puis tu te reconnectes en choissant au préalable la session xubuntu qui vient d'apparaitre ! Comme dans les deux cas, ça reste un environnement graphique xfce, ça ne plantera pas au démarrage.
Après cela, tu devrais avoir accès aux options "paramètres sonores" de pulseaudio.
Pour plus de sécurité, quand tu auras fini, tu peux revenir en mode xfce en faisant

export DESKTOP_SESSION="xfce"

puis déconnexion/reconnexion en choisissant la session xfce.
C'est un peu lourd mais ça doit fonctionner.

A bientôt,
Bruno

Dernière modification par Bruno Letat (Le 12/05/2017, à 18:47)

Hors ligne

#3 Le 16/05/2017, à 10:05

nco7

Re : [Résolu]Session xfce et session xubuntu

Salut, merci pour ta réponse.
Ta manip n'a pas fonctionné sad

Hors ligne

#4 Le 16/05/2017, à 14:20

Bruno Letat

Re : [Résolu]Session xfce et session xubuntu

Sur mon poste (xubuntu), ça a fonctionné. quand je fais le export avec "xfce", je me déconnecte et reconnecte avec la session xfce et j'ai le même problème que toi. Puis quand je refais export avec "xubutu", que je me déconnecte et reconnecte avec la session xubuntu, ça fonctionne.
Je vais te poser une question stupide : as-tu bien changé de session à chaque fois ?
Quand tu fais export DESKTOP_SESSION="xubuntu" et qu'en suite, tu fais echo $DESKTOP_SESSION  est-ce qu'il te dit bien "xubuntu" en réponse ?

A bientôt,
Bruno

Hors ligne

#5 Le 22/05/2017, à 01:07

nco7

Re : [Résolu]Session xfce et session xubuntu

J'ai résolu mon soucis en réinstallant xubuntu-desktop.
Merci pour ton temps

Hors ligne

#6 Le 23/05/2017, à 09:07

Bruno Letat

Re : [Résolu]Session xfce et session xubuntu

Pas de souci, je pensais qu'une simple modification allait suffire mais finalement une installation complète de l'environnement xubuntu s'est imposée !
Bonne journée.
Bruno

Hors ligne