Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 19/05/2017, à 14:24

Purdey

apparmor me bloque dnsmasq

Bonjour à tous,

Après une dist-upgrade de 14.04 à 16.04, je me retrouve avec un problème de dns. Aucun nom n'est résolu sur ma bécane. Dans les logs, il y a apparmor qui bloque dnsmasq. J'ai ce message (recopié à la mano) :

...apparmor "allowed" operation "connect" info="Failed name lookup - disconnected path" error=-13 profile="/usr/sbin/dnsmasq" ... etc...

Je comprends pas ce que je peux faire avec apparmor et pourquoi dnsmasq lui pose un soucis.
Un avis? Merci par avance!

Hors ligne

#2 Le 19/05/2017, à 15:24

Purdey

Re : apparmor me bloque dnsmasq

Ben, je me réponds à moi même...
En fait apparmor et les profils d'application n'ont pas été mis à jour pendant la dist-upgrade. Hors il y a un bug dans apparmor notamment pour dnsmasq, cups, et quelques autres, bug qui devient bloquant avec le noyau utilisé sur la 16.04. Donc au reboot, plus de résolution de nom.
Du coup j'ai fait :

sudo aa-disabled dnsmasq
# dnsmasq n'est plus bloqué par apparmor
# mise à jour du system
sudo apt-get update && apt-get upgrade
# apparmor et les profils d'application sont mis à jour
sudo aa-complain dnsmasq

smile

Hors ligne

#3 Hier à 12:10

LeoMajor

Re : apparmor me bloque dnsmasq

bonjour,

c'est un peu le grand écart côté migration 14.04 -> 16.04

supprimer, purger apparmor, provisoirement. Attention aux  résidus de configuration des profiles apparmor
désactiver apparmor, provisoirement, .

GRUB_CMDLINE_LINUX_DEFAULT="security=\"\" apparmor=0 ..."
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd" 

modules de Sécurité:  Apparmor, SElinux, Tomoyo, LSB ....

pour chromium, qui met longtemps à réagir

chromium-browser --password-store=basic

Je me rappelle plus trop ce que j'ai fait question réseau. regarde la doc de gentoo, archlinux ..

si LVM,  (lvm détecté mais pas activé, ou activé très tardivement)
cat /etc/initramfs-tools/scripts/local-top/90-lvm.conf

#!/bin/sh
#90-lvm.conf  activate
lvm vgchange -ay

sinon 3 minutes d'attente au boot.

sudo update-initramfs -u -k $(uname -r)
sudo update-grub

Hors ligne