Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 13/05/2017, à 21:37

winux

[RÉSOLU] Problème de connexion LAN

Bonsoir

J'ai un Pb avec l'ajout d'un 3e PC (PC3) dans mon réseau

Constitution du réseau
PC1  /  nom : gerard  / mot de passe : MP1  / smbpasswd :  smb1  /   Ubuntu 17.04
PC2  /  nom : gerard /  mot de passe : MP1  / smbpasswd :  smb1  /   Ubuntu 14.04
PC3  /  nom : N         /  mot de passe : MP3  / smbpasswd  :  smb1  /   Ubuntu 17.04
Nom du réseau : FONTENAY

Les 3 PCs ont tous, au minimum, le bureau en partage réseau
Ils ont tous le même smb.conf (seul "comment = Bureau PCi" est adapté au nom du PC

 [global]

	workgroup = FONTENAY
	server string = 
	dns proxy = no

#### Debugging/Accounting ####

	log file = /var/log/samba/log.%m
	max log size = 1000
	syslog = 0
	panic action = /usr/share/samba/panic-action %d

####### Authentication #######

	security = user
	encrypt passwords = true
	passdb backend = tdbsam
#  obey pam restrictions = yes

	invalid users = root
#	usershare owner only = False

	unix password sync = yes
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

	pam password change = yes
	map to guest = bad user

############ Misc ############

	socket options = TCP_NODELAY
	username map = /etc/samba/smbusers




#======================= Share Definitions =======================

[Bureau]
	comment = Bureau PCi
	path = /home/gerard/Bureau
	browseable = yes
	writeable = yes
	create mask = 0775
	directory mask = 0775
	valid users = gerard

[DATA-GG]
	path = /media/DATA-GG
	browseable = yes
	writeable = yes
	valid users = gerard

[printers]
	comment = All Printers
	browseable = no
	path = /var/spool/samba
	printable = yes
	create mask = 0700

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/printers
;	browseable = yes
;	read only = yes
;	guest ok = no 

Accès vers le bureau distant
depuis PC1 vers PC2 : OK
depuis PC2 vers PC1 : OK

depuis PC3 vers PC1 : OK
depuis PC3 vers PC2 : OK

depuis PC1 ou PC2 vers PC3 :
une fenêtre s'ouvre me demandant un mot de passe
si j’introduis smb1, la fenêtre m'est représentée

1j2joi.png

Je pense qu'on attend de moi que je déverrouille le porte clé, sauf que cette option ne m'est pas proposée.
Y a-t-il un moyen de franchir l'obstacle autrement.

Merci et bonne soirée

Dernière modification par winux (Le 30/05/2017, à 09:10)


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne

#2 Le 14/05/2017, à 21:42

winux

Re : [RÉSOLU] Problème de connexion LAN

Ah les WE ensoleillés ... pas bon pour faire avancer mon schmilblick !!!


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne

#3 Le 16/05/2017, à 11:06

ikoula

Re : [RÉSOLU] Problème de connexion LAN

Bonjour,

Sauf erreur de ma part sur PC3 tu dois avoir un user systeme "gerard" peux tu vérifier ?


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#4 Le 16/05/2017, à 16:39

winux

Re : [RÉSOLU] Problème de connexion LAN

Merci ikoula.
Je suis en province cette semaine.  je regarderai à mon retour et te tiendrai au courant.
@+
Edit : Le nom de pc3 n'est pas gerard .
par contre smbpasswd est bien gerard.
Est ce que ça répond à ta question user system ?


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne

#5 Le 17/05/2017, à 09:42

ikoula

Re : [RÉSOLU] Problème de connexion LAN

Absolument pas, si tu veux te connecter sur PC3 depuis PC1 et PC2 avec le user gerard le compte gerard doit exister sur PC3.


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#6 Le 17/05/2017, à 15:49

winux

Re : [RÉSOLU] Problème de connexion LAN

Merci pour cette précision Ikoula
Petite question : suffit-il de créer sur pc3 un nouvel usager gerard,  sans rien de plus ?
Faut-il que son password de connexion soit le même que celui de smbpasswd ou est ce complètement indépendant ?
Merci et bonne soirée

Dernière modification par winux (Le 17/05/2017, à 15:49)


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne

#7 Le 18/05/2017, à 11:02

ikoula

Re : [RÉSOLU] Problème de connexion LAN

Si tu veux te connecter avec gerard sans entrer de mdp tu dois mettre le même partout.


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#8 Le 18/05/2017, à 13:14

winux

Re : [RÉSOLU] Problème de connexion LAN

salut ikouila

Ca y est je suis rentré à la maison. J'ai parcouru la doc Ubuntu

1- J'ai d'abord trouvé ceci pour gérer le user gerard sur pc3 en mode graphique
https://doc.ubuntu-fr.org/users-admin
j'ai bien installé gnome-system-tools avec synaptic
mais comme l'indique la doc, lorsque j'ai recherché Utilisateurs et groupes
je n'ai trouvé que comptes utilisateurs qu'on trouve aussi dans les paramètres et qui ne permet pas d'introduire un mot de passe

2- comme ça n'allait pas, j'ai cherché ailleurs et trouvé ceci
https://doc.ubuntu-fr.org/adduser
qui me permet d'introduire un user et son password en mode console, ce que j'ai fait
  - user=gerard
  - pass= le même que gerard sur pc1-pc2 et smbpasswd
par sécurité je reboote

3- je veux ensuite me connecter depuis pc1 à pc3
pareil que d'habitude
j'ai beau entrer gerard et le bon password, pas de connexion

4- dernier essai, j'ouvre pc3 non pas avec le nom pris à l'installe (donc admin et avec un mot de passe différent), mais avec gerard que je viens de créer : pareil

Je suis un peu coincé, il ne manque sûrement pas grand chose et ton aide serait précieuse
Merci d'avance et @+

Dernière modification par winux (Le 18/05/2017, à 13:15)


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne

#9 Le 19/05/2017, à 10:31

ikoula

Re : [RÉSOLU] Problème de connexion LAN

Bonjour,

Si tu as bien crée le compte gerard avec la commande adduser sur PC3 tu dois pouvoir sur PC3 ouvrir une session locale avec le user gerard, est ce que ça déjà ça fonctionne ?
Si non le user gerard est peut-être mal crée sur PC3 ce qui expliquerait que la connexion PC1 --> PC3 ne fonctionne pas.


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#10 Le 19/05/2017, à 15:34

winux

Re : [RÉSOLU] Problème de connexion LAN

Hello

Eh oui j'ouvre bien la session sous gerard qui a le même mot de passe que smbpasswd, mais no change.

20q101t.jpg

Néanmoins d'un point de vue théorique il y a une chose qui me chagrine. Le principe d'un réseau c'est quand même que user1 puisse accéder à user2 avec le mot de passe réseau commun, sinon je ne comprends pas bien l'intérêt ????
Il doit y avoir autre chose qui coince dans smb.conf, mais quoi ?

Dernière modification par winux (Le 19/05/2017, à 15:38)


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne

#11 Le 22/05/2017, à 11:01

ikoula

Re : [RÉSOLU] Problème de connexion LAN

Bonjour,

Peut être une histoire de ports.
Peux tu faire la commande:
#netstat -ano
sur les trois machines et regarder si tu as la même chose ?
Tu peux aussi comparer les règles (si firewall il y a) avec la commande:
#iptables -L


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#12 Le 30/05/2017, à 09:09

winux

Re : [RÉSOLU] Problème de connexion LAN

Salut Ikoula

Me voici de retour de mon petit voyage.
Il semblerait que tout marche ... à peu près, depuis que :
j'ai rajouté gerard dans la machine qui ne l’avait pas
remis sudo smbpasswd -a gerard sur toutes les machines et sur les 2 utilisateurs de la dernière machine

A peu près ... car :
des fois ça se passe bien et dans tous les sens, des fois pas
en effet il faut parfois un certain temps après l'ouverture d'un PC pour que le réseau se mette en route ???

POUR MOI L'IDEAL SERAIT :
dans la mesure où mes 3 PC sont en Ubuntu
d'avoir un réseau purement Linux, sans samba (si c'est possible) et facile à mettre en oeuvre.
Je n'ai pas trouvé de docs claires sur le sujet, peut-être as-tu un lien qui pourrait m'aider.

Sinon, je ferai avec ce que j'ai : samba !!

Quoi qu'il en soit, merci pour ton aide tout au long de ce post. Je vais mettre résolu, même si pas parfait
Bonne journée


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 280 Mbps utiles -  Triple  boot : Ubuntu 16.04 & 17.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD : 1To chacun

Hors ligne