Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#2051 Le 14/01/2017, à 19:22

michcauch

Re : Script d'installation pour imprimantes Brother

Merci pour ton aide,
mais j'ai déjà tout essayé bien aidé déjà sur un autre fil (celui-là)


Cordialement
Michel
___
Ubuntu 14.04.3 sur Lenovo ThinkPad Edge E320 et Xubuntu 16.04 sur Ordinateur de bureau Materiel.net Elite (Processeur Intel Core i3 6100, Intel HD Graphics, SSD 120 Go, 4 Go DDR4)

Hors ligne

#2052 Le 21/01/2017, à 16:26

lagrifolle

Re : Script d'installation pour imprimantes Brother

Bon, je retire ce que j'ai dit. C'est vraiment galère, j'arrive à scanner, mais Xsane plante de plus en plus souvent. Une des fenêtres s'est fermée à jamais.
Et l'impression est de très mauvaise qualité.
"Tu m'as décu Brother !"

Hors ligne

#2053 Le 21/01/2017, à 16:45

L_d_v_c@

Re : Script d'installation pour imprimantes Brother

lagrifolle a écrit :

Bon, je retire ce que j'ai dit. C'est vraiment galère, j'arrive à scanner, mais Xsane plante de plus en plus souvent. Une des fenêtres s'est fermée à jamais.
Et l'impression est de très mauvaise qualité.
"Tu m'as décu Brother !"

Pour l'impression, voir :
https://doc.ubuntu-fr.org/imprimantes_brother
et
http://support.brother.com/g/s/id/linux … edirect=on
(imprimante CUPS)

Mais ce qui semble fonctionner le mieux est : Driver Install Tool (Brother)


Pourquoi GNU/Linux
Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#2054 Le 22/01/2017, à 00:25

lefrenchwestisland

Re : Script d'installation pour imprimantes Brother

bon jour je suis novice sur Ubuntu j'ai bien rendu le fichier en cliquant exécutable mais quand je saisi
sudo ./instal....

J'ai un message d'erreur Veuillez activer le dépôt universe puis relancez le script.

alors que le dépôt est bien activé (je suis en 64 bits)

un indice ?


compte supprimé a écrit :

Salut,
Pour la commande chmod +x install.sh en peut l’enlever en rend le fichier exécutable avec le clic droit + propriétés + permission   

wget http://demonipuch.free.fr/brother.tar.gz
tar zxvf brother.tar.gz
cd brother
sudo ./install.sh

Hors ligne

#2055 Le 01/02/2017, à 17:20

xunil2003

Re : Script d'installation pour imprimantes Brother

Bonjour,

Je suis sur Kubuntu 14.04 X64
mon imprimante est une Brother MFC-9140CDN
J'ai téléchargé votre script Brother ici :
http://demonipuch.free.fr/brother.tar.gz
Mais mon imprimante ne figure pas dans le choix d'installation de model proposé.

Pouvez-vous m'aider ?

J'ai suivi la page conseil de brother :
http://support.brother.com/g/b/download … &type3=561
Dépendance :
http://support.brother.com/g/s/id/linux … ect=on#004
Mais l'installation plante

Installation des dépendances :

laurent@cercle-amd:~$ sudo apt-get install ia32-libs lib32stdc++ sane-utils
[sudo] password for laurent: 
Unknown parameter encountered: "encrypt password"
Ignoring unknown parameter "encrypt password"
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de lib32stdc++6-4.4-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6 pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.5-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++-4.8-dev pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.0-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.6-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.1-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.7-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.7-dev pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.2-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.8-dbg pour l'expression rationnelle « lib32stdc+ »
Note : sélection de lib32stdc++6-4.3-dbg pour l'expression rationnelle « lib32stdc+ »
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
laurent@cercle-amd:~$ 

Téléchargement du pilote :

laurent@cercle-amd:~$ wget http://download.brother.com/welcome/dlf100407/mfc9140cdncupswrapper-1.1.4-0.i386.deb
--2017-02-01 16:34:18--  http://download.brother.com/welcome/dlf100407/mfc9140cdncupswrapper-1.1.4-0.i386.deb
Résolution de download.brother.com (download.brother.com)… 104.93.206.30
Connexion à download.brother.com (download.brother.com)|104.93.206.30|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 13594 (13K) [image/x-deb]
Enregistre : «mfc9140cdncupswrapper-1.1.4-0.i386.deb.1»

100%[=================================================================================================================================================================>] 13 594      --.-K/s   ds 0,001s  

2017-02-01 16:34:18 (12,7 MB/s) - «mfc9140cdncupswrapper-1.1.4-0.i386.deb.1» enregistré [13594/13594]

Installation du pilote :
laurent@cercle-amd:~$ 
laurent@cercle-amd:~$ sudo dpkg  -i  --force-all mfc9140cdncupswrapper-1.1.4-0.i386.deb
(Lecture de la base de données... 250799 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de mfc9140cdncupswrapper-1.1.4-0.i386.deb ...
Dépaquetage de mfc9140cdncupswrapper (1.1.4-0) sur (1.1.4-0) ...
dpkg: mfc9140cdncupswrapper : problèmes de dépendances, mais configuration comme demandé :
 mfc9140cdncupswrapper dépend de mfc9140cdnlpr.

Paramétrage de mfc9140cdncupswrapper (1.1.4-0) ...
ERROR : Brother LPD filter is not installed.
cups stop/waiting
cups start/running, process 7478
lpadmin -p MFC9140CDN -E -v dnssd://Brother%20MFC-9140CDN._ipp._tcp.local/ -P /usr/share/cups/model/Brother/brother_mfc9140cdn_printer_en.ppd
laurent@cercle-amd:~$ 

Vérification :

laurent@cercle-amd:~$ dpkg -l | grep Brother
ii  brmfcfaxcups                              1.0.0-2                                             i386         Brother MFC/FAX fax share function driver
ii  brmfcfaxlpd                               1.0.0-2                                             i386         Brother MFC-FAX LPD driver
ii  brscan-skey                               0.2.4-1                                             amd64        Brother Linux scanner S-KEY tool
ii  brscan4                                   0.4.4-1                                             amd64        Brother Scanner Driver
ii  mfc9140cdncupswrapper                     1.1.4-0                                             i386         Brother CUPS Laser Printer Definitions
ii  printer-driver-ptouch                     1.3-8                                               amd64        printer driver Brother P-touch label printers
laurent@cercle-amd:~$
laurent@cercle-amd:~$ lpinfo -m | grep brother
gutenprint.5.2://brother-dcp-1200/expert Brother DCP-1200 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-dcp-8045d/expert Brother DCP-8045D - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-4ve/expert Brother HL-4Ve - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-10h/expert Brother HL-10h - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-10v/expert Brother HL-10V - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-630/expert Brother HL-630 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-660/expert Brother HL-660 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-760/expert Brother HL-760 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-960/expert Brother HL-960 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1040/expert Brother HL-1040 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1050/expert Brother HL-1050 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1060/expert Brother HL-1060 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1070/expert Brother HL-1070 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1240/expert Brother HL-1240 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1250/expert Brother HL-1250 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1260/expert Brother HL-1260 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1270n/expert Brother HL-1270N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1430/expert Brother HL-1430 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1440/expert Brother HL-1440 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1450/expert Brother HL-1450 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1470n/expert Brother HL-1470N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1650/expert Brother HL-1650 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1660e/expert Brother HL-1660e - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1670n/expert Brother HL-1670N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1850/expert Brother HL-1850 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-1870n/expert Brother HL-1870N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-2030/expert Brother HL-2030 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-2035/expert Brother HL-2035 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-2060/expert Brother HL-2060 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-2460/expert Brother HL-2460 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-2460n/expert Brother HL-2460N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5030/expert Brother HL-5030 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5040/expert Brother HL-5040 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5050/expert Brother HL-5050 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5070n/expert Brother HL-5070N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5140/expert Brother HL-5140 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5150d/expert Brother HL-5150D - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-5170dn/expert Brother HL-5170DN - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-7050/expert Brother HL-7050 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-hl-7050n/expert Brother HL-7050N - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-mfc-6550mc/expert Brother MFC-6550MC - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-mfc-8300/expert Brother MFC-8300 - CUPS+Gutenprint v5.2.10-pre2
Brother/brother_mfc9140cdn_printer_en.ppd Brother MFC-9140CDN CUPS
lsb/usr/Brother/brother_mfc9140cdn_printer_en.ppd Brother MFC-9140CDN CUPS
gutenprint.5.2://brother-mfc-9500/expert Brother MFC-9500 - CUPS+Gutenprint v5.2.10-pre2
gutenprint.5.2://brother-mfc-9600/expert Brother MFC-9600 - CUPS+Gutenprint v5.2.10-pre2
laurent@cercle-amd:~$ 

Pour imprimer un fichier txt en réseau depuis la console bash, quel commande faut-il taper ?

Merci

Dernière modification par xunil2003 (Le 02/02/2017, à 09:51)


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#2056 Le 03/02/2017, à 17:36

giacou

Re : Script d'installation pour imprimantes Brother

bonjour
j'ai essayé le tuto ça fonctionne uniquement jusqu'à l'extraction de l'archive après je n'arrive pas à me placer dans le dossier brother "cd brother" commande introuvable. Un autre problème est survenu, non seulement l'imprimante n'imprime pas lorsque je lui demande mais imprime d'elle-même automatiquement tous les fichiers de l'ordi. Franchement je ne sais plus quoi faire et j'ai bien envie de tout laisser tomber.  cordialement giacou

Hors ligne

#2057 Le 06/02/2017, à 21:58

hophophop

Re : Script d'installation pour imprimantes Brother

Alors là bravo pour le script qui introduit ce fil de discussion

Parfait novice, j'ai lutté des heures, en vain, pour installer mon imprimante Brother MFC-7420 en suivant les tuto du forum et là, je suis bêtement les instructions et tout se met en place sans l'ombre d'un obstacle.

Merci Demonipuch !

Hors ligne

#2058 Le 06/02/2017, à 22:27

giacou

Re : Script d'installation pour imprimantes Brother

je suis content pour vous mais ça ne résout pas mon problème
cordialement

Hors ligne

#2059 Le 07/02/2017, à 13:45

VictoRiseUp

Re : Script d'installation pour imprimantes Brother

Merci beaucoup demonipuch ça fonctionne bien sur une Brother DCP-J152W.

Pour faire fonctionner le scanner (cf doc' Brother Ubuntu ) :
Sur Ubuntu 16.10 il manque 2 fichiers à installer sans quoi scanner ne sera pas reconnu.

sudo apt-get install libusb-0.1-4 libusb-0.1-4:i386

Sur la version 64bits il faudra également ajouter un lien symbolique pour les bibliothèques de sane :

sudo ln -s /usr/lib64/sane /usr/lib/sane

Hors ligne

#2060 Le 07/02/2017, à 14:24

L_d_v_c@

Re : Script d'installation pour imprimantes Brother

Bonjour !

VictoRiseUp a écrit :

Merci beaucoup demonipuch ça fonctionne bien sur une Brother DCP-J152W.

Pour faire fonctionner le scanner (cf doc' Brother Ubuntu ) :
Sur Ubuntu 16.10 il manque 2 fichiers à installer sans quoi scanner ne sera pas reconnu.

sudo apt-get install libusb-0.1-4 libusb-0.1-4:i386

Bon, les dépendances, ça peut se comprendre. En espérant que ces fichiers soient ajoutés dans les dépendances lors des mises à jour.

VictoRiseUp a écrit :

Sur la version 64bits il faudra également ajouter un lien symbolique pour les bibliothèques de sane :

sudo ln -s /usr/lib64/sane /usr/lib/sane

Pourquoi faut-il faire cette manipulation manuellement ?
Quelqu'un peut-il contacter l'équipe de sane pour leur faire ajouter cette ligne à l'installation de sane sur architecture AMD/Intel en 64 bits, s'il-vous-plaît ?

Je ne suis pas passé par le script de demonipuch récemment pour installer l'imprimante HL4040CN sur Ubuntu 16.04 en PC64 bits, mais par la procédure indiqué sur le site de BROTHER, comme indiqué dans un message précédent, et je remarque que deux paquets gérant l'impression sont à surveiller :

$ ubuntu-support-status --show-unsupported
Résumé de l'état du support de « ubuntu-64 » :

Vous avez 1867 paquets (83.1%) pris en charge jusqu'à avril 2021 (5y)
Vous avez 250 paquets (11.1%) pris en charge jusqu'à avril 2019 (3y)
Vous avez 15 paquets (0.7%) pris en charge jusqu'à février 2022 (5y)

Vous avez 3 paquets (0.1%) qui ne peuvent pas ou plus être téléchargés
Vous avez 113 paquets (5.0%) qui ne sont pas pris en charge

Ne sont plus téléchargeables :
hl4040cncupswrapper:i386 hl4040cnlpr:i386 xnview 

Non pris en charge : 
…

Pour l'instant, l'impression de plusieurs dizaines de feuilles, fonctionne normalement, sans faire des pauses d'une minute entre chaque page (problème rencontré par le passé).

L'imprimante a ses 64 Mio de RAM intégrée + une barrette d'occasion de 256 Mio (qui avait amélioré la rapidité d'impressions multi-pages).

Dernière modification par L_d_v_c@ (Le 07/02/2017, à 14:29)


Pourquoi GNU/Linux
Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#2061 Le 05/03/2017, à 00:24

Davduf

Re : Script d'installation pour imprimantes Brother

Bonjour à tous.

Je possede une DCP-L2520DW
J'ai installé le pilote directement depuis le site Brother. Super.
Puis le scan. Super.
Sauf que l'imprimante ne marche plus.

Comment faire pour tout supprimer et réinstaller ?

Voici mes messages d'erreur:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lib32ncurses5 lib32z1

E: Le paquet « ia32-libs » n'a pas de version susceptible d'être installée
dpkg -x dcpl2520dwlpr-3.2.0-1.i386.deb /
dpkg -x dcpl2520dwcupswrapper-3.2.0-1.i386.deb /
dpkg-deb: building package 'dcpl2520dwlpr' in 'dcpl2520dwlpr-3.2.0-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcpl2520dwlpr-3.2.0-1a.i386.deb
dpkg-deb: building package 'dcpl2520dwcupswrapper' in 'dcpl2520dwcupswrapper-3.2.0-1a.i386.deb'.
dpkg -b ./brother_driver_packdir dcpl2520dwcupswrapper-3.2.0-1a.i386.deb
dpkg -i --force-all dcpl2520dwlpr-3.2.0-1a.i386.deb
Sélection du paquet dcpl2520dwlpr:i386 précédemment désélectionné.
(Lecture de la base de données... 224040 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcpl2520dwlpr-3.2.0-1a.i386.deb ...
Dépaquetage de dcpl2520dwlpr:i386 (3.2.0-1) ...
Paramétrage de dcpl2520dwlpr:i386 (3.2.0-1) ...
dpkg -i --force-all dcpl2520dwcupswrapper-3.2.0-1a.i386.deb
Sélection du paquet dcpl2520dwcupswrapper:i386 précédemment désélectionné.
(Lecture de la base de données... 224058 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de dcpl2520dwcupswrapper-3.2.0-1a.i386.deb ...
Dépaquetage de dcpl2520dwcupswrapper:i386 (3.2.0-1) ...
Paramétrage de dcpl2520dwcupswrapper:i386 (3.2.0-1) ...
lpinfo: L’exécution de « cups-deviced » a échoué.
lpadmin -p DCPL2520DW -E -v usb://dev/usb/lp0 -P /usr/share/ppd/brother/brother-DCPL2520DW-cups-en.ppd
lpadmin: Bad device-uri scheme "usb".
###############################ls: impossible d'accéder à '/usr/share/ppd/*.ppd': Aucun fichier ou dossier de ce type
#
lpinfo: L’exécution de « cups-deviced » a échoué.

0 (I): Specify IP address.
1 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->1

lpadmin -p DCPL2520DW -v usb://dev/usblp0 -E -P /usr/share/cups/model/brother-DCPL2520DW-cups-en.ppd
lpadmin: Bad device-uri scheme "usb".
Test Print? [y/N] ->y

wait 5s.
echo DCPL2520DW \| lpr  -P DCPL2520DW
You are going to install following packages.
   brscan4-0.4.4-1.amd64.deb
dpkg -i --force-all brscan4-0.4.4-1.amd64.deb
Sélection du paquet brscan4 précédemment désélectionné.
(Lecture de la base de données... 224063 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de brscan4-0.4.4-1.amd64.deb ...
Dépaquetage de brscan4 (0.4.4-1) ...
Paramétrage de brscan4 (0.4.4-1) ...
This software is based in part on the work of the Independent JPEG Group.
You are going to install following packages.
   brscan-skey-0.2.4-1.amd64.deb
dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
Sélection du paquet brscan-skey précédemment désélectionné.
(Lecture de la base de données... 224100 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de brscan-skey-0.2.4-1.amd64.deb ...
Dépaquetage de brscan-skey (0.2.4-1) ...
Paramétrage de brscan-skey (0.2.4-1) ...

Un peu de (grande) aide ne serait pas de refus :-)
Merci !!!


Ubuntu 16.10 - Gnome 3.20 - Kernel 4.8.0-40-generic -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-ubuntu-+

Hors ligne

#2062 Le 05/03/2017, à 13:23

Davduf

Re : Script d'installation pour imprimantes Brother

En réinstallant Cups, les choses semblent meiux marcher :-)


Ubuntu 16.10 - Gnome 3.20 - Kernel 4.8.0-40-generic -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-ubuntu-+

Hors ligne

#2063 Le 10/03/2017, à 22:25

mdp-linux

Re : Script d'installation pour imprimantes Brother

Hello Demonipuch,

bien content d'avoir trouvé ton script, et pour l'info il fonctionne toujours super bien!!!

suite aux problèmes d'installation d'une Brother HL-L2300D j'ai repris ton script, suivi les instructions,
j'ai du prendre un type inférieur à la 2300 ce qui ne permet pas l'utiilisation de toutes les options
comme le recto/verso, mais bon je ferai sans en attendant le driver spécifique...

Merci beaucoup

Un pauvre utilisateur souvent perdu ;o)

Michel

Hors ligne

#2064 Le 17/03/2017, à 12:38

jyb44

Re : Script d'installation pour imprimantes Brother

Super script pour un nul comme moi
j'ai une imprimante DCP 195C que j'avais installée sur ma freebox, mais après une mise à niveau elle ne voulait rien savoir.
j'ai exécuté le script magique, mais je coince sur l'adresse ip de l'imprimante.
j'ai entré l'adresse de ma freebox mais ça ne marche pô...
comment trouver l'ip de mon imprimante lorsqu'elle est connectée sur ma box ?

j'ai quand même réussi à faire fonctionner l'imprimante en ré-exécutant le script. et en choisissant l'option USB, mais je préférerai le faire en réseau.

encore bravo


chaque connerie que je fais m'apprend quelque chose, j'en apprends tous les jours, et j'en ai encore beaucoup à apprendre

Hors ligne

#2065 Le 17/03/2017, à 15:40

giacou

Re : Script d'installation pour imprimantes Brother

bonjour

moi j'ai réglé mes problèmes d'imprimante brother en téléchargeant l'appli ubuntu  "imprimantes" qui se trouve dans les logiciels ubuntu.C'est très simple et ne prend que quelques minutes. Bonne chance

Hors ligne

#2066 Le 17/03/2017, à 16:23

Ayral

Re : Script d'installation pour imprimantes Brother

giacou a écrit :

bonjour

moi j'ai réglé mes problèmes d'imprimante brother en téléchargeant l'appli ubuntu  "imprimantes" qui se trouve dans les logiciels ubuntu.C'est très simple et ne prend que quelques minutes. Bonne chance

Il me semble que cette application est installée par défaut.


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#2067 Le 17/03/2017, à 16:33

giacou

Re : Script d'installation pour imprimantes Brother

c'est possible mais elle est bien pratique

Hors ligne

#2068 Le 23/03/2017, à 23:02

azafranero

Re : Script d'installation pour imprimantes Brother

Bonsoir

Un jeune agriculteur de mon entourage a un problème avec cette imprimante  Brother MFC-J5720dw sous Ubuntu 16.04 Mate

L'imprimante n'est pas reconnue par le script demonipuch

L'imprimante est reconnue avec les pilotes propriétaires de Brother et fonctionne recto-verso avec des documents odt mais la fonction recto-verso est absente pour les documents pdf

Le scanner est opérationnel

Avez-vous une piste ?

Merci

Hors ligne

#2069 Le 04/04/2017, à 13:40

newlinuxman

Re : Script d'installation pour imprimantes Brother

Bonjour;

J'essaye d'installer une imprimante Bother MFC J480 DW sur monPC qui tourne sous Ubuntu 16.04 LTS.

Je parviens à Scanner.
Mais je ne parviens pas à imprimer alors que mon imprimante apparait bien dans le dossier Imprimante.

Quelqu'un pourrait-il m'aider à résoudre ce problème ?

Hors ligne

#2070 Le 05/04/2017, à 11:00

Anard

Re : Script d'installation pour imprimantes Brother

Bonjour,

Sous Ubuntu 16.10, je veux installer une DCP-195C. J'ai tout essayé : les drivers trouvés sur le site Brother ainsi que le script de Demonipuch mais je ne peux toujours rien scanner.
En revanche, pour les impressions, tout va très bien.
Lorsque j'ouvre l'appli SimpleScan installée par défaut, elle me dit qu'il manque des pilotes et me renvoie sur le site de téléchargement de Brother.
Si je tente malgré tout de lancer un scan, la connexion à l'imprimante est impossible et évidemment, si j'essaie de scanner directement depuis les boutons qui se trouvent sur l'imprimante, elle affiche "Connexion PC" et rien ne se passe...

Pourriez-vous m'aider à faire fonctionner ce satané scanner ?
Merci infiniment.

PS : j'ai également essayé en VM sur 16.04 avec le même résultat

EDIT : Ca y est. J'ai réussi à scanner un document : il faut que j'indique "Text" dans le choix du document à numériser dans SimpleScan. Quelle différence ça fait ? Je n'en sais rien. Si j'indique "Photo", j'ai toujours un message "Echec de la numérisation".
Evidemment, si j'essaie d'utiliser les touches de l'imprimante pour scanner directement vers un document ou vers un mail, l'écran de l'imprimante indique "Connexion PC" et rien ne se passe…
Donc si vous avez des idées pour régler ces problèmes, je suis toujours preneur. Merci beaucoup.

Dernière modification par Anard (Le 05/04/2017, à 12:52)


"iMack" : GA-B85M-D3H, Intel i5 4460, 8Go RAM, Intel HD4600, SSD 128+60Go / Bootloader Clover - macOS Sierra / Ubuntu Artful Aardvark / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go RAM, Radeon X1250, HDD 160Go / Grub2 - Xubuntu Xenial Xerus / Windows 10

Hors ligne

#2071 Le 06/04/2017, à 09:55

sinbad83

Re : Script d'installation pour imprimantes Brother

Bonjour Anard,
pour la fonction Scan en 16.10, consulte la doc que j'ai rédigée sur http://www.coursinforev.org/doku.php/im … _lts_64bit

Dernière modification par sinbad83 (Le 06/04/2017, à 09:56)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 17.04 et Ten,   HP Pavillon G6 U16.04 et Ten, Samsung N150 U16.04 et Seven, Serveurs Ubuntu 16.04 et 14.04

Hors ligne

#2072 Le 05/06/2017, à 16:37

cilae1

Re : Script d'installation pour imprimantes Brother

Bonjour,
je viens de changer d'ordinateur  et suis donc en cours d'installation de mon imprimante
j'ai acheté un portable d'occasion préinstallé ubuntu 14.04
mais ne suis pas du tout apte à la littérature des codes informatiques

mon imprimante est une brother DCP J152
j'ai appliqué le protocole démonipuch pour l'installation de la dite imprimante
elle semble installée : elle apparaît dans les menus d'impression... mais  elle n'imprime pas
"Traitement en cours - Waiting for printer to become available." est la seule indication que j'ai sur l'activité de l'imprimante
j'ai vérifié l'activation des dépots universes, redémaré
mais rien
si vous pouviez m'éclairer?

je vous en remercie

cilae

Hors ligne

#2073 Le 05/06/2017, à 17:19

jibel

Re : Script d'installation pour imprimantes Brother

Bonjour,
Normalement vous suivez le tuto de deponimuch a la lettre, soit imprimante branchée ou non...a certains momemt lors de l'installe vous devez brancher votre imprimante, le choix de la marque et de votre modèle va s'afficher, confirmer son installe en USB etc-etc tout devrait être bon, pas a pas, votre printer serait utilisable smile si c'est une 4X1 fonctions ....


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub14.04,VoyagerX2,X8,Debian 8.2, 8,3 , handy-linux 2.2, emma 3 .PC medion akira  DD 1T + 2 .

Hors ligne

#2074 Le 05/06/2017, à 19:59

cilae1

Re : Script d'installation pour imprimantes Brother

Bonjour,
je viens de changer d'ordinateur  et suis donc en cours d'installation de mon imprimante
j'ai acheté un portable d'occasion préinstallé ubuntu 14.04
mais ne suis pas du tout apte à la littérature des codes informatiques

mon imprimante est une brother DCP J152
j'ai appliqué le protocole démonipuch pour l'installation de la dite imprimante
elle semble installée : elle apparaît dans les menus d'impression... mais  elle n'imprime pas
"Traitement en cours - Waiting for printer to become available." est la seule indication que j'ai sur l'activité de l'imprimante
j'ai vérifié l'activation des dépots universes, redémaré
mais rien
si vous pouviez m'éclairer?

je vous en remercie

cilae

Hors ligne

#2075 Le 05/06/2017, à 20:06

cilae1

Re : Script d'installation pour imprimantes Brother

Bonjour,
Normalement vous suivez le tuto de deponimuch à la lettre, soit imprimante branchée ou non...a certains momemt lors de l'installe vous devez brancher votre imprimante, le choix de la marque et de votre modèle va s'afficher, confirmer son installe en USB etc-etc tout devrait être bon, pas a pas, votre printer serait utilisable smile si c'est une 4X1 fonctions ....

je n'ai pas de problème pour effectuer la manip de démonipuch, je l'avais déjà effectuée sur mon ancien ordi sans aucun problème...
mais là l'imprimante apparaît dans les menus d'impression mais quand il s'agit de la tester ou d'imprimer quelque chose c'est comme si l'imprimante ne recevait pas l'information... mystère
je galère là dessus  depuis ce matin...
merci de vos lumières
cilae

Hors ligne