Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#201 Le 26/07/2017, à 10:12

abelthorne

Re : extension non valable

J5012 a écrit :

c'est etonnant ca ? bibitoi74 n'avait-il pas deja reinstallé ubuntu ? ou est-ce le meme que depuis ce post #1 ?

Non, pas encore de réinstallation, bien que je pense que c'est la seule solution.

pourquoi a-t-il besoin de ce ppa padoka pour mesa : sa carte graphique est tellement sophistiquée qu'elle ne peut utiliser la version mesa du depot ?

Mesa évolue beaucoup et régulièrement, la version des dépôts est vite dépassée (oui, même celle des dépôts 17.04). Si on joue sur Linux, notamment avec un GPU AMD, c'est plutôt une bonne idée de mettre à jour Mesa.

si 5 libs coincent apt, il n'aura peut-etre pas le choix : il lui faudra d'abord purger ces 5 libs avec leurs dependances respectives ...

C'est bien le problème : ça fait trois semaines qu'on essaie. Les cinq biblis en question apparaissent en tant que paquets :i386 alors que c'est une distro 32 bits et qu'ils devraient s'afficher sans le suffixe. Et APT n'arrive pas à les gérer.

En ligne

#202 Le 26/07/2017, à 10:28

J5012

Re : extension non valable

avec dpkg ...
http://manpages.ubuntu.com/manpages/zes … pkg.1.html

dpkg -r package --purge

Hors ligne

#203 Le 26/07/2017, à 10:32

abelthorne

Re : extension non valable

Deuxième détail : dans les paquets en question, il y a libdns et bind9. J'ai un peu peur qu'en les supprimant en force, la résolution DNS soit HS et qu'APT ne puisse plus trouver les dépôts pour les réinstaller.

En ligne

#204 Le 26/07/2017, à 11:09

J5012

Re : extension non valable

alors forcer la reintall à partir des depots officiels mais pour ca il faut s'assurer qu'aucun depot externe ne fournisse une version modifiée de ces libs ni aucune de leurs dependances !

tu peux  utiliser apt pour telecharger le paquet au lieu de l'installer ...

ou/et installer avec dpkg -i ... fera desinstaller le paquet ayant une version pre ou post ...

des retours interessants :

dpkg --print-architecture

et

dpkg --print-foreign-architectures

chez moi 64b , c'est amd64 et i386
chez lui 32b , ca devrait etre i386 et rien du tout ...

Hors ligne

#205 Le 26/07/2017, à 16:57

bibitoi74

Re : extension non valable

Bonjour j'ai essayé
dpkg --print-architecture
dpkg --print-foreign-architectures j'ai essayé deux fois
et voici les retours

bussiere@bussiere-P4i65G:~$ dpkg --print-architecture
i386
bussiere@bussiere-P4i65G:~$ dpkg --print-foreign-architectures
bussiere@bussiere-P4i65G:~$ dpkg --print-foreign-architectures
bussiere@bussiere-P4i65G:~$ 

Dernière modification par bibitoi74 (Le 26/07/2017, à 20:45)

Hors ligne

#206 Le 26/07/2017, à 17:08

bibitoi74

Re : extension non valable

Dois je réinstaller ubuntu ou j’attends encore un peu car après tout pour l’instant çà fonctionne.
Merci quand mème pour votre recherche.

Hors ligne

#207 Le 26/07/2017, à 21:37

J5012

Re : extension non valable

bibitoi74 a écrit :

Bonjour j'ai essayé
dpkg --print-architecture
dpkg --print-foreign-architectures j'ai essayé deux fois
et voici les retours

bussiere@bussiere-P4i65G:~$ dpkg --print-architecture
i386
bussiere@bussiere-P4i65G:~$ dpkg --print-foreign-architectures
bussiere@bussiere-P4i65G:~$ dpkg --print-foreign-architectures
bussiere@bussiere-P4i65G:~$ 

c'est donc normal ... et tu n'as pas de problemes avec apt ... le probleme vient des dependances : à un moment donné de tes installations, une dependance d'une des libs en erreur est venue remplacer la dependance officielle, et maintenant que les depots externes ont ete virés sans avoir remis prealablement les bonnes versions officielles, tu es bloqué ...

si tu veux un ubuntu mate qui fonctionne, reinstalle proprement :
→ à savoir une installation minimale + une installation de suite du paquet de paquets ubuntu-mate-desktop

si tu acceptes de rester avec gnome metacity en l'etat, ne reinstalle , mais tu n'auras pas acces aux mises à jour ...

edit : un truc que tu peux faire , fais-toi accompagner :
- utiliser un live cdrom pour avoir le depot temporaire du cdrom pour reinstaller les libs en erreur, en fait surtout les libs qui impactent la connectivité au net que alberthorne craint de ne plus avoir apres desinstallation par dpkg
- desinstaller avec dpkg toutes les libs en erreur et leurs dependances
- reinstaller les composant qui manqueront avec le depot du cdrom ou celui d'un dvd live encore mieux ...
- tu pourras meme utiliser synaptic ...

Dernière modification par J5012 (Le 26/07/2017, à 21:42)

Hors ligne

#208 Le 27/07/2017, à 17:38

bibitoi74

Re : extension non valable

Bonjour
comment faire une installation minimale + une installation de suite du paquet de paquets ubuntu-mate-desktop
je suis novice sur LINUX et je ne connais pas très bien les commandes
si je fais une installation minimal + une installation de suite de paquets ubuntu je perd quoi de mon installation initial ?
que dois je sauvegarder ?

Merci

Hors ligne

#209 Le 27/07/2017, à 17:52

abelthorne

Re : extension non valable

Je ne suis pas bien sûr de comprendre pourquoi J5012 conseille une installation minimale + installation de MATE ensuite, autant télécharger directement Ubuntu MATE (16.04 si tu veux rester en LTS, 17.04 pour la version normale à mettre à jour tous les six mois). À moins que ton PC ait plus de 10 ans et seulement un CPU 32 bits, tu devrais partir sur une version 64 bits.

Pour ce qui est des données à sauvegarder, c'est simple : tout le contenu perso qu'il y a sur ton disque dur où Ubuntu MATE est installé. Ce qu'il y a dans ton dossier perso, en prenant en compte les fichiers cachés (ctrl + H pour les afficher avec le gestionnaire de fichiers). Concrètement, est-ce que tu as des données "lourdes" (vidéos, musique...) et est-ce que tu as de quoi faire une sauvegarde (disque dur externe, ou même interne) ?

En ligne

#210 Le 27/07/2017, à 22:47

J5012

Re : extension non valable

@bibitoi74 : une install minimale demarre avec une image iso (cdlive/install ou usblive/install) comme les autres sauf qu'on ne peut pas l'utiliser dans une session bureau : on ne peut l'utiliser que pour installer à partir du reseau (l'image a donc deja tous les outils de connectivité au net) une version minimale du systeme, à partir duquel il sera aisé de faire la commande au prochain demarrage de session :

sudo apt-get install ubuntu-mate-desktop --install-suggests

ce seul paquet installera tout bien comme il faut sans les paquets supplementaires qui viendrait avec une ubuntu desktop ordinaire + mate ... → pas d'outils en double par ex ...

→ en echange de cette "liberté" , tu as une session : ecran noir, texte blanc, pas d'indicateur systeme que tu es bien connecté ... : si il y a dans ton coin des parrains ubuntu avancés , n'hesite pas appelle les ...

@alberthorne : l'installation minimale ne convient pas à tout le monde, mais les utilisateurs qui n'arretent pas d'avoir des blemes devraient en profiter ... malheureusement il n'y a pas de mecanisme pour faciliter cette procedure ...

l'inconvenient de l'image toute faite ubuntu-mate est qu'elle n'est pas aussi finie et bien configurée que pourra l'etre une ubuntu minimale + mate ... ex : j'ignore si l'image 16.04 (la premiere release) ubuntu-mate est toujours dispo, mais quand je l'avais essayé à sa sortie, le systeme obtenu etait legerement plus lent et un peu plus gourmand en temps cpu qu'il aurait du l'etre, comparé à une ubuntu mini+mate sad

Hors ligne

#211 Le 28/07/2017, à 07:50

bibitoi74

Re : extension non valable

Un grand merci a tous pour ces conseilles !

Hors ligne

#212 Le 31/07/2017, à 11:05

bibitoi74

Re : extension non valable

Bonjour
Si quelqu'un a d'autres idées je prend merci

Hors ligne