Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 06/11/2016, à 11:11

ronan008

[Résolu]Plus de connexion en mode graphique possible

Bonjour,
Depuis ce matin, je ne peux plus me connecter en mode graphique sur mon Ubuntu 16-04.
Lorsque j'entre mon identifiant et mon mdp, l'écran passe au noir et revient en quelques secondes à l'affichage qui me demande identifant + mpd.
J'ai essayé Ctrl+F1, et j'arrive à me connecter. Un message m'indique qu'il y a 129 paquets qui peuvent être mis à jour et 4 mises à jours de sécurité. Peut-être que faire ces MAJ pourrait suffire à régler le pb, mais je ne sais pas faire ces MAJ !
Je ne suis pas du tout expert en ligne de commande.
Si quelqu'un a une piste pour m'aider, ce serait bien sympa.
Merci d'avance.

Dernière modification par ronan008 (Le 11/11/2016, à 18:40)

Hors ligne

#2 Le 06/11/2016, à 11:23

metalux

Re : [Résolu]Plus de connexion en mode graphique possible

Bonjour,
Pour mettre à jour,

sudo apt update && sudo apt full-upgrade

Possible qu'il y a un souci avec ton fichier .Xauthority. Dans ce cas il suffit de le supprimer et de redémarrer. Qu'elles sont les droits et le propriétaire de ce fichier?

ls -la | grep .X*

Hors ligne

#3 Le 06/11/2016, à 11:27

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

1- J'ai fait la "super" mise à jour, mais ça ne change rien malheureusement.

2- Je suis le propriétaire du fichier .Xauthority (droit rw)
Je ne l'ai pas supprimé (prudence..) mais renommé en "sauve-Xauthority" et j'ai rebooté. Le problème persiste.
Cependant, j'ai un nouveau fichier .Xauthority qui est apparu mais j'imagine que ça doit être normal !

Dernière modification par ronan008 (Le 06/11/2016, à 11:50)

Hors ligne

#4 Le 07/11/2016, à 09:10

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Bonjour,
J'ai poursuivi un peu mes recherches de mon côté et j'ai consulté la page
https://doc.ubuntu-fr.org/probleme_session_ubuntu
J'ai testé les commandes proposées :
- je suis incapable de comprendre le fichier de log.
- je n'ai pas de fichier lighthdm.conf
Il y a bien lightdm.conf.d, mais il est vide.
Est-ce que ces infos peuvent aider ?

Attention : je déplace cette discussion dans la section "Généralité" du forum car visiblement je n'ai pas un problème directement graphique mais plus d'ouverture de session avec Unity.


Edit modo : j'ai fusionné les deux sujets et je mets le tout dans Unity.

Dernière modification par cqfd93 (Le 07/11/2016, à 10:46)

Hors ligne

#5 Le 07/11/2016, à 10:16

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Bonjour,

Depuis hier mon Ubuntu 16-04 ne démarre plus de session sous Unity. Lorsque j'essaie de me connecter avec LightDM, je vois le fond d'écran quelques secondes puis écran noir et retour à l'écran de connexion lightDM. (Idem avec une session invité.)

En me connectant en console (ctrl-alt-f1), j'ai installé toutes les mises à jours (au cas où...) et j'ai essayé de supprimer .Xauthority et rebooté mais ça ne change rien (sous les conseils de ce message).

Du coup, j'ai installé gnome-session-flashback pour  essayer de me connecter avec un autre environnement que Unity. Avec gnome flashback (Compiz), ça ne marche pas non plus, mais ça fonctionne avec gnome flashback (Metacity).
Voilà où j'en suis de mes investigations.

J'avoue que j'aimerais bien comprendre un peu qui ce passe et pouvoir utiliser de nouveau unity (maintenant que j'ai fait l'effort d'apprendre à l'utiliser quotidiennement, je ne souhaite pas trop revenir à gnome).

Si quelqu'un peut m'aider, je l'en remercie grandement par avance.

Hors ligne

#6 Le 07/11/2016, à 10:49

cqfd93

Re : [Résolu]Plus de connexion en mode graphique possible

Bonjour,

Dans le tty1 (avec ctrl-alt-F1), essaye :

cd .cache
mv compizconfig-1 compizconfig-1_old

et pour lancer l'interface graphique :

startx

(attention ! Pas sudo startx !)

En ligne

#7 Le 07/11/2016, à 18:23

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Merci pour la tentative cqfd93, mais malheureusement après la commande startx, j'ai un écran noir de quelques secondes, puis un retour en mode console avec des messages assez longs (je ne vois pas le début) que je ne comprends pas. Et je ne suis pas plus avancé !
J'ai regardé quand même si cette action avait créé un nouveau répertoire compizconfig-1, la réponse est non.
J'ai ensuite tenté de redémarrer une session unity à partir de lightDM et ça ne fonctionne toujours pas, mais ça recrée bien un répertoire compizconfig-1.

Hors ligne

#8 Le 07/11/2016, à 18:55

cqfd93

Re : [Résolu]Plus de connexion en mode graphique possible

Puisque ce que je t'ai proposé ne marche pas, essaye ça :

sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install --reinstall unity
dconf reset -f /org/compiz/ && setsid unity

En ligne

#9 Le 07/11/2016, à 18:58

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

J'imagine que ces opérations réinstallent Unity.
Est-ce que je suis certain qu'il me restera au moins Gnome Metacity de fonctionnel (accessible avec lightDM) si jamais ça plantait... ?
Je préfère demander avant de prendre le risque.

Hors ligne

#10 Le 07/11/2016, à 19:02

cqfd93

Re : [Résolu]Plus de connexion en mode graphique possible

En principe, oui, mais je ne peux pas te le certifier à 100%.

En ligne

#11 Le 07/11/2016, à 19:10

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Bon, je fais une sauvegarde de mon /home sur un disque externe (ça me prend 3h !) puis je tente la manip... et je te dis ce qui se passe.

Dernière modification par ronan008 (Le 07/11/2016, à 19:14)

Hors ligne

#12 Le 07/11/2016, à 19:19

cqfd93

Re : [Résolu]Plus de connexion en mode graphique possible

OK, bonne chance. À plus.

En ligne

#13 Le 07/11/2016, à 20:46

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Bon ben ça ne marche toujours pas (mais tout n'a pas planté, heureusement smile)
Cela dit la commande

dconf reset -f /org/compiz/ && setsid unity

a généré une erreur dont je retransmets l'essentiel :

error: Cannot autolaunch D-Bus without X11 $DISPLAY

(La suite du message était de la doc sur l'utilisation de la command dconf)
Affaire à suivre...

Hors ligne

#14 Le 07/11/2016, à 21:04

cqfd93

Re : [Résolu]Plus de connexion en mode graphique possible

Si je comprends bien, tu n'as toujours pas le moindre affichage graphique ?

À tout hasard, il n'y aurait pas un problème de place sur ton disque ? Les commandes qui permettent de le voir sont :

df -h
df -i

Tu ne dois pas pouvoir faire de copier / coller mais au moins recopier dans ta réponse les lignes où tu vois des pourcentages entre 80% et 100%.

En ligne

#15 Le 07/11/2016, à 21:23

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Tout va bien pour l’espace disque :
- 16% pour la racine / (sur une partition de 46Go)
- 18% pour mon /home (sur une autre partition de 428 Go)
Ce sont les valeurs maxi. (loin des 80%)

Si je comprends bien, tu n'as toujours pas le moindre affichage graphique ?]

Je peux me connecter avec l'environnement Gnome flashback (Metacity), mais plus avec Unity, ni Gnome Flashback (Compiz).

Hors ligne

#16 Le 11/11/2016, à 11:29

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Je poursuis mes recherches et je pense avoir trouvé une bonne piste. Je pense que j'ai perdu l'accélération graphique 3D et ça doit expliquer que Compiz ne fonctionne pas (dons Unity non plus).
J'ai une carte NVDIA (GeForce 6150SE NFoprce 430)  et j'utilise un pilote propriétaire nvidia-304.
Les commandes

 /usr/lib/nux/unity_support_test -p

  ou

glxinfo | grep "direct rendering"

renvoient le message d'erreur suivant :

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  87
  Current serial number in output stream:  88

Maintenant, je ne sais pas trop quelle opération effectuer pour essayer de remédier à ce problème.
Mais sans doute quelqu'un parmi vous a-t-il la solution magique !
Merci d'avance pour votre aide...

Hors ligne

#17 Le 11/11/2016, à 12:04

metalux

Re : [Résolu]Plus de connexion en mode graphique possible

Peux-tu donner la version exacte de ton pilote S.T.P?

glxinfo | grep OpenGL

Il y a apparemment un bug avec la version 304.132, il faut dans ce cas revenir à la 304.131.

Hors ligne

#18 Le 11/11/2016, à 13:02

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Je ne peux pas utiliser glxinfo (voir mon message précédent), désolé.
Cela dit, je sais que j'ai la version 304.132 en effet (visible dans le gestionnaire de pilotes additionnels).  Mais je ne sais pas comment revenir à la 304.131 !

Dernière modification par ronan008 (Le 11/11/2016, à 13:04)

Hors ligne

#19 Le 11/11/2016, à 13:08

metalux

Re : [Résolu]Plus de connexion en mode graphique possible

Ah oui, désolé!
et cette commande est-ce qu'elle passe?

ldd /usr/bin/glxinfo | grep 304.13

Sinon essaye en root avec sudo pour voir si la commande du post précédent fonctionne dans le cas ou cette dernière n'est pas fonctionnelle non plus.
Assure toi que mesa-utils est installé.
Edit: je n'avais pas vu que tu avais confirmé avoir la version 304.132. Soit j'ai lu en travers, soit tu l'as ajouté après coup lors de l'edit de ton message.
Pour revenir à la version précédente le temps que le bug soit corrigé, soit tu passes par hold, soit par le pinning comme sur Debian. Tu peux également bloquer en graphique avec synaptic mais dans ce cas le blocage ne sera pas opérant si tu utilises également la ligne de commande.
Voici comment revenir à la 304.131 avec hold:

sudo apt install nvidia-304=304.131-0ubuntu3

Puis bloquer la version avec:

sudo apt-mark hold nvidia-304

Pour repasser sur une version plus récente lorsque le bug sera corrigé, il faudra utiliser la commande unhold à la place

Dernière modification par metalux (Le 11/11/2016, à 13:33)

Hors ligne

#20 Le 11/11/2016, à 13:59

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Merci Metalux pour ces réponses rapides.

J'ai effectué l'installation du pilote 304.131 et je suis passé en hold pour nvidia-304.
Je reboote et je peux de nouveau démarrer une session avec Unity !
Merci !!!!

Cela dit, une petite question encore. Dans les paramètres systèmes -> logiciels et mises à jours -> pilotes additionnels, c'est encore indiqué que j'utilise le pilote 304.132.
Mais la commande

glxinfo | grep OpenGL

(qui fonctionne désormais) indique bien le pilote 304.131.
Est-ce grave docteur ?

Hors ligne

#21 Le 11/11/2016, à 15:40

metalux

Re : [Résolu]Plus de connexion en mode graphique possible

Non, ce n'est pas grave si glxinfo t'indique bien le bon pilote, c'est lui qui est utilisé.
Surveille la correction de ce bug et quand il sera résolu tu pourras mettre à jour vers la version plus récente en supprimant le marquage avec la même commande mais en remplaçant hold par unhold.
Tu peux passer en [Résolu] en éditant le titre de ton 1er message.

Hors ligne

#22 Le 11/11/2016, à 18:40

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

Merci beaucoup !

Hors ligne

#23 Le 07/08/2017, à 16:01

ronan008

Re : [Résolu]Plus de connexion en mode graphique possible

!!! Alerte Nouveauté !!!
Aujourd'hui (7 août 2017), j'ai eu de nouveau le problème de connexion graphique. Seul le "mode" Metacity fonctionne (avec une résolution pourrie !).
J'ai essayé de réinstaller dans un Terminal le pilote nvidia304.131(au cas où...) avec la commande :

sudo apt install nvidia-304=304.131-0ubuntu3

et j'ai obtenu un message m'indiquant que le paquet était déjà installé mais j'ai aussi eu un message d'erreur dont je copie l'essentiel :

Les paquets suivants contiennent des dépendances non satisfaites :
linux-generic : Depend : linux-headers-generic (= 4.4.0.89.95) mais 4.4.0.83.89 devra être installé

Le message propose aussi pour corriger le problème de taper la commande :

sudo apt-get -f install

J'ai donc essayé cette commande et effectivement tout rentre dans l'ordre.
J'ai juste l'impression d'être repassé sur un noyau plus ancien, mais cela reste ma propre interprétation !!!
On verra au cours des prochaines MAJ si "ça tient"...

Hors ligne