Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 06/08/2017, à 07:01

guy-pierre

Services

Bonjour,
je viens d'installer Lubuntu 17.04, qui me paraît bien sympathique et surtout....rapide, eu égard à mon PC qui date de 2012.

Deux petites questions :
1) Comment faire pour désactiver le pavé tactile ? (je ne me sers que de la souris ou du clavier et parfois le curseur se déplace lorsqu'on effleure le pavé avec le doigt en travaillant sur le clavier, ce qui est gênant pour moi).
2) Parmi les services suivants, lesquels pourrais-je désactiver sans risque au démarrage ?

guy-pierre@guypierre-N76VZ:~$  systemd-analyze blame | head 
          9.750s dev-sda4.device
          8.255s keyboard-setup.service
          7.934s resolvconf.service
          7.076s systemd-sysctl.service
          6.464s systemd-udevd.service
          5.829s NetworkManager-wait-online.service
          3.228s NetworkManager.service
          2.837s accounts-daemon.service
          2.781s ModemManager.service
          2.168s grub-common.service
guy-pierre@guypierre-N76VZ:~$  

Merci de votre aide. Désolé, je n'ai ouvert qu'une seule discussion pour deux thèmes...

En ligne

#2 Le 06/08/2017, à 08:14

guy-pierre

Re : Services

...Oubliez la question du pavé tactile. Je l'ai résolue grâce à la commande

syndaemon -i 1.0 -d -K 

En ligne

#3 Le 09/08/2017, à 07:28

guy-pierre

Re : Services

Bonjour,
j'ai parlé trop vite au sujet du touchpad. En fait, la commande

 syndaemon -i 1.0 -d -K 

ne fonctionne que de façon ponctuelle. A chaque démarrage d'une nouvelle session, hop ! le pavé tactile est réactivé...et ça m'énerve. Je suis preneur d'une solution qui désactive le touchpad définitivement. Je suis sous Lubuntu 17.04, environnement LXDE. Mon touchpad est un Elantech, comme on peut le voir ici :

guy-pierre@guypierre-N76VZ:~$ egrep -i 'synap|alps|etps' /proc/bus/input/devicesN: Name="ETPS/2 Elantech Touchpad"
guy-pierre@guypierre-N76VZ:~$   

Merci de votre aide.

En ligne

#4 Le 09/08/2017, à 12:22

Bastien85

Re : Services

Bonjour,

pour désactiver le touchpad:

sudo apt install xinput
xinput list

Trouve ton touchpad dans la liste

Utilise la commande ci-dessous et remplace 12 par l'ID du touchpad.

xinput set-prop 12 "Device Enabled" 0

Source: https://doc.ubuntu-fr.org/touchpad

Bastien85


Lubuntu 17.04

Hors ligne

#5 Le 09/08/2017, à 17:36

guy-pierre

Re : Services

Bonjour,
j'ai oublié de préciser que j'avais déjà vu ta solution sur le forum Ubuntu et que je l'avais déjà essayée. J'avais donc remplacé 12 par 16 comme indiqué ici :

 guy-pierre@guypierre-N76VZ:~$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v2.0	id=11	[slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v2.0	id=12	[slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                	id=16	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Microsoft Microsoft® Nano Transceiver v2.0	id=10	[slave  keyboard (3)]
    ↳ ASUS USB2.0 Webcam                      	id=13	[slave  keyboard (3)]
    ↳ Asus WMI hotkeys                        	id=14	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=15	[slave  keyboard (3)]
    ↳ Microsoft Microsoft® Nano Transceiver v2.0	id=17	[slave  keyboard (3)]
    ↳ Microsoft Microsoft® Nano Transceiver v2.0	id=18	[slave  keyboard (3)]
guy-pierre@guypierre-N76VZ:~$ 
 

Le problème est que cette solution ne marche que dans la session ouverte. Lorsque je redémarre le PC, le touchpad est de nouveau activé !
Il se trouve que j'ai Kubuntu installé sur une autre partition et que j'ai pu désactiver sans problème le pavé tactile avec cette distribution. Mais là, avec Lubuntu, pas moyen.

En ligne

#6 Le 09/08/2017, à 18:54

guy-pierre

Re : Services

Bon, j'ai fini par retrouver la solution que j'avais déjà appliquée en 2012 mais que j'avais complètement oubliée : Il suffit de mettre le module "psmouse" en blacklist comme indiqué dans ce tuto :

 https://doc.ubuntu-fr.org/tutoriel/tout_savoir_sur_les_modules_linux

. Le module ne se charge plus au démarrage et le pavé tactile est définitivement désactivé.

Il reste la question des services, soulevée dans mon premier post. Dois-je ouvrir une nouvelle discussion ?

En ligne