Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 15/08/2017, à 12:09

Vivi936

Installation VLC

Bonjour,
Je suis tout nouveau sur ubuntu 16.04, et je n'arrive pas à installer vlc via la logithèque (l'installation ne progresse pas) et j'ai essayé d'installer un jeu pour voir : ça marche.

sur le terminal, j'ai ça :

$ sudo apt-get install vlc
[sudo] Mot de passe de vivi : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 vlc : Dépend: libgles1-mesa (>= 7.8.1) mais ne sera pas installé ou
                libgles1
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Quelqu'un peut-il m'aider ?

Dernière modification par Vivi936 (Le 15/08/2017, à 12:47)

Hors ligne

#2 Le 15/08/2017, à 12:33

abelthorne

Re : Installation VLC

Le problème est un peu complexe mais pour résumer : tu as une version du pilote graphique à laquelle un élément a été supprimé (pas chez toi par accident : supprimé du pilote lui-même il y a quelques mois) et la version de VLC qui est dans les dépôts en dépend.

Pour confirmer ça, donne-moi le retour des commandes suivantes :

uname -a
glxinfo | grep OpenGL

La solution va être de passer par un dépôt tiers soit pour mettre à jour le pilote graphique en rétablissant l'élément manquant, soit pour trouver une version de VLC qui né dépend pas de l'élément en question.

Hors ligne

#3 Le 15/08/2017, à 12:38

Vivi936

Re : Installation VLC

uname -a
Linux vira-Lenovo-Flex-2-14D 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:19:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
glxinfo | grep OpenGl
Le programme « glxinfo » n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt install mesa-utils

J'ai fait sudo apt install mesa-utils puis  glxinfo | grep OpenGl qui ne me renvoie plus rien.

Dernière modification par Vivi936 (Le 15/08/2017, à 12:41)

Hors ligne

#4 Le 15/08/2017, à 13:51

abelthorne

Re : Installation VLC

C'est parce que c'est "OpenGL" (L majuscule), pas "OpenGl".

EDIT : après vérification sur une 16.04.3 de mon côté, j'ai l'impression que le problème que tu as est censé être corrigé. Est-ce que tu utilises des dépôts tiers sur ton système ? Dans le doute, donne le retour de :

ls /etc/apt/sources.list.d
cat /etc/apt/sources.list

Précise aussi ta versione xacte d'Ubuntu :

cat /etc/lsb-release

Et vérifie si le système est à jour :

sudo apt-get update && sudo apt-get dist-upgrade

Dernière modification par abelthorne (Le 15/08/2017, à 14:21)

Hors ligne

#5 Le 15/08/2017, à 21:30

Vivi936

Re : Installation VLC

Alors pour les retours :

$ ls /etc/apt/sources.list.d
videolan-ubuntu-stable-daily-xenial.list

$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

Pour ma version exacte de Ubuntu :

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.3 LTS"

Ensuite, tu m'as demandé de vérifier si le système est à jour :

$ sudo apt-get update && sudo apt-get dist-upgrade
[sudo] Mot de passe de vivi : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial InRelease
Réception de:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Réception de:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [619 kB]
Réception de:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [344 kB]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [595 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [250 kB]
Réception de:10 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [322 kB]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [305 kB]
Réception de:12 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [210 kB]
Réception de:13 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [517 kB]
Réception de:14 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [145 kB]
Réception de:15 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [59,9 kB]
Réception de:16 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [56,5 kB]
Réception de:17 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [497 kB]
Réception de:18 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [156 kB]
Réception de:19 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [137 kB]
Réception de:20 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [202 kB]
Réception de:21 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [171 kB]
Réception de:22 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [226 kB]
Réception de:23 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [79,8 kB]
Réception de:24 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [48,8 kB]
Réception de:25 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5 892 B]
Réception de:26 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3 324 B]
Réception de:27 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [5 136 B]
Réception de:28 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [69,1 kB]
5 329 ko réceptionnés en 13s (383 ko/s)                                        
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  firefox firefox-locale-en firefox-locale-fr snapd ubuntu-core-launcher
  xul-ext-ubufox
6 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 52,4 Mo dans les archives.
Après cette opération, 52,3 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 ubuntu-core-launcher amd64 2.26.10 [1 566 B]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 snapd amd64 2.26.10 [10,1 MB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 firefox amd64 55.0.1+build2-0ubuntu0.16.04.2 [41,1 MB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 firefox-locale-en amd64 55.0.1+build2-0ubuntu0.16.04.2 [687 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 firefox-locale-fr amd64 55.0.1+build2-0ubuntu0.16.04.2 [444 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 xul-ext-ubufox all 3.4-0ubuntu0.16.04.1 [30,9 kB]
52,4 Mo réceptionnés en 1min 51s (472 ko/s)                                    
(Lecture de la base de données... 215532 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../ubuntu-core-launcher_2.26.10_amd64.deb ...
Dépaquetage de ubuntu-core-launcher (2.26.10) sur (2.25) ...
Préparation du dépaquetage de .../snapd_2.26.10_amd64.deb ...
Warning: Stopping snapd.service, but it can still be activated by:
  snapd.socket
Dépaquetage de snapd (2.26.10) sur (2.25) ...
Préparation du dépaquetage de .../firefox_55.0.1+build2-0ubuntu0.16.04.2_amd64.deb ...
Dépaquetage de firefox (55.0.1+build2-0ubuntu0.16.04.2) sur (54.0+build3-0ubuntu0.16.04.1) ...
Préparation du dépaquetage de .../firefox-locale-en_55.0.1+build2-0ubuntu0.16.04.2_amd64.deb ...
Dépaquetage de firefox-locale-en (55.0.1+build2-0ubuntu0.16.04.2) sur (54.0+build3-0ubuntu0.16.04.1) ...
Préparation du dépaquetage de .../firefox-locale-fr_55.0.1+build2-0ubuntu0.16.04.2_amd64.deb ...
Dépaquetage de firefox-locale-fr (55.0.1+build2-0ubuntu0.16.04.2) sur (54.0+build3-0ubuntu0.16.04.1) ...
Préparation du dépaquetage de .../xul-ext-ubufox_3.4-0ubuntu0.16.04.1_all.deb ...
Dépaquetage de xul-ext-ubufox (3.4-0ubuntu0.16.04.1) sur (3.2-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5.1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Paramétrage de snapd (2.26.10) ...
Installation de la nouvelle version du fichier de configuration /etc/apparmor.d/usr.lib.snapd.snap-confine.real ...
Paramétrage de ubuntu-core-launcher (2.26.10) ...
Paramétrage de firefox (55.0.1+build2-0ubuntu0.16.04.2) ...
Please restart all running instances of firefox, or you will experience problems.
Paramétrage de firefox-locale-en (55.0.1+build2-0ubuntu0.16.04.2) ...
Paramétrage de firefox-locale-fr (55.0.1+build2-0ubuntu0.16.04.2) ...
Paramétrage de xul-ext-ubufox (3.4-0ubuntu0.16.04.1) ...

Alors si j'ai bien compris (j'en profite pour comprendre le langage du terminal), sudo apt-get update && sudo apt-get dist-upgrade : il y a 2 instructions en une ligne : télécharger les mises à jour et installer les mises à jour c'est ça ?

Hors ligne

#6 Le 15/08/2017, à 21:42

abelthorne

Re : Installation VLC

C'est bien ça : tu peux enchaîner les instructions sur la même ligne avec &&. Attention à bien mettre deux &, un seul a une toute autre signification (ça permet de lancer un processus en arrière-plan et de récupérer la main).

Pour le reste, tu utilises le PPA de VLC. À cause du problème que j'ai évoqué plus haut, tu ne peux pas installer les paquets qui sont dedans, il faut t'en tenir à la version de VLC des dépôts Ubuntu. Donc, supprime le dépôt :

sudo rm /etc/apt/sources.list.d/videolan-ubuntu-stable-daily-xenial.list

Recharge à nouveau la liste des sources :

sudo apt-get update

Et essaie à nouveau d'installer VLC :

sudo apt-get install vlc

Hors ligne

#7 Le 15/08/2017, à 22:09

Vivi936

Re : Installation VLC

J'ai un message différent de la première fois :

sudo apt-get install vlc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 vlc : Dépend: vlc-nox (= 2.2.2-5ubuntu0.16.04.4) mais 2.2.2+git20170721+r59033+56~ubuntu16.04.1 devra être installé
       Recommande: vlc-plugin-notify (= 2.2.2-5ubuntu0.16.04.4) mais ne sera pas installé
       Recommande: vlc-plugin-samba (= 2.2.2-5ubuntu0.16.04.4) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#8 Le 15/08/2017, à 22:12

abelthorne

Re : Installation VLC

Donne-moi le retour de :

apt-cache policy vlc vlc-nox vlc-plugin-notify vlc-plugin-samba

D'autre part, installe Synaptic :

sudo apt-get install Synaptic

Lance-le (depuis le menu des applis, pas depuis le terminal) et dis-moi si dans État (en bas à gauche) tu vois une section "Installés (locaux ou obsolètes)" (dans la liste en haut à gauche) ? Si oui, quels paquets contient-elle ?

Hors ligne

#9 Le 15/08/2017, à 22:34

Vivi936

Re : Installation VLC

le retour que tu m'as demandé

apt-cache policy vlc vlc-nox vlc-plugin-notify vlc-plugin-samba
vlc:
  Installé : (aucun)
  Candidat : 2.2.2-5ubuntu0.16.04.4
 Table de version :
     2.2.2-5ubuntu0.16.04.4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
     2.2.2-5 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
vlc-nox:
  Installé : 2.2.2+git20170721+r59033+56~ubuntu16.04.1
  Candidat : 2.2.2+git20170721+r59033+56~ubuntu16.04.1
 Table de version :
 *** 2.2.2+git20170721+r59033+56~ubuntu16.04.1 100
        100 /var/lib/dpkg/status
     2.2.2-5ubuntu0.16.04.4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
     2.2.2-5 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
vlc-plugin-notify:
  Installé : (aucun)
  Candidat : 2.2.2-5ubuntu0.16.04.4
 Table de version :
     2.2.2-5ubuntu0.16.04.4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
     2.2.2-5 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
vlc-plugin-samba:
  Installé : (aucun)
  Candidat : 2.2.2-5ubuntu0.16.04.4
 Table de version :
     2.2.2-5ubuntu0.16.04.4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
     2.2.2-5 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

Et j'arrive pas à installer synaptic

sudo apt-get install Synaptic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet Synaptic

Hors ligne

#10 Le 15/08/2017, à 22:56

abelthorne

Re : Installation VLC

Ah, j'ai fait une faute de frappe, c'est un s minuscule :

sudo apt-get install synaptic

Avant de l'installer, fais ça :

sudo apt-get remove --purge vlc-nox
sudo apt-get install vlc

Si l'installation fonctionne, pas besoin de Synaptic.

Hors ligne

#11 Le 15/08/2017, à 23:09

Vivi936

Re : Installation VLC

Super ! Ça marche ! T'es un chef.
Et pour synaptic c'est bon aussi mais ça sert à quoi synaptic ?

Hors ligne

#12 Le 16/08/2017, à 08:20

abelthorne

Re : Installation VLC

Synaptic, c'est un gestionnaire de paquets assez complet mais avec une interface beaucoup moins abordable qu'un logiciel comme la Logithèque.

Il est très pratique pour avoir un aperçu de la situation quand il y a un problème sur des paquets : vérifier s'il y en a qui ne viennent pas d'un dépôt, les dépendances cassées, etc. Je voulais te le faire installer pour vérifier s'il y avait des paquets sans source qui bloquaient tout mais j'ai eu la réponse avec la commande que je t'ai demandée, c'était au cas où le problème soit plus complexe que ça.

Hors ligne

#13 Le 21/08/2017, à 11:41

GEORGES44

Re : Installation VLC

Merci pour le topic,

J'avais le même problème et j'ai pu le résoudre grâce à vos conseils!

Hors ligne

#14 Le 21/08/2017, à 12:20

Christophe C

Re : Installation VLC

abelthorne l'a plus ou moins expliqué, mais allons un poil plus loin : Ubuntu met à disposition des dépôts (qui sont des répertoires sur internet, en pratique).

Dans ces dépôts il y a des paquets. Un paquet peut comprendre des librairies, des polices, des wallpapers, des logiciels.

Les dépôts officiels sont testés pour être cohérents entre eux. Donc normalement il ne manque pas une librairie pour l'installation d'un logiciel.

On peut (nous sommes dans les logiciels liiiiiiiibres wink ) ajouter des dépôts non officiels (PPA, dépôts debian ...). Sauf que là, plus aucun contrôle. Le système va ainsi installer la version la plus haute qu'il trouve (en termes de numérotation du fichier control qui se trouve dans le paquet), version qui viendra par exemple du dépôt ajouté. Sauf que rien ne garantie que ce dépôt ajouté a la bonne librairie. Pire, il peut l'avoir, mais son N° sera inférieur au N° de la librairie dans le dépôt officiel, et donc c'est cette dernière qui s'installera .... mais elle est peut-être incompatible.

J'utilise des dépôts ajoutés, soyons clair, mais on entre forcément dans quelque chose de potentiellement instable. Le 1er réflexe en cas de problème c'est d'effacer le dépôt. A la ligne de commande, ou avec l'interface graphique qui permet de décocher (donc désactiver) le dépôt. Ensuite, par prudence, on peut désinstaller ce qui était installé à partir du dépôt ajouté, et réinstaller. C'est ce que avez fait.

En bref : si problème, commencez par désactiver vos dépôts tiers et par désinstaller ce qui coince.

C'est pour éviter ces problèmes (entre autre) qu'on été créés les paquets snap, flatpack ou appimage (ils intègrent l'ensemble des dépendances nécessaires et s’exécutent dans un environnement séparé - donc normalement aucun risque d'anomalie). Mais c'est une autre histoire smile

Dernière modification par Christophe C (Le 21/08/2017, à 12:25)


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#15 Le 21/08/2017, à 12:37

abelthorne

Re : Installation VLC

J'ajoute quand même que le cas de VLC est un cas très particulier. Il y a quelques mois, une nouvelle version de Mesa (pilote graphique libre) est sortie qui a supprimé une bibli (libgles1) et le paquet qui y correspond. Depuis cette mise à jour − et si on l'utilise, bien sûr − tous les paquets qui dépendent de libgles1 se retrouvent avec une dépendance manquante et ne peuvent donc plus être installés. Ça concerne notamment VLC.

La mise à jour de Mesa, elle, est notamment dans les dépôts de Ubuntu-X-swat (màj pour X / Mesa, PPA maintenu par Canonical), Xorg-edgers (màj de dév pour X / Mesa, PPA maintenu par Canonical), Oibaf, Padoka (qui a continué à empaqueter libgles1 à ma demande et n'a donc pas le problème). Elle est aussi intégrée d'office à Ubuntu 16.0.3 (voire .2).

Pour corriger le problème, les développeurs d'Ubuntu avaient publié un nouveau paquet pour VLC dans le PPA Ubuntu-X-swat qui ne dépend pas du paquet Mesa manquant. Depuis, je pense qu'il a été ajouté directement aux backports 16.04 / 17.04. En revanche, tous les autres dépôts qui proposent un paquet pour VLC non modifié, tel que le PPA officiel de VideoLAN, ne peuvent plus être utilisés sur un système qui a Mesa suffisamment à jour.

Dernière modification par abelthorne (Le 21/08/2017, à 12:46)

Hors ligne

#16 Le 01/09/2017, à 11:40

etoine73

Re : Installation VLC

bonjour,
j'ai un soucis vlc , j'ai bien essayer de suivre les différents conseil mais rien! vlc se lance tres bien mais j'ai que le son et pas l'image!

une idée?

Hors ligne

#17 Le 01/09/2017, à 12:08

abelthorne

Re : Installation VLC

Va dans ses préférences et teste les différentes sorties vidéo (essentiellement Xvideo, GLX, X11).

Hors ligne

#18 Le 01/09/2017, à 18:25

etoine73

Re : Installation VLC

yes, merci ça marche!!

Hors ligne

#19 Le 24/09/2017, à 14:05

PeaceAndYunnanTea

Re : Installation VLC

Un grand merci aux participants de ce topic


Ubuntu 16.04 Unity

Hors ligne