Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 18/08/2017, à 19:48

Pacifick_FR42

Lets Encrypte & ISPconfig

Bonjour !
Perso, j'ai un problème avec Let's encrypte et ISPconfig.
Maintenant il est intégré via ISPconfig, seul problème est que à chaque fois je doit changer le vhost à la mains quant je l'active pour un domaine (ou un sous.domaine):

</VirtualHost>
<VirtualHost *:443>
en
<VirtualHost domaine.ltd:443>

Quelqu'un à une idée du pourquoi ?

Hors ligne

#2 Le 19/08/2017, à 08:23

vincen

Re : Lets Encrypte & ISPconfig

Tu dois faire la modification avant de lancer le script Let's Encrypt ? Quel est ton vhost avant et après cette fameuse modif ??


Portable Clevo W355ST Ubuntu Xenial 16.04 LTS
PC Assemblage Ubuntu 16.04 double écran sur NVidia
[img]https://www.linuxcounter.net/cert/46271.png[/img]
Bépo fan :)

Hors ligne

#3 Le 19/08/2017, à 18:08

HPIR40

Re : Lets Encrypte & ISPconfig

Bonjour

ISPConfig court circuite en quelque sorte apache.

va voir la pour le duo IPSConfig et Let'sencrypt: https://www.oboqo.com/blog/lets-encrypt … tuitement/

ou la: https://aide.lws.fr/base/Serveurs-dedie … ncrypt-VPS

Dernière modification par HPIR40 (Le 19/08/2017, à 18:09)

Hors ligne

#4 Le 22/08/2017, à 03:44

Pacifick_FR42

Re : Lets Encrypte & ISPconfig

vincen a écrit :

Tu dois faire la modification avant de lancer le script Let's Encrypt ? Quel est ton vhost avant et après cette fameuse modif ??

Merci de ton intérêt
Avant que je modifie moi même le Vhost voilà ce que j'ai dans le domaine concerné :

<VirtualHost *:443>

Si je garde cette confige, j'ai une erreur SSL.
Si je regarde le certificat provoquant cette erreur, elle appartient au dernier nom de domaine utilisé, pas celui du nom de domaine concerné (c'est assez difficile à expliquer)
Bref, je suis obligé de remplacé le "jocker" (*:443) par le nom de domaine concerné...

Hors ligne

#5 Le 22/08/2017, à 03:47

Pacifick_FR42

Re : Lets Encrypte & ISPconfig

HPIR40 a écrit :

Bonjour

ISPConfig court circuite en quelque sorte apache.

va voir la pour le duo IPSConfig et Let'sencrypt: https://www.oboqo.com/blog/lets-encrypt … tuitement/

ou la: https://aide.lws.fr/base/Serveurs-dedie … ncrypt-VPS

Merci pour tes liens, mais depuis la 3.1, on ne doit plus agir "manuellement", et c'est tous le bute !
Normalement, on doit juste cocher Let'e Encrypte dans ISP > Site > Domaine (du site concerné) et activé la redirection de HTTP à HTTPS dans "Redirection" et c'est tous.

Hors ligne

#6 Le 22/08/2017, à 18:10

HPIR40

Re : Lets Encrypte & ISPconfig

Pacifick_FR42 a écrit :

[
Si je garde cette confige, j'ai une erreur SSL.
Si je regarde le certificat provoquant cette erreur, elle appartient au dernier nom de domaine utilisé, pas celui du nom de domaine concerné (c'est assez difficile à expliquer)
Bref, je suis obligé de remplacé le "jocker" (*:443) par le nom de domaine concerné...

As tu essayé de révoquer le certificat du dernier nom de domaine utilisé déjà en place, pour ensuite en recréer un avec le nouveau nom de domaine ?

Hors ligne

#7 Le 22/08/2017, à 18:53

Pacifick_FR42

Re : Lets Encrypte & ISPconfig

HPIR40 a écrit :
Pacifick_FR42 a écrit :

[
Si je garde cette confige, j'ai une erreur SSL.
Si je regarde le certificat provoquant cette erreur, elle appartient au dernier nom de domaine utilisé, pas celui du nom de domaine concerné (c'est assez difficile à expliquer)
Bref, je suis obligé de remplacé le "jocker" (*:443) par le nom de domaine concerné...

As tu essayé de révoquer le certificat du dernier nom de domaine utilisé déjà en place, pour ensuite en recréer un avec le nouveau nom de domaine ?

le truc, c'est que à chaque fois ça change de domaine, j'essaye de m'expliquer :
J'active le SSL (LE) pour domaineA.ltd
J'active domaineB.ltd --> il prendra le domaineA
Si je modifie manuellement le vhost en le forçant à utiliser domaineB tout est ok
j'active domaineC.ltd, il prends le certificat de domaineB, et ainsi de suite, comme j'en ai plus de 200 (de nom de domaine), c'est chaud...
Surtout qu'a chaque fois que j'interviens sur un des domaines modifier, je dois le remodifier à la main, car ISP réécrit avec le jocker *:443...

Hors ligne

#8 Le 22/08/2017, à 19:19

Pacifick_FR42

Re : Lets Encrypte & ISPconfig

j'ai trouvé une solution, il suffit de modifier le template du fichier vhost :

ISPCONFIG Template Vhost a écrit :

Fichier concerné : /usr/local/ispconfig/server/conf/vhost.conf.master
Modification de la ligne (ligne 15 chez moi) :
<VirtualHost {tmpl_var name='ip_address'}:{tmpl_var name='port'}>
En
<VirtualHost {tmpl_var name='domain'}:{tmpl_var name='port'}>

Bon, à modifier à chaque mise à jour de ISPconfig, mais c'est déjà moins chiant que de modifier à chaque fois les vhost des domaines !! wink

Dernière modification par Pacifick_FR42 (Le 22/08/2017, à 19:20)

Hors ligne

#9 Le 01/09/2017, à 17:44

Pacifick_FR42

Re : Lets Encrypte & ISPconfig

Up ? wink

Hors ligne

#10 Le 02/09/2017, à 07:46

HPIR40

Re : Lets Encrypte & ISPconfig

Bonjour

Hébergeant plusieurs services web, je n'utilise pas ISPConfig donc malheureusement je ne peux pas t'aider sur ce point.

Perso, j'ai d'abord créé un reverseproxy apache (c'est lui qui, entre autres, gère tous les certificats directement dans les vhosts comme décrit ici: https://forum.ubuntu-fr.org/viewtopic.php?id=2012936) et ensuite chaque service web est dans sa propre VM.

Si j'ajoute un service web, je n'ai plus qu'à ajouter le vhost qui va bien dans le reverseproxy avec le certificat SSL quivabien sans me préoccuper de la config apache dans la VM elle même.

Dernière modification par HPIR40 (Le 02/09/2017, à 07:49)

Hors ligne

#11 Le 03/09/2017, à 23:29

Pacifick_FR42

Re : Lets Encrypte & ISPconfig

@HPIR40 Merci de l'info, mais effectivement, ça m'aide pas, je ne peux pas me permettre de me passer d'ISPConfig.

Hors ligne