Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 11/09/2017, à 18:44

jeremyy55

installation de PacketTracer 7.1 sur Ubuntu 17.04

Bonjour,

Je me suis rendu sur le site officiel afin de télécharger la version officielle du logicielle destinée à être installer sur linux.
j'ai ainsi obtenu un fichier que j'ai décompressé, puis me suis rendu dans le fichier et ait exécuté le fichier :
./install

J'ai complété l'installation du logiciel puis j'ai essayé de me rendre dans le tableau de bord( dash) pour y trouver le logiciel où il ne se trouvait pas.
Par ligne de commande, j'ai essayé de taper :
packettracer
et cela me dit simplement: "Starting Packet Tracer 7.1" et ne fait plus rien ensuite.
Je suis tombé sur un lien internet qui me suggérait d'aller dans vim modifié le fichier "/usr/share/applications/pt7.desktop" la ligne :
Exec=PacketTracer7
par
Exec=/opt/pt/bin/PacketTracer7
La seule modification provoquée par cette action est que j'ai maintenant "Packettracer 7 et son logo accessibles dans le Dash mais le comportement reste le même que précédemment: Dans les deux cas, le programme fait mine de se lancer puis rien ne se passe.

l'un de vous saurait ce que je peux faire ?

Hors ligne

#2 Le 11/09/2017, à 20:09

Zakhar

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Aucune idée de ce que la chose est sensée faire... mais en général tu as plus d'indication quand tu lances un programme en ligne de commande.

Donc tu ouvres un beau terminal, et tu lances :

/opt/pt/bin/PacketTracer7

(puisque ça la l'air d'être là où tu l'as mis !)

Et tu regardes ce que ça te dit de plus.


"A computer is like air conditioning: it becomes useless when you open windows." (Linus Torvald)

Hors ligne

#3 Le 11/09/2017, à 20:55

jeremyy55

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Salut,

Quand j'accède au fichier pour
./PacketTracer7: error while loading shared libraries: libQt5Script.so.5: cannot open shared object file: No such file or directory

En cherchant un peu sur internet ce que le message d'erreur indiquait, j'ai d'abord vu que parfois, il suffisait d'utiliser la commande "ldconfig" pouvait résoudre le problème mais ça me renvoie juste vers des fichiers relatif à nvidia dans /usr/bin , je pense pas qu'il y ait de lien avec la question ci-dessus.

J'ai aussi vu quelqu'un qui disais qu'il fallait expliquer à l'OS où elle se situaient, donc j'ai suivit les commandes indiquées :

sudo find ./ | grep libQt5Script.so

qui m'a renvoyé le chemin :

"/opt/pt/lib/"
et qui a aussi proposé de regardé ce que renvoyait la variable " $LD_LIBRARY_PATH " . Cette dernière ne renvoie rien.

ils proposent ensuite de faire des manipulation avec cette variable que je ne comprends pas, comme égaler cette dernière à /usr/local/lib. ca peut servir à quelque chose ?
Si pas, est-ce que ça aiguille un peu sur ce qu'est réellement le problème et quelle est la solution ?

Dernière modification par jeremyy55 (Le 11/09/2017, à 20:55)

Hors ligne

#4 Le 11/09/2017, à 20:58

gabcyr

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Bonjour, je viens d'installer PacketTracer, il manquait une librairie : libqt5designer5 (si mes souvenirs sont bons). En laissant dans un terminal /opt/pt/bin/PacketTracer7, la librairie manquante est indiquée.

Hors ligne

#5 Le 11/09/2017, à 21:02

jeremyy55

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

GabCyr, ça rejoint ce que j'ai mis il y a quelque minutes juste au dessus, tu as trouvé comment joindre la librairie ? smile

Dernière modification par jeremyy55 (Le 11/09/2017, à 21:37)

Hors ligne

#6 Le 12/09/2017, à 17:25

gabcyr

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Bonjour est-ce que tu as installé le paquet manquant libqt5script5 ? Pour ma part sur une Gnome-Ubuntu 17.04, je n'ai installé qu'un paquet, ensuite le logiciel se lance sans problème.

Hors ligne

#7 Le 12/09/2017, à 18:12

jeremyy55

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Je viens de le faire mais à l'instant mais ça ne résous pas mon cas,

je suis retourné voir le fichier /opt/pt/bin/PacketTracer7 et quand je l'ouvre, il m'indique qu'il me manque la librairie : " libQt5ScriptTools.so.5"
j'ai donc essayé de refaire la même chose que précédemment en l'adaptant à la librairie , donc je tape :

sudo apt-get install  libqt5scripttools5

Et maintenant, ça fonctionne quand je vais chercher le fichier /usr/pt/bin/PacketTracer7 smile
En revanche, quand je tape simplement dans le terminal packettracer, ça me met toujours :
"Starting Packet Tracer 7.1"
sans que le programme ne se lance.
je pensais que modifier le fichier /usr/share/applications/pt7.desktop avec vim pour remplacer la ligne :
Exec=PacketTracer7
par
Exec= /usr/pt/bin/PacketTracer7
me permettrant de le lancer mais ce n'est pas le cas.

Tu sais ce que je dois modifier pour l'appeler simplement par ligne de commande ?

Hors ligne

#8 Le 12/09/2017, à 21:33

gabcyr

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Bonsoir, personnellement comme je suis sous gnome-shell j'ai créé avec le logiciel "menu" un lanceur (j'ai installé une extension "applications menu", j'aime bien avoir un menu pour lancer mes applications), et j'utilise le chemin complet : /opt/pt/bin/PacketTracer7

Hors ligne

#9 Le 13/09/2017, à 11:32

jeremyy55

Re : installation de PacketTracer 7.1 sur Ubuntu 17.04

Ok Ok,

Et bien merci pour tout Gabcyr, tu m'as été d'une grande aide pour cette installation smile

Hors ligne