Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 29/08/2017, à 20:19

Dnij

[RÉSOLU] Problème avec le service munin

Bonsoir,
Je possède un serveur FTP/web/Proxy depuis plusieurs années, je l'avais installé en 14.04 à l'époque, à l'heure actuelle je suis sur la 16.04 LTS suite aux mises à jour.
Mes graphs générés par munin ont subitement arrêté de fonctionner.
Lorsque je regarde le statut des services avec systemctl, apache et munin-node sont bien active (running) mais munin lui est 'masked' inactive (dead).
Après plusieurs jours de recherche, des réinstallations et un essai de créer le fichier /lib/systemd/system/munin.service moi-même, je n'arrive toujours à rien même si je suis maintenant en état active (exited)
Quelqu'un qui utilise munin qui fonctionne pourrait vérifier s'il a bien ce script systemctl et le partager svp ?

Pour info, ma version de munin est actuellement la 2.0.25-2.

Merci d'avance.

Dernière modification par Dnij (Le 13/09/2017, à 20:37)

Hors ligne

#2 Le 01/09/2017, à 19:59

Dnij

Re : [RÉSOLU] Problème avec le service munin

UP Svp !
Si vous avez besoin de plus d'infos demandez, n'hésitez pas.
Je compte bien entendu les donner mais j'aimerais seulement essayer ce script avant, si quelqu'un peut me le donner.

Hors ligne

#3 Le 11/09/2017, à 19:22

Dnij

Re : [RÉSOLU] Problème avec le service munin

Up SVP !!!

Hors ligne

#4 Le 12/09/2017, à 07:22

bruno

Re : [RÉSOLU] Problème avec le service munin

Bonjour,

Donnes-nous le retour de :

sudo systemctl restart munin

et le contenu des logs.

En ligne

#5 Le 12/09/2017, à 14:40

Dnij

Re : [RÉSOLU] Problème avec le service munin

bruno a écrit :

Bonjour,

Donnes-nous le retour de :

sudo systemctl restart munin

et le contenu des logs.

Bonjour,
Pas de retour sur cette commande :

root@FTP-server:~# systemctl restart munin
root@FTP-server:~# systemctl status munin
● munin.service - LSB: Create /var/run/munin on boot
   Loaded: loaded (/etc/init.d/munin; bad; vendor preset: enabled)
   Active: active (exited) since mar. 2017-09-12 17:12:01 RET; 16s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 533 ExecStop=/etc/init.d/munin stop (code=exited, status=0/SUCCESS)
  Process: 542 ExecStart=/etc/init.d/munin start (code=exited, status=0/SUCCESS)

sept. 12 17:12:01 FTP-server systemd[1]: Stopped LSB: Create /var/run/munin on boot.
sept. 12 17:12:01 FTP-server systemd[1]: Starting LSB: Create /var/run/munin on boot...
sept. 12 17:12:01 FTP-server systemd[1]: Started LSB: Create /var/run/munin on boot.

Et je n'ai aucun log dans les fichiers munin-cgi-graph et munin-cgi-html.
Vous vouliez d'autres logs ?

Hors ligne

#6 Le 12/09/2017, à 15:42

bruno

Re : [RÉSOLU] Problème avec le service munin

Normalement la commande devrait échouer en indiquant que le service munin est masqué :

# systemctl restart munin
Failed to restart munin.service: Unit munin.service is masked.
# systemctl status munin
● munin.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

Je t'invite a remettre le fichier munin.service d'origine.

Si tes graphes ont « cessé de fonctionner » (à décrire précisément) il faut t'assurer que ta configuration est correcte :
- le fichier de configuration du serveur web ;
- les tâches cron dans /etc//cron.d ;
- les fichiers de configuration de munin dans /etc/munin.conf

En ligne

#7 Le 12/09/2017, à 16:08

Dnij

Re : [RÉSOLU] Problème avec le service munin

bruno a écrit :

Normalement la commande devrait échouer en indiquant que le service munin est masqué :

# systemctl restart munin
Failed to restart munin.service: Unit munin.service is masked.
# systemctl status munin
● munin.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

Je t'invite a remettre le fichier munin.service d'origine.

Si tes graphes ont « cessé de fonctionner » (à décrire précisément) il faut t'assurer que ta configuration est correcte :
- le fichier de configuration du serveur web ;
- les tâches cron dans /etc//cron.d ;
- les fichiers de configuration de munin dans /etc/munin.conf

C'est parce que j'ai essayé de recréer un script systemctl à la main. Mais avant ça j'avais bien le message d'erreur "service masqué".
C'est bien mon problème : où retrouver ce fichier munin.service d'origine ?
J'ai déjà essayé la réinstallation complète de munin mais rien n'y fait : suite à la réinstallation, mon /lib/systemd/system/munin.service est un lien symbolique vers /dev/null donc service masqué...

Hors ligne

#8 Le 12/09/2017, à 20:40

bruno

Re : [RÉSOLU] Problème avec le service munin

mon /lib/systemd/system/munin.service est un lien symbolique vers /dev/null donc service masqué

C'est normal. Le cas échéant il faut recréer ce lien symbolique.

Outre les vérifications que j'ai déjà indiqué il faut aussi examiner munin-update.log.

En ligne

#9 Le 13/09/2017, à 13:13

Dnij

Re : [RÉSOLU] Problème avec le service munin

J'ai fait pas mal de choses hier et je pense avoir avancé un peu. En effet, mes graphs ont recommencé à se mettre à jour à un moment donné.
Mais une autre modif que j'ai faite après a à nouveau arrêté la production de graph.
Dans le munin-update.log, je vois que le RRD Cached n'arrive pas à écrire : permission denied. J'essaye de comprendre d'où ça vient.

Hors ligne

#10 Le 13/09/2017, à 13:28

bruno

Re : [RÉSOLU] Problème avec le service munin

Est-ce que le paquet rrdcached est bien installé ? Est-ce que le fichier munin.conf contient bien une ligne du type :

rrdcached_socket /run/rrdcached.sock

Dernière modification par bruno (Le 13/09/2017, à 14:22)

En ligne

#11 Le 13/09/2017, à 13:38

Dnij

Re : [RÉSOLU] Problème avec le service munin

Oui, en version 1.5.5-4.
Oui dans munin.conf j'ai bien :

rrdcached_socket /var/run/rrdcached.sock

Par contre, je ne suis pas sûr des droits/owner à donner à /var/run/rrdcached. Par défaut il est à 755 et owner root:root.
J'ai essayé un chgrp www-data mais toujours même erreur.
Peut-être faut-il aussi changer les droits ou l'owner sur /var/lib/munin/home (là où il doit écrire les RRD) ?
Actuellement c'est en 775 et owner root:www-data (modifié par moi il me semble).
J'ai également suivi ce tuto pour la configuration du /etc/init.d/rrdcached

Hors ligne

#12 Le 13/09/2017, à 14:24

bruno

Re : [RÉSOLU] Problème avec le service munin

Ok suivant ce tuto tu dois avoir dans munin.conf :

rrdcached_socket /var/run/munin/rrdcached.sock

Car le tuto en question te fait utiliser une instance particulière de rrdcahed lancée en tant qu'utilisateur 'munin' pour éciter justement les problèmes de droits.

En ligne

#13 Le 13/09/2017, à 20:01

Dnij

Re : [RÉSOLU] Problème avec le service munin

Après avoir créer le munin.service pour systemctl et installer ACL je n'ai plus d'erreur de droits dans munin-update.log
Mais toujours pas de graph... J'ai des erreurs RRD 'Could not draw graph' dans munin-cgi-graph.log

EDIT : j'ai mis des droits à 777 sur le dossier /var/lib/munin/cgi-tmp/munin-cgi-graph/home et les graphs refonctionnent !!!
Il ne me reste plus qu'à trouver pourquoi ça ne fonctionne pas sur mon autre node maintenant smile

Dernière modification par Dnij (Le 13/09/2017, à 20:23)

Hors ligne

#14 Le 13/09/2017, à 20:37

Dnij

Re : [RÉSOLU] Problème avec le service munin

Dnij a écrit :

Après avoir créer le munin.service pour systemctl et installer ACL je n'ai plus d'erreur de droits dans munin-update.log
Mais toujours pas de graph... J'ai des erreurs RRD 'Could not draw graph' dans munin-cgi-graph.log

EDIT : j'ai mis des droits à 777 sur le dossier /var/lib/munin/cgi-tmp/munin-cgi-graph/home et les graphs refonctionnent !!!
Il ne me reste plus qu'à trouver pourquoi ça ne fonctionne pas sur mon autre node maintenant smile

EDIT 2 : finalement pas besoin de ce vilain 777 il suffisait de faire un chown www-data:www-data sur les dossiers de chaque node

Merci beaucoup pour ton aide bruno

Hors ligne