Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 23/09/2017, à 17:32

abelthorne

[résolu] Plus de menus dans les applis Qt

Bonjour,
Tout à l'heure, j'ai décidé de faire un peu de nettoyage dans mes applis et mes fichiers de config (notamment parce que je suis récemment repassé de GNOME à MATE et que c'est un peu le bordel). Je viens de me rendre compte que je n'avais plus du tout de barre de menu dans mes applis Qt. J'ai testé VLC (Qt5), Scribus (Qt4) et VirtualBox (Qt5). Détail "amusant" : si je crée un nouvel utilisateur, qui a donc un profil vierge, les menus apparaissent dans Scribus mais pas dans VLC ni dans VirtualBox.

Je suis un peu perdu : le fait que le problème se produise sur les applis Qt5 avec un nouvel utilisateur me fait penser à un problème de paquet manquant mais je n'ai rien supprimé en rapport avec Qt à part des paquets de dev dont je n'avais plus besoin. Et le fait que ça fonctionne sur les applis Qt4 avec un nouveau compte me fait penser à un problème de config.

Quelqu'un a déjà rencontré un problème similaire ?

Dernière modification par abelthorne (Le 23/09/2017, à 17:48)

Hors ligne

#2 Le 23/09/2017, à 17:47

abelthorne

Re : [résolu] Plus de menus dans les applis Qt

Bon, problème résolu et il n'avait pas grand chose à voir avec Qt mais avec le HUD de MATE.

Je n'avais pas pensé à le préciser mais en faisant des tests avec MATE Tweak dans la journée, j'ai activé le HUD pour voir ce que ça faisait (à première vue, rien) et je l'ai désactivé par la suite. Mais il a quand même été ajouté à mes applications au démarrage et tournait en tâche de fond. Manifestement, il n'est pas très copain avec Qt. Je ne sais pas s'il est censé gérer un menu global qui déconne ou quelque chose dans le genre, et les menus des applis Qt se retrouvent détachées pour apparaître nulle part ?

Hors ligne