Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/10/2017, à 00:31

vivushko

problème d'installation wine sur ubuntu 16.04

Bonjour à tous

J'essaye désespérément d'installer wine sur mon PC (ubuntu 16.04 LTS, 64 bits)

Après avoir fait sudo apt install wine puis réitérer la même opération pour wine1.6, wine1.6-i386, j'arrive finalement au message d'erreur :

Les paquets suivants contiennent des dépendances non satisfaites :
 wine1.6-i386:i386 : Dépend: libglu1-mesa:i386 mais ne sera pas installé ou
                              libglu1:i386
                     Dépend: libgphoto2-6:i386 (>= 2.5.9) mais ne sera pas installé
                     Dépend: libgphoto2-port12:i386 (>= 2.5.9) mais ne sera pas installé
                     Dépend: libldap-2.4-2:i386 (>= 2.4.7) mais ne sera pas installé
                     Recommande: libasound2-plugins:i386 mais ne sera pas installé
                     Recommande: libcups2:i386 mais ne sera pas installé
                     Recommande: libdbus-1-3:i386 mais ne sera pas installé
                     Recommande: libgif7:i386 mais ne sera pas installé
                     Recommande: libgnutls30:i386 mais ne sera pas installé
                     Recommande: libosmesa6:i386 mais ne sera pas installé
                     Recommande: libpulse0:i386 mais ne sera pas installé
                     Recommande: libsane:i386 mais ne sera pas installé
                     Recommande: libxt6:i386 mais ne sera pas installé
                     Recommande: p11-kit-modules:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

J'ai cherché sur les forums avec notamment ce post qui ressemble beaucoup à mon problème. Après 2h de tentative de résolution du problème à l'aide des indications données, il faut se rendre à l'évidence, c'est un échec.

Vu mon niveau sous Linux, il me faut des lignes de code en plus des indications pour résoudre le pb et apprendre un peu au passage

Si ça peut aider, sous synaptic, j'ai essayé de réparer les paquets cassés de wine1.6 mais je me heurte à :

E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

Merci de votre aide!

Hors ligne

#2 Le 12/10/2017, à 09:00

LukePerp

Re : problème d'installation wine sur ubuntu 16.04

vivushko a écrit :

J'essaye désespérément d'installer wine sur mon PC (ubuntu 16.04 LTS, 64 bits)

Bonjour,
Tu n'as pas cherché suffisamment sur le forum, j'ai eu et résolu le même problème.

Il faut installer wine stable officiel à partir du dépot officiel de wine, qui est winehq

Solution dans le dernier post de ce sujet :
https://forum.ubuntu-fr.org/viewtopic.php?id=2013591

Mais, avant d'installer wine, supprimer toute trace de tes tentatives précédente :

sudo apt remove wine winetricks -y && rm -rf ~/.wine && sudo apt autoclean && sudo apt autoremove --purge -y

Une fois que tu auras corriger les dépendances de wine, voici une ligne la commande pour installer wine :

sudo dpkg --add-architecture i386 && wget -nc https://dl.winehq.org/wine-builds/Release.key && sudo apt-key add Release.key && sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/ -y && sudo apt-get update && sudo apt-get install --install-recommends winehq-stable winetricks -y

Dernière modification par LukePerp (Le 12/10/2017, à 09:06)


Desktop : Ubuntu Mate 14.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

Hors ligne

#3 Le 12/10/2017, à 17:32

vivushko

Re : problème d'installation wine sur ubuntu 16.04

Merci pour ta réponse. Pour l'instant ça ne fonctionne toujours pas.
Voilà ce que j'ai fait :
1)j'ai supprimé toute traces de wine puis j'ai suivi la même procédure que toi sur ton post
2)j'ai simulé l’installation avec aptitude pour voir ce qui sort. J'ai alors beaucoup de dépendances non satisfaites :

Les paquets suivants ont des dépendances non satisfaites :
 libkrb5-3 : Casse: libkrb5-3:i386 (!= 1.13.2+dfsg-5ubuntu2) mais 1.13.2+dfsg-5 doit être installé.
 libkrb5-3:i386 : Casse: libkrb5-3 (!= 1.13.2+dfsg-5) mais 1.13.2+dfsg-5ubuntu2 est installé.
 libgssapi-krb5-2 : Casse: libgssapi-krb5-2:i386 (!= 1.13.2+dfsg-5ubuntu2) mais 1.13.2+dfsg-5 doit être installé.
 libgssapi-krb5-2:i386 : Casse: libgssapi-krb5-2 (!= 1.13.2+dfsg-5) mais 1.13.2+dfsg-5ubuntu2 est installé.
 libdbus-1-3 : Casse: libdbus-1-3:i386 (!= 1.10.6-1ubuntu3.3) mais 1.10.6-1ubuntu3.1 doit être installé.
 libdbus-1-3:i386 : Casse: libdbus-1-3 (!= 1.10.6-1ubuntu3.1) mais 1.10.6-1ubuntu3.3 est installé.
 libdrm-nouveau2 : Casse: libdrm-nouveau2:i386 (!= 2.4.70-1~ubuntu16.04.1) mais 2.4.67-1 doit être installé.
 libdrm-nouveau2:i386 : Casse: libdrm-nouveau2 (!= 2.4.67-1) mais 2.4.70-1~ubuntu16.04.1 est installé.
 libsystemd0 : Casse: libsystemd0:i386 (!= 229-4ubuntu16) mais 229-4ubuntu10 doit être installé.
 libsystemd0:i386 : Casse: libsystemd0 (!= 229-4ubuntu10) mais 229-4ubuntu16 est installé.
 libglapi-mesa : Casse: libglapi-mesa:i386 (!= 12.0.6-0ubuntu0.16.04.1) mais 11.2.0-1ubuntu2 doit être installé.
 libglapi-mesa:i386 : Casse: libglapi-mesa (!= 11.2.0-1ubuntu2) mais 12.0.6-0ubuntu0.16.04.1 est installé.
 libk5crypto3 : Casse: libk5crypto3:i386 (!= 1.13.2+dfsg-5ubuntu2) mais 1.13.2+dfsg-5 doit être installé.
 libk5crypto3:i386 : Casse: libk5crypto3 (!= 1.13.2+dfsg-5) mais 1.13.2+dfsg-5ubuntu2 est installé.
 libudev1 : Casse: libudev1:i386 (!= 229-4ubuntu16) mais 229-4ubuntu10 doit être installé.
 libudev1:i386 : Casse: libudev1 (!= 229-4ubuntu10) mais 229-4ubuntu16 est installé.
 libllvm3.8 : Casse: libllvm3.8:i386 (!= 1:3.8-2ubuntu4) mais 1:3.8-2ubuntu1 doit être installé.
 libllvm3.8:i386 : Casse: libllvm3.8 (!= 1:3.8-2ubuntu1) mais 1:3.8-2ubuntu4 est installé.
 libdrm-amdgpu1 : Casse: libdrm-amdgpu1:i386 (!= 2.4.70-1~ubuntu16.04.1) mais 2.4.67-1 doit être installé.
 libdrm-amdgpu1:i386 : Casse: libdrm-amdgpu1 (!= 2.4.67-1) mais 2.4.70-1~ubuntu16.04.1 est installé.
 libpulse0 : Casse: libpulse0:i386 (!= 1:8.0-0ubuntu3.2) mais 1:8.0-0ubuntu3 doit être installé.
 libpulse0:i386 : Casse: libpulse0 (!= 1:8.0-0ubuntu3) mais 1:8.0-0ubuntu3.2 est installé.
 libkrb5support0 : Casse: libkrb5support0:i386 (!= 1.13.2+dfsg-5ubuntu2) mais 1.13.2+dfsg-5 doit être installé.
 libkrb5support0:i386 : Casse: libkrb5support0 (!= 1.13.2+dfsg-5) mais 1.13.2+dfsg-5ubuntu2 est installé.
 libdrm2 : Casse: libdrm2:i386 (!= 2.4.70-1~ubuntu16.04.1) mais 2.4.67-1 doit être installé.
 libdrm2:i386 : Casse: libdrm2 (!= 2.4.67-1) mais 2.4.70-1~ubuntu16.04.1 est installé.
 libgl1-mesa-dri : Casse: libgl1-mesa-dri:i386 (!= 12.0.6-0ubuntu0.16.04.1) mais 11.2.0-1ubuntu2 doit être installé.
 libgl1-mesa-dri:i386 : Casse: libgl1-mesa-dri (!= 11.2.0-1ubuntu2) mais 12.0.6-0ubuntu0.16.04.1 est installé.
 libosmesa6 : Dépend: libglapi-mesa (= 11.2.0-1ubuntu2) mais 12.0.6-0ubuntu0.16.04.1 est installé.
 libgl1-mesa-glx : Casse: libgl1-mesa-glx:i386 (!= 12.0.6-0ubuntu0.16.04.1) mais 11.2.0-1ubuntu2 doit être installé.
 libgl1-mesa-glx:i386 : Casse: libgl1-mesa-glx (!= 11.2.0-1ubuntu2) mais 12.0.6-0ubuntu0.16.04.1 est installé.
 libdrm-intel1 : Casse: libdrm-intel1:i386 (!= 2.4.70-1~ubuntu16.04.1) mais 2.4.67-1 doit être installé.
 libdrm-intel1:i386 : Casse: libdrm-intel1 (!= 2.4.67-1) mais 2.4.70-1~ubuntu16.04.1 est installé.
 libp11-kit0 : Casse: libp11-kit0:i386 (!= 0.23.2-5~ubuntu16.04.1) mais 0.23.2-3 doit être installé.
 libp11-kit0:i386 : Casse: libp11-kit0 (!= 0.23.2-3) mais 0.23.2-5~ubuntu16.04.1 est installé.
 libdrm-radeon1 : Casse: libdrm-radeon1:i386 (!= 2.4.70-1~ubuntu16.04.1) mais 2.4.67-1 doit être installé.
 libdrm-radeon1:i386 : Casse: libdrm-radeon1 (!= 2.4.67-1) mais 2.4.70-1~ubuntu16.04.1 est installé.
 libgstreamer1.0-0 : Casse: libgstreamer1.0-0:i386 (!= 1.8.3-1~ubuntu0.1) mais 1.8.0-1 doit être installé.
 libgstreamer1.0-0:i386 : Casse: libgstreamer1.0-0 (!= 1.8.0-1) mais 1.8.3-1~ubuntu0.1 est installé.

3)Il semble là aussi qu'il faille rétrogradé un certain nombre de version de ces librairies mais ne sachant pas lesquelles, j'ai commencé par la première pour remplacer la version 1.13.2+dfsg-5ubuntu2 de libkrb5-3 par la version 1.13.2+dfsg-5

sudo apt-get install libkrb5-3=1.13.2+dfsg-5

Voila le retour, négatif:

Les paquets suivants contiennent des dépendances non satisfaites :
 gkbd-capplet : Dépend: libgnomekbd8 (>= 3.6.0) mais ne sera pas installé
 ibus : Dépend: gir1.2-gtk-3.0 (>= 3.8.5) mais ne sera pas installé
        Dépend: adwaita-icon-theme mais ne sera pas installé
 libcheese-gtk25 : Dépend: gstreamer1.0-clutter-3.0 mais ne sera pas installé
 libcheese8 : Dépend: libclutter-gst-3.0-0 (>= 3.0.4) mais ne sera pas installé
 libcups2 : Dépend: libgssapi-krb5-2 (>= 1.10+dfsg~) mais ne sera pas installé
 libgrilo-0.2-1 : Dépend: libtotem-plparser18 (>= 3.10.0) mais ne sera pas installé
 libgtk-3-0 : Dépend: libgtk-3-common (>= 3.18.9-1ubuntu3.1) mais ne sera pas installé
 libgtk-3-bin : Dépend: libgtk-3-common (>= 3.18.9-1ubuntu3.1) mais ne sera pas installé
 libkrb5-3 : Dépend: libkrb5support0 (= 1.13.2+dfsg-5) mais 1.13.2+dfsg-5ubuntu2 devra être installé
 system-config-printer-gnome : Dépend: system-config-printer-common (>= 1.3.11+20120807-0ubuntu7) mais ne sera pas installé
                               Dépend: adwaita-icon-theme mais ne sera pas installé
                               Dépend: gir1.2-gtk-3.0 mais ne sera pas installé
 unity-asset-pool : Dépend: adwaita-icon-theme mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Visiblement j'ai touché à un gros poisson, je prend ce retour comme un "ne pas trop toucher à ça si tu ne t'y connais pas".
Je me dis que même si j'arrivais à rétrogradé correctement les versions des autres librairy qui posent problème, j'aurais toujours la dépendance non satisfaite de libkrb5-3 donc je ne bidouille pas plus et je préfère reporter sur le forum

Hors ligne

#4 Le 12/10/2017, à 18:57

LukePerp

Re : problème d'installation wine sur ubuntu 16.04

En effet, il y a trop de dépendance pour que la méthode fonctionne. Je te confirme d'arreter de rétrograder.
Que donne le retour de :

sudo apt install -f

Desktop : Ubuntu Mate 14.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

Hors ligne

#5 Le 12/10/2017, à 20:57

vivushko

Re : problème d'installation wine sur ubuntu 16.04

ça donne

Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne