Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 02/11/2017, à 10:55

Marko

[Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Bonjour,

comment activer le verrouillage du pavé numérique au démarrage de session, c'est à dire à la saisie du mot de passe ?

J'ai recherché dans le forum, mais je n'ai rien trouvé pour la nouvelle version 17.10.
le gestionnaire de connexion est à priori gdm3, alors, j'ai utilisé la doc https://doc.ubuntu-fr.org/numlockx

- installation de numlockx
- ajout des lignes suivantes dans /etc/gdm3/Init/default

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi

c'est sans effet.

Vous avez une idée ?

Je vous remercie par avance pour votre aide.

Cdt

Dernière modification par Marko (Le 02/11/2017, à 10:56)


Fractal Design R4 / GA Z87-HD3 / Intel Core I5-4670K sous 14.04 64 Bits / Win10

Hors ligne

#2 Le 02/11/2017, à 19:41

Bertrand49

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Bonjour,
Quand cela m'arrive, j'appuie sur la touche NumLock située en haut à gauche du pavé numérique.

Hors ligne

#3 Le 02/11/2017, à 19:51

Roschan

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

pffff.

Les gens savent se servir d'un clavier, merci, c'était pas la question.

Hors ligne

#4 Le 02/11/2017, à 20:42

frenchy82

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

C'est étonnant car en passant d'unity à gs et donc à gdm3 le clavier numérique reste activé au démarrage sur mon pc alors que numlock n'est pas installé.

Mais je suis sur un pc avec clavier usb. Peut être que suivant la config le comportement est différent.

Tu as essayé sans numlock et de redémarrer le poste avec le clavier numéro activé?

Hors ligne

#5 Le 02/11/2017, à 22:27

ylag

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Salut,

Tu pourrais tenter cette commande pour déterminer en premier l'état de la clé dconf remember-numlock-state :

gsettings get org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state

...si le retour est false, faire :

sudo gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true

.
Une fois la valeur true passée à cette clé, activer le numlock sur ton clavier et redémarrer ...?

Il est aussi possible de vérifier ou modifier l'état de cette clé en utilisant dconf-editor

Voir cette discussion: https://unix.stackexchange.com/question … n-in-gnome (en anglais, par contre).

Note: Pas certain de l'existence de cette clé sous Ubuntu 17.10, à toi de vérifier...

A+

Dernière modification par ylag (Le 02/11/2017, à 22:29)

Hors ligne

#6 Le 02/11/2017, à 22:32

Roschan

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

ylag a écrit :

Voir cette discussion: https://unix.stackexchange.com/question … n-in-gnome (en anglais, par contre).

"questions/235683/remember-numlock-state-after-login-in-gnome"

C'est "before" login qui serait intéressant

Hors ligne

#7 Le 02/11/2017, à 22:37

ylag

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Salut,

@Roschan:

Bien vu....
Dans ce cas, peut-être une piste de ce côté:
https://wiki.archlinux.org/index.php/Ac … Bootup#GDM
https://unix.stackexchange.com/question … screen-gdm

A+

Dernière modification par ylag (Le 03/11/2017, à 12:28)

Hors ligne

#8 Le 03/11/2017, à 12:28

ylag

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Salut,

Si on se fie aux deux discussions citées dans le commentaire #7, il semblerait que gdm n'exécute plus les scripts placés dans /etc/gdm/Init, et qu'il faudrait plutôt essayer en placant le script de lancement de numlock dans le fichier /etc/gdm3/PreSession/Default ...?

A+

Dernière modification par ylag (Le 03/11/2017, à 12:28)

Hors ligne

#9 Le 12/11/2017, à 18:17

wil_sly

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Hello,

Bon mauvaise idée de place un script dans ce fichier => impossibilité de se loguer. Je pense néanmoins qu'il doit falloir lancer numlockx à partir de ce fichier.
Je vais continuer de chercher...

A+ Wil

Hors ligne

#10 Le 12/11/2017, à 18:54

wil_sly

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

En suivant dans le lien donné, la méthode de don_crissti, j'y suis personnellement arrivé. Pour résumé, voici ce que j'ai fait :

  1. j'ai ouvert un terminal indépendant (CTRL+ALT+F3), loggué en tant que root et j'ai exécuté les commandes suivantes :

    $ su - gdm -s /bin/sh

    pour basculer sur l'utilisateur gdm

  2. puis :

    export $(dbus-launch)

    et

    GSETTINGS_BACKEND=dconf gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on

    puis exit pour revenir à l'utilisateur root

  3. et enfin :

    systemctl restart gdm

    pour redémarrer gdm

chez moi ça a fonctionné, j'espère que ça vous aidera wink

A+ Wil

Dernière modification par wil_sly (Le 12/11/2017, à 18:57)

Hors ligne

#11 Le 12/11/2017, à 19:18

Marko

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Merci à tous pour vos conseils.

J'ai laché l'affaire pour l'instant, mais je garde vos conseils précieusement.
Je suis passé pour l'instant sur Linux Mint Mate, histoire de tester un peu, car j'avais de gros problèmes avec la 17.10 sous gnome (ralentissements, problèmes graphiques, etc...)
Mais j'y reviendrai certainement, à l'occasion d'une LTS.

Pour la petite histoire, sur Mint Mate, le numlockx ne fonctionne pas non plus. l'herbe n'est pas plus verte ailleurs ;-)


Fractal Design R4 / GA Z87-HD3 / Intel Core I5-4670K sous 14.04 64 Bits / Win10

Hors ligne

#12 Le 16/11/2017, à 21:00

Michka B

Re : [Ubuntu 17.10] verrouillage du pavé numérique au démarrage de session

Bonjour à tous, et en particulier à wil_sly,

Étant donné que j'ai ce même problème avec GDM
(mais aussi que le pavé numérique ne fonctionne pas avec Firefox et Thunderbird !)
je m'adresse à vous après avoir fait les manips proposées par wil_sly.
Je me fais jeté par GDM ainsi (j'ai oublié une lettre au départ !) :

# su - gdm -s /bin/sh
$ export $(dbus-lauch)
-su: 1: dbus-lauch: not found
export COLORTERM='truecolor'
export DBUS_SESSION_BUS_ADDRESS='unix:path=/run/user/127/bus'
export DISPLAY=':0'
export HOME='/var/lib/gdm3'
export LANG='fr_FR.UTF-8'
export LOGNAME='gdm'
export MAIL='/var/mail/gdm'
export PATH='/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/snap/bin'
export PWD='/var/lib/gdm3'
export SHELL='/bin/sh'
export TERM='xterm-256color'
export USER='gdm'
export XDG_DATA_DIRS='/usr/local/share:/usr/share:/var/lib/snapd/desktop'
export XDG_RUNTIME_DIR='/run/user/127'
export XDG_SESSION_ID='3'
$ export $(dbus-launch)
No protocol specified
#

Que se passe-t-il ?

Hors ligne