Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/10/2017, à 23:07

Pépère DK

Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Bonjour,

J'ai tenté d'installer mon Epson Perfection V300 photo sur mon nouveau PC avec Ubuntu 64 bits.

J'ai téléchargé iscan deb en 64bit sur la page http://support.epson.net/linux/en/iscan … sion=1.0.1.

Conformément au fichier read me, j'ai lancé l'installation via le terminal (commande ./install.sh)

L'installation s'est lancée mais elle a échoué.
Message "Aucune version du paquet libsane n'est disponible... Cependant les paquets suivants le remplacent libsane1: i386 libsane1"

Que dois-je faire ?

Merci d'avance de votre concours.

Hors ligne

#2 Le 21/10/2017, à 10:52

foustala

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

hello,

tu es sur quelle version d'ubuntu? artful?

lsb_release -a

copie tout le log d'installation stp entre balises

très certainement qu'installer libsane1 suffit.

sudo apt-get install libsane1

Hors ligne

#3 Le 29/10/2017, à 22:52

Pépère DK

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Bonjour,

Je suis sur :
Description:    Ubuntu 17.10
Release:    17.10
Codename:    artful

Hors ligne

#4 Le 02/12/2017, à 11:32

francois-web

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Bonjour,

J'ai pour ma part un V600, mais la problématique est la même.
Le problème vient des changements effectués dans la version 17.10 (en particulier libsane renommée en libsane1).

La procédure expliquée par Gaurang Arora fonctionne : https://askubuntu.com/questions/946198/ … 626#974626
Pour résumer en français :

    - Activer les mises à jour en pré-version (artful-proposed) : personnellement, je ne l'ai pas fait et cela fonctionne, puis mettre à jour les sources
    - Installer libsane1
    - Copier les fichiers libsane-epkowa vers les bibliothèques x86-64 (en console) : sudo cp /usr/lib/sane/libsane-epkowa.* /usr/lib/x86_64-linux-gnu/sane/
    - Installer le "bundle" Epson correspondant http://download.ebz.epson.net/dsc/searc … archModule
    - Il faut ensuite modifier le fichier /etc/udev/rules.d/79-udev-epson.rules (le créer s'il n'existe pas) et ajouter les lignes suivantes

#chmod device EPSON group
ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0777"

    -Un redémarrage plus loin, le scanner fonctionne à nouveau smile

Gaurang Arora cite Tanstaafl comme message source https://forum.ubuntuusers.de/topic/epso … 0-geloest/

Je suis tombé dessus ensuite, mais le fil https://forum.ubuntu-fr.org/viewtopic.php?id=2016865 donne aussi des informations sur ce problème (entre deux prises de bec wink )

Bons scans

Dernière modification par francois-web (Le 02/12/2017, à 11:50)


Artful // Gnome-Shell

Hors ligne

#5 Le 02/12/2017, à 12:09

moko138

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Ceci #19 ./viewtopic.php?pid=21821815#p21821815  (et #23) devrait suffire !


Conseiller les dépôts "proposed" est une très dangereuse idée en général (cf. notre Doc).
Mais les conseiller 2 mois après la sortie de la 17.10 en s'appuyant sur un fil de 08/17, donc un fil de test, 2 mois avant la sortie de la 17.10, ça me semble dénué de sens.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#6 Le 02/12/2017, à 12:29

francois-web

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Bonjour Moko,

Sur les "proposed" rien à redire.
Merci d'avoir pris le temps de corriger.
Pour la forme, je reste dubitatif. Mais c'est sans importance.


Artful // Gnome-Shell

Hors ligne

#7 Le 22/08/2018, à 10:06

Robert Algoud

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Bonjour

Je reviens sur le sujet lancé par Pépère DK.
J'ai aussi un scanner Epson V300. Sous Xubuntu 16.04 jusqu'à présent, je viens de faire une réinstallation (jamais de mise à niveau !!!) avec la 18.04.1 LTS. Plus moyen de faire fonctionner mon scanner après l'installation du Bundle Epson.
J'ai donc appliqué la méthode proposée par francois-web (libsane1 fait partie du package de la 18.04.1) :

Copier les fichiers libsane-epkowa vers les bibliothèques x86-64 (en console) : sudo cp /usr/lib/sane/libsane-epkowa.* /usr/lib/x86_64-linux-gnu/sane/

Il faut ensuite modifier le fichier /etc/udev/rules.d/79-udev-epson.rules (le créer s'il n'existe pas) et ajouter les lignes suivantes :

#chmod device EPSON group
ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0777"

Cela fonctionne très bien. Merci !


Ubuntu depuis Hardy Héron - Xubuntu 18.04 LTS

Hors ligne

#8 Le 04/10/2018, à 11:58

Athol

Re : Problème pour installer Epson Perfection V300 photo avec Ubuntu 64 bit

Merci François-web,

ça a très bien fonctionné pour moi aussi!!!    smile smile

Hors ligne