Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/12/2017, à 11:36

Fredo29260

[RPi3] VLC avec accélération matérielle

Bonjour,

Je cherche à installer vlc avec l'installation matérielle sur le RPi3, en suivant ce tutoriel : http://www.x90x90x90.com/raspberry-pi-3 … aterielle/

Seulement arrivé à l'installation de ça :

sudo apt-get install libv4l-dev libva-dev libvcdinfo-dev libvdpau-dev libvncserver-dev libvorbis-dev libx11-dev libx264-dev libxcb-composite0-dev libxcb-keysyms1-dev libxcb-randr0-dev libxcb-shm0-dev libxcb-xv0-dev libxcb1-dev libxext-dev libxinerama-dev libxml2-dev libxpm-dev libzvbi-dev lua5.2 oss4-dev pkg-config zlib1g-dev libpng12-dev libtool build-essential autoconf

J'obtiens ces erreurs :

Les paquets suivants contiennent des dépendances non satisfaites :
 libpng-dev : Est en conflit avec: libpng12-dev mais 1.2.54-6 devra être installé
 libpng12-dev : Est en conflit avec: libpng-dev mais 1.6.28-1 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

J'ai effectué plusieurs recherches mais impossible d'en venir à bout, quelqu'un aurait-il une solution ?

Merci d'avance!

Hors ligne

#2 Le 07/12/2017, à 14:57

thegamer94400

Re : [RPi3] VLC avec accélération matérielle

De mémoire, il faut faire

apt-get install —fix

La chose devant «fix» est deux tirets (du 6)


Passionné d'informatique et de photographie. J'essaie d'utiliser le plus possible linux
Mon site photo : http://alexandrejublotphotographie.website

Hors ligne

#3 Le 07/12/2017, à 16:16

Fredo29260

Re : [RPi3] VLC avec accélération matérielle

Merci pour ta réponse, j'ai une erreur avec cette ligne :

E: Command line option --fix is not understood in combination with the other options

Hors ligne

#4 Le 07/12/2017, à 16:51

erresse

Re : [RPi3] VLC avec accélération matérielle

Pourquoi ce "--fix" ?

sudo apt install -f

doit bien être suffisant, mais je suis pas sûr que ça résolve ton problème de dépendances pour autant...


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#5 Le 07/12/2017, à 17:07

Fredo29260

Re : [RPi3] VLC avec accélération matérielle

La commande avec -f fonctionne mais ne corrige pas le problème effectivement

Hors ligne

#6 Le 07/12/2017, à 18:21

thegamer94400

Re : [RPi3] VLC avec accélération matérielle

Alors un

apt-get dist-upgrade --fix missing

Cette fois ci l'argument est bon

Devrait marcher


Passionné d'informatique et de photographie. J'essaie d'utiliser le plus possible linux
Mon site photo : http://alexandrejublotphotographie.website

Hors ligne

#7 Le 07/12/2017, à 18:30

cqfd93

Re : [RPi3] VLC avec accélération matérielle

thegamer94400 a écrit :

Alors un

apt-get dist-upgrade --fix missing

Cette fois ci l'argument est bon

Devrait marcher

Euh… ça ne serait pas --fix-missing ?


cqfd93

En ligne

#8 Le 07/12/2017, à 18:38

thegamer94400

Re : [RPi3] VLC avec accélération matérielle

Effectivement merci pour les erreurs de frappe


Passionné d'informatique et de photographie. J'essaie d'utiliser le plus possible linux
Mon site photo : http://alexandrejublotphotographie.website

Hors ligne

#9 Le 08/12/2017, à 10:16

Fredo29260

Re : [RPi3] VLC avec accélération matérielle

Malheuresement, toujours la même erreur

Hors ligne

#10 Le 21/05/2018, à 14:55

Pat054

Re : [RPi3] VLC avec accélération matérielle

Bonjour,

Problème identique :

Les paquets suivants contiennent des dépendances non satisfaites :
 libpng-dev : Est en conflit avec: libpng12-dev mais 1.2.54-6 devra être installé
 libpng12-dev : Est en conflit avec: libpng-dev mais 1.6.28-1 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Quelqu'un aurait la solution?

Dans l'attente, cordialement.

Hors ligne