Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/12/2017, à 17:14

Ezzmazz

Problème installation Python 3.6

Bonjour,

J'aimerai me mettre à apprendre le python. Je vais donc sur le site Openclassroom et je suis les instructions suivantes :

1. Décompressez l'archive en tapant :tar -xzf Python-3.4.0.tar.bz2(cette commande est bien entendu à adapter suivant la version et le type de compression).
2. Attendez quelques instants que la décompression se termine, puis rendez-vous dans le dossier qui vient d'être créé dans le répertoire courant (Python-3.4.0dans mon cas).
3. Exécutez le scriptconfigureen tapant./configuredans la console.
4. Une fois que la configuration s'est déroulée, il n'y a plus qu'à compiler en tapantmakepuismake installen tant que super-utilisateur.

Bon, je remplace Python 3.4.0 par la dernière version, donc la 3.6.3 mais au moment de l'installation, j'ai ce message :

The directory '/home/XXXXX/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/XXXXX/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already up-to-date: setuptools in /usr/local/lib/python3.6/site-packages
Requirement already up-to-date: pip in /usr/local/lib/python3.6/site-packages

Il semblerait que c'est un problème de permission... Je lance pourtant la commande en " sudo "...

Pourriez-vous m'aider ?

Merci d'avance ! smile

Hors ligne

#2 Le 14/12/2017, à 18:40

cqfd93

Re : Problème installation Python 3.6

Bonjour,

Dans les instructions que tu as citées, il n'y a pas de sudo, ça vient probablement de là, on n'utilise pas sudo quand ça n'est pas nécessaire.

Donne le retour complet de :

ls ~/.cache/pip -l

(et surtout sans XXXXXX comme dans le message d'erreur que tu as donné)

Par exemple, chez moi, ça donne :

moi@aurore:~$ ls ~/.cache/pip -l
total 12
drwx------ 12 moi moi 4096 déc  8 22:49 http
-rw-rw-r--  1 moi moi   69 déc  8 20:01 selfcheck.json
drwxrwxr-x  6 moi moi 4096 déc  8 22:49 wheels
moi@aurore:~$ 

cqfd93

Hors ligne

#3 Le 14/12/2017, à 19:10

bipede

Re : Problème installation Python 3.6

Bonjour,
Tu es sur quel système ?
Sur Ubuntu Python 2.7 et Python 3.6 sont déjà installés...


Desktop: MSI - Intel® Core™ i5-3330 CPU @ 3.00GHz × 4 - RAM 8 go- Ubuntu 18.04 - Système sur SSD 64 Go - /home sur HDD 500 Go.
Laptop: DELL Inspiron-15 3567 - Intel® Core™ i5-7200 CPU @ 2.50GHz × 4 - RAM 8 go - HDD 1 To - Ubuntu 18.04 avec /home séparé.

Mon site: Les contributions du bipède

Hors ligne

#4 Le 14/12/2017, à 19:22

Ezzmazz

Re : Problème installation Python 3.6

cqfd93 a écrit :

Bonjour,

Dans les instructions que tu as citées, il n'y a pas de sudo, ça vient probablement de là, on n'utilise pas sudo quand ça n'est pas nécessaire.

Donne le retour complet de :

ls ~/.cache/pip -l

(et surtout sans XXXXXX comme dans le message d'erreur que tu as donné)

Par exemple, chez moi, ça donne :

moi@aurore:~$ ls ~/.cache/pip -l
total 12
drwx------ 12 moi moi 4096 déc  8 22:49 http
-rw-rw-r--  1 moi moi   69 déc  8 20:01 selfcheck.json
drwxrwxr-x  6 moi moi 4096 déc  8 22:49 wheels
moi@aurore:~$ 

Bonjour et merci pour votre réponse;

Voici le retour de la commande :

timothee@timothee-MS-7924:~$ ls ~/.cache/pip -l
ls: impossible d'accéder à '/home/timothee/.cache/pip': Aucun fichier ou dossier de ce type

Le " XXXXX " c'était juste pour ne pas afficher mon prénom... big_smile

bipede a écrit :

Bonjour,
Tu es sur quel système ?
Sur Ubuntu Python 2.7 et Python 3.6 sont déjà installés...

Je suis sous Ubuntu 16.04 LTS. Et oui, Python 2.7 est bien installé. Sur le site d'Openclassroom, il est conseillé d'installer la dernière version disponible.

Hors ligne

#5 Le 14/12/2017, à 19:33

bipede

Re : Problème installation Python 3.6

Ezzmazz a écrit :

Je suis sous Ubuntu 16.04 LTS. Et oui, Python 2.7 est bien installé. Sur le site d'Openclassroom, il est conseillé d'installer la dernière version disponible.

Ouvre un terminal et tape

 python3

Tu verras quelle est la version installée.
Pour info, la commande

python

lance python 2.7 par défaut.
C'est une mauvaise idée de remplacer la version présente sur ta distribution par une plus récente.
En effet, de nombreuses briques de ton système sont réalisées en Python et tu risques de créer des dysfonctionnements.
OpenClassRoom donne ce conseil surtout à destination des utilisateurs de Windows.


Desktop: MSI - Intel® Core™ i5-3330 CPU @ 3.00GHz × 4 - RAM 8 go- Ubuntu 18.04 - Système sur SSD 64 Go - /home sur HDD 500 Go.
Laptop: DELL Inspiron-15 3567 - Intel® Core™ i5-7200 CPU @ 2.50GHz × 4 - RAM 8 go - HDD 1 To - Ubuntu 18.04 avec /home séparé.

Mon site: Les contributions du bipède

Hors ligne

#6 Le 14/12/2017, à 21:54

Ezzmazz

Re : Problème installation Python 3.6

bipede a écrit :
Ezzmazz a écrit :

Je suis sous Ubuntu 16.04 LTS. Et oui, Python 2.7 est bien installé. Sur le site d'Openclassroom, il est conseillé d'installer la dernière version disponible.

Ouvre un terminal et tape

 python3

Tu verras quelle est la version installée.
Pour info, la commande

python

lance python 2.7 par défaut.
C'est une mauvaise idée de remplacer la version présente sur ta distribution par une plus récente.
En effet, de nombreuses briques de ton système sont réalisées en Python et tu risques de créer des dysfonctionnements.
OpenClassRoom donne ce conseil surtout à destination des utilisateurs de Windows.


D'accord, merci ! smile

Hors ligne